SA 5.0.0.3 slow down on NT 4.0 server

We are having a problem with SA 5.0.0.3 slowing down over a period of time
on an NT 4.0 (Service Pak 2) server
Searches that used to take 5-15 secs start taking longer and longer,
sometimes as long as 2-3 MINUTES.
The only "solution" we have found is to shutdown the server. A warm reboot
is not sufficient to return the performance to normal. We must power off
the machine and restart. Once we do this, we are back to seconds for
searches.
Does anybody else have any input for this problem....Have already opened an
issue with Sybase, seeking additional info to help diagnose the problem.
We are not in a position to move to 5.5 x because of the new testing cycle
that would be involved.

0
Steve
4/24/1997 4:38:07 PM
sybase.sqlanywhere.general 32637 articles. 22 followers. Follow

8 Replies
615 Views

Similar Articles

[PageSpeed] 35

Steve,
	The fact that a cold boot is required to resolve the problem may
indicate a problem at the network level. Network cards often require a
cold boot to reset their state. Check with your network card vendor to
determine if they have updated drivers. 

Steve Radman, Sybase Inc.
0
Steve
4/24/1997 7:09:37 PM
I friend of mine reported problemes similar to this and later found out
that speed went down if connections to the database was not shut down and
stayed open if a client-computer got hung. The problem was solved if he
dissconnected these "empty" connections on the server. I belive this
problem has something to do with TCP/IP.
Hope this solves the problem.
Best regards
Ketil Tuft
Norway

Steve hood <steve.hood@riseinc.com> wrote in article
<01bc50d6$ae911b60$1696bfcc@qapentium>...
> We are having a problem with SA 5.0.0.3 slowing down over a period of
time
> on an NT 4.0 (Service Pak 2) server
> Searches that used to take 5-15 secs start taking longer and longer,
> sometimes as long as 2-3 MINUTES.
> The only "solution" we have found is to shutdown the server. A warm
reboot
> is not sufficient to return the performance to normal. We must power off
> the machine and restart. Once we do this, we are back to seconds for
> searches.
> Does anybody else have any input for this problem....Have already opened
an
> issue with Sybase, seeking additional info to help diagnose the problem.
> We are not in a position to move to 5.5 x because of the new testing
cycle
> that would be involved.
> 
> 
0
Ketil
4/28/1997 4:23:56 PM
We've seen something similar on our WinNT4 server(s). The only difference
is that an extraordinary simple query (delete 1 row from a simple 3col
table with 50-60 records) take "forever" to execute (read: upto 50mins). We
found that removing the foreign key "solves" the problem - the query then
takes only a few secs to complete. Taking this anomaly to Sybase (Norway),
has lead to the conclusion that there may be some rather "serious"/peculiar
bugs in the SA engine, which could seem to slow down the entire engine as
it makes it scan the entire leaf level of the index trees (B-trees) in
search for even a single row. Our case has been reproduced at Sybase and
they're going to look further into it.

Of course, this may not be what's happening on your server, but I thought
maybe you'd want to know...

So, 'till further notice from Sybase, we're "standing by" (hope it doesn't
take too long before they come up with a solution).




Steve hood <steve.hood@riseinc.com> wrote in article
<01bc50d6$ae911b60$1696bfcc@qapentium>...
> We are having a problem with SA 5.0.0.3 slowing down over a period of
time
> on an NT 4.0 (Service Pak 2) server
> Searches that used to take 5-15 secs start taking longer and longer,
> sometimes as long as 2-3 MINUTES.
> The only "solution" we have found is to shutdown the server. A warm
reboot
> is not sufficient to return the performance to normal. We must power off
> the machine and restart. Once we do this, we are back to seconds for
> searches.
> Does anybody else have any input for this problem....Have already opened
an
> issue with Sybase, seeking additional info to help diagnose the problem.
> We are not in a position to move to 5.5 x because of the new testing
cycle
> that would be involved.
> 
> 
0
Morten
4/30/1997 3:08:42 PM
Steve hood wrote:
> 
> We are having a problem with SA 5.0.0.3 slowing down over a period of time
> on an NT 4.0 (Service Pak 2) server
> Searches that used to take 5-15 secs start taking longer and longer,
> sometimes as long as 2-3 MINUTES.
> The only "solution" we have found is to shutdown the server. A warm reboot
> is not sufficient to return the performance to normal. We must power off
> the machine and restart. Once we do this, we are back to seconds for
> searches.
> Does anybody else have any input for this problem....Have already opened an
> issue with Sybase, seeking additional info to help diagnose the problem.
> We are not in a position to move to 5.5 x because of the new testing cycle
> that would be involved.
Take care what kind of stuff is used in this programs !!
We have really complicated stored procedure to execute witch needs
temporary tables. With more than one user we had (WinNT Server) the same
problems !! No answers for the Server for 20 Minutes !!
I had written the procedure with 'DECLARE LOCAL TEMPORARY TABLES'.
After no more other ideas I rewrote all stuff with GLOBAL TEMPORARY
TABLES and all problems went away !!! 
This was on Rel 5.0.02 Now we work on 5.5 but I can't say wheter the
problem persist or not, I sure will not go rewrite everything !!
Anyone have an explanation ??
Bye
R. Somaini
rosoma@mail.tic.ch


0
R
5/1/1997 10:52:35 AM
How long are your keys?  In SQL Anywhere the length of the key can have a
dramatic affect on performance.
-- 
Jim Egan [TeamPS]
Dealer Solutions, LLC
Houston, TX
0
Jim
5/1/1997 4:59:47 PM
In article <01bc53f9$1a45dec0$d11dd6c1@coyote>, "Ketil Tuft" <ktuft@sn.no> wrote:
>I friend of mine reported problemes similar to this and later found out
>that speed went down if connections to the database was not shut down and
>stayed open if a client-computer got hung. The problem was solved if he
>dissconnected these "empty" connections on the server. I belive this
>problem has something to do with TCP/IP.
>Hope this solves the problem.
>Best regards
>Ketil Tuft
>Norway
>
>Steve hood <steve.hood@riseinc.com> wrote in article
><01bc50d6$ae911b60$1696bfcc@qapentium>...
>> We are having a problem with SA 5.0.0.3 slowing down over a period of
>time
>> on an NT 4.0 (Service Pak 2) server
>> Searches that used to take 5-15 secs start taking longer and longer,
>> sometimes as long as 2-3 MINUTES.
>> The only "solution" we have found is to shutdown the server. A warm
....

Try applying the TCPIP-FIX hot fix to your NT Service Pack 2. It's available 
at <http://w3.ime.net/~peteb/ntserv.htm>. We experienced similar symptoms 
(100% CPU utilization) even without an SA server running. Since applying the 
patch, the problem has not reocurred.
0
pneuf
5/6/1997 4:29:57 AM
We use both local and global temp tables.  We haven't seen this problem in
5.5/5.5.01.
-- 
Jim Egan [TeamPS]
Dealer Solutions, LLC
Houston, TX


0
Jim
5/9/1997 11:29:26 AM
In the table mentioned previously, the key is comprised of two integers. 

After some dicussing with Sybase, we've tried regenerating our database
using triggers for RI (instead of the normal "foreign key type RI"). This
has lead to a DRAMATIC performance improvement (at least concerning the
example posted earlier in this thread). We're now down to under .5s, which
is pretty darn close to what we'd expect in this case. 

When "converting" relationships to triggers, we had to create individual
indexes for all the previous foreign keys (as they're really a special kind
of index in SA). This has really improved (at least some of) our queries
and response is now far, far, far better. 

But; there's still more to be done to improve performance.... Guess we're
not satisfied until we're down to 0 secs on all queries!! ;-)

(Sybase confirmed what we suspected all along; SA isn't very good at index
scanning when there are lots and lots of them, and that they'll try to
improve this algorithm in the next release....)

Morten Myrvold
Sysdeco Profdoc AS,
Kongsberg, Norway

Jim Egan <eganjp@compuserve.com> wrote in article
<01bc5659$e43e56a0$3aa3b9ce@jegan.carman.com>...
> How long are your keys?  In SQL Anywhere the length of the key can have a
> dramatic affect on performance.
> -- 
> Jim Egan [TeamPS]
> Dealer Solutions, LLC
> Houston, TX
> 
0
Morten
5/12/1997 10:11:24 AM
Reply:

Similar Artilces:

1.5.0.0.3 vs 1.5.0.0.4
I have had numerous difficulties with FF 1.5.0.0.4, in particular, some sites often just hang when I click on links. A particularly bad site is Dell http://www.dell.com/, which - when I try to configure a computer - gets all kinds of "waiting for dell" status bar messages. I tried it with a clean profile, to no avail. It works flawlessly with IE. I downloaded fresh copies of 1.5.0.3 and 1.5.0.4 with the intent of uninstalling the latter and then trying the former. *The uninstall process hung*. So I installed 1.5.0.3 on top of 1.5.0.4. The Dell site now works fl...

0.0.0.0
Can someone tell me the function of this scan? FWIN,2001/08/28,20:06:43 -6:00 GMT,0.0.0.0:800,255.255.255.255:800,UDP "Ben" <notben@home.com> wrote in message news:9mhion$2hf9$1@news.grc.com... > Can someone tell me the function of this scan? > FWIN,2001/08/28,20:06:43 -6:00 GMT,0.0.0.0:800,255.255.255.255:800,UDP Ben, I haven't a clue. 800 TCP mdbs_daemon 800 UDP mdbs_daemon http://www.robertgraham.com/pubs/firewall-seen.html http://www.robertgraham.com/pubs/firewall-seen.html#3.6 http://www.robertgraham.com/pubs/firewall-seen.html#3.2 -- ...

0.0.0.0 ????
Obviously a local IP, but what are its functions/purpose? Thanks for educating the uneducated. In article <MPG.18bf7ade16e851cb989680@news.grc.com>, shr@p.com says... > > > Obviously a local IP, but what are its functions/purpose? > > Thanks for educating the uneducated. > Any available adapter - i.e. not bound to specific IP address. -- Bloated Elvis In article <MPG.18bf7ade16e851cb989680@news.grc.com>, shr@p.com says... > > > Obviously a local IP, but what are its functions/purpose? > > Thanks for educating the une...

ASE12.0.0.3 -> RS11.5 -> ASE12.0.0.3 on NT
hello, I would like to know if anyone successfully using this config or had any problem. thanks for any infor. Some time we using that config without any problem ...

Running PB 3.0, 4.0, 5.0 and 6.0 on same PC
I am attempting to run PowerBuilder 3, 4, 5 (both 16 and 32 bit), and 6 on the same PC. I know that sounds crazy but all of those releases are still in use at my company. The only problem I am having is I can't get 6.0 to use its own pb.ini file. I am running NT 4.0 and have made the following entries in my WIN.INI in the [Powerbuilder] section: INITPATH=c:\...... statement for PB3, INITPATH040 for PB4, INITPATH050 for PB5, and INITPATH060 for PB6. This method works for PB3, 4, and 5 but not 6. PB6 seems to be using the INITPATH statement but ignores the INITPATH060 statement. M...

New versions after 1.5.0.12 2.0.0.3 and 2.0.0.4 do not work properly
Name: Jelle van Buuren Email: jelleatvan-buurendotnet Product: Firefox Summary: New versions after 1.5.0.12 2.0.0.3 and 2.0.0.4 do not work properly Comments: Helleo, I'm sorry to say I am not a webdeveloper expert at all, just a loyal and up till now satisfied daily user. I got lost in your official bug-reports-system, so had to do it this way. I don't even know if my problem can be called a bug, but please take a look to f.i. www.nbrecords.com or www.ns.nl through the new browser FF 2.0 etc. and then do so through FF 1.5.0.12 or IExplorer and you will notice immedi...

PB 5.0.04 on NT 4.0 running MS SQL Server 7.0?
Anyone running PB 5.0.04 on MS SQL 7.0? We're running against MS SQL 6.5 and are considering upgrading to take advantage of some of the new features. Are there new SQL drivers available or required? TIA, pat yuen pyuen@carmafinancial.com 5.0.04 doesn't work with SQL7, you'll need to upgrade to PB 6.5.1 or 7.0 Simon Pat Yuen wrote in message ... >Anyone running PB 5.0.04 on MS SQL 7.0? We're running against MS SQL 6.5 >and are considering upgrading to take advantage of some of the new features. >Are there new SQL drivers available or required?...

63.0.0.0.0/255..0.0.0
Has anyone ever heard of this or know where it goes to.It was asking permission to act as a server? Thanks in advance for any help. "pb" <nothing@nomail.com> wrote in message news:9pa1u4$38b$1@news.grc.com... > Has anyone ever heard of this or know where it goes to.It was asking > permission to act as a server? Thanks in advance for any help. If it shows in your firewall log, can you post a copy of it? -- � -- Robert grc.com forum FAQ - http://grc.com/discussions.htm grc.com forum quick reference - http://grc.com/nntpquickref.htm grc.com forum disclaim...

Slow network response after upgrading from 5.5.0.4 to 6.0.0.643
Hi. I upgraded my DB from 5.5.0.4 to 6.0.0.643, since the upgrade the Data Transfer from the server to the clients become very slow. 1. To upgrade my DB I used the upgrade database util from the central of ASA6. (Success) 2. My Command Line on the server is: "C:\Program Files\Sybase\Adaptive Server Anywhere 6.0\win32\dbsrv6.exe" -nWinOM -c 16M -x tcpip{Host=10.0.0.1} C:\Projects\Projects\WinOM\DB\WINOM0001.DB On the Client Side I am running ODBC. ODBC Configuration for Adaptive Server AnyWhere Login TAB --------------- UserID: dba Password: sql Da...

Firefox 2.0.0.3 and 2.0.0.4
In order to fix a small number of serious regressions, we are looking to do a very quick 2.0.0.3/1.5.0.11 release to pick up some fixes for recent regressions. 2.0.0.4/1.5.0.12 will be the next regular security/stability releases. 2.0.0.3 blockers https://bugzilla.mozilla.org/buglist.cgi? keywords_type=nowords&keywords=fixed1.8.1.3 +verified1.8.1.3&field0-0-0=flagtypes.name&type0-0-0=equals&value0-0-0=b locking1.8.1.3%2B&order=map_assigned_to.login_name,bugs.bug_id We are going to be looking at nominations over the next few days, based on the follo...

PB 5.0.4 and ASA 6.0.3 with ODBC 3.0.28.xxx
Hi, I've tried applying ODBC 3.0.28 over the 3.0.51 version from ASA 6.0.3 and still have problems, but this time it's the "no catalogue tables" and "xxx has no columns" when opening a table. No database access is successful. I've applied the PB 5.0.4 EBF #3 from the support library too. Please help. Thanks and regards, Andre Lipinski hello... I'm facing the same problem but my PB is version 6.5.1 Any solution yet from sybase pertaining to the problem........ Thanks a lot Andre Lipinski <AndreL@globalserve.net> wrote in messa...

RC 3.0 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008051206 Firefox/3.0
Name: Jonathan Dudley Email: jdudleydotieatgmaildotcom Product: Firefox Release Candidate Summary: RC 3.0 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008051206 Firefox/3.0 Comments: In google maps (maps.google.com) I get messages saying "no maps at this zoom level for this region" many times at different zoom levels where this works fine in Firefox 2.0 and in IE. The maps are for Ireland - and there has always been full maps in the areas I am looking at before. Thanks. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Ge...

Pbuilder 4.0.5 and SA 5.0.5
I'm concerned about connecting from PB 4.0.5 to SA 5.0.5. I tried from ISQL and everything works fine but when defining my profile from PB it just doesn't connect. Has anybody stablished an Transact SQL DB in SA and connected from PB, when I tried setting the quoted_identifier = OFF it complains about the PRECISION option. thank's in advance. Ruben Valenzuela Here is a portion of one of our faxlines. I'm assuming that you are using 16-bit PB. To see other faxlines call (508) 287-1600 Faxline Document 4477 Connecting 16-bit ODBC Applications to a 32-bi...

stalled or no download: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.3) Gecko/20060425 SUSE/1.5.0.3-7 Firefox/1.5.0.3
I experience stalled or no download of all (not only specific web-sites) using firefox while another browser "Konquereor" is working normally. Firefox is looking up.. connecting... transfering and then stalled sometimes I get the message "I cant find the server", suprisingly because the status shows transfering, or a login window for the router shows up what has not been seen with the other web browser. A second Linux PC in the network is working as supposed, the router is wide open... connection settings are alredy checked. May be anybody has a hint? Ber...

Web resources about - SA 5.0.0.3 slow down on NT 4.0 server - sybase.sqlanywhere.general

X.Org Server - Wikipedia, the free encyclopedia
X.Org Server refers to the X server release packages stewarded by the X.Org Foundation , which is hosted by freedesktop.org , and grants public ...

Windows Server 2016 moving to per core, not per socket, licensing
Windows Server 2016, not likely to arrive until the second half of next year, is going to shake up the way Microsoft licenses its server operating ...

Intel Rising: Server Stronger Than Ever, Says JMP; Here Comes Apple?
... stock to Market Outperform from Market Perform, assigning a $45 price target, righting that the company will strengthen its hold on its server ...

Server shipments, vendor revenue go up in Q3 2015
In the third quarter of 2015, worldwide server shipments grew 9.2 percent from the third quarter of 2014, while vendor revenue increased 7.5 ...

Bloodborne servers taken down for 'emergency maintenance'
An exploit and other "serious issues" have been detected.

PR Guru Working For Clinton Server IT Firm Donated To Hillary’s Campaign
PR Guru Working For Clinton Server IT Firm Donated To Hillary’s Campaign

Quanta, Wiwynn see more orders from server clients for 2016
Quanta Computer and Wiwynn, a server subsidiary of Wistron, are expected to land more cloud server orders from their clients in 2016 as Internet ...

Server Files Sexual Harassment Complaint Against Pigalle Restaurant
... restaurant Pigalle is being accused of sexual harassment by a waitress , who says that management implied her jeans were "too much." The server ...

Hyper-V, PowerShell Top IT Pros' Windows Server 2016 Wish List
Container support is nice, but most IT pros are looking forward to Hyper-V virtualization updates and new PowerShell capabilities.

Many Android apps talk to private servers — and it’s often not clear why
A new report finds that a significant percentage of Android applications engage in covert communication but it's not always clear who they are ...

Resources last updated: 12/5/2015 3:15:52 AM