Powerbuilder 10.5.1 and ClearCase LT 7.0.0.1 problem

Hi,

Sorry for the long post (you'll see. :))

I've been trying to get Powerbuilder 10.5.1 to work with
ClearCase LT 7.0.0.1, but even though PB is able to connect
to ClearCase, and the Orcascript can populate the PBLs just
fine, when I add the target to the PB workspace, all objects
are displayed with a "+" next to them, as if nothing
(including the target) is under version control.

Here's a quick rundown of how we do things:

- We have four environments: Production, Acceptance, Test
and Development.  These are set up in a "hierarchy" (wrong
terminology, I'm sure) in Clearcase:

	PROD
	----Acceptance
	      ----Test
	          ---- Dev

This is setup as a UCM project, since we will be using
ClearQuest for tracking our work.

We initially created a PROD view in ClearCase, and used
Powerbuilder to add the project to source control.  This
worked relatively well, although for each object it did
complain about not finding the exported files (kind of odd,
considering it had not created any of them yet.)  However,
this did not prevent things from working on a first test we
did last month (only one environment, under Base (rather
than UCM) ClearCase.  I just assumed it was one of many PB
peculiarities.

Now this is where things get cute.  Since this will work in
such a way that DEV work is eventually promoted to Test,
then Acceptance and ultimately Prod, the other three
environments were loaded using a Clearcase command line tool
(I believe it's clearfstool.)  This was done by the
ClearCase administrator.  Essentially this only loads the
differences between each environment, rather than all the
code.  For example: If only 5 objects differ between
Acceptance and Prod, then the tool only loaded the code for
those 5 objects.  Since Acceptance is a "child" of Prod,
ClearCase knows where to get the other files when creating a
view.

To get the files for those three environments, we just used
"PBNative" and selected an output directory for the export
files.  The ClearCase command line tool did the rest,
essentially doing a "diff" between those exported files and
what is in PROD.

Alright, so everybody is now happily into its place in
ClearCase.  Here's how I (try to) get Powerbuilder to play:

1) We create a view in ClearCase - this creates the
directory structure, with all the export files ready to be
loaded into the PBLs.  We create our views under a directory
named Viewstore.  So, for example, TEST would be loaded
into: U:\Viewstore\renamic_BP2000_BP2T.   The PB code is a
bit further down:
U:\Viewstore\renamic_BP2000_BP2T\SDD_BP2000_GUI\PBGUI.

2) Open Powerbuilder and create a new workspace under
U:\Viewstore\renamic_BP2000_BP2T\SDD_BP2000_GUI\PBGUI.  I
then set the SCC properties:

Source code control system: ClearCase

User ID: renamic

Project:  ***** I left this blank - the ellipsis doesn't do
anything. This worked on Base ClearCase and I'm wondering
what I should put in there (if anything.)  I tried using the
same as the local root directory, as well as
U:\Viewstore\renamic_BP2000_BP2T (where view.dat is
located), but no go.

Local Root directory:
U:\Viewstore\renamic_BP2000_BP2T\SDD_BP2000_GUI\PBGUI

I then click on Connect.  This sometimes work, sometimes I
have to close the workspace and reopen it.  Go figure.

After that I have an Orcascript that creates the PBLs and
populates them:

start session
create library "bp2000.pbl" "Main BP2000 Program"
create library "datawind\datawind.pbl" "Data window Library"
create library "dddw\dddw.pbl" "Drop Down Data Window
Library"
create library "dwbatch\dwbatch.pbl" "BATCH Data Window
Library"
create library "dwcntrl\dwcntrl.pbl" "CONTROL Data Window
Library"
create library "dwcodset\dwcodset.pbl" "CODESET Data Window
Library"
create library "dwinstr\dwinstr.pbl" "INSTRUMENT Data Window
Library"
create library "dwle\dwle.pbl" "LEGAL ENTITY Data Window
Library."
create library "dwlink\dwlink.pbl" "LINK Data Window
Library"
create library "dwmerger\dwmerger.pbl" "MERGER Data Window
Library"
create library "dwrefer\dwrefer.pbl" "REFERENCE Data Window
Library"
create library "dwsource\dwsource.pbl" "SOURCE DATA  Data
Window Library"
create library "dwsps\dwsps.pbl" "SPS - LONG TERM Data
Window Library"
create library "dwtrans\dwtrans.pbl" "Instrument TRANSACTION
Data Window Library"
create library "function\function.pbl" "Function Library"
create library "report\report.pbl" "Report Library"
create library "structur\structur.pbl" "Structure Library"
create library "userobj\userobj.pbl" "User Object Library"
create library "window\window.pbl" "Window library"
create library "wnbatch\wnbatch.pbl" "BATCH Window Library"
create library "wncntrl\wncntrl.pbl" "CONTROL Window
Library"
create library "wncodset\wncodset.pbl" "CODESET Window
Library"
create library "wninstr\wninstr.pbl" "INSTRUMENT Window
Library"
create library "wnle\wnle.pbl" "LEGAL ENTITY Window Library"
create library "wnlink\wnlink.pbl" "LINK Window Library"
create library "wnmerger\wnmerger.pbl" "MERGER Window
Library"
create library "wnrefer\wnrefer.pbl" "REFERENCE Window
Library"
create library "wnsource\wnsource.pbl" "SOURCE DATA  Window
Library"
create library "wnsps\wnsps.pbl" "SPS - LONG TERM Window
Library"
create library "wntrans\wntrans.pbl" "Instrument TRANSACTION
Window Library."
create library "zzzadwin\zzzadwin.pbl" "Template DataWindow
Objects"
create library "zzzafunc\zzzafunc.pbl" "Template Global
Function Objects"
create library "zzzamenu\zzzamenu.pbl" "Template Menu
Objects"
create library "zzzastru\zzzastru.pbl" "Template Structure
Objects"
create library "zzzauobj\zzzauobj.pbl" "Template User
Objects"
create library "zzzawin\zzzawin.pbl" "Template Window
Objects"
SCC get connect properties "bp2000.pbw"
scc set connect property logfile "fullupdate.log"
SCC Connect
SCC set target "ap_bop_am.pbt" "REFRESH_ALL IMPORTONLY"
SCC refresh target "full"
SCC Close
end session

This worked fine on Base Clearcase.  In fact, it appears to
work fine here as well - no errors are logged (except for
two PBLs whose objects we exclude from source control, but
it doesn't seem to prevent the script from terminating
properly.  Here's the end of the log:

Bootstrapping Application...
PBORCA_SccRefreshTarget. Full Rebuild
Unable to process map file:
u:\viewstore\renamic_bp2000_bp2000\sdd_bp2000_gui\pbgui\menu\menu.pbg
u:\viewstore\renamic_bp2000_bp2000\sdd_bp2000_gui\pbgui\menu\menu.pbl
cannot be refreshed.
Unable to process map file:
u:\viewstore\renamic_bp2000_bp2000\sdd_bp2000_gui\pbgui\zzzadwin\zzzadwin.pbg
u:\viewstore\renamic_bp2000_bp2000\sdd_bp2000_gui\pbgui\zzzadwin\zzzadwin.pbl
cannot be refreshed.
Calling cm_rebuild_application(CM_REBUILD_FULL).
PBORCA_SccClose
26/06/2007   13:45 Source control terminated

My first intuition was that the problem was that Acceptance,
Test and Dev were not loaded directly using PB (even though
ClearCase did create the view correctly, so this shouldn't
be an issue in PB...  So anyway, I created a PROD view,
hoping it was just a matter of "load via PB", but ended up
with the same problem: PB connects fine to ClearCase, but
every object has a "+" beside it.  This is driving me nuts.

Not that since this is ClearCase LT, we have to use snapshot
views, since it doesn't support dynamic views.  That
probably does not matter much anyway.

So anyway, if anyone out there has any idea, or could
describe how they are successfully using the
PB/ClearCase/UCM combination, that would be much
appreciated.  I have the feeling that the Project field has
something to do with it, but I've tried just about
everything I could think of, including a few things that
literally crashed PB. :)

thanks!
Michel
0
Michel
6/27/2007 7:05:04 PM
sybase.source-control 1715 articles. 0 followers. Follow

0 Replies
1087 Views

Similar Articles

[PageSpeed] 12
Get it on Google Play
Get it on Apple App Store

Reply:

Similar Artilces:

superreview granted: [Bug 300819] Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 : [Attachment 189342] Bump Fx version to 1.0.6, GRE to 1.7.10
Brian Ryner <bryner@brianryner.com> has granted Chase Phillips <chase@mozilla.org>'s request for superreview: Bug 300819: Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/show_bug.cgi?id=300819 Attachment 189342: Bump Fx version to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/attachment.cgi?id=189342&action=edit ...

superreview requested: [Bug 300819] Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 : [Attachment 189342] Bump Fx version to 1.0.6, GRE to 1.7.10
Chase Phillips <chase@mozilla.org> has asked David Baron <dbaron@mozillafoundation.org> for superreview: Bug 300819: Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/show_bug.cgi?id=300819 Attachment 189342: Bump Fx version to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/attachment.cgi?id=189342&action=edit ...

Updates after 1.5.0.7 (1.5.0.9, 2.0.0.1)can't access the web.
Name: Jay Product: Firefox Summary: Updates after 1.5.0.7 (1.5.0.9, 2.0.0.1)can't access the web. Comments: see summary Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7 ...

stalled transfer Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.3) Gecko/20060425 SUSE/1.5.0.3-7 Firefox/1.5.0.3
I experience stalled or no download of all (not only specific web-sites) using firefox while another browser "Konquereor" is working normally. Firefox is looking up.. connecting... transferring and then stalled sometimes I get the message "I cant find the server", surprisingly because the status shows transferring, or a login window for the router shows up what has not been seen with the other web browser. A second Linux PC in the network is working as supposed, the router is wide open... connection settings are already checked. May be anybody has a hint? ...

stalled or no download: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.3) Gecko/20060425 SUSE/1.5.0.3-7 Firefox/1.5.0.3
I experience stalled or no download of all (not only specific web-sites) using firefox while another browser "Konquereor" is working normally. Firefox is looking up.. connecting... transfering and then stalled sometimes I get the message "I cant find the server", suprisingly because the status shows transfering, or a login window for the router shows up what has not been seen with the other web browser. A second Linux PC in the network is working as supposed, the router is wide open... connection settings are alredy checked. May be anybody has a hint? Ber...

Problem Building firefox 1.5.0.7 and 1.5.0.9
Hello! I'm trying to compile both firefox 1.5.0.7 and 1.5.0.9 in a Fedora Core 6 to build a new extension. However, I'm getting the problem that I attach bellow.... My mozconfig file is: mk_add_options MOZ_CO_PROJECT=browser # add other common options here, such as making a static release build and # disabling tests ac_add_options --enable-optimize --disable-debug ac_add_options --disable-tests # Build Firefox mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/firefox-static ac_add_options --enable-application=browser and I compile using: #!/bin/bash export MOZCONF...

Need Basic Assistance setting up PB 10.5.1 Build 6021 application in ClearCase 7.0.0.1
Greetings to all, I've been working with PowerBuilder since the 4.0 days and I've worked with various source control systems - no problem until I meet ClearCase(either that, or I'm losing my mind!). Any way, as the long subject line says, I need basic assistance, a step-by-step guide, if possible. Here's where I'm at. I've converted the app from PB 6.5 to 10.5 and cleaned up the "edges". I've got a directory tree set up with a master directory and a subdirectory beneath it for each PBL. I've placed each PBL in it's subdirectory and...

Thunderbird 1.5.0.5 and 1.0.7
Name: Douglas Boyd Email: drboyd_at_charter.net Product: Firefox Summary: Thunderbird 1.5.0.5 and 1.0.7 - Layout control non functional Comments: View/Layout/ (classic, wide and vertical) don't work. I installed 1.5.0.5 first. Layout control worked a couple of times and then quit(stayed on vertical) no matter if I selected classic or wide. SO, I unintalled 1.5.0.5 and installed 1.0.7 hoping to correct the problem. But, I found the layout control in 1.0.7 wouldn't work either. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.6) Gecko/200...

EAServer 5.3.0, Oracle 8.1.7 Database with Oracle 10.1.0.2 client VARCHAR2(4000) problem
Hello! I'm having some problems in this configuration on Windows XP. I am developing websites on an Oracle database (8.1.7), with EAServer 5.3.0 (build 53016), Java objects using JSP as a front end. Here is my problem, I have a table with 2 VARCHAR2(4000), and when I access the webpage, the they are displayed as '?????????????'. If I debug the PB component, when I affect the DW field to a variable, it displays it as it doesn't "understand" a thing (each character is replaced by a square). The codeset of EAServer is UTF8, and on my client, it is AM...

Problem with some links since upgrade Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Name: Nick Product: Firefox Summary: Problem with some links since upgrade Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1 Comments: Hi, I encountered some problem to click links that i used to be able to click with the previous Firefox, i paste a link to let you experience it too http://shop33455054.taobao.com/?catId=39839020&queryType=cat&categoryName=%C8%AB%B3%A1175%D4%AA+C1RCA&browseType=#pagebar as you can see the sub-categories can't be browsed (talking about the menu on the left side) i tried again with the pr...

Is it just me or has the Fandango site stopped working with FF (1.5.0.7, 1.5.0.9, 2.0) on eComStation 1.2 ?
Hi all, I've possibly messed up my Firefox installations, but other pages still seem to work OK. Has anyone else had problems recently with http://www.fandango.com ? The home page comes up, and then completely hangs my system, and even if I ctrl-alt-delete and kill Firefox with TOP, I just get a black screen and have to re-boot. It used to work fine. If it's just me, does anyone have any advice for what might be happening or how to go about figuring it out ? Thanks in advance, Karen Roberts On Sat, 3 Mar 2007 19:13:13 UTC, Karen Roberts <kvroberts@comcast.net>...

superreview granted: [Bug 362139] bump SeaMonkey versions to 1.0.7/1.1 on 1.8.0/1.8 branches, localeVersion to 1.8.1 on 1.8 branch : [Attachment 246921] 1.8.0 patch: SeaMonkey version -> 1.0.7
neil@parkwaycc.co.uk <neil@httl.net> has granted Robert Kaiser <kairo@kairo.at>'s request for superreview: Bug 362139: bump SeaMonkey versions to 1.0.7/1.1 on 1.8.0/1.8 branches, localeVersion to 1.8.1 on 1.8 branch https://bugzilla.mozilla.org/show_bug.cgi?id=362139 Attachment 246921: 1.8.0 patch: SeaMonkey version -> 1.0.7 https://bugzilla.mozilla.org/attachment.cgi?id=246921&action=edit ...

superreview requested: [Bug 362139] bump SeaMonkey versions to 1.0.7/1.1 on 1.8.0/1.8 branches, localeVersion to 1.8.1 on 1.8 branch : [Attachment 246921] 1.8.0 patch: SeaMonkey version -> 1.0.7
Robert Kaiser <kairo@kairo.at> has asked neil@parkwaycc.co.uk <neil@httl.net> for superreview: Bug 362139: bump SeaMonkey versions to 1.0.7/1.1 on 1.8.0/1.8 branches, localeVersion to 1.8.1 on 1.8 branch https://bugzilla.mozilla.org/show_bug.cgi?id=362139 Attachment 246921: 1.8.0 patch: SeaMonkey version -> 1.0.7 https://bugzilla.mozilla.org/attachment.cgi?id=246921&action=edit ------- Additional Comments from Robert Kaiser <kairo@kairo.at> This is the 1.8.0 branch patch for bumping SeaMonkey version to 1.0.7 ...

Smoke [5.10.1] perl-5.10.1-RC1-1-gbadf489 FAIL(F) netbsd 5.0.1 (i386/1 cpu)
Automated smoke report for 5.10.1 patch badf48949ef0f6be41c06a682330f4aa37c4f4ff perl-5.10.1-RC1-1-gbadf489 p5netbsd: Intel 686-class (i386/1 cpu) on netbsd - 5.0.1 using cc version 4.1.3 20080704 prerelease (NetBSD nb2 20081120) smoketime 9 hours 14 minutes (average 1 hour 9 minutes) Summary: FAIL(F) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (after miniperl), t = ...

Web resources about - Powerbuilder 10.5.1 and ClearCase LT 7.0.0.1 problem - sybase.source-control

PowerBuilder - Wikipedia, the free encyclopedia
PowerBuilder is an integrated development environment owned by Sybase , a division of SAP . It has been in use since 1991, peaking around 1998 ...

Sybase PowerBuilder tool readied for Microsoft's .Net
... Win32 or newer style .Net development After several years of work, Sybase is ready to deliver on the final step in its plan to move PowerBuilder ...

Jim O'Neil (@jimoneil) on Twitter
Sign in Sign up To bring you Twitter, we and our partners use cookies on our and other websites. Cookies help personalize Twitter content, tailor ...

Open Directory - Computers: Programming: Languages
about dmoz - dmoz blog - report abuse/spam - help the entire directory only in Programming/Languages Description Top : Computers : Programming ...

The HP Booth Staff (Goons) Owe Me an Apology
... when you might need to use it. For instance, when I was in the WinRunner world there were plugins for driving terminal emulators and powerbuilder ...

Contact Us - Sybase Inc
Thanks for visiting the 主页 section of Sybase.com. Here you will find information about Contact Us. For more information about Business Intelligence, ...

热门搜索 - 我的异常网
... 我的异常网 » 热门搜索 sdpnet2 移动【A111】其它用户原因鉴权失败,是什么意思啊 http:// 192.168.1.102:22578 本网站服务器位于美国,受美国法律保护 MiniUI js 破解 http://192.168.1.103:8080/ powerbuilder ...

Mobile app security: Always keep the back door locked
The best way to keep mobile apps safe is to secure the services they connect to.

10 Tech Skills That Will Instantly Net You A $100,000+ Salary
... that let's developers run Java applications. Java is highly popular language for writing web apps and custom enterprise apps. No. 8: PowerBuilder ...

Top Ranked Articles
Top Ranked Articles - Free source code and tutorials for Software developers and Architects.; Updated: 23 Feb 2013

Resources last updated: 12/7/2015 10:42:18 PM