From AppModeler 6.1.0 to 6.1.5

Hi,

I just installed PowerDesigner AppModeler 6.1.5. I was using version
6.1.0 before.

Is there any migration procedure to follow for my models created with
6.1.0 ?

With 6.1.5 the comparison between the PDM and the APM seems not to work.
The Menu Item �Database | Modify Database� detects changes where there
are none.

What could be the problem ?

Simon.
0
Simon
1/11/2001 4:51:56 PM
sybase.powerdesigner.general 9408 articles. 1 followers. Follow

3 Replies
542 Views

Similar Articles

[PageSpeed] 1

I think the archive created with 6.1.0 may not be 100% compatible with 6.1.5.  I
seem to remember them adding fields to the file somewhere in there.  If you have
a backup copy of the PDM, then you should open that in 6.1.5 and re-archive it.
Then open the current model in 6.1.5 and do the Modify Database.  Let me know
what happens.

--

Michael F. Nicewarner [TeamSybase]
mailto:psyclo@datamodel.org
http://www.datamodel.org


"Simon Blais" <SBlais@cegep-fxg.qc.ca> wrote in message
news:3A5DE4AC.F8B11016@cegep-fxg.qc.ca...
> Hi,
>
> I just installed PowerDesigner AppModeler 6.1.5. I was using version
> 6.1.0 before.
>
> Is there any migration procedure to follow for my models created with
> 6.1.0 ?
>
> With 6.1.5 the comparison between the PDM and the APM seems not to work.
> The Menu Item �Database | Modify Database� detects changes where there
> are none.
>
> What could be the problem ?
>
> Simon.


0
Michael
1/12/2001 3:23:33 PM
Il s'agit d'un message multivolet au format MIME.
--------------E9F209C3F9A38CFFF583527D
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit

Sorry if the answer comes so late...

We already tried this. We even created a new model from scratch, archived it and
tried the compare with no more success. The generated file still
drops all tables, wether there are changes or not.  To be precise, the problem
occurs whenever we check the "create temporary tables" option. If we
do not check this option, the compare seems to detect real changes only but then,
the generate script is often unacceptable for an Oracle database
because sometimes, you do have to create temporary tables to perform certain changes
(ex: changing a columns datatype).


"Michael F. Nicewarner [TeamSybase]" a �crit :

> I think the archive created with 6.1.0 may not be 100% compatible with 6.1.5.  I
> seem to remember them adding fields to the file somewhere in there.  If you have
> a backup copy of the PDM, then you should open that in 6.1.5 and re-archive it.
> Then open the current model in 6.1.5 and do the Modify Database.  Let me know
> what happens.
>
> --
>
> Michael F. Nicewarner [TeamSybase]
> mailto:psyclo@datamodel.org
> http://www.datamodel.org
>
> "Simon Blais" <SBlais@cegep-fxg.qc.ca> wrote in message
> news:3A5DE4AC.F8B11016@cegep-fxg.qc.ca...
> > Hi,
> >
> > I just installed PowerDesigner AppModeler 6.1.5. I was using version
> > 6.1.0 before.
> >
> > Is there any migration procedure to follow for my models created with
> > 6.1.0 ?
> >
> > With 6.1.5 the comparison between the PDM and the APM seems not to work.
> > The Menu Item �Database | Modify Database� detects changes where there
> > are none.
> >
> > What could be the problem ?
> >
> > Simon.

--
Simon Blais, analyste
Coll�ge Fran�ois-Xavier-Garneau,
688-8310 (2359).


--------------E9F209C3F9A38CFFF583527D
Content-Type: text/x-vcard; charset=us-ascii;
 name="SBlais.vcf"
Content-Transfer-Encoding: 7bit
Content-Description: Carte pour Simon Blais
Content-Disposition: attachment;
 filename="SBlais.vcf"

begin:vcard 
n:Blais;FXG-Simon
x-mozilla-html:FALSE
adr;dom;quoted-printable:;;1609, du Petit-Prince=0D=0AL'Ancienne-Lorette;;;G2E 5N9;
version:2.1
email;internet:SBlais@cegep-fxg.qc.ca
note:cellulaire: 571-4538
x-mozilla-cpt:;0
tel;home:877-4368
fn:FXG-Simon Blais
end:vcard

--------------E9F209C3F9A38CFFF583527D--

0
Simon
2/2/2001 4:16:20 PM
Try the following:

Repost from "Modify Database problem again" 8/7/00


This sounds like a case where the internal OID numbers are mixed up in
the file format.  The way to correct this is to delete and recreate
the objects that are being generated in error.

To save time, you may want to do the following:
1) Create a copy of the table
2) Move all references from the orginal table to the copy
3) Delete the orginal table
4) Rename the copy of the table to the original table name.

HTH,
Anthony Hill
PowerDesigner Product Support


On Fri, 02 Feb 2001 11:16:20 -0500, Simon Blais
<SBlais@cegep-fxg.qc.ca> wrote:

>Il s'agit d'un message multivolet au format MIME.
>--------------E9F209C3F9A38CFFF583527D
>Content-Type: text/plain; charset=iso-8859-1
>Content-Transfer-Encoding: 8bit
>
>Sorry if the answer comes so late...
>
>We already tried this. We even created a new model from scratch, archived it and
>tried the compare with no more success. The generated file still
>drops all tables, wether there are changes or not.  To be precise, the problem
>occurs whenever we check the "create temporary tables" option. If we
>do not check this option, the compare seems to detect real changes only but then,
>the generate script is often unacceptable for an Oracle database
>because sometimes, you do have to create temporary tables to perform certain changes
>(ex: changing a columns datatype).
>
>
>"Michael F. Nicewarner [TeamSybase]" a �crit :
>
>> I think the archive created with 6.1.0 may not be 100% compatible with 6.1.5.  I
>> seem to remember them adding fields to the file somewhere in there.  If you have
>> a backup copy of the PDM, then you should open that in 6.1.5 and re-archive it.
>> Then open the current model in 6.1.5 and do the Modify Database.  Let me know
>> what happens.
>>
>> --
>>
>> Michael F. Nicewarner [TeamSybase]
>> mailto:psyclo@datamodel.org
>> http://www.datamodel.org
>>
>> "Simon Blais" <SBlais@cegep-fxg.qc.ca> wrote in message
>> news:3A5DE4AC.F8B11016@cegep-fxg.qc.ca...
>> > Hi,
>> >
>> > I just installed PowerDesigner AppModeler 6.1.5. I was using version
>> > 6.1.0 before.
>> >
>> > Is there any migration procedure to follow for my models created with
>> > 6.1.0 ?
>> >
>> > With 6.1.5 the comparison between the PDM and the APM seems not to work.
>> > The Menu Item �Database | Modify Database� detects changes where there
>> > are none.
>> >
>> > What could be the problem ?
>> >
>> > Simon.
>
>--
>Simon Blais, analyste
>Coll�ge Fran�ois-Xavier-Garneau,
>688-8310 (2359).
>
>
>--------------E9F209C3F9A38CFFF583527D
>Content-Type: text/x-vcard; charset=us-ascii;
> name="SBlais.vcf"
>Content-Transfer-Encoding: 7bit
>Content-Description: Carte pour Simon Blais
>Content-Disposition: attachment;
> filename="SBlais.vcf"
>
>begin:vcard 
>n:Blais;FXG-Simon
>x-mozilla-html:FALSE
>adr;dom;quoted-printable:;;1609, du Petit-Prince=0D=0AL'Ancienne-Lorette;;;G2E 5N9;
>version:2.1
>email;internet:SBlais@cegep-fxg.qc.ca
>note:cellulaire: 571-4538
>x-mozilla-cpt:;0
>tel;home:877-4368
>fn:FXG-Simon Blais
>end:vcard
>
>--------------E9F209C3F9A38CFFF583527D--
>

0
ahill
2/2/2001 4:42:15 PM
Reply:

Similar Artilces:

kdesvn 1.0.5 or 1.0.6 for KDE 3.5 subversion 1.6.3?
Installed: Code: -------------------- Subversion 1.6.3-1.1 KDE 3.5.10 -------------------- I upgraded subversion to 1.6.3, and wanted to make sure I had the latest kdesvn for KDE 3.5 and subversion 1.6.3. I went to kdesvn support site but it wasn't clear if 1.0.5 was sufficient for subversion 1.6, so I downloaded kdesvn 1.0.6 and built it myself (previously 1.0.5 had come from opensuse). Everything looked okay, but... When I click on the Help | Info about kdesvn part I see: Code: -------------------- Built with subversion library 1.4.4 Running ...

selecting ? selecting of 1., 2. , 3., 4., 5., 6. is slow (1-3 second) then selecting of 7.,8.,9. go on is so fast (0.1 second or more fast).. how can i get fast for selecting of 1., 2. , 3., 4., 5., 6
hello friends selecting of 1., 2. , 3., 4.(sometime even 5., 6.) is slow (1-3 second) then selecting of 7.,8.,9.(sometimes 5., 6.,) go on is so fast (0.1 second or more fast).. how can i get fast for selecting of 1., 2. , 3., 4., 5., 6. is slow ?? recordcount is almost 1.050.000.. i do selecting 1.2.3. go on same page with treeview1.. treeview1 in masterpage.master.. gridview1 and datasource1 are in pagelist.aspx (it connets datasource1)..productnumber is primarykey for index.. kategori, kategori1 and kategori2, price, datemin are index from keys/index in table1 (right clicking menu)....

Smoke [5.10.1] perl-5.10.1-6-ge94431a FAIL(F) linux 3.0.35-cm-fx6-6.1 [debian] (armv7l/4 cpu)
Automated smoke report for 5.10.1 patch e94431af0ada74486afd65207f3e0345fe7485fe perl-5.10.1-6-ge94431a utilite: ( 0MHz) (armv7l/4 cpu) on linux - 3.0.35-cm-fx6-6.1 [debian] using cc version 4.7.2 smoketime 11 hours 17 minutes (average 1 hour 36 minutes) Summary: FAIL(F) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (after miniperl), t = make test-prep perl-5.10.1-...

SOS: Sync with Oracle 8.1.6.1.0 using 8.1.6.1.0 ODBC Driver
Help! If any customer has successfully replicated bi-directionally from ASA7 to Oracle 8i (8.1.6) using the Oracle 8.1.6 Oracle ODBC Driver, we would appreciate any insight you may have concerning the small number of steps involved in implementing replication. I may be contacted directly at (206) 933-4956. Martin Douglas Senior Data Architect e-Commerce Group Food Services of America Please always specify the version and MORE importantly the BUILD number of ASA you are using with each post. If you are having problems with this Oracle driver, some of our customers hav...

[ishay@checkpoint.com: Storable 0.6.1.5 on Windown Perl 5.6.1]
----- Forwarded message from Ishay Inbar <ishay@checkpoint.com> ----- Date: Mon, 11 Feb 2002 15:52:35 +0200 From: "Ishay Inbar" <ishay@checkpoint.com> Subject: Storable 0.6.1.5 on Windown Perl 5.6.1 To: <Raphael_Manfredi@pobox.com> Cc: "Ofer Ben Ben-David" <obdavid@checkpoint.com> X-Mailer: Microsoft Outlook IMO, Build 9.0.2416 (9.0.2911.0) X-getcost: 1000500 Hi, First I want to tell you we are working with Storable a lot, and most of the time it makes our like much easier. Second, the question ? We work with Perl 5.005 on multi-pla...

Concurrent perl 5.6.0, 5.6.1, 5.8.0, and 5.8.0threaded
Hi, So, I'd like to have multiple versions of perl installed on my system, for testing stuff, poking around, etc. It's not really that difficult, actually - you just arrange that they have different @INC directories (or that they overlap in the ways you want them to), and you make /usr/bin/perl point as a symlink to whichever version you want to use regularly (probably 5.6.1). Here's what I think I'd have, creating a few fink packages to manage things for me: * /usr/bin/perl5.6.0 - Apple's perl, unmodified, @INC is: /System/Library/Perl/darwin ...

superreview granted: [Bug 300819] Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 : [Attachment 189342] Bump Fx version to 1.0.6, GRE to 1.7.10
Brian Ryner <bryner@brianryner.com> has granted Chase Phillips <chase@mozilla.org>'s request for superreview: Bug 300819: Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/show_bug.cgi?id=300819 Attachment 189342: Bump Fx version to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/attachment.cgi?id=189342&action=edit ...

superreview requested: [Bug 300819] Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 : [Attachment 189342] Bump Fx version to 1.0.6, GRE to 1.7.10
Chase Phillips <chase@mozilla.org> has asked David Baron <dbaron@mozillafoundation.org> for superreview: Bug 300819: Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/show_bug.cgi?id=300819 Attachment 189342: Bump Fx version to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/attachment.cgi?id=189342&action=edit ...

Smoke [5.13.6] v5.13.6-97-g422d053 FAIL(M) cygwin_nt-5.1 1.7.7(0.230/5/3) (x86/2 cpu)
Automated smoke report for 5.13.6 patch 422d053b400e15f0154beccd0cbcd57e26d0a23a v5.13.6-97-g422d053 philips: Genuine Intel(R) CPU T2300 @ 1.66GHz(~1663 MHz) (x86/2 cpu) on cygwin_nt-5.1 - 1.7.7(0.230/5/3) using gcc version 4.3.4 20090804 (release) 1 smoketime 30 minutes 5 seconds (average 30 minutes 5 seconds) Summary: FAIL(M) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = ...

Smoke [5.10.1] perl-5.10.1-6-ge94431a FAIL(m) netbsd 6.1.5 (i386/2 cpu)
Automated smoke report for 5.10.1 patch e94431af0ada74486afd65207f3e0345fe7485fe perl-5.10.1-6-ge94431a philips.bandsman.co.uk: Intel 686-class (i386/2 cpu) on netbsd - 6.1.5 using cc version 4.5.3 smoketime 1 minute 9 seconds (average 1 minute 9 seconds) Summary: FAIL(m) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (after miniperl), t = make test-prep perl-5.10.1-...

NW 6.5 Upgrade from NW 5.1 SP 6 and Edir 8.7.1.1
Heres a good one. Current config. nw 5.1 sp 5 with edir 8.7.0.3 We upgraded our NW 5.1 to SP 6, Then to edir 8.7.1, But an error poped up "Unable to update the data base" hit enter and it continued. Then went to 8.7.1.1. Loaded nw 5.1 ran health check and dsrepair. No errors. Go figure ?????? Loaded "startx" at the console and started the upgrade. It ran through the copy process of both cd's and then rebooted. Server came back up in the "Install mode" copied a bunch of drivers, then went to a GUI screen. Made our selections of what we wanted to...

Can the PB 6.5 or 6.5.1 maintenance release be ran on PB 6.0
Yes. ...

Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6
After I upgraded to 1.5.0.5, I noticed that my forward and back mouse buttons weren't working anymore. They still work in IE, so I'm forced to think that it is firefox. When I went to .0.6, the buttons still don't work it ff, and still work in IE. Is there some little thing that I am just being stupid about or is this an actual issue? For the record, my mouse is a Logitech MX Laser, and I'm running WinXP SP2. Thanks for any help! Sheila gwtc wrote: > Sheila Stading wrote: >> After I upgraded to 1.5.0.5, I noticed that my forward and back mouse ...

Smoke [5.6.2] maint-5.6-3-g2bce232 FAIL(m) linux 3.1.0-1-amd64 [debian] (x86_64/8 cpu)
Automated smoke report for 5.6.2 patch 2bce2321552345ccb985b6a4b87542c3eaefbac5 maint-5.6-3-g2bce232 gateway: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz (GenuineIntel 3392MHz) (x86_64/8 cpu) on linux - 3.1.0-1-amd64 [debian] using cc version 4.6.2 smoketime 20 seconds (average 20 seconds) Summary: FAIL(m) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (after miniperl), t =...

Web resources about - From AppModeler 6.1.0 to 6.1.5 - sybase.powerdesigner.general

Resources last updated: 11/30/2015 12:11:57 AM