"Out of Memory" in creating DW's as post script

PB = v6.5.1
DBMS = Sybase 11.5.1 (Soon Moving to 12)
OS = NT4
PRINTER=HP LaserJet 8100 Series PS
RAM = 400MB
VirtualMemory = 350MB

Hello All,

I'm using DW's to print reports as post script (then distilled to PDF). I do
this by (1) Retrieve() my data, (2) Setting the DW's Filename =
'c:\reports\rpt_name.prn' method to set the path and file name, and (3)
issuing a print() on the DW...then on to the next report.

Some of the reports are rather large up to 3,500 pages and 100 MB+. A couple
of the reports are large and they are getting "ERROR","Out of Memory" error
messages with no partial report, nothing. In watching task manager the
reports are only using at most 250MB of RAM. I've searched the solved cases
on Sybase for such errors and found nothing.....

So has anyone....come up against this before...heard of something similar to
this...had any luck using the Save to Disk method instead of the default
memory...had better luck using a different print driver....?

Thanks


0
JacobL
4/10/2001 4:47:42 PM
sybase.powerbuilder.objects 3160 articles. 0 followers. Follow

2 Replies
419 Views

Similar Articles

[PageSpeed] 12
Get it on Google Play
Get it on Apple App Store

Yes, you could probably have better luck using a different print driver....
Try it ...

HTH,

Javier Barbieri

>
"JacobL" <jacob_ll@yahoo.com> wrote in message
news:reFFrCewAHA.259@forums.sybase.com...
> PB = v6.5.1
> DBMS = Sybase 11.5.1 (Soon Moving to 12)
> OS = NT4
> PRINTER=HP LaserJet 8100 Series PS
> RAM = 400MB
> VirtualMemory = 350MB
>
> Hello All,
>
> I'm using DW's to print reports as post script (then distilled to PDF). I
do
> this by (1) Retrieve() my data, (2) Setting the DW's Filename =
> 'c:\reports\rpt_name.prn' method to set the path and file name, and (3)
> issuing a print() on the DW...then on to the next report.
>
> Some of the reports are rather large up to 3,500 pages and 100 MB+. A
couple
> of the reports are large and they are getting "ERROR","Out of Memory"
error
> messages with no partial report, nothing. In watching task manager the
> reports are only using at most 250MB of RAM. I've searched the solved
cases
> on Sybase for such errors and found nothing.....
>
> So has anyone....come up against this before...heard of something similar
to
> this...had any luck using the Save to Disk method instead of the default
> memory...had better luck using a different print driver....?
>
> Thanks
>
>


0
Alessandro
4/11/2001 3:01:57 PM
Have you tried running the report in PrintPreview mode to see if the report
actually runs OK?  If it does, then you can probably rule out RAM.  The next
thing to look at is are you printing to a print spooler?  If so, it could be
that that is running out of space.  The next thing would be to look at the
print driver to see if there has been any updates to it.  Have you tried to
print to a different printer or from a different PC?


"JacobL" <jacob_ll@yahoo.com> wrote in message
news:reFFrCewAHA.259@forums.sybase.com...
> PB = v6.5.1
> DBMS = Sybase 11.5.1 (Soon Moving to 12)
> OS = NT4
> PRINTER=HP LaserJet 8100 Series PS
> RAM = 400MB
> VirtualMemory = 350MB
>
> Hello All,
>
> I'm using DW's to print reports as post script (then distilled to PDF). I
do
> this by (1) Retrieve() my data, (2) Setting the DW's Filename =
> 'c:\reports\rpt_name.prn' method to set the path and file name, and (3)
> issuing a print() on the DW...then on to the next report.
>
> Some of the reports are rather large up to 3,500 pages and 100 MB+. A
couple
> of the reports are large and they are getting "ERROR","Out of Memory"
error
> messages with no partial report, nothing. In watching task manager the
> reports are only using at most 250MB of RAM. I've searched the solved
cases
> on Sybase for such errors and found nothing.....
>
> So has anyone....come up against this before...heard of something similar
to
> this...had any luck using the Save to Disk method instead of the default
> memory...had better luck using a different print driver....?
>
> Thanks
>
>


0
Andy
4/16/2001 7:48:43 PM
Reply:

Similar Artilces:

Deleting "to's" and "from's" on emails
Name: Rae McFarland Email: larryatmacsmachinedotcom Product: Firefox Summary: Deleting "to's" and "from's" on emails Comments: There doesn't seem to be a way to edit and email and then forward it. Some people send something I'd like to forward, but there's a whole page of previous mailing addresses. I'd like to delete them before forwarding. I've tried and the whole email gets deleted. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16 From URL: http://hendrix.mozi...

Wired's Vista "Do's" Have Some Major "Don'ts"
Wired has an article up about how to speed up Vista. While they have a couple OK tips in there, there are a couple of suggestions that caught my attention as colossally BAD. I tried to edit the wiki page to reflect this, but I was rebuffed by the original author. So much for community contributions. http://www.windows-now.com/blogs/robert/archive/2008/02/27/wireds-vista-dos-have-some-major-donts.aspx -- "Never drive faster than your ANGEL can fly" In grc.techtalk, on Fri, 14 Nov 2008 17:32:04, paradoX wrote: >Wired has an article up about how to speed up Vist...

What's with "~/" and NOT "~/" ?
In trying to deplay test projects to my provider (GoDaddy) I'm finding a consistent barfness with the form of reference that I read as "in this directory, this file"  or "~/filename.filetype". I am having to consistently strip the "~/" to make it work.Is there a way to strip off this type of reference through a preference? In the past, I've been led to believe that "filename.filetype" when in the same directory was just FINE as that -- no need for this "~/".Hints, direction, etc. welcomed and appreciated in advance ... mahalos .....

Do's anyone know of a perl script which prints only sentence line s containing either a period "." question"?"
Hello, Do's anyone know of a perl script which prints only sentence lines containing either a period "." question"?" and a "," comma. Many Thanks:) Just a beginner:) JA Hello, JA Sorry my very week english language. I have try to find a solution for your problem. But I'm a beginner to. At least. This work on my Red Hat Linux 7.1 OS If you try this:-) Copy and past everything between ==start== and ==stop== Save it in a file named misc.pl (or misc.cgi) chmod 755 misc.pl run it like this: perl misc /path/to/the/source_file >...

RE: Do's anyone know of a perl script which prints only sentence line s containing either a period "." question"?"
> -----Original Message----- > From: AMORE,JUAN (HP-Roseville,ex1) [mailto:juan_amore@hp.com] > Sent: Thursday, October 04, 2001 7:20 PM > To: Beginners@Perl. Org (E-mail) > Cc: Juan Amore (E-mail); AMORE,JUAN (HP-Roseville,ex1) > Subject: Do's anyone know of a perl script which prints only sentence > line s containing either a period "." question"?" > > > > Hello, > Do's anyone know of a perl script which prints only sentence lines > containing either a period "." question"?" > and a &quo...

Where can I find "CBO" and it's method's "InitializeObject" etc.
Hello, Anyone knows where in the code, i could find CBO and all it's methods? THX DotNetNuke.Common.Utilities.CBO Or if your looking for the file, try DNNRoot\Components\Shared\CBO.vb Dave...

Re: Do's anyone know of a perl script which prints only sentence line s containing either a period "." question"?" (fwd)
---------- Forwarded message ---------- PST! Just a little correction... Sorry.. Karl Hello, JA Sorry my very week english language. I have try to find a solution for your problem. But I'm a beginner to. At least. This work on my Red Hat Linux 7.1 OS If you try this:-) Copy and past everything between ==start== and ==stop== Save it in a file named misc.pl (or misc.cgi) chmod 755 misc.pl run it like this: perl misc /path/to/the/source_file > print_the_results Then you can open the new file named "print_the_results" and every linje with a ".&q...

Here's a headscratcher! "I" and "*"
We have a user, all of a sudden whenever he types in the body of a message from GroupWise (6.5.5), he can't type the letter "I" as in "me myself and I." When he does, what appears instead of an I is either an asterisk (*) or a dash (-). It's the wierdest thing and I can't find anything to even remotely describe this situation. At first I suspected his keyboard but he does not have this issue typing in Word or other applications, just GroupWise. Anyone ever see this? What in the world is going on there? (By the way, it's a really funny situa...

Subtitle of "What's New" video on Firefox 13 "What's New" Page
I'd seen lots of subtitle improvements on "What's New" video of Firefox 13 on Amara stayed in the draft status and wait for approve. Is there anybody follow the revision of movie on following change? Their must be problems that we showing the subtitled on "what's new" page with Amara UI, allowed peoples to improve it directly with Amara, but no mention about that they need to wait for someone's review and approve. We just can't make contributor wondering why the subtitled stay on draft for life long time. Also is there anyone who watch behind the A...

"save without compile" or "change object's view while editing it"
Since regenerating is there as a mandatory action before running, i would very much like to see PB allow the developer to save an object that's being edited, without the compile. I agree that this is not advisable, but i have been in several occasions and gone mad over it becos you know exactly where it goes wrong, but you can't save your efforts.. some time chances later PB crashes. Occasions: changed signatures, getting a (source-control soft.) newer version of other sources than the one edited could cause this, .. An alternative (satisfying) option would be the ability...

" Cannot find the script or external object that implements prefix 'fn' " error when I use "fn" prefix in xslt and I call it with ASP.NET.2.0
Hi, I’m trying to display the contents of an xml file using an xslt file. I’m using ASP.NET.2.0 and the xsltCompiledTransform method in order to achieve the transformation. Everything works fine when I don’t have xPath functions in my xslt but when I declare the namespace ‘xmlns:fn=http://www.w3.org/2005/02/xpath-functions' and I use Xpath functions in my xslt file, it comes up with the following error message : ‘Cannot find the script or external object that implements prefix 'fn'. Just to mention I use VB as a scripting language in my ASP page. Could anyone please tell me w...

Web resources about - "Out of Memory" in creating DW's as post script - sybase.powerbuilder.objects

Resources last updated: 1/16/2016 9:01:36 AM