PB runtime problem

  I've built an msi file using the PB Runtime Packager for that .net 
components that are needed for my pb 12 webform. The problem is when I 
run the msi file it wants to remove the pb 11.5 runtime on the web 
server. I can't do that because I've got pb 11.5 web services running 
that need those files. Why is the runtime packager even looking at the 
pb 11.5 files? If I choose uninstall then the pb 11.5 webservices stop 
working. Is there a setting that the packager uses to determine which 
version to package? I noticed that pbpack115.exe and pbpack120.exe are 
in the same shared folder. Any ideas?

Thanks,
Mark
0
Mark
7/30/2010 8:25:35 PM
sybase.powerbuilder.net 284 articles. 0 followers. Follow

6 Replies
651 Views

Similar Articles

[PageSpeed] 58
Get it on Google Play
Get it on Apple App Store

Hi Mark;

  Sounds like a definite bug to me.
I would suggest that you log this bug to Sybase using CaseXpress.


Regards ... Chris
President: OSUG / STD Inc.
Blog: http://chrispollach.pbdjmagazine.com
SourceForge: http://sourceforge.net/projects/stdfndclass



"Mark" <mlibner@yahoo.com> wrote in message news:4c53353f$1@forums-1-dub...
>  I've built an msi file using the PB Runtime Packager for that .net 
> components that are needed for my pb 12 webform. The problem is when I 
> run the msi file it wants to remove the pb 11.5 runtime on the web 
> server. I can't do that because I've got pb 11.5 web services running 
> that need those files. Why is the runtime packager even looking at the 
> pb 11.5 files? If I choose uninstall then the pb 11.5 webservices stop 
> working. Is there a setting that the packager uses to determine which 
> version to package? I noticed that pbpack115.exe and pbpack120.exe are 
> in the same shared folder. Any ideas?
> 
> Thanks,
> Mark 
0
Chris
8/1/2010 10:58:17 PM
  Hi Chris,

I reported the problem to Sybase. This is a definite problem for me 
because I can't deploy the system I just finished. :(

Thanks,
Mark

On 8/1/2010 6:58 PM, Chris Pollach wrote:
> Hi Mark;
>
>  Sounds like a definite bug to me.
> I would suggest that you log this bug to Sybase using CaseXpress.
>
>
> Regards ... Chris
> President: OSUG / STD Inc.
> Blog: http://chrispollach.pbdjmagazine.com
> SourceForge: http://sourceforge.net/projects/stdfndclass
>
>
>
> "Mark" <mlibner@yahoo.com> wrote in message 
> news:4c53353f$1@forums-1-dub...
>>  I've built an msi file using the PB Runtime Packager for that .net 
>> components that are needed for my pb 12 webform. The problem is when 
>> I run the msi file it wants to remove the pb 11.5 runtime on the web 
>> server. I can't do that because I've got pb 11.5 web services running 
>> that need those files. Why is the runtime packager even looking at 
>> the pb 11.5 files? If I choose uninstall then the pb 11.5 webservices 
>> stop working. Is there a setting that the packager uses to determine 
>> which version to package? I noticed that pbpack115.exe and 
>> pbpack120.exe are in the same shared folder. Any ideas?
>>
>> Thanks,
>> Mark 
0
Mark
8/2/2010 11:54:55 AM
I have seen this problem reported before as well - I share your 
disappointment.  :-(



"Mark" <mlibner@yahoo.com> wrote in message news:4c56b20f$1@forums-1-dub...
>  Hi Chris,
>
> I reported the problem to Sybase. This is a definite problem for me 
> because I can't deploy the system I just finished. :(
>
> Thanks,
> Mark
>
> On 8/1/2010 6:58 PM, Chris Pollach wrote:
>> Hi Mark;
>>
>>  Sounds like a definite bug to me.
>> I would suggest that you log this bug to Sybase using CaseXpress.
>>
>>
>> Regards ... Chris
>> President: OSUG / STD Inc.
>> Blog: http://chrispollach.pbdjmagazine.com
>> SourceForge: http://sourceforge.net/projects/stdfndclass
>>
>>
>>
>> "Mark" <mlibner@yahoo.com> wrote in message 
>> news:4c53353f$1@forums-1-dub...
>>>  I've built an msi file using the PB Runtime Packager for that .net 
>>> components that are needed for my pb 12 webform. The problem is when I 
>>> run the msi file it wants to remove the pb 11.5 runtime on the web 
>>> server. I can't do that because I've got pb 11.5 web services running 
>>> that need those files. Why is the runtime packager even looking at the 
>>> pb 11.5 files? If I choose uninstall then the pb 11.5 webservices stop 
>>> working. Is there a setting that the packager uses to determine which 
>>> version to package? I noticed that pbpack115.exe and pbpack120.exe are 
>>> in the same shared folder. Any ideas?
>>>
>>> Thanks,
>>> Mark 

0
Chris
8/3/2010 12:24:46 AM
  Apparently the 1.1 framework was the last one that shipped with the 
gacutil.exe program. I'm not familiar with the equivalent for the 2.0 
framework so I can't do this in a batch mode. I've downloaded and 
installed the .net sdk on the server. I'm in the process of manually 
registering the necessary files in the GAC using the mscorcfg.msc 
module. I really wish the pb 12 runtime packager worked!

On 8/2/2010 8:24 PM, Chris Pollach wrote:
> I have seen this problem reported before as well - I share your 
> disappointment.  :-(
>
>
>
> "Mark" <mlibner@yahoo.com> wrote in message 
> news:4c56b20f$1@forums-1-dub...
>>  Hi Chris,
>>
>> I reported the problem to Sybase. This is a definite problem for me 
>> because I can't deploy the system I just finished. :(
>>
>> Thanks,
>> Mark
>>
>> On 8/1/2010 6:58 PM, Chris Pollach wrote:
>>> Hi Mark;
>>>
>>>  Sounds like a definite bug to me.
>>> I would suggest that you log this bug to Sybase using CaseXpress.
>>>
>>>
>>> Regards ... Chris
>>> President: OSUG / STD Inc.
>>> Blog: http://chrispollach.pbdjmagazine.com
>>> SourceForge: http://sourceforge.net/projects/stdfndclass
>>>
>>>
>>>
>>> "Mark" <mlibner@yahoo.com> wrote in message 
>>> news:4c53353f$1@forums-1-dub...
>>>>  I've built an msi file using the PB Runtime Packager for that .net 
>>>> components that are needed for my pb 12 webform. The problem is 
>>>> when I run the msi file it wants to remove the pb 11.5 runtime on 
>>>> the web server. I can't do that because I've got pb 11.5 web 
>>>> services running that need those files. Why is the runtime packager 
>>>> even looking at the pb 11.5 files? If I choose uninstall then the 
>>>> pb 11.5 webservices stop working. Is there a setting that the 
>>>> packager uses to determine which version to package? I noticed that 
>>>> pbpack115.exe and pbpack120.exe are in the same shared folder. Any 
>>>> ideas?
>>>>
>>>> Thanks,
>>>> Mark 
>
0
Mark
8/3/2010 11:21:42 AM
Test
>   I've built an msi file using the PB Runtime Packager for
> that .net  components that are needed for my pb 12
> webform. The problem is when I  run the msi file it wants
> to remove the pb 11.5 runtime on the web  server. I can't
> do that because I've got pb 11.5 web services running
> that need those files. Why is the runtime packager even
> looking at the  pb 11.5 files? If I choose uninstall then
> the pb 11.5 webservices stop  working. Is there a setting
> that the packager uses to determine which  version to
> package? I noticed that pbpack115.exe and pbpack120.exe
> are  in the same shared folder. Any ideas?
>
> Thanks,
> Mark
0
Henry
8/3/2010 2:57:45 PM
Not sure if this will work but it might be worth a shot.  Try running
your msi file and allow it to uninstall the 11.5 runtime files.  Then
try re-deploying your 11.5 web services.  If that doesn't work, you may
have to use the project to deploy directly to the web server instead of
via msi file.

KR

On 8/3/2010 7:21 AM, Mark wrote:
>  Apparently the 1.1 framework was the last one that shipped with the
> gacutil.exe program. I'm not familiar with the equivalent for the 2.0
> framework so I can't do this in a batch mode. I've downloaded and
> installed the .net sdk on the server. I'm in the process of manually
> registering the necessary files in the GAC using the mscorcfg.msc
> module. I really wish the pb 12 runtime packager worked!
> 
> On 8/2/2010 8:24 PM, Chris Pollach wrote:
>> I have seen this problem reported before as well - I share your
>> disappointment.  :-(
>>
>>
>>
>> "Mark" <mlibner@yahoo.com> wrote in message
>> news:4c56b20f$1@forums-1-dub...
>>>  Hi Chris,
>>>
>>> I reported the problem to Sybase. This is a definite problem for me
>>> because I can't deploy the system I just finished. :(
>>>
>>> Thanks,
>>> Mark
>>>
>>> On 8/1/2010 6:58 PM, Chris Pollach wrote:
>>>> Hi Mark;
>>>>
>>>>  Sounds like a definite bug to me.
>>>> I would suggest that you log this bug to Sybase using CaseXpress.
>>>>
>>>>
>>>> Regards ... Chris
>>>> President: OSUG / STD Inc.
>>>> Blog: http://chrispollach.pbdjmagazine.com
>>>> SourceForge: http://sourceforge.net/projects/stdfndclass
>>>>
>>>>
>>>>
>>>> "Mark" <mlibner@yahoo.com> wrote in message
>>>> news:4c53353f$1@forums-1-dub...
>>>>>  I've built an msi file using the PB Runtime Packager for that .net
>>>>> components that are needed for my pb 12 webform. The problem is
>>>>> when I run the msi file it wants to remove the pb 11.5 runtime on
>>>>> the web server. I can't do that because I've got pb 11.5 web
>>>>> services running that need those files. Why is the runtime packager
>>>>> even looking at the pb 11.5 files? If I choose uninstall then the
>>>>> pb 11.5 webservices stop working. Is there a setting that the
>>>>> packager uses to determine which version to package? I noticed that
>>>>> pbpack115.exe and pbpack120.exe are in the same shared folder. Any
>>>>> ideas?
>>>>>
>>>>> Thanks,
>>>>> Mark 
>>

0
Kevin
8/8/2010 4:54:43 PM
Reply:

Similar Artilces:

Project Problem, ASP.NET runtime error: Could not find a part of the path, ASP.NET runtime error: There is no build provider registered for the extension, designer.cs not updating
I'm working with a solution with many projects, there is some cross sharing.I'm in VS2005/2.0 on Vista/iis7.My original issue came about when I tried to add a new asp:DropDownList control to a user control, to add some new functionality I saved the .ascx file, then went to the codebehind to work with the newly added control.The code behind couldn't recognize the newly placed drop down.I came to discover that the designer.cs file was not updating like it should. I deleted the designer.cs file, then recreated it by right clicking on the .ascx file and choosing 'conver...

Problem consuming PB 11 .NET web service from PB 11 WebForm
Okay, great! What I am trying to accomplish is to consume a .NET webservice created with PB 11 from a WebForm target created in PB 11. First off, the only way I could find to generate the web service proxy is to create a new PB Application target, then generate the proxy into a library that is part of the library search path for the WebForm target. When I tried to generate directly into the WebForm target the option is greyed out on the Project page. I imported the appropriate file to get the soapconnection and soapexception objects into my webform target and everything in webfo...

PB .Net Debug Problem
Hi, I am trying to debug my application but when I run the application and open an initial window using openwithparm it generates an error 'could not evalaute expression - Attempt to read or write protected memory. This is often an indication that other memory is corrupt'. Of course this doesn't happen when I run the application. The window opens fine. Has anyone got any ideas? Hi Grant; I seem to remember getting into this "pickle" in Beta. If I remember correctly, here is what I did ... 1) Reran a manual registration of all the sybase.powerbuilder....

Problem with powerbuilder dll runtime libraries
Hi. I have a server with a lot of PB aplicactions, the runtime libraries are locate in C:\Program Files\Sybase\Shared\PowerBuilder and registred in environment variables but when i run the aplications does not work. the only way that the aplications run is put the runtime libraries on the same directory where place the aplication, course, that is not ideal for me. what is wrong Sorry for may english Jose A. The runtime need to appear in the search path for the application. You can do that by putting their location in the system search path, or by creating app path en...

Deploying pb nvo to .net problems
I'm using the powerobjects example. Have a production nvo currently connecting via PB and am trying to create an .aspx page to call the same. The package is pb_eligibility, the component is nfc_cst_webform. (Yes, I've checked the spelling a million times). Thanks for any direction. -cp Keep getting the following error on the Create().Narrow() method: Server Error in '/MedicalNecessity' Application. ---------------------------------------------------------------------------- ---- The fully scoped interface name passed as an argument to the Narrow_ metho...

PB 12 .NET Toolbox problems
I am trying to add components to the toolbox. I go to 'Choose toolbox items' and select COM Components and select my component. The component then appears in the toolbox but grayed out. I have tried this with many different components including .NET components. Each time they appear in the toolbox but grayed out. Am I missing something? Andy Visual components have to be WPF. If it is a visual item, a window or userobject painter has to be open (having an NVO painter open and selected will disable visual contols in the toolbox). On 5/19/2010 1:16 PM, Andy ...

Problem with .NET Framework Runtime install
Hello, I recently had to uninstall IIS on a machine that had the framework installed. Because of this I had to execute the Aspnet_regiis.exe utility to re-install asp.net once IIS was reinstalled. This worked fine and I thought I was up and running. However, it would appear as though this has only installed version 1.0. I am now getting errors on pages that are using features exclusive to 1.1 (the .HasRows property of the OleDbDataReader class for example). Does anyone know if there is some sort of option I should have selected when running the Aspnet_regiis.exe - I can't see what I...

PowerBuilder 9 and .NET PROBLEM URGENT!!!
Dear All, I have an application which is made with Powerbuilder Version 9.0.3 Build 8004 Inside this application am defining a C# API which am calling its functions normally in my application. When am running my application from Powerbuilder ( not using EXE) and specifically the window which uses this API it is crashing and am getting an error calling external function.... in the ue_postopen event... BUT when am making an exe and executing it, am not getting this error and everything works fine. it is so important for me that it works in pb mode so i can develop and debug an...

PB 12 .NET LIC Problem
Hi All, I have installed PB 12 and have a valid enterprise license and set valid host id. My question is, why my license valid for PB 12 Classic and not valid for PB12.Net (Visual Studio Isolated Shell)?The message is trial period is expired.Why this happen? Thanks, Keane In article <4c4b10d1.ed7.1681692777@sybase.com>, Keane says... > > Hi All, > > I have installed PB 12 and have a valid enterprise license > and set valid host id. My question is, why my license valid > for PB 12 Classic and not valid for PB12.Net (Visual Studio > Isolated Shell...

ASP.NET Controls Runtime Problem
I've got an odd problem where the asp.net controls are losing their default formatting during runtime. The textbox control looses it's border and padding so that it appears as just a white bar, the button control displays as just a gray square with text, and so on.  The controls look fine during development but during runtime just get stripped of any formatting unless I explicitly apply a css style via the control's CssClass. I believe it's related to my use of AJAX and the CSS friendly templates, but I was curious if anyone else has experienced a...

PB 6.5 and Runtime Problems
I have just converted an entire project from 5.0.02 to 6.5. The code migration went smoothly (with the exception of a few incompatablities). After making a few changes, everything was working fine. As I run the application in development mode, everything runs as is. When I compile the application (native/speed/DLLs) and deploy it with the new PB virtual machine files and necessary DLLs for datawindow etc., the application does not run at all. The error reported is: ----------------------------------------------- PowerBuilder Application Execution Error (R0002) Application Ter...

Runtime PB/ASA/ODBC Problem
Hi, I am using Win98/PB 7.0 C3 - 8046 and ASA V 6 ODBC 3.5 I have set up a db profile and run my PB application against it in development environment and no problems. After I created an executable, the PowerBuilder application runs but I cannot get the DB engine to start (Application starts but it give a message that it cannot connect to the DB using the ini file). I use n_cst_appmanager to point to my ini file. I believe I had the proper ASA runtime but after a while I copied all DLLs and .Exe files for ASA into my application path and still no go. I also believe I have c...

Accessing .NET Component in PB
Hi guys. I know this is not the right place to ask this question but I really need your help fast. The other company made a COM object in .NET 2.0 which manages connection to web service and signing of xml file. We copy those dll files to location where app using it is running, use regasm.exe to register the component and out tests using it were !successful!. BUT. If I run application as administrator it all works perfectly, but if I run application as "user" oleobject.connecttonewobject returns 0 - success but function calls fail and return message says something like...

Problems, problems, problems
Name: Hans Halvorsen Email: capricorn_at_online.no Product: Thunderbird Summary: Problems, problems, problems Comments: Hi, I downloaded Thunderbird some time ago, and I was over-satisfied whit it and how well it worked. In fact it worked 100% PERFECTLY UNTIL I got an newer update version of it. Since then I' ve had nothing BUT trouble! I've checked adresses, notes, password, deleted accounts and made new one's, checked sign-ins and sign-outs, passwords inside and out, upside and down, so many times that my frustration now is about to turn into pure and major ...

Web resources about - PB runtime problem - sybase.powerbuilder.net

Android Runtime - Wikipedia, the free encyclopedia
Android Runtime ( ART ) is an application runtime environment used by the Android mobile operating system . ART replaces Dalvik , which is the ...

Runtime (@Runtimeapp) on Twitter
Sign in Sign up To bring you Twitter, we and our partners use cookies on our and other websites. Cookies help personalize Twitter content, tailor ...

Runtime - Simple Run Tracking on the App Store on iTunes
Get Runtime - Simple Run Tracking on the App Store. See screenshots and ratings, and read customer reviews.

HSA Foundation Launches ‘HSA 1.0 Final’ – Architecture, Programmers Reference and Runtime Specifications ...
... of the hardware, - the HSA Programmers’ Reference Manual for the software ecosystem targeting tools and compiler developers, - the HSA Runtime ...

ART: The Android runtime that will eventually replace Dalvik is in KitKat in preview form
Google has, for all intents and purposes, rewritten Android several times since first launching the platform back in 2008. But there's a part ...

Experimental ART runtime available on new HTC One
Attention smartphone nerds — the new HTC One (M8) includes the option to use the experimental, pre-release ART runtime should you desire to make ...

ART runtime Archives - Android Origin
The team behind the custom ROM, Paranoid Android, has just released a brand new beta. As always, it includes various bug fixes, but this update ...

ART runtime Archives - Android Police - Android News, Apps, Games, Phones, Tablets
It was only 3 months ago when we first met the brand new Android Runtime, dubbed ART . In that time it has gained a substantial following by ...

Objective-C Runtime Reference
Describes the data structures and functions of the Objective-C runtime support library.

Apps can affect Mac performance, battery runtime, temperature, and fan activity - Apple Support
You can use Activity Monitor to see whether a Mac app is using more of the CPU than it should.

Resources last updated: 12/25/2015 9:46:22 PM