Worked in 7. no work 8.

Just wondering if something has changed in the PB logic from PB 7 to 8.

The thing that's not working is too complicated to tell in detail, but the
overview is this.  I have a window that has a static text object on it .
This object is passed values that tells the user you are on "Record x of x",
for a datawindow that is part of the window.

My problem is this.  I have a retrieve dialog that the user enters criteria
in. If before bringing up the dialog the user is viewing record 1 of 1 but
as a result of the new retrieve the window now has 150 records, this static
text object does not say record 1 of 150.  It still says record 1 of 1.  If
I do it again it says 1 of 150 but it is obviously an iteration behind where
it should be.  This routine works in 7.x and does not in 8.x.   Just
wondering if there is something obvious here to someone else that may give
me a clue as to why, and how to remedy it.








0
Woody
6/5/2002 12:22:11 AM
sybase.powerbuilder.general 62418 articles. 19 followers. Follow

3 Replies
779 Views

Similar Articles

[PageSpeed] 10

You can try to POST the routine that updates the static text, so that is
executes after the retrieve() has completed.

--
<hopethishelps />
Roy Kiesler [TeamSybase]
MySybase -- http://www.sybase.com/mysybase


"Woody" <woody@splawns.com> wrote in message
news:h6BOdgCDCHA.70@forums.sybase.com...
> Just wondering if something has changed in the PB logic from PB 7 to 8.
>
> The thing that's not working is too complicated to tell in detail, but the
> overview is this.  I have a window that has a static text object on it .
> This object is passed values that tells the user you are on "Record x of
x",
> for a datawindow that is part of the window.
>
> My problem is this.  I have a retrieve dialog that the user enters
criteria
> in. If before bringing up the dialog the user is viewing record 1 of 1 but
> as a result of the new retrieve the window now has 150 records, this
static
> text object does not say record 1 of 150.  It still says record 1 of 1.
If
> I do it again it says 1 of 150 but it is obviously an iteration behind
where
> it should be.  This routine works in 7.x and does not in 8.x.   Just
> wondering if there is something obvious here to someone else that may give
> me a clue as to why, and how to remedy it.
>
>
>
>
>
>
>
>


0
Roy
6/5/2002 12:20:19 AM
Or put it in the RetrieveEnd event.
You could also use a computed field in the datawindow.
'Row ' + GetRow() + ' of ' + RowCount()

Roy Kiesler [TeamSybase] wrote in message ...
>You can try to POST the routine that updates the static text, so that is
>executes after the retrieve() has completed.
>
>--
><hopethishelps />
>Roy Kiesler [TeamSybase]
>MySybase -- http://www.sybase.com/mysybase
>
>
>"Woody" <woody@splawns.com> wrote in message
>news:h6BOdgCDCHA.70@forums.sybase.com...
>> Just wondering if something has changed in the PB logic from PB 7 to 8.
>>
>> The thing that's not working is too complicated to tell in detail, but
the
>> overview is this.  I have a window that has a static text object on it .
>> This object is passed values that tells the user you are on "Record x of
>x",
>> for a datawindow that is part of the window.
>>
>> My problem is this.  I have a retrieve dialog that the user enters
>criteria
>> in. If before bringing up the dialog the user is viewing record 1 of 1
but
>> as a result of the new retrieve the window now has 150 records, this
>static
>> text object does not say record 1 of 150.  It still says record 1 of 1.
>If
>> I do it again it says 1 of 150 but it is obviously an iteration behind
>where
>> it should be.  This routine works in 7.x and does not in 8.x.   Just
>> wondering if there is something obvious here to someone else that may
give
>> me a clue as to why, and how to remedy it.
>>
>>
>>
>>
>>
>>
>>
>>
>
>


0
Jerry
6/5/2002 1:30:47 PM
Thank you.  I am considering your and Jerry's suggestions.  However, this
does not answer my question about whether something basic has changed from
PB 7 to 8.  I have a variety of code based on similar logic.  It would be
good to know where to look for potential problems.  Any thoughts?




"Roy Kiesler [TeamSybase]" <SPAM_FREE_roy.kiesler@teamsybase.com> wrote in
message news:ykWUhiCDCHA.81@forums.sybase.com...
> You can try to POST the routine that updates the static text, so that is
> executes after the retrieve() has completed.
>
> --
> <hopethishelps />
> Roy Kiesler [TeamSybase]
> MySybase -- http://www.sybase.com/mysybase
>
>
> "Woody" <woody@splawns.com> wrote in message
> news:h6BOdgCDCHA.70@forums.sybase.com...
> > Just wondering if something has changed in the PB logic from PB 7 to 8.
> >
> > The thing that's not working is too complicated to tell in detail, but
the
> > overview is this.  I have a window that has a static text object on it .
> > This object is passed values that tells the user you are on "Record x of
> x",
> > for a datawindow that is part of the window.
> >
> > My problem is this.  I have a retrieve dialog that the user enters
> criteria
> > in. If before bringing up the dialog the user is viewing record 1 of 1
but
> > as a result of the new retrieve the window now has 150 records, this
> static
> > text object does not say record 1 of 150.  It still says record 1 of 1.
> If
> > I do it again it says 1 of 150 but it is obviously an iteration behind
> where
> > it should be.  This routine works in 7.x and does not in 8.x.   Just
> > wondering if there is something obvious here to someone else that may
give
> > me a clue as to why, and how to remedy it.
> >
> >
> >
> >
> >
> >
> >
> >
>
>


0
Woody
6/5/2002 5:09:37 PM
Reply:

Similar Artilces:

SQL Works in 7.0
This is a multi-part message in MIME format. ------=_NextPart_000_0012_01C21C6A.79FB7930 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable This SQL has been working since Watcom days. One of our users upgraded = to 8.0 and now it does not work Has anybody any idea what this error is about ? Its on the latest build = - 8.01 with the latest patch/EBF (Jun 14, I think) This is very urgent and please email reply if possible.=20 Data Base error Number is: -845 Data Base error Message is: Select error: SQLSTATE =3D S0002 [Sybase]...

Powerbuilder 10 and MAPI does not work, works in PB 7
Hi, I have a powerbuilder application that uses MAPI to send e-mails using the customers e-mail client. Customer uses Netscape 4.7 With Powerbuilder 7.0, everything worked fine. Now with PB 10, the mailLogon function always fails. With PB 7 it works with Netscape, Outlook and Outlook Express. With PB 10, it does NOT work with Netscape and Outlook Express. It works with Outlook 2000, but only if I put the real e-mail address in both 'name' and 'address' Problem is: customer definitely uses Netscape. Anyone has any ideas ? Perhaps something to do with PB 10 w...

Powerbuilder 10 and MAPI does not work, works in PB 7
Hi, I have a powerbuilder application that uses MAPI to send e-mails using the customers e-mail client. Customer uses Netscape 4.7 With Powerbuilder 7.0, everything worked fine. Now with PB 10, the mailLogon function always fails. With PB 7 it works with Netscape, Outlook and Outlook Express. With PB 10, it does NOT work with Netscape and Outlook Express. It works with Outlook 2000, but only if I put the real e-mail address in both 'name' and 'address' Problem is: customer definitely uses Netscape. Anyone has any ideas ? Perhaps something to do with PB 10 w...

Working
I have two servers running NW65sp4A (different trees). I initially installed BM3.8 patched to sp4 with VPN services ( Firewall services to follow after I know I have VPN working). My problem is that it appears to be working but its not working. I can open my Windows Explorer (from the SLAVE side network) and reach the MASTER, authenticate and open files. The MASTER NRM VPN monitor shows 1 (one) Active Connections 0 (zero) Packets Received and lots of Packets Sent. The VPN Member List Status shows both servers as �Being Configured�. The Audit Log has two recurring RED entrie...

Do I need to install both oracle 7.3 and oracle 8 clients to work my PB applications some with ora 7.3 and some ora 8?
Hi, My PB5 application uses Oracle 7.3 and PB8 applications uses oracle 8i. Do I need to install both Oracle 7.3 and Oracle 8 clients to deploy my PB 5 and PB 8 application. Please comment Thanks Mulinti I've answered this elsewhere. -- Terry Dykstra (TeamSybase) Please state PB / OS / DB versions in your post. SDN: http://www.sybase.com/developer/ http://www.pb9books.com <Mulinti> wrote in message news:D3D0347141F544BB0059FE7585256CBD.0059FE8585256CBD@webforums... > Hi, > > My PB5 application uses Oracle 7.3 and PB8 applications uses oracle 8i....

DBD::ODBC works in perl 5.8.7 but fails in 5.8.8 and above
Hi, Back in March this year Jonathan Gillespie reported the following error in DBD::ODBC test suite: Can't change param 1 maxlen (51->50) after first bind at >t/20SqlServer.t line 180. (see http://www.mail-archive.com/dbi-users@perl.org/msg26946.html). The same version of DBI and DBD::ODBC works fine in perl 5.8.7 but fails in perl 5.8.8 and later. I've even tried 5.9.4. I never really got to the root of the problem but it appears: in dbdimp.c did a: svGrow(phs->sv, 50+1) but SvLEN(phs->sv) returns 52! DBD::ODBC does not expect this so the tes...

LDAP does not work after the installation of eDirectory 8.7.3.7
Hello, I installed eDirectory 8.7.3.7 on a SLES 9. After the installation everything seemed to work fine. My domains, mailboxes etc. where accessible in ConsoleOne. GroupWise 7.0.1 also works well. When I try to start the Novell LDAP server (/etc/init.d/nldap) I get the error message: Novell eDirectory LDAP Server TCP port is disabled. Novell eDirectory LDAP Server TLS port is disabled. After that the LDAP server does not work (Port 389 is not available). Can anyone tell me what mistake I made during the installation? Thank you in advance, Bernd Bernd.Franke@coi.de wrote: ...

Sql server 7 Opening connection in asp.net; works in asp, works with OTHER sql server 7
Hi allThis is my first post here, so forgive me if I'm doing something dumb.I have a connection string:provider=SQLOLEDB;Persist Security Info=False;User ID=user;Initial Catalog=cat;Data Source=server.com;pwd=userthat works in asp, we use it all the time, but it does not work in asp.net. the server is sql server 7; we don't have access to the sql server. however, we have another sql server 7 that does work in asp.net.any thought on what could be the deal, if a setting in sql server that could somehow affect asp.net but not asp?ThanksNeil Hi, that is OLEDB connection string so it would be ...

Applied edir 8.7.3.8 patch and LDAP stopped working
I have applied edir8738 patch and now NLDPA will not load. I receive the following Novell eDirectory LDAP SErver TCP port is not listening Novell eDirectory LDAP SErver TLS port is not listening I have used "netstat -anp |grep LISTEN |grep 389" "netstat -anp |grep LISTEN |grep 636" to confirm that nothing elese is listening. Open LDAP is not installed Any help would be appreciated. Thanks Rob C It appears that upgrade removed a symbolic link from the /var/novell/ directory Giving the following error in /var/nds/ndsd.log file Jun 25 23:23...

Work offline does not work
Name: Saad Shamsaei Email: saaddotshamsaeiatgmaildotcom Product: Firefox Summary: Work offline does not work Comments: Hello. i use ff 3.1 beta 2. i usually use work offline. ff3.1b2 was ok. but when i change option->offline storage cashe from 50 to 200 mb my ff got slow and haevy. i delete my offline data. and then browsed the web. but after that my work offline doesnt work! Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2 From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a...

PXE no work to do... was working
My imaging setup was working friday, and now all of a sudden all I get is "no work to do" I have done a DSREPAIR and still nothing happens... Any ideas? sending PROXY_CMD_PXE_FILE packet proxyGetPXEFilename returned workToDo = 1 proxyGetPXEFilename returned SUCCESS PXE Filename = /cmds/z_auto.cmd pxeProxyInit Success EXIT ZENGetPXEFilename returning (workToDo) 0 EXIT ZENGetPXEFilename returning (filename) /cmds/z_auto.cmd -- joshund On Mon, 09 Oct 2006 15:19:30 GMT, joshund wrote: > Any ideas? any change? could you post the imgserv log when yo...

unescaping working or not working
I have created a very simple webservice, which returns a string like this : <div>hello world</div>. When returning the string, it is encoded like this:  "\u003cdiv\u003eHello world\u003c/div\u003e". I would then like to place the returned string (in the variable called value) on a div in my HTML like this:        $get('myDiv').innerHTML=unescape(value);But the value is not decoded/unescaped. If I then start firebug and enter: unescape( "\u003cdiv\u003eHello world\u003c/div\u003e") it is decoded/unescaped correct. Wh...

Does not work as Safari works
Name: Norihide Kimura Email: nkimuraatwtadotattdotnedotjp Product: Firefox Release Candidate Summary: Does not work as Safari works Comments: Please refer to the URL http://web.mac.com/nori44/. There is PHOTOS(PARTY) which is clicable name on the topline of the page. When you click of it, ther should be appeared the photographs and you will be able to enjoy slidshows on Mac Safari or Firefox Windows version. But it doesn't work on Firefox Mac version. Browser Details: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; ja-JP-mac; rv:1.9) Gecko/2008051202 Firefox/3.0 From...

Unit working on delphi 7
Hello, i have unit working on delphi7 - 2010 BUT on XE5 give me a lot of errors can you help me please to check whats wrong in the unit on XE5 {$WARNINGS OFF} unit CommonMemoryUnit; interface uses Windows, Messages, SysUtils, Classes, Dialogs; type TCommMemNT = class(TObject) private FMemPtr:pointer; FhProcess:THandle; FdwProcessId:DWORD; FSize:integer; FPosition : Cardinal; protected procedure Open(AllocSize:integer); procedure Close; public constructor Create(hTarget:HWND;AllocSize:integer); destructor Destroy;override; procedure Ze...

Web resources about - Worked in 7. no work 8. - sybase.powerbuilder.general

List of countries by GDP (PPP) per hour worked - Wikipedia, the free encyclopedia
^ "The Conference Board Total Economy Database, Summary Statistics 1995 - 2010" (PDF). The Conference Board . September 2010. Table 8: Labor ...

Tiger Pistol’s Crowd Intelligence Allows Facebook Page Admins To See What Worked For Similar Pages
Imitation is the sincerest form of flattery, and the Crowd Intelligence marketing platform launched by Tiger Pistol Thursday is aimed at allowing ...

If you worked for Doritos, what would you advise them to do about this parody?
... ★YouTube Guru★Video Marketing Expert★President and Co-founder of SEO-PR, an Award-Winning Content Marketing Agency 7 months ago If you worked ...

Bill Murray Worked at Little Caesar’s - YouTube
Bill talks about the jobs he had selling hot dogs and making pizza at Little Caesar’s. SUBSCRIBE to get the latest #KIMMEL: http://bit.ly/JKLSubscribe ...

AFL 101: three things we worked out from round 10 (so far)
The high-flying WA teams come crashing back down to earth, Richmond (gulp) actually looks like the real deal, the Hawks flex a little muscle ...

This Guy Was Fired As CEO From His Own Company, Worked His Way Back, And Just Raised $US35 Million
OpenDNS has landed a $US35 million investment from Cisco and other big names to help it stop some of the worst kinds of hack attacks on the internet. ...

Dank has worked with clubs since '90s
STEPHEN DANK has had involvement with NRL clubs for more than 20 years, says Warriors coach Matt Elliott.

'Outlander' star Sam Heughan strong contender for Golden Globes award; Diana Gabaldon feels cast worked ...
After the Emmy disappointment, “Outlander” TV series may get a chance to win a Golden Globe award.

Malcolm Turnbull on Cayman Islands accounts: Others have worked harder than me
MALCOLM Turnbull yesterday acknowledged he and wife Lucy had been lucky and were wealthier than most Australians who worked harder than them. ...

French factory suspect 'worked alone'
A French prosecutor says there's no sign that a suspect held over an attack at a factory had an accomplice.

Resources last updated: 11/22/2015 8:55:20 AM