PB5 and Oracle connection problem (TNS-12203)

 We have a PowerBuilder 5.0.4 app running under Windows 95 connecting to

> Oracle.
>
> The problem is that we get the following message when the application
> takes a long time running.
>
> "ORA-12203:  TNS:unable to  connect to destination"
>
> The entry in the Oracle sqlnet.log (spanish language):
>
> VERSION INFORMATION:
>  TNS for 32-bit Windows: Version 8.0.6.0.0 - Production
>  Windows NT TCP/IP NT Protocol Adapter for 32-bit Windows: Version
> 8.0.6.0.0 - Production
>   Time: 09-MAR-01 07:40:54
>   Tracing not turned on.
>   Tns error struct:
>     nr err code: 12203
>     TNS-12203: TNS:no se puede conectar con el destino
>     ns main err code: 12560
>     TNS-12560: TNS:error del adaptador de protocolo
>     ns secondary err code: 0
>     nt main err code: 530
>     TNS-00530: Error del adaptador de protocolo
>     nt secondary err code: 55
>     nt OS err code: 0.
>
> To try to narrow down the problem, I've create the most simple
application
> possible.
> In the Open event of the application call the timer(59).
>
> The timer event sets up SQLCA and connects and disconnects to Oracle.
> The code works fine until the 95-100 tries. After that, ever trigger
> error.
>
> The software we are running on is:
> Oracle 8.0.5.1 for Unix
> PowerBuilder 5.04
> Using PBs native driver version: O72
> Oracle Client 8.0.6
>
> Any one have any suggestion on what might be the problem?
>
> Thank you
>
> Regards


0
Manuel
3/9/2001 1:19:59 PM
sybase.powerbuilder.database 9855 articles. 2 followers. Follow

1 Replies
569 Views

Similar Articles

[PageSpeed] 3
Get it on Google Play
Get it on Apple App Store

Use the O73 driver, not the O72 driver.

--
Terry Dykstra (TeamSybase)
Please state PB / OS / DB versions in your post.
MySybase http://my.sybase.com/mysybase
Search Deja: http://www.pfcguide.com/_newsgroups/search.asp

"Manuel Serrano" <nekkar.mserrano@iberia.es> wrote in message
news:3AA8D87F.B6EB244A@iberia.es...
> We have a PowerBuilder 5.0.4 app running under Windows 95 connecting to
>
> > Oracle.
> >
> > The problem is that we get the following message when the application
> > takes a long time running.
> >
> > "ORA-12203:  TNS:unable to  connect to destination"
> >
> > The entry in the Oracle sqlnet.log (spanish language):
> >
> > VERSION INFORMATION:
> >  TNS for 32-bit Windows: Version 8.0.6.0.0 - Production
> >  Windows NT TCP/IP NT Protocol Adapter for 32-bit Windows: Version
> > 8.0.6.0.0 - Production
> >   Time: 09-MAR-01 07:40:54
> >   Tracing not turned on.
> >   Tns error struct:
> >     nr err code: 12203
> >     TNS-12203: TNS:no se puede conectar con el destino
> >     ns main err code: 12560
> >     TNS-12560: TNS:error del adaptador de protocolo
> >     ns secondary err code: 0
> >     nt main err code: 530
> >     TNS-00530: Error del adaptador de protocolo
> >     nt secondary err code: 55
> >     nt OS err code: 0.
> >
> > To try to narrow down the problem, I've create the most simple
> application
> > possible.
> > In the Open event of the application call the timer(59).
> >
> > The timer event sets up SQLCA and connects and disconnects to Oracle.
> > The code works fine until the 95-100 tries. After that, ever trigger
> > error.
> >
> > The software we are running on is:
> > Oracle 8.0.5.1 for Unix
> > PowerBuilder 5.04
> > Using PBs native driver version: O72
> > Oracle Client 8.0.6
> >
> > Any one have any suggestion on what might be the problem?
> >
> > Thank you
> >
> > Regards
>
>


0
Terry
3/12/2001 4:48:43 PM
Reply: