ConnectToNewObject( "PowerBuilder.Application" )

The following code runs without problem on development workstation,
but fails when deployed to workstation with only runtime files
deployed.

PBObject = Create oleObject
iResult = PBObject.ConnectToNewObject( "PowerBuilder.Application" )

iResult returns -2

Search of registry found that  "PowerBuilder.Application"  is
registered on workstations with PowerBuilder deployed on, but is not
on workstations with runtime deployed.  Have tried registering
pbvm90.dll, but get error message pbvm90.dll was loaded, but the
DllRegisterServer entry point was not found.  Not sure that pbvm90.dll
can or should be registered.

Am sure that we are missing something obvious.

Any help appreciated.
0
calbert
2/24/2004 11:53:58 PM
sybase.ole-ocx-activex 6324 articles. 0 followers. Follow

3 Replies
1304 Views

Similar Articles

[PageSpeed] 53
Get it on Google Play
Get it on Apple App Store

 Only the development IDE uses that!

"Curtis Albert" <calbert@epiqsystems.com> wrote in message
news:403be1d9.33393397@forums.sybase.com...
> The following code runs without problem on development workstation,
> but fails when deployed to workstation with only runtime files
> deployed.
>
> PBObject = Create oleObject
> iResult = PBObject.ConnectToNewObject( "PowerBuilder.Application" )
>
> iResult returns -2
>
> Search of registry found that  "PowerBuilder.Application"  is
> registered on workstations with PowerBuilder deployed on, but is not
> on workstations with runtime deployed.  Have tried registering
> pbvm90.dll, but get error message pbvm90.dll was loaded, but the
> DllRegisterServer entry point was not found.  Not sure that pbvm90.dll
> can or should be registered.
>
> Am sure that we are missing something obvious.
>
> Any help appreciated.


0
Chris
2/25/2004 12:33:59 PM
Where did you get that idea?


pbm_thisusuallydoesnothelp:-))
Philip Salgannik

"Chris Pollach" <PollachC@SCC-CSC.gc.ca> wrote in message
news:403c9637$1@forums-1-dub...
> Only the development IDE uses that!


0
Philip
2/25/2004 2:14:20 PM
Not true!  We have a shipping app that uses PowerBuilder Automation.

Tim Wallace

"Chris Pollach" <PollachC@SCC-CSC.gc.ca> wrote in message
news:403c9637$1@forums-1-dub...
> Only the development IDE uses that!
>
> "Curtis Albert" <calbert@epiqsystems.com> wrote in message
> news:403be1d9.33393397@forums.sybase.com...
> > The following code runs without problem on development workstation,
> > but fails when deployed to workstation with only runtime files
> > deployed.
> >
> > PBObject = Create oleObject
> > iResult = PBObject.ConnectToNewObject( "PowerBuilder.Application" )
> >
> > iResult returns -2
> >
> > Search of registry found that  "PowerBuilder.Application"  is
> > registered on workstations with PowerBuilder deployed on, but is not
> > on workstations with runtime deployed.  Have tried registering
> > pbvm90.dll, but get error message pbvm90.dll was loaded, but the
> > DllRegisterServer entry point was not found.  Not sure that pbvm90.dll
> > can or should be registered.
> >
> > Am sure that we are missing something obvious.
> >
> > Any help appreciated.
>
>


0
Tim
2/25/2004 6:42:02 PM
Reply:

Similar Artilces:

pbobj.connectToNewObject("Powerbuilder.Application")
I am using this to create a GUID. OLEObject pbobj string ls_guid long ll_rc pbobj = create OLEObject pbobj.connectToNewObject("Powerbuilder.Application") ll_rc = pbobj.generateguid(ref ls_guid) When I run locally it works, I get a GUID every time. If I build my application and deploy it I don't get the GUID. Is there any powerbuilder dll that I need to include in my deployment for this to work. The rpcrt4.dll is in the path in the C:\WINNT\System32 directory. When deployed the application is running through citrix would this cause an ...

Powerbuilder application "crashing" another powerbuilder application
This is a repost of the above subject since there has been some problem for messages posted on the 19th - 22nd July 2002. *************** Hi All, I have an application (App A)built using PB7.0.3 build 10077 and it seems to work fine. However, recently, another application (App B) built using PB 7.0.3 build 10047 as well was installed and it seems to trigger Dr Watson on App A. There is an embedded OCX on a "main" window on App A, which receives triggers from external applications. The OCX will then call another function sitting on another main window. That function w...

.ALLCOL("%COLUMN%", " ", ", ", ", ")
Do you know anyway for me to exclude a subset of columns returned by this function. We have two columns (rec_user and rec_datetime) which are in all of our tables, but when generating triggers I want automatically generate a script which does not include those two columns but does include all other columns in that table. Bruce I should add that I am using PD 9.0.0.580. Bruce "Bruce Lamb" <lamb.bruce@mayo.edu> wrote in message news:6HgI315nCHA.155@forums.sybase.com... > Do you know anyway for me to exclude a subset of columns returned by this > function. ...

Precedence of "where" ("of", "is", "will")?
Nobody on #perl6 today could answer this one. Is: Str | Int where { $_ } the same as: (Str | Int) where { $_ } or: Str | (Int where { $_ }) ? Followup questions, Mr. President: What kind of operators are "where", "of", "is", and "will"? Is there a reason that S03 doesn't list them? What are their precedence(s)? -- Chip Salzenberg - a.k.a. - <chip@pobox.com> Open Source is not an excuse to write fun code then leave the actual work to others. Chip Salzenberg writes: &...

quotes, quotes, quotes...
I am getting this error and I know what is causing it, but I have no idea how to fix it, any help would be great. The script steps through the /var/log/messages file on a linux server and puts The entries into a mysql database. However when it gets to the 'hlt' line in the messages file it just barfs. The single quotes are freaking it out. I know about quotes but not how to use in this situation. Thanks, Paul Error: May 27 17:53:00 localhost kernel: Checking 'hlt' instruction... OK. <----- doesn't like this in the messages file DBD::mysql::st exec...

How To Set "Trial Application" and "Bound To This Machine" .NET application only
Hi, This is the first time I made a web application for a client. Since he has not paid me, what should I do so that the application will terminate within x days starting from the day I install the application in his server ? And is it possible to make application works on his server only ? I don't want the files copied without my permission.   Thank you very much for your attention.  ===================================Don't Quote And Flame Me If I Am Wrong===================================...

"classname" parameter of function "connecttonewobject"
Hi: I'm using function "ConnectToNewObject" to work with Word, the "classname" parameter is "word.application".If I want to work with other OLE classes, like excel, powerpoint,etc,How can I get their "classname"? I'm using Formula One 6, I don't know its classname,so some methods and properties can't be used in my app. Thanks in advance. hi, check in the object browser in pb and go to OLE tab and look in programmable ole objects. Cicy John Shen wrote: > Hi: > I'm using function "ConnectToNewO...

replace the "." with a ","
Oi.... I need to build a small programm in ASP.NET and chose to use C# for it.Now i got everything working but there's one little problem.the first textbox is a double. I need to make it so that when someone enters a "." then it gets replaced by a ","any ideas?Ghan  string blah = "4.2.2.2";blah = blah.Replace(".", ",");Ryan Ryan OlshanASPInsider | Microsoft MVP, ASP.NEThttp://ryanolshan.comHow to ask a question...

"Using" or "With"
Hi all Please can someone enlighten to me as regards the difference with the "Using" and "With" statement when accessing data - which is better, what are the limitations and/or any pointers. Many thanks. Regards DaveDavid WinchesterPlease mark as answer if this is the solution.  using gives you the ability to use the connection and it closes the connection directlly after you finish using it. and there is no need to try- cach - finaly. there is no limitation on using USING keywordMuhanad YOUNISMCSD.NETMy Blog || My Photos || LinkedIn I have a dataobject the re...

Using "+" or "||"
Using SQLAnywhere 5.5.04, I've gotten into the habit of using "||" in ISQL to indicate a string concatenation. I needed to paste my SQL statement into the PowerBuilder script painter for some embedded SQL, and PB didn't like the "||" very much at all. I changed it to "+" and it seems to be ok. Do these two operators indicate ~exactly~ the same thing? moin, afaik these two's are not the same! if you're using "||" and any term is NULL then in the resultstring the term will be ignored if you use "+" then the resu...

"Me" is better than "You"
Yes I know, strings are frozen. But let me talk about it, I really can't get through the idea of a PC talkin to me. I consider my PC as an extension of myself, not a dumb companion who addresses Me as You. Yes there are times when I get angry with Him while I work and get wrong calculations etc.., but it really is my fault, Me using wrong istructions and eventually wanting to find someone else to blame, but it's Me. And yes, I consider Thunderbird my mail program, reading my mail on my PC as Me. So I personally like to have Me in the header bar as a compact address ...

"-" not "_"
I wrote a SQL statement in the data tab. I wrote a bunch of alaises as example ' word-type ' but when I hit the layout tab it converts the "-" to "_". So now my field name is ' word_type '. Is there any way to prevent this? CardGunner Don' use a hypen ( - ).  It isn't a valid character for column names.   See http://searchsqlserver.techtarget.com/expert/KnowledgebaseAnswer/0,289625,sid87_gci1188931,00.html   Here's an excerpt about column names: Letters as defined in the Unicode Standard 2.0 Decimal numbers from either B...

Cache("My_DS") or Application("My_DS")
What is the difference between the above? Thanks. Hi, There are major difference between Cache("My_DS") and Application("My_DS") . If large amount of reqiest is coming then cache data is deleted automatically. This feature is called scavanging. This feature is not in application state. With regards Anurag Pandey Anurag Pandey Software Developer Consulting Engineering Services India Pvt. Ltd. New Delhi, India Hi, Cache("My_DS") will maintain the content in the Cache object. Application("My_DS") will maintain the conte...

double quote
hello there...  i tried everything of think but not working the way i wanted to be... not sure what i'm missing...i'm generating a <span> in code behind and then using in javascript.... here is what i'm doing code behind: int i=0string _keywordID = "keyword";string _name = row["visit_info_nm"].ToString().Trim(); String _getElementByID = String.Format("<span id='{0}' OnClick = \"document.getElementById('{1}').value='{2}';\">{3}</span><br>", i, _keywordID, _name, _name); here is what it generate : <span id='1' OnClick = \"document.getElementById('keyword')...

Web resources about - ConnectToNewObject( "PowerBuilder.Application" ) - sybase.ole-ocx-activex

Resources last updated: 12/16/2015 12:47:53 AM