EAServer 5.3 JDK 1.5 problems

I've upgraded my EAServer to patch 14147, following it's
instructions I've also changed the serverstart.bat and the
setenv.bat.

I can deploy a jar created using JDK 1.4.2_06, and create
stubs and skeletons (deploying manually or using ant
scripts).

When I deploy the same code in jar file compilied with JDK
1.5.0_09

I get a bunch of warnings: [jag_gen_stubs]
java.lang.ClassFormatError: version number not valid

which looks like this in the Jaguar log:

Mar 15 15:08:16 2007: 050015-Generate code for: Package /
MyFramework
Mar 15 15:08:16 2007: 050016-Generation compiler option:
-generatedependentclasses
Mar 15 15:08:16 2007: 050016-Generation compiler option:
-stonserver
Mar 15 15:08:16 2007: 050016-Generation compiler option:
-compilestubs
Mar 15 15:08:16 2007: 050016-Generation compiler option:
-ejb
Mar 15 15:08:16 2007: 050016-Generation compiler option: -jv
Mar 15 15:08:16 2007: 050016-Generation compiler option: 1.2
Mar 15 15:08:16 2007: 050016-Generation compiler option:
-hpp
Mar 15 15:08:16 2007: 050016-Generation compiler option:
$JAGUAR/include
Mar 15 15:08:17 2007: 070013-Caught Exception:
java.lang.ClassFormatError: version number not valid
0
Leah
3/15/2007 7:12:18 PM
sybase.easerver.general 7903 articles. 0 followers. Follow

2 Replies
649 Views

Similar Articles

[PageSpeed] 53
Get it on Google Play
Get it on Apple App Store

If I understand correctly you are deploying components that are compiled 
with JDK1.5 to the server that is running with JDK1.4 ? This will not 
work properly as JDK 1.5 classes cannot be loaded by JDK1.4

Thanks,

Sandip

Leah Stephens wrote:
> I've upgraded my EAServer to patch 14147, following it's
> instructions I've also changed the serverstart.bat and the
> setenv.bat.
> 
> I can deploy a jar created using JDK 1.4.2_06, and create
> stubs and skeletons (deploying manually or using ant
> scripts).
> 
> When I deploy the same code in jar file compilied with JDK
> 1.5.0_09
> 
> I get a bunch of warnings: [jag_gen_stubs]
> java.lang.ClassFormatError: version number not valid
> 
> which looks like this in the Jaguar log:
> 
> Mar 15 15:08:16 2007: 050015-Generate code for: Package /
> MyFramework
> Mar 15 15:08:16 2007: 050016-Generation compiler option:
> -generatedependentclasses
> Mar 15 15:08:16 2007: 050016-Generation compiler option:
> -stonserver
> Mar 15 15:08:16 2007: 050016-Generation compiler option:
> -compilestubs
> Mar 15 15:08:16 2007: 050016-Generation compiler option:
> -ejb
> Mar 15 15:08:16 2007: 050016-Generation compiler option: -jv
> Mar 15 15:08:16 2007: 050016-Generation compiler option: 1.2
> Mar 15 15:08:16 2007: 050016-Generation compiler option:
> -hpp
> Mar 15 15:08:16 2007: 050016-Generation compiler option:
> $JAGUAR/include
> Mar 15 15:08:17 2007: 070013-Caught Exception:
> java.lang.ClassFormatError: version number not valid
0
Sandip
3/15/2007 8:38:31 PM
I think you misunderstood.

I have upgraded EAServer and run it with the JDK1.5.0_09
that is included in the patch...

My first test was to deploy my Jars compiled with JDK 1.4 to
the EAServer running 1.5 - it works fine.

My second test was to deploy my Jars compiled with the same
JDK 1.5 as EAServer - and this is where I got the warnings.

I found also, that my web app does work with the warnings -
however my Java application is getting
java.rmi.RemoteException: CORBA UNKNOWN errors when I
attempt to use it.

Thank
Leah

> If I understand correctly you are deploying components
> that are compiled  with JDK1.5 to the server that is
> running with JDK1.4 ? This will not  work properly as JDK
> 1.5 classes cannot be loaded by JDK1.4
>
> Thanks,
>
> Sandip
>
> Leah Stephens wrote:
> > I've upgraded my EAServer to patch 14147, following it's
> > instructions I've also changed the serverstart.bat and
> > the setenv.bat.
> >
> > I can deploy a jar created using JDK 1.4.2_06, and
> > create stubs and skeletons (deploying manually or using
> > ant scripts).
> >
> > When I deploy the same code in jar file compilied with
> > JDK 1.5.0_09
> >
> > I get a bunch of warnings: [jag_gen_stubs]
> > java.lang.ClassFormatError: version number not valid
> >
> > which looks like this in the Jaguar log:
> >
> > Mar 15 15:08:16 2007: 050015-Generate code for: Package
> > / MyFramework
> > Mar 15 15:08:16 2007: 050016-Generation compiler option:
> > -generatedependentclasses
> > Mar 15 15:08:16 2007: 050016-Generation compiler option:
> > -stonserver
> > Mar 15 15:08:16 2007: 050016-Generation compiler option:
> > -compilestubs
> > Mar 15 15:08:16 2007: 050016-Generation compiler option:
> > -ejb
> > Mar 15 15:08:16 2007: 050016-Generation compiler option:
> > -jv Mar 15 15:08:16 2007: 050016-Generation compiler
> > option: 1.2 Mar 15 15:08:16 2007: 050016-Generation
> > compiler option: -hpp
> > Mar 15 15:08:16 2007: 050016-Generation compiler option:
> > $JAGUAR/include
> > Mar 15 15:08:17 2007: 070013-Caught Exception:
> > java.lang.ClassFormatError: version number not valid
0
Leah
3/16/2007 12:23:12 PM
Reply:

Similar Artilces:

EAServer 5.1 vs 5.1 or 5.0
I am looking at deploying EAServer version 5.2 on Windows. Has anybody tried this before? what are the changes between version 5.0 and 5.1 or between version 5.0 and version 5.2. Will appreciate any response in this regards. TIA Sandy wrote: > I am looking at deploying EAServer version 5.2 on Windows. Sandy, Where are you seeing EAServer 5.2??? I just checked downloads on Sybase for the last 12 months and there is no 5.2 version. > Has anybody tried this before? what are the changes between version 5.0 and > 5.1 or You would want to use 5.1 and not 5...

Problem with connection cache EASERVER 5.1/ASE 12.5.1
I have just migrated our application of EASERVER 4.2.4 (developer edition) towards EASERVER 5.1 (licensed advanced edition). I have two connection cache (ODBC, JDBC) with a ASE 12.5.1. it's a mixed-site PowerDynamo (ODBC) and JSP (JDBC). I have this problem which occurs in a random way (ODBC Cache) : oct. 18 08:50:59 2004: Error: An attempt was made to obtain an XA connection from cache: 'intermetiers', but 2 Phase Commit option is not licensed for this server. oct. 18 08:50:59 2004: HTMLDW: RetrieveEX Failed, DB message below oct. 18 08:50:59 2004: HTMLDW: Canno...

Easerver 5.2 and JDK 1.5
Hello everybody : Anybody got EAServer 5.2 to work with JDK 1.5? I'm getting this error : failed to access Jaguar/JavaInit Thanks. -Kian- I would think that the easerver code is compatible with 1.5. It would be the same situation if you try and run java code in 1.4 that had been compiled with 1.3. Having said that I just ran some code compiled with 1.4.2 using 1.5.0_01 and it ran so it might be something else. In getting easerver to run with jdk1.5.0 did you just modify one of the variables in the setenv.bat file? Even if you did get it to work I doub...

Problems to integrate Axis 1.3 to EAServer 5.1
Hi, has anyone used Axis 1.3 from EAServer 5.1? I am trying this out but gets into some problem that most probably comes from commons-logging. When I try to instantiate my Client class from an EJB on EAServer it seems that LogFactory.newInstance gets a NullpointerException. I have tried multiple things like setting used log in my client to SimpleLog or NoOpLog. I have checked the verbose log from jvm that the latest commons-logging.jar is used when loading the classes. But still it simply refuses to insantiate my Axis client. Anyone succeded with this or have any tip? ...

EAServer 3.5 C5 and IE 5.0 vs 5.5
Latest issue in the production release of my first EAServer product... Environment: EAServer 3.5 C5 Build PB 10077 NT4, SP6 Oracle 8.1.7...using OCI connection caches When using the IE 5.0 browser, most things seem to work (all work in development environment of course). Users using IE 5.5 are getting the generic PB error in TryInvoke (calling a component method). That effectively invalidates the Jaguar server; thus, the server must be restarted. Has anyone else encountered this issue? I just now discovered it was the browser version causing the problem...I've been d...

5.3.1 -> 5.3.1.8 Problems
I am new to eBiz-Impact but have over 20 years of experience in Unix as a developer and Admin. The eBiz Impact has me a little baffled on the client side. First I have installed eBiz Impact v5.3.1 server on a Solaris 2.8 machine and added the patches to bring it to v5.3.1.8 (I have a few comments on the patching procedure we are forced to take, I will save that for another time.) All this went fine. Second I installed the eBiz Impact v5.3.1 client on a Windows XP System, the initial installation worked fine. I have patched to v5.3.8 and I can not get the MMC snap-in stuf...

Proplem with..Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Name: Tony Email: Accuscopeathotmaildotcodotuk Product: Firefox Summary: Proplem with..Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729) Comments: I have used Firefox for many years but I am not happy with latest version. You can set options such as home page and security and privacy settings but as soon as you close the browser and re start it remembers none of the settings??? Very frustrating! I have re-installed several times and rebooted every time but it always goes back to a default page as though I had just do...

3.5/3.5.1/3.5.2
Name: david levy Email: davidatlevy98dotfsnetdotcodotuk Product: Firefox Summary: 3.5/3.5.1/3.5.2 Comments: Scrap this version as it is crap. Add-ons no longer work, including my Norton security, web pages struggle to load. General loading of Firefox has been tripled in load time. Takes up to much memory. Some web pages do not work properly when they had worked before. Its rubbish - I went back to 3.0.13. That at least works as Firefox should work. Chuck version 3.5 in the bin and restart from 3.0.13 which is the last version that works. Browser Details: Mozilla/5.0 (Wind...

EASERVER 3.5 and EASERVER 3.6
Hi ALL Who can tell me the difference between with EASERVER 3.5 and EASERVER 3.6 (EASERVER 3.6.1) thanks 361 is J2EE 1.2 complianant 36 is close to being compliant, and the final features are in 361 for J2EE 1.2 EAS 35 supports ejb 1.0. I strongly suggest you upgrade to 361. ...

JSF 1.1 on Easerver 5.5
I am currently building and application using JSF 1.1 and trying to deploy it into the Web Container on EaServer 5.5 I have built the application based on the JSP 2.3 standard and included both the props files and the sybase-easserver-config.xml within the META-INF directory of my webroot. All the necessary class library=92s are within the META-INF/lib directory. Errors: The following error has been observed in the jaguarhttpservlet log Mar 20 09:18:31 2008: HTTP Listener(s) for web applications: http://sarrcp001t1:8080 HTTPS Listener(s) supporting integ...

EAServer 5.5 IIOP Connections vs EAServer 5.2
We just upgrade from EAServer 5.2 to 5.5. We are noticing different behavior with the iiop sessions. We are running the same code on both versions. Basically we only have stateless session beans deployed to EAServer. With 5.2 the number of iiop sessions never goes above 2. However with version 5.5 the number of iiop sessions grows quickly until it hits the max of 20 (I guess the developer version limit was changed from 5 to 20). Does anyone know if version 5.5 of EAServer change the way it manages the iiop connections? When are these connections released? Any information abo...

PB 10.5 and EAServer 5.3 (Intially posted on EAServer NewsGroup)
We are migrating from PB 9.0.1 to PB 10.5. Currently, we employ EAServer 5.1.0 in both development and production environments. The PB 10.5 installation guide states that if you migrate to PB 10.5 you need EAServer 5.3 or later. Can we migrate EAServer components built using PB 9.0.1 to PB 10.5 and deploy them to EAServer 5.1.0? Can we migrate JSP Targets built using PB 9.0.1 to PB 10.5 and deploy them to EAServer 5.1.0? We do not employ any functionality in reference to WebServices or any of the new Web features in PB 10.5. P.S. This question was initially posed on t...

SQLCentral problems with ASE12.5.2 and EAServer 5.1
I added ASE 12.5.2 on my W2000 PC that has EAServer 5.1 on it. I lost the plugin for EAS but got it back by reinstalling EAS client but I cannot see the installed ASE servers on the PC. Before in earlier versions I saw ASE plus the servers below and then logged in to configure them. Did I miss a step on the install for 12.5.2? TIA Joe ...

EAServer 5.5 problem
Hi, I'm trying to upgrade our TEST EAServer to 5.5 (Win 2003 server, Oracle DB). We're able to simulate user transactions by sending HTTP requests to the ISS server pointed towards the EAServer. If the CPU load of the "jagsrv.exe" is less than 50% in "windows task manager", the server runs for days. But if there is more than 50% CPU of the "jagsrv.exe" the EAServer freezes after a few hours : - the logs are not updated (no sign of a problem at all in the logs). - the CPU usage of the "jagsrv.exe" drops to 0 . - it is not possible t...

Web resources about - EAServer 5.3 JDK 1.5 problems - sybase.easerver.general

Java IO - Real's HowTo
Real's HowTo Custom Search Java Language String and Number Applet AWT Swing Environment IO Javascript interaction JDBC Thread Networking JSP ...

Sybase Product Documentation
Sybase On-line Product Manuals


Why Choose Jetty? - Webtide
There are several open source HTTP servers and Servlet Containers available: Eclipse Jetty, Apache Tomcat, Glassfish, Resin, so a frequently ...

Contact Us - Trusted SSL Certificate - Wildcard SSL Certificate - SSL
To contact Entrust online-support, see this page for phone, fax, email and hours of operation. Or to track a service request (SR), fill out the ...

Jetty Documentation - Jetty - Codehaus
Skip to content Skip to breadcrumbs Skip to header menu Skip to action menu Skip to quick search Quick Search Browse Pages Blog Labels Attachments ...

Liquidmatrix Security Digest - Default Passwords List - Liquidmatrix Security Digest
A large portion of this list was compiled using the great work by Phenoelit [table id=2 /]

Sow Ching Shiong - Vulnerability Research: Directory Traversal
Description Sybase EAServer is the leading solution for distributed and Web-enabled PowerBuilder applications. EA Server can be used to run ...

Powerbuilder Consultant, Powerbuilder Migration and Bespoke Software Development in West Sussex
Based in West Sussex UK, Powersoft offer a wide range of bespoke software development services. Our Powerbuilder & EAServer developers have 20 ...

Java Networking - Real's HowTo
Real's HowTo Custom Search Java Language String and Number Applet AWT Swing Environment IO Javascript interaction JDBC Thread Networking JSP ...

Resources last updated: 12/3/2015 2:06:13 PM