Easerver 5.2 and JDK 1.5

Hello everybody :
Anybody got EAServer 5.2 to work with JDK 1.5?
I'm getting this error :
failed to access Jaguar/JavaInit
Thanks.
-Kian- 

0
Kian
4/19/2005 9:36:41 PM
📁 sybase.easerver.general
📃 7903 articles.
⭐ 0 followers.

💬 3 Replies
👁️‍🗨️ 599 Views


I would think that the easerver code is compatible with 1.5. It would be 
the same situation if you try and run java code in 1.4 that had been 
compiled with 1.3.
Having said that I just ran some code compiled with 1.4.2 using 1.5.0_01 
and it ran so it might be something else.
In getting easerver to run with jdk1.5.0 did you just modify one of the 
variables in the setenv.bat file?
Even if you did get it to work I doubt it would be supported
Pete
Kian Tan wrote:
> Hello everybody :
> 
> Anybody got EAServer 5.2 to work with JDK 1.5?
> 
> I'm getting this error :
> 
> failed to access Jaguar/JavaInit
> 
> Thanks.
> 
> -Kian- 
> 
> 
0
Peter
4/19/2005 10:59:31 PM
I would highly discourage anyone from using a JDK with EAServer that is 
not specifically supported by Sybase.  We ran into strange, erratic 
crashes when we upgraded to an interim JDK release - not even a point 
release.  The problem is that EAServer does JNI calls to dlls that 
apparently depend on some JVM internal structures that are not 
guaranteed to be the same in different releases.
In article <426579e5$1@forums-2-dub>, kian@nospam.com says...
> Hello everybody :
> 
> Anybody got EAServer 5.2 to work with JDK 1.5?
> 
> I'm getting this error :
> 
> failed to access Jaguar/JavaInit
> 
> Thanks.
> 
> -Kian- 
> 
> 
> 
0
Mark
4/20/2005 12:05:18 AM
Yup.  Its not as easy as changing an environment variable.  You can only 
use JDK's listed as supported by Sybase.
Dave Wolf
Cynergy Systems
http://www.cynergysystems.com
Mark Maslow wrote:
> I would highly discourage anyone from using a JDK with EAServer that is 
> not specifically supported by Sybase.  We ran into strange, erratic 
> crashes when we upgraded to an interim JDK release - not even a point 
> release.  The problem is that EAServer does JNI calls to dlls that 
> apparently depend on some JVM internal structures that are not 
> guaranteed to be the same in different releases.
> 
> In article <426579e5$1@forums-2-dub>, kian@nospam.com says...
> 
>>Hello everybody :
>>
>>Anybody got EAServer 5.2 to work with JDK 1.5?
>>
>>I'm getting this error :
>>
>>failed to access Jaguar/JavaInit
>>
>>Thanks.
>>
>>-Kian- 
>>
>>
>>
0
Dave
4/20/2005 5:46:26 PM
Reply: