Re:[wxperl-users] Symbol Lookup Error

  Hello,

> just compiled wxPerl 0.21 under SuSe Linux 9.2 with gtk2. W=
hen I try to start
my programm I get :
> 
> perl: symbol lookup error:=
 /usr/local/lib/libwx_gtk2u-2.4.so: undefined
symbol: _gtk_accel_group_a=
ttach
> 
> Did I do something wrong ?

  From a quick Google search i=
t looks like a bug in wxGTK 2.4.2.
Could you try with wxGTK 2.6.0 (the n=
ew stable release)?

Regards
Mattia
=0A=0A=0A=0A_____________________=
_______________________________________=0A6X velocizzare la tua navigazio=
ne a 56k? 6X Web Accelerator di Libero!=0AScaricalo su INTERNET GRATIS 6X=
 http://www.libero.it=0A


0
mattia
5/24/2005 7:38:06 AM
perl.wxperl.users 3070 articles. 0 followers. Follow

2 Replies
383 Views

Similar Articles

[PageSpeed] 7
Get it on Google Play
Get it on Apple App Store

Hi All,

I am trying to size my grid correctly but I am having a few issues.

I try and autosize my grid columns to fill the grid by getting the size of
the grid using $grid->GetClientSize->width then setting the column widths
using $grid->SetColSize( n ).

The problem I am having is that the grid then grows in width to accomodate
the vertical scrollbars (which are not shown since the grid only has one
row). I try and use the method $grid->GetVirtualSize, since wxGrid is
derived from wxScrolledWindow but is says that the method does not exist.

I then wanted to 'always' display the vertical scrollbars whether needed or
not but I could not find a way to do this.

Does anybody know anything to assist here? I basically want my columns to
fill the grid without the silly extra white space to the right of the
columns.

Many thanks
Mark


0
mark
5/25/2005 6:50:12 AM
On Wed, 25 May 2005 08:45:32 +0200 Mark Wardell <mark@netcontrol.co.za> wrote:

  Hello,

> I am trying to size my grid correctly but I am having a few issues.

  Sorry, this answer is late and useless... this question should be asked
on wx-users (not because it is offtopic, but since this really is
wxWidgets behaviour, it is more likely the question will be answered there).

Regards
Mattia


0
mattia
5/29/2005 10:44:39 AM
Reply:

Similar Artilces:

RE: [wxperl-users] Symbol Lookup Error
This is a multi-part message in MIME format. ------_=_NextPart_001_01C56065.C06CE4D4 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable Hi Andre, it's a bug with wxWidgets-2.4. the following patch fix it: =20 --- orig/wxWindows-2.4.2/src/gtk/menu.cpp 2003-09-20 12:24:30.000000000 +0200 +++ wxWindows-2.4.2/src/gtk/menu.cpp 2004-12-16 11:53:03.299421800 +0100 @@ -30,7 +30,7 @@ #ifdef __WXGTK20__ #include <glib-object.h> =20 - #define gtk_accel_group_attach(g, o) _gtk_accel_group_attach((g), (o)) + #defin...

Re: [wxperl-users] Re: wxperl
yes !! its really time to help more mattia. things i could offer are beside bug reports is to help to buil a better brwosable doku, this is one of my long time wish so are so. herbert "Graciliano M. P." <gmpowers@terra.com.br> schrieb am 11.12.04 03:29:27: > > > hey all, > > > > I just tried downloading the cvs snapshot, Wx-0.20, Wx-0.19, and Wx-0.18 > > and trying to install them on solaris (without luck). I tried both > wxAll-2.4.2 > > and wxWidgets-2.5.3. > > > > Furthermore, I went to the wikis for more in...

[wxperl-users] Re:Error trying to compile wxPerl
[CC-ing wxperl-users@lists.sourceforge.net] Hello, > I have recently installed wxWidgets and was trying to install wxPerl bu= t > am having trouble installing the module. > > perl Makefile.PL works find. > Most of the compilation works fine however, I get the following message= : > > g++ -c -I. -I. -I/usr/lib64/wx/include/gtk2-unicode-release-2.5 > -I/usr/include/wx-2.5 -O2 -fmessage-length=3D0 -Wall -g -Wall -pipe = > -DVERSION=3D\"0.26\" -DXS_VERSION=3D\"0.26\" -fPIC > "-I/usr/lib/perl5/5.8.6/x86_64-linux-t...

[wxperl-users] Symbol Lookup Error
This is a multi-part message in MIME format. ------=_NextPart_000_0013_01C55FF7.B02A4C10 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Hi, just compiled wxPerl 0.21 under SuSe Linux 9.2 with gtk2. When I try to = start my programm I get : perl: symbol lookup error: /usr/local/lib/libwx_gtk2u-2.4.so: undefined = symbol: _gtk_accel_group_attach Did I do something wrong ? Thanks, Andre ------=_NextPart_000_0013_01C55FF7.B02A4C10 Content-Type: text/html; charset="iso-8859-1" Content-Transfer-Encoding...

Fwd: wxPerl on the Mac; was: [wxperl-users] Re: problems with wxPerl
>To: Jouke Visser <jouke@pvoice.org>, wxperl-users@lists.sourceforge.net >From: Christian Jaeger <christian.jaeger@sl.ethz.ch> >Subject: wxPerl on the Mac; was: [wxperl-users] Re: problems with wxPerl >Date: Sun, 30 Sep 2001 23:08:19 +0100 > >Hello, > >I'm crossposting this reply to the macosx-perl mailing list because >there is some interest, too. Actually I forgot to put the macosx-perl adress on it. >At 14:02 Uhr +0200 24.9.2001, Jouke Visser wrote: >>I wondered if anyone yet tried to compile wxPerl on a Mac. If not, I'...

[wxperl-users] [ wxperl-Patches-1430238 ] OSX wxPerl bundle error
Patches item #1430238, was opened at 2006-02-12 11:08 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=315655&aid=1430238&group_id=15655 Please note that this message will contain a full copy of the comment thread, including the initial issue submission, for this request, not just the latest update. Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: John Ralls (jralls) Assigned to: Nobody/Anonymous (nobody) Summary: OSX wxPerl b...

RE: [wxperl-users] Re: wxValidator available via wxPerl
Dear Mattia (or others, if they can help), I've been delving into how to use wxValidators, and I think I understand the concept (and I like it!). However, I'm having real trouble deriving my own validator (called, unimaginitively, myValidator) from Wx::PlValidator. >From the wxWindows documentation, all validators must implement a Clone method. I have tried implementing a Clone method, which I can see getting called, but myValidator's Validate, TransferFromWindow, and TransferToWindow never seem to get called. Here is my code (with the methods apart from Clone do...

RE: [wxperl-users] Re: wxValidator available via wxPerl
Mattia, Thanks, as usual, for the to-the-point and quick support! If/when I manage to produce a useful validator, I would be more than happy to submit it. Currently I'm still getting my head round how everything fits together! James > -----Original Message----- > From: Mattia Barbon [mailto:mbarbon@dsi.unive.it] > Sent: 13 December 2001 11:04 > To: wxperl-users@lists.sourceforge.net > Subject: [wxperl-users] Re: wxValidator available via wxPerl >=20 >=20 > > Dear Mattia, > > I would like to use validators in my Perl application, but=20 ...

Re:[wxperl-users] Re: wxPerl 0.23 release
> Mattia Barbon <mattia.barbon@libero.it> writes: > > > On Tue, 28 J= un 2005 22:44:29 +0200 Johan Vromans <jvromans@squirrel.nl> wrote:=0D = > > Under Windows the change in the default font is to > > be expected= .. > > I'm using Fedora Core 2... :-) I suppose I could not be m= ore wrong... Anyway: the font change looks like a GTK+ 1.2 vs 2.x ch= ange. For the button width you should try the wxBU_EXACTFIT style fo= r the buttons that need to be smaller than standard buttons. HTH=0D = Mattia =0A=0A=0A...

Re: [wxperl-users] wxPerl on Gentoo
we both assumed too negative, please look here: http://www.gentoo.org/doc/en/ebuild-submit.xml this information you should also give on your site regards herbert ...

RE: [wxperl-users] wxPerl and Printing
VB users would rate things like Active Reports and VPE (Virtual Print = Engine). Both very capable systems and better than Crystal for many = uses, but obviously depends on your ability to use ActiveX controls in = your project. =20 Ed W -----Original Message----- From: Mark Wardell [mailto:mark@netcontrol.co.za] Sent: 13 August 2003 11:42 To: wxperl-users@lists.sourceforge.net Subject: [wxperl-users] wxPerl and Printing Hi All, This is a fairly broad topic, but I am interested to hear what experiences other users have had with printing from wxPerl applications, as well...

RE: [wxperl-users] MozEmbed and WxPerl
I have tested the Mozilla ActiveX plugin using the Wx::ActiveX module = and it works (have google in a Wx right now). =20 =20 Since I haven't gotten around to fixing the Wx::ActiveX module (as per a = discussion some time ago), you would need to use the Win32::OLE = compatible object from GetOLE() for some of the method and property = calls. =20 Unfortunately, as with all things ActiveX, it is Windows centric and may = not be what you are looking for. =20 Anyway, the Wx::ActiveX::Mozilla package would look something like this: =20 package Wx::ActiveX::Mozilla; use Wx::ActiveX...

Re: [wxperl-users] wxperl on MacOSX
> Hello Hello > Tough I'm a bit in doubt > whether wxperl will work on the mac (primarily MacOSX, MacOS9 would > be cool too)? There are various problems: 1 - I don't have a Mac, so someone else shoild work on it ( any takers? ;-) ) 2 - wxWindows on MacOS X is still not as stable as the Windows/GTK ports, though it is progressing steadily, and the developers are generally very responsive WRT bugreports; on MacOS 9 it should be pretty stable though 3 - On MacOS 9 you need to use Codewarrior which isn't free If you want to give it a tr...

Re: [wxperl-users] wxPerl on wxX11 ?
Hello, > is it possible to compile wxPerl on wxX11 rather than on wxGTK ? It should be possible. > If yes, will it be functional ? As functional as wxX11 itself, I guess. Regards Mattia ...

Web resources about - Re:[wxperl-users] Symbol Lookup Error - perl.wxperl.users

Resources last updated: 12/19/2015 12:21:07 AM