[wxperl-users] 0.51 compile error

hello mattia,
maybe i help you, when i pointing you to some problems one of our board members had to compile wxperl. shure its german but may the errormsg is helpful to you.

http://board.perl-community.de/cgi-bin/ikonboard/ikonboard.cgi?s=60d7df9b51ef5e4a660626f7e5310cf1;act=ST;f=4;t=207;st=0;r=1;&#entry6

keep up the good work
herbert
______________________________________________________________
Verschicken Sie romantische, coole und witzige Bilder per SMS!
Jetzt bei WEB.DE FreeMail: http://f.web.de/?mc=021193


0
deirdre_skye (208)
7/8/2006 10:24:59 AM
perl.wxperl.users 3070 articles. 0 followers. Follow

5 Replies
2771 Views

Similar Articles

[PageSpeed] 43
Get it on Google Play
Get it on Apple App Store

On Sat, 08 Jul 2006 12:24:59 +0200
herbert breunung <deirdre_skye@web.de> wrote:

  Hello,

> maybe i help you, when i pointing you to some problems one of our board members had to compile wxperl. shure its german but may the errormsg is helpful to you.
> 
> http://board.perl-community.de/cgi-bin/ikonboard/ikonboard.cgi?s=60d7df9b51ef5e4a660626f7e5310cf1;act=ST;f=4;t=207;st=0;r=1;&#entry6

  I understand the poster is using Linux, but in this
case the important part is: which wxWidgets version?

  Could you ask them for me? (I do not know German...)

Thanks,
Mattia

0
mattia
7/8/2006 8:22:22 PM
it was  2.6.1.2

Mattia Barbon wrote:
> On Sat, 08 Jul 2006 12:24:59 +0200
> herbert breunung <deirdre_skye@web.de> wrote:
>
>   Hello,
>
>   
>> maybe i help you, when i pointing you to some problems one of our board members had to compile wxperl. shure its german but may the errormsg is helpful to you.
>>
>> http://board.perl-community.de/cgi-bin/ikonboard/ikonboard.cgi?s=60d7df9b51ef5e4a660626f7e5310cf1;act=ST;f=4;t=207;st=0;r=1;&#entry6
>>     
>
>   I understand the poster is using Linux, but in this
> case the important part is: which wxWidgets version?
>
>   Could you ask them for me? (I do not know German...)
>
> Thanks,
> Mattia
>
>   


0
deirdre_skye
7/9/2006 10:11:19 PM
Hello All,

is there a way to compile wxPerl 0.53 without 'Alien' ?

I mean, in the same manner wxPerl 0.26 used to be compiled ?

Thanks,
  Sergei.



Applications From Scratch: http://appsfromscratch.berlios.de/

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

0
sergstesh
7/11/2006 9:23:29 PM
On Mon, 10 Jul 2006 00:11:19 +0200
herbert breunung <deirdre_skye@web.de> wrote:

> it was  2.6.1.2

  2.6.1 works for me with wxPerl 0.53, it's likely to be already fixed.

Regards
Mattia
 
> Mattia Barbon wrote:
> > On Sat, 08 Jul 2006 12:24:59 +0200
> > herbert breunung <deirdre_skye@web.de> wrote:
> >
> >   Hello,
> >
> >   
> >> maybe i help you, when i pointing you to some problems one of our board members had to compile wxperl. shure its german but may the errormsg is helpful to you.
> >>
> >> http://board.perl-community.de/cgi-bin/ikonboard/ikonboard.cgi?s=60d7df9b51ef5e4a660626f7e5310cf1;act=ST;f=4;t=207;st=0;r=1;&#entry6
> >>     
> >
> >   I understand the poster is using Linux, but in this
> > case the important part is: which wxWidgets version?
> >
> >   Could you ask them for me? (I do not know German...)
> >
> > Thanks,
> > Mattia
> >
> >   
> 
> 
> 
> -------------------------------------------------------------------------
> Using Tomcat but need to do more? Need to support web services, security?
> Get stuff done quickly with pre-integrated technology to make your job easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
> _______________________________________________
> wxperl-users mailing list
> wxperl-users@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/wxperl-users

0
mattia
7/11/2006 9:23:55 PM
Hello All,

is it possible to compile wxPerl on wxX11 rather than on wxGTK ?

If yes, will it be functional ?

Thanks,
  Sergei.

Applications From Scratch: http://appsfromscratch.berlios.de/

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

0
sergstesh
7/12/2006 12:31:19 AM
Reply:

Similar Artilces:

[wxperl-users] wxPerl 0.51
Hi, I have just compiled the new wxPerl with Alien. The question for me is now, which wxWidgets is in use when I start my app. The one under Alien or the one under Wx ? Is the Version String correct with a comma (was a point before) ? And when I try to use Wx::Notebook HitTest, I get an error that the function isn't implemented. But when I check the XS files it is defined there. Did I do something wrong ? Should I have deleted the old wxPerl before compiling ? Systeminfo: Windows XP SP2, Perl 5.8.6, wxWidgets 2.6.3 Thanks for the great work so far and keep it ...

[wxperl-users] [ wxperl-Bugs-935780 ] WxPerl 0.18 fails to compile with wxGTK 2.5.1
Bugs item #935780, was opened at 2004-04-15 19:21 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=935780&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Philipp Thomas (psmt) Assigned to: Nobody/Anonymous (nobody) Summary: WxPerl 0.18 fails to compile with wxGTK 2.5.1 Initial Comment: When trying to compile WxPerl against wxGTK 2.5.1, g++ stops with an error because in 2.5.1 void wxLogTrace...

[wxperl-users] compile wxperl on SLES 8.0
Hello! I try to compile wxPerl (Wx-0.13) on SUSE LINUX Enterprise Server.=20 Perl version: 5.8.0 wxgtk-2.4-config --version says: 2.4.0 After a while the build stops with the following error message: make[3]: Entering directory `/home/admin/wxperl/Wx-0.13/ext/pperl/carp' Array found where operator expected at /usr/lib/perl5/5.8.0/warnings.pm l= ine=20 294, at end of line (Missing operator before ?) syntax error at /usr/lib/perl5/5.8.0/warnings.pm line 294, near "croak @_= " Compilation failed in require at /usr/lib/perl5/5.8.0/warnings/register.p= m=...

[wxperl-users] Re:Error trying to compile wxPerl
[CC-ing wxperl-users@lists.sourceforge.net] Hello, > I have recently installed wxWidgets and was trying to install wxPerl bu= t > am having trouble installing the module. > > perl Makefile.PL works find. > Most of the compilation works fine however, I get the following message= : > > g++ -c -I. -I. -I/usr/lib64/wx/include/gtk2-unicode-release-2.5 > -I/usr/include/wx-2.5 -O2 -fmessage-length=3D0 -Wall -g -Wall -pipe = > -DVERSION=3D\"0.26\" -DXS_VERSION=3D\"0.26\" -fPIC > "-I/usr/lib/perl5/5.8.6/x86_64-linux-t...

[wxperl-users] [ wxperl-Bugs-853977 ] Compile error
Bugs item #853977, was opened at 2003-12-04 03:37 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=853977&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Nobody/Anonymous (nobody) Assigned to: Nobody/Anonymous (nobody) Summary: Compile error Initial Comment: Hello, OS : Solaris 7 on sparc Wxperl version : 0.18 perl : ActivePerl-5.8 my email: maurizio.rojnic@uljanik.hr I tried to compile Wxp...

[wxperl-users] [ wxperl-Bugs-838690 ] compile error
Bugs item #838690, was opened at 2003-11-09 08:47 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=838690&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Marco Lamberto (lmarco) Assigned to: Nobody/Anonymous (nobody) Summary: compile error Initial Comment: Hi, I'm running RedHat Linux 9, perl version is 5.8.0, the standard rpm shipped by RedHat, latest update. Gcc version is 3.2.2 20030222 (Re...

[wxperl-users] [ wxperl-Bugs-1605379 ] Compile error on Windows
Bugs item #1605379, was opened at 2006-11-29 09:16 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=1605379&group_id=15655 Please note that this message will contain a full copy of the comment thread, including the initial issue submission, for this request, not just the latest update. Category: None Group: None Status: Open Resolution: None Priority: 5 Private: No Submitted By: Nobody/Anonymous (nobody) Assigned to: Nobody/Anonymous (nobody) Summa...

[wxperl-users] [ wxperl-Bugs-1290970 ] nmake compilation error
Bugs item #1290970, was opened at 2005-09-14 14:48 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=1290970&group_id=15655 Please note that this message will contain a full copy of the comment thread, including the initial issue submission, for this request, not just the latest update. Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Outaspace (outaspace) Assigned to: Nobody/Anonymous (nobody) Summary: nmake compila...

[wxperl-users] Re:Some difficulty compiling wxPerl 0.26
Hello, in general, it is a good idea to send questions to wxperl-users@lists.sorceforge.net (CCd); I have limited connectivity these days. > I've tried to build and install wxPerl 0.26, but have come across a > compilation error. My system is Mandriva Linux 10.2. I have wxGTK 2.5.3= > installed. 'make' ran very cleanly until it got to compiling Constant.c= .. > The output is shown below: > > Constant.c: In function `double constant(const char*, int)': > Constant.c:640: error: `wxBUFFER_VIRTUAL_AREA' undeclared (first use th= is >...

[wxperl-users] [ wxperl-Bugs-588884 ] wxperl will not compile
Bugs item #588884, was opened at 2002-07-30 17:13 You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=588884&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Dan Stahlke (danstahlke) Assigned to: Nobody/Anonymous (nobody) Summary: wxperl will not compile Initial Comment: I cannot get the wxPerl module to compile. It breaks with this message: c++ -c -I/usr/local/lib/wx/include/gtk-2.3 -I/usr/local/include -I. -fno-rtti -fno-exceptions -O2 -DVERSION=\0.10\ -DXS_VERSION=\...

[wxperl-users] [ wxperl-Bugs-794428 ] could not compile 0.15 on RH9
Bugs item #794428, was opened at 2003-08-24 20:38 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=794428&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Jim Liedeka (jliedeka) Assigned to: Nobody/Anonymous (nobody) Summary: could not compile 0.15 on RH9 Initial Comment: has a lot of lines like this: invalid use of undefined type `struct wxStyledTextCtrl' cpp/st_typedef.h:20: forward declara...

[wxperl-users] wxperl-0.15 does not compile on mandrake 9.1
Hello, on mandrake 9.1 i tried to use the build rpm with "--nodeps" option howeve= r due to diffrent file locations between redhat and mandrake it seems not to work even with some work aroun= d.=20 I tried to build wxperl0-15 from source . The "make" stops at the dnd.c= file with the error message: c++ -c -I. -I/usr/lib/wx/include/gtk2-2.4 -I../.. -I/home/dakna/rpm/BUILD= /Wx-0. 15/..//contrib/include -O2 -fomit-frame-pointer -pipe -march=3Di586 -mcpu=3Dpe= ntiump ro -DVERSION=3D\"0.01\" -DXS=5FVERSION=3D\"0.01\" -fpic "-I/u...

[wxperl-users] [ wxperl-Patches-1430238 ] OSX wxPerl bundle error
Patches item #1430238, was opened at 2006-02-12 11:08 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=315655&aid=1430238&group_id=15655 Please note that this message will contain a full copy of the comment thread, including the initial issue submission, for this request, not just the latest update. Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: John Ralls (jralls) Assigned to: Nobody/Anonymous (nobody) Summary: OSX wxPerl b...

[wxperl-users] 0.52 OSX Compile error
Wx-0.52 does fix the wxMediaCtrl compile issues, but here is a new one on OSX 10.4.7 -- I think all the other version numbers are below. Let me know if you need anything else... macbook:~/src/Wx-0.52 mike$ make g++ -c -I. -I. -I/Library/Perl/5.8.6/darwin-thread-multi-2level/Alien/wxWidgets/mac_2_6_3/lib/wx/include/mac-ansi-release-2.6 -I/Library/Perl/5.8.6/darwin-thread-multi-2level/Alien/wxWidgets/mac_2_6_3/include/wx-2.6 -UWX_PRECOMP -O3 -DVERSION=\"0.52\" -DXS_VERSION=\"0.52\" "-I/System/Library/Perl/5.8.6/darwin-thread-multi-2level/CORE&qu...

Web resources about - [wxperl-users] 0.51 compile error - perl.wxperl.users

O'Reilly Open Source Convention 2007 • July 23-27, 2007 • Portland, Oregon
O'Reilly Open Source Convention 2007 - July 23-27, 2007 - Portland, Oregon

Resources last updated: 12/27/2015 1:23:21 AM