Uh-oh, the C compiler 'cc' doesn't seem to be working.

PPC Mac Mini, Mac OS X 10.4.8, I'm following along in README.macosx  
and I've done this:

export SDK=/Developer/SDKs/MacOSX10.4u.sdk

and I call

../Configure -Accflags="-nostdinc -b$SDK/user/include/gcc -B$SDK/usr/ 
lib/gcc -isystem$SDK/usr/include -F$SDK/System/Library/Frameworks" - 
Aldflags="-W1,-syslibroot,$SDK"

as suggested. I take defaults until it checks the compiler. Here's  
the what happens there:

--------------------------
Use which C compiler? [cc]
powerpc-apple-darwin8-gcc-4.0.1: '-b' must come at the start of the  
command line
Uh-oh, the C compiler 'cc' doesn't seem to be working.
powerpc-apple-darwin8-gcc-4.0.1: '-b' must come at the start of the  
command line
Uh-oh, the C compiler 'cc' doesn't seem to be working.
You need to find a working C compiler.
Either (purchase and) install the C compiler supplied by your OS vendor,
or for a free C compiler try http://gcc.gnu.org/
I cannot continue any further, aborting.
--------------------------

The README indicates that the parameters are useful for making perl  
aware of the SDK, as I understand it, so I'm going to try this  
without parameters.

But I thought I'd go ahead and ask if anyone can confirm that these  
parameters aren't necessary if I'm not making the parallel install  
aware of the sdk, or if anyone can give me a hint about what I'm  
doing. (I've never used such parameters when compiling perl in the  
past, haven't done an install in a year or so.)

There is a possibility I erased part of the SDK when I was intending  
to move an alias to XCode into the applications folder and forgot  
that the actual bundle moves when users that can modify the  
applications folder (admin users) drag and drop wtihout the option key.

Also, the notes in README.macosx seem to indicate that shared  
libraries and threads are now functional. Anyone on the list here  
using them with (parallel installs of) apache 2 and mod_perl?
0
joel_rees
10/28/2006 11:00:32 AM
perl.macosx 2309 articles. 0 followers. Follow

5 Replies
2190 Views

Similar Articles

[PageSpeed] 18

On Oct 28, 2006, at 7:00 AM, Joel Rees wrote:

> PPC Mac Mini, Mac OS X 10.4.8, I'm following along in README.macosx  
> and I've done this:
>
> export SDK=/Developer/SDKs/MacOSX10.4u.sdk

Well, first things first. You asked if you *really* need to use the SDK.

You need to use an SDK if you're cross-compiling, such as:

	a. Making a Universal Binary build of Perl, either to distribute or  
to use for building and distributing UB modules.
	b. Building Perl to run on a OS version other than the one you're  
building with.

> There is a possibility I erased part of the SDK

SDKs are separate sub-packages in the Xcode package, so you can re- 
install them pretty easily, without installing the whole thing.

sherm--

Web Hosting by West Virginians, for West Virginians: http://wv-www.net
Cocoa programming in Perl: http://camelbones.sourceforge.net


0
sherm
10/28/2006 12:36:58 PM
In article <D371767A-B42A-46D6-86B3-5668FBA610F6@sannet.ne.jp>,
 joel_rees@sannet.ne.jp (Joel Rees) wrote:

> PPC Mac Mini, Mac OS X 10.4.8, I'm following along in README.macosx  
> and I've done this:
> 
> export SDK=/Developer/SDKs/MacOSX10.4u.sdk
> 
> and I call
> 
> ./Configure -Accflags="-nostdinc -b$SDK/user/include/gcc -B$SDK/usr/ 
> lib/gcc -isystem$SDK/usr/include -F$SDK/System/Library/Frameworks" - 
> Aldflags="-W1,-syslibroot,$SDK"
> 
> as suggested. I take defaults until it checks the compiler. Here's  
> the what happens there:
> 
> --------------------------
> Use which C compiler? [cc]
> powerpc-apple-darwin8-gcc-4.0.1: '-b' must come at the start of the  
> command line
> Uh-oh, the C compiler 'cc' doesn't seem to be working.
> powerpc-apple-darwin8-gcc-4.0.1: '-b' must come at the start of the  
> command line
> Uh-oh, the C compiler 'cc' doesn't seem to be working.
> You need to find a working C compiler.
> Either (purchase and) install the C compiler supplied by your OS vendor,
> or for a free C compiler try http://gcc.gnu.org/
> I cannot continue any further, aborting.
> --------------------------

hello,

trying to compile perl 5.8.8 for panther, i get the same error !!



-- 
klp
0
kurtzlepirate
10/28/2006 1:26:11 PM
On 28 okt 2006, at 13.00, Joel Rees wrote:

> PPC Mac Mini, Mac OS X 10.4.8, I'm following along in README.macosx  
> and I've done this:
>
> export SDK=/Developer/SDKs/MacOSX10.4u.sdk
>
> and I call
>
> ./Configure -Accflags="-nostdinc -b$SDK/user/include/gcc -B$SDK/usr/ 
> lib/gcc -isystem$SDK/usr/include -F$SDK/System/Library/Frameworks" - 
> Aldflags="-W1,-syslibroot,$SDK"
>
> as suggested. I take defaults until it checks the compiler. Here's  
> the what happens there:
>
> --------------------------
> Use which C compiler? [cc]
> powerpc-apple-darwin8-gcc-4.0.1: '-b' must come at the start of the  
> command line
>
	This message is clearly indicative. You should try putting the -b  
option first in -Accflags
-Accflags="-b$SDK/user/include/gcc  -nostdinc -B$SDK/usr/lib/gcc - 
isystem$SDK/usr/include -F$SDK/System/Library/Frameworks"
> Uh-oh, the C compiler 'cc' doesn't seem to be working.
> powerpc-apple-darwin8-gcc-4.0.1: '-b' must come at the start of the  
> command line
> Uh-oh, the C compiler 'cc' doesn't seem to be working.
> You need to find a working C compiler.
> Either (purchase and) install the C compiler supplied by your OS  
> vendor,
> or for a free C compiler try http://gcc.gnu.org/
> I cannot continue any further, aborting.
> --------------------------
>
> The README indicates that the parameters are useful for making perl  
> aware of the SDK, as I understand it, so I'm going to try this  
> without parameters.
>
> But I thought I'd go ahead and ask if anyone can confirm that these  
> parameters aren't necessary if I'm not making the parallel install  
> aware of the sdk, or if anyone can give me a hint about what I'm  
> doing. (I've never used such parameters when compiling perl in the  
> past, haven't done an install in a year or so.)
>
> There is a possibility I erased part of the SDK when I was  
> intending to move an alias to XCode into the applications folder  
> and forgot that the actual bundle moves when users that can modify  
> the applications folder (admin users) drag and drop wtihout the  
> option key.
>
> Also, the notes in README.macosx seem to indicate that shared  
> libraries and threads are now functional. Anyone on the list here  
> using them with (parallel installs of) apache 2 and mod_perl?

-------------------------------------
This sig is dedicated to the advancement of Nuclear Power
Tommy Nordgren
tommy.nordgren@chello.se



0
tommy
10/28/2006 2:08:12 PM
Hi, Sherm,

On 2006/10/28, at 21:36, Sherm Pendley wrote:

> On Oct 28, 2006, at 7:00 AM, Joel Rees wrote:
>
>> PPC Mac Mini, Mac OS X 10.4.8, I'm following along in  
>> README.macosx and I've done this:
>>
>> export SDK=/Developer/SDKs/MacOSX10.4u.sdk
>
> Well, first things first. You asked if you *really* need to use the  
> SDK.
>
> You need to use an SDK if you're cross-compiling, such as:
>
> 	a. Making a Universal Binary build of Perl, either to distribute  
> or to use for building and distributing UB modules.
> 	b. Building Perl to run on a OS version other than the one you're  
> building with.

Then since this copy of perl is for apache 2, I don't need it.

Thanks.

>> There is a possibility I erased part of the SDK
>
> SDKs are separate sub-packages in the Xcode package, so you can re- 
> install them pretty easily, without installing the whole thing.

Yeah, I figured re-installing XCode should be sufficient, since the  
only thing that I moved (and then tried to delete because I thought  
it was an alias) was XCode.

Building perl without the SDK options worked.

But I'm still wondering whether I wanted the shared libraries and  
threads. In fact, looking at perl -V on the system perl and comparing  
it to the parallel perl, I'm thinking maybe I wanted that  
multiplicity thing and I probably did want the large files option and  
what is PERL_IMPLICIT_CONTEXT, and, oh, it looks like there are some  
advisories I need to check.

Especially I'm thinking the shared libraries and threads are going to  
be useful with mod_perl.

thanks more.

> sherm--
>
> Web Hosting by West Virginians, for West Virginians: http://wv-www.net
> Cocoa programming in Perl: http://camelbones.sourceforge.net
>
>

0
joel_rees
10/28/2006 4:15:55 PM
On 2006/10/28, at 23:08, Tommy Nordgren wrote:

>
> On 28 okt 2006, at 13.00, Joel Rees wrote:
>
>> PPC Mac Mini, Mac OS X 10.4.8, I'm following along in  
>> README.macosx and I've done this:
>>
>> export SDK=/Developer/SDKs/MacOSX10.4u.sdk
>>
>> and I call
>>
>> ./Configure -Accflags="-nostdinc -b$SDK/user/include/gcc -B$SDK/ 
>> usr/lib/gcc -isystem$SDK/usr/include -F$SDK/System/Library/ 
>> Frameworks" -Aldflags="-W1,-syslibroot,$SDK"
>>
>> as suggested. I take defaults until it checks the compiler. Here's  
>> the what happens there:
>>
>> --------------------------
>> Use which C compiler? [cc]
>> powerpc-apple-darwin8-gcc-4.0.1: '-b' must come at the start of  
>> the command line
>>
> 	This message is clearly indicative. You should try putting the -b  
> option first in -Accflags
> -Accflags="-b$SDK/user/include/gcc  -nostdinc -B$SDK/usr/lib/gcc - 
> isystem$SDK/usr/include -F$SDK/System/Library/Frameworks"

I though about trying that, but cc --help says the -b option is for  
the architecture. And I realized that maybe I didn't want to be doing  
something I'd have to specify the architecture for.

Thanks.

>> Uh-oh, the C compiler 'cc' doesn't seem to be working.
>> powerpc-apple-darwin8-gcc-4.0.1: '-b' must come at the start of  
>> the command line
>> Uh-oh, the C compiler 'cc' doesn't seem to be working.
>> You need to find a working C compiler.
>> Either (purchase and) install the C compiler supplied by your OS  
>> vendor,
>> or for a free C compiler try http://gcc.gnu.org/
>> I cannot continue any further, aborting.
>> --------------------------
>>

0
joel_rees
10/28/2006 4:19:13 PM
Reply:

Similar Artilces:

''''''''''''''''''''
Name: haznen Email: haznenatyahoodotcom Product: Gran Paradiso Alpha 8 Summary: '''''''''''''''''''' Comments: '''''''''''''''''''''''''''''''''''' Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061204 UGES/1.7.2.0 GranParadiso/3.0a1 From URL: http://www.mozilla.org/projects/granparadiso/ Note to readers: Hendrix gives...

'printsetup' doesn't seem to work
This is a multi-part message in MIME format. ------=_NextPart_000_0014_01BFE733.FBB8BDC0 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Dear All, I have a rte control in which there would be different types of contents = that require either letter or legal size paper. Before I called 'print()', I called 'printsetup()' so that the user can = switch the size of the paper through this nice little box. However, the settings my users put in this pop-up setup dialogue box = don't seem to be taken by the p...

'do' won't 'do' if '/'
Greetings to All from Au, Have a NetWare Perl 5.8.4 and wanted to tweak File\Spec\NW.pm to try and standardise on '/' separators. If I run a test script (t/uni/lower.t) with an unmodified NW.pm, it calls t/uni/case.pl, that, in case.pl, (when the path separators are '\'), the $file is '..\lib\unicore\To\Lower.pl' and the following code portion works, with $simple getting a returned table: sub casetest { my ($base, $spec, $func) = @_; my $file = File::Spec->catfile(File::Spec->catdir(File::Spec->updir, "lib", &qu...

'''''
Name: mario Email: ramar17atfastwebnetdotit Product: Gran Paradiso Alpha 2 Summary: ''''' Comments: K: Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2) Gecko/20070206 GranParadiso/3.0a2 ...

[% IF UserInGroup('advanced') %] doesn't seem to work ...
I have defined a new group called 'advanced', and in order to only let the so-called advanced users view certain fields, I have enclosed the code in the templates as follows: [% IF UserInGroup('advanced') %] <tr> [% sel = { description => 'Platform', name => 'rep_platform' } %] [% INCLUDE select %] </tr> <tr> [% sel = { description => 'OS', name => 'op_sys' } %] [% INCLUDE select %] </tr> [% END %] However, this does not seem to work, as the code enclosed wit...

The 'a' command in the debugger doesn't seem to be working in blead
< does seem to work ...

Installation 'Sybase DataWindow PS' printer on W98 doesn't work (so PDF export can't work either)
I have a problem with export DataWindow content to PDF on W98 systems. (I don't have any problem with PDF export on other systems like as WINNT, W2K, WXP). I found out that the problem is in the Sybase DataWindow PS printer. It looks like installed but it DOESN'T WORK on W98. When I try print something on this printer then no PostScript file is created. So I tried manual installation of it but it occurs an error during manual installation (I used description of instalation from Bruce Armstrong). The error said that printer driver (PSCRIPT.DLL) can't be loaded. I use...

'To', 'CC', & 'BCC'
Name: Dick Tracy Email: philipdottracyatoptusnetdotcomdotau Product: Thunderbird Summary: 'To', 'CC', & 'BCC' Comments: I have just started using Thunderbird and while I find it quite excellent- I suggest having a button to add addressees to 'BCC' as well. Currently each 'BCC' addressee has to be selected manually. I send e-mail to quite a number of people at a time and I do not wish to readily spread others addresses easily. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0....

Firefox doesn't work well in 'User' mode as opposed to 'Administrator' mode
Name: Dave Wintermute Email: dewin59atgmaildotcom Product: Firefox Summary: Firefox doesn't work well in 'User' mode as opposed to 'Administrator' mode Comments: Logging into my account fails on http://www.boynton-beach.org/ in User logon, but works fine in Administrator logon. Similarly, loggin into my account at wireless.att.com fails in the User logon, but works ok in the Administrator logon. I recently downloaded Chrome and discovered that I do not have these problems when logging into my accounts with either of the above sites. I will probably s...

'Tab' control 's visible doesn't work.Why?
I use tab control in my applition. And I set visible=false, but it doesn't work. my code is: ----------------------------------------------- <asp:ScriptManager ID="ScriptManager1" runat="server" />  <div>   <ajaxToolkit:TabContainer runat="server" ID="Tabs" Height="138px" ActiveTabIndex="0"    Width="402px">    <ajaxToolkit:TabPanel runat="server" ID="Panel1" HeaderText="Tab1" Visible="f...

Why doesn't C# have a 'with' statement?
For the many people that ask "Why doesn't C# have a 'with' statement?" in this forum I thought I would put the answer up and just let them do a search. So here is your answer directly from Microsoft: http://msdn.microsoft.com/vcsharp/team/language/ask/withstatement/default.aspxView My Blog Download My URL Rewriter and Reverse ProxyOnly $9.95/month, ASP.NET, 2GB & SQL 2005 i don't know why, but i still think it is a bad programming practiceGO HOKIES!!! Harold, Do you think not having 'With' is a good programming practice or having 'With' is a good programming practice...

'exists'? Why doesn't it work?
------_=_NextPart_001_01C31893.158D4106 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Hi everybody, I'm having a problem using the exists function. I have the following = code that takes a list of searchwords (@search) and searches texts = stored in a MySQL database and orders them by relevance. My idea was that records that contain more than one search word are = probably more relevant than others.=20 The search results (id, rank) are stored in a hash with id as key and = rank as the corresponding value. As it may be p...

It isn't useful to me at all
Name: Dan Product: eBay Companion Summary: It isn't useful to me at all - doesn't seem to work Comments: The sidebar doesn't function at all. I can't client the "connect to ebay" button - nothing happens. There doesn't seem to be any place that I can tell it about what account to log in with. The buttons in the menu that it added to my menu bar don't work. The only function that does work is the button in the menu bar that brings up the options, takes me to the ebay home page, and the search bar in the sidebar takes me to searches. All ...

C# How to insert new line into multi-line textbox? '\n' doesn't work!
There are plenty of places that tell you how to do this in a Windows Textbox, but not in the .net textbox. Not only does '\n' not work, but neither does '\r\n', or Environment.NewLine Lets say that I want to return a number of email addresses from a databases, and foreach record set the email address as a new line in the textbox. Can anybody help?MCAD You may try this: String mssage = "This is first one\n" ; mssage+= "This is second one\n"; mssage+="This is third one"; TextBox1.Text = mssage; This po...

Web resources about - Uh-oh, the C compiler 'cc' doesn't seem to be working. - perl.macosx

Resources last updated: 12/27/2015 11:42:04 PM