X client 'Can't open display' on OS11

I'm having a difficult time getting a remote x client to display on my
machine. I have an xserver running locally, and connect via ssh.

I turned on X11 forwarding in remote host sshd_config:
X11Forwarding yes 
X11DisplayOffset 10
X11UseLocalhost yes

I set the local ssh(OpenSSH) connection for X11 Forwarding. 

An X server, Xming, is running locally.

X on the remote host is running without listening on port 6000:
# ps -ef |grep X
root      1940  1924  0 Aug20 tty7     00:34:30 /usr/bin/X :0 -audit 0
-br -auth /var/lib/gdm/:0.Xauth -nolisten tcp vt7

netstat -an |grep 6000 returns nothing.

Running an X client doesn't work:
oracle@oraman:~> xclock
Error: Can't open display: 

It's my understanding that with tunneling I don't have to turn on TCP
listening for ssh on the host. 

I checked the SDB and seem to have things set up correctly, but it's
not working. 

What am I missing?


-- 
DonMLewis
------------------------------------------------------------------------



0
DonMLewis
8/29/2008 7:46:02 PM
opensuse.org.network-internet 6943 articles. 1 followers. Follow

6 Replies
1054 Views

Similar Articles

[PageSpeed] 28

Sorry, no one has answered you. I would love to help you out, except I
have the exact same problem, and I don't know what to do either. Did you
ever figure this out?


-- 
zak89
------------------------------------------------------------------------
zak89's Profile: http://forums.opensuse.org/member.php?userid=10788
View this thread: http://forums.opensuse.org/showthread.php?t=394056

0
zak89
11/3/2008 6:26:01 PM
I use suse 11.3 on PIII, loaded with <init 3>, as gateway to/from
internet. I access my data on this gateway with, for example, <gedit &>
at home or outside with xming+putty. On suse 11.4/12.1 i cant't use
gedit in such way. I get error: "Cannot open display". This issue is
from suse 11.4/12.1 only, because there is no problems with 11.3.


-- 
makauskas
------------------------------------------------------------------------
makauskas's Profile: http://forums.opensuse.org/member.php?userid=45338
View this thread: http://forums.opensuse.org/showthread.php?t=394056

0
makauskas
11/21/2011 7:46:03 AM
On 11/21/2011 08:46 AM, makauskas wrote:
> I get error: "Cannot open display".

is this as a normal user, or as root?

i assume you have not logged into the Gnome GUI as root and i _guess_ 
you are wanting to launch a graphical application (like gedit) in gnome 
with root powers....to do that you need to be in the terminal as a 
normal user, then issue this command:

[code]
gnomesu gedit
[/code]

and, give the root password when asked for..

does that work for you?

-- 
DD http://tinyurl.com/DD-Caveat
dump Flash: http://www.bbc.co.uk/news/technology-15797399
0
DenverD
11/21/2011 11:36:24 AM
Set DISPLAYMANAGER_REMOTE_ACCESS="yes" is not enough


-- 
makauskas
------------------------------------------------------------------------
makauskas's Profile: http://forums.opensuse.org/member.php?userid=45338
View this thread: http://forums.opensuse.org/showthread.php?t=394056

0
makauskas
11/21/2011 11:56:02 AM
DenverD;2407625 Wrote: 
> On 11/21/2011 08:46 AM, makauskas wrote:
> > I get error: "Cannot open display".
> 
> is this as a normal user, or as root?
> 
> i assume you have not logged into the Gnome GUI as root and i _guess_
> you are wanting to launch a graphical application (like gedit) in
> gnome
> with root powers....to do that you need to be in the terminal as a
> normal user, then issue this command:
> 
> > 
Code:
--------------------
  >   > 
  > gnomesu gedit
  > 
--------------------
> > 
> 
> and, give the root password when asked for..
> 
> does that work for you?
> 
> --
> DD 'DD Caveat' (http://tinyurl.com/DD-Caveat)
> dump Flash: 'BBC News - 'Occupy Flash' manifesto calls for end to
> Adobe plug-in' (http://www.bbc.co.uk/news/technology-15797399)


I enable "Remote root login in the display manager" and "Remote access
to the X server" aditionaly.
Then log as normal user
<gnomesu gedit> through the same "Cannot open display" error in putty
window.
And I'm not asked for any password !

With <su> in putty
<init 5>
<gedit>
I have the same error "Cannot open display"

But with suse 11.3 I can log as normal user into remote and run gedit
in window on local WinXp. Suse 11.3 is loaded with run level = 3. 
With suse 11.4/12.1 can't do it remotely.


-- 
makauskas
------------------------------------------------------------------------
makauskas's Profile: http://forums.opensuse.org/member.php?userid=45338
View this thread: http://forums.opensuse.org/showthread.php?t=394056

0
makauskas
11/21/2011 12:36:03 PM
sorry, i can't help any...hope someone else can..

-- 
DD
0
DenverD
11/21/2011 1:16:49 PM
Reply:

Similar Artilces:

''''''''''''''''''''
Name: haznen Email: haznenatyahoodotcom Product: Gran Paradiso Alpha 8 Summary: '''''''''''''''''''' Comments: '''''''''''''''''''''''''''''''''''' Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061204 UGES/1.7.2.0 GranParadiso/3.0a1 From URL: http://www.mozilla.org/projects/granparadiso/ Note to readers: Hendrix gives...

'do' won't 'do' if '/'
Greetings to All from Au, Have a NetWare Perl 5.8.4 and wanted to tweak File\Spec\NW.pm to try and standardise on '/' separators. If I run a test script (t/uni/lower.t) with an unmodified NW.pm, it calls t/uni/case.pl, that, in case.pl, (when the path separators are '\'), the $file is '..\lib\unicore\To\Lower.pl' and the following code portion works, with $simple getting a returned table: sub casetest { my ($base, $spec, $func) = @_; my $file = File::Spec->catfile(File::Spec->catdir(File::Spec->updir, "lib", &qu...

'''''
Name: mario Email: ramar17atfastwebnetdotit Product: Gran Paradiso Alpha 2 Summary: ''''' Comments: K: Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2) Gecko/20070206 GranParadiso/3.0a2 ...

[perl6/specs] fac7a1: can't mix 'my Dog $x' with 'my $x of Dog'
----==_mimepart_521397ad3ea1b_457f66fd50681b7 Date: Tue, 20 Aug 2013 09:22:05 -0700 Mime-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit Content-ID: <521397ad3f5fc_457f66fd50682f0@hookshot-fe4-pe1-prd.aws.github.net.mail> Branch: refs/heads/master Home: https://github.com/perl6/specs Commit: fac7a1ae9b6407749ef236d4f9510ef5d6ab8163 https://github.com/perl6/specs/commit/fac7a1ae9b6407749ef236d4f9510ef5d6ab8163 Author: Larry Wall <larry@wall.org> Date: 2013-08-20 (Tue, 20 Aug 2013) Changed paths: M S02-...

'NMDayTim', 'Psock' , 'NMTime' , 'NMFtp' can not be opened.
hello, my colleague have developed an application under c++ builder 5. so now i should undertake it and optimize it. last days i have installed the C++ Builder 2010 testversion to get some experience on it, because i have not used it before. when i try to compile the old project in C++ builder 2010, comes some Compile errors. Also, there are some Includes like 'NMDayTim', 'Psock' , 'NMTime' , 'NMFtp' in this old Project. they can be found and compiled in the old c++ Builder 5. but not in c++ builder 2010. so i want to know do i solve this problem or go...

I can't get no cache, I can't get no cache. 'Cause I try and I try and I try and, I can't get no, I can't get no cache.
I have fiddled out for days tinkering with the setting in about:config trying to get FireFox 12 to use the disk cache. I have NOT found the trick. This One Trick Pony ain't doing it like it used to up until recently. Pray tell anyone, What information can I share that will point a knowledgeable person to aid me in getting FF to disk.cache? I have also tried restarting FF with add-ons disabled, (There were NOT too many to do this to, so it was quick and easy) Here is my stab at trying to convey the information that MIGHT govern matters Using about:cache Informatio...

Re: I can't get no cache, I can't get no cache. ' Cause I try and I try and I try and, I can't get no, I can't get no cache.
<div>please com e see me about htis<br /> <br /> ------- Original Message f= rom the Global Relay Archive -------<br /> From: Hp &lt;ferd@farkel.net&gt;= <br /> To: "support-firefox@lists.mozilla.org" &lt;support-firefox@lists.mo= zilla.org&gt;<br /> Sent: Sun, 27 May 2012 18:30:18 -0700<br /> Subject: I = can't get no cache, I can't get no cache. 'Cause I try and I try and I try = and, I can't get no, I can't get no cache.<br /> <br /></div> <pre class=3D"gr-maex-body-pre&qu...

2010: Can't register - can't download the software - can't register until I have the software
I have active maintenance on Rad Studio: From: Vicky Rassmisaengthong [mailto:Vicky.Rassmisaengthong@EMBARCADERO.COM] Sent: Wednesday, February 25, 2009 1:58 PM To: rgrossman Cc: amer.supportadmin@codegear.com; Ashley Cosentino Subject: Software Assurance Support for Tech III Inc PO# Credit Card Dear Embarcadero Technologies Support Customer, Welcome! You have been registered as the primary contact on support account number AM####### Herewith we confirm your Embarcadero Technologies support agreement covering: Qty 1 RAD Studio Enterprise Named User licens...

Can't open a connection to site '%S_SRVID' because 'set up channel' message was not acknowledged
I'm using Adaptive Server Enterprise/12.5.2/EBF 11798/P/NT (IX86)/OS 4.0/ase1252/1831/32-bit/OPT/Fri Apr 09 04:15:03 2004 This morning the prod db server semi-hung. Although not pinned at 100%, all 4 cpus were constantly above 95% utilization. All application connecting to it became unusable. Killing spids did not help. When I issued a "shutdown <server_name> with nowait" I got the following message back: "Msg 7211, Level 18, State 1 Can't open a connection to site '<server_name>' because 'set up channel' message was not ack...

I can't stop a 'what's new' tab opening
Name: Bradley Crees Product: Shiretoko Summary: I can't stop a 'what's new' tab opening Comments: every time I open firefox it opens a tab with http://en-us.www.mozilla.com/en-US/firefox/3.1b1/whatsnew/ I can't stop it coming up, and it's affecting my ocd Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1 From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback but if you wish to provide one you must BCC (not CC) the sender for them to ...

Again with the 'reset' and 'can't be found' stuff...
Name: William Jones Email: jbillyjonesatyahoodotcom Product: Firefox Summary: Again with the 'reset' and 'can't be found' stuff... Comments: Hello Again FireFox, Listen...I'm just a simple guy, a 'dial-up baby boomer' who's had to learn the hard way all the way through. I recently sent a similar e-mail requesting assistance with this ridiculous and incessant 'pop up' that informs me that 'my connection has been reset', and/or, 'a problem locating page'....huh? I was just on the damn thing and even switching from one ...

xrdb: Connection refused AND xrdb: Can't open display ':1002'
Hi everyone, I'm trying to log into an LXDE workstation over FreeNX/NX. I've recently upgraded from 11.4 to 12.1. New users created after the upgrade can log in while users that existed on 11.4 cannot. The NX authentication succeeds and the !M window appears for about 3 or 4 seconds, then disappears. Looking in the ~/.nx/C-host-xxxx/sessions file shows the following errors below. Also a core file appears in the user's home directory, but I don't know how to analyze it. Any ideas on what is failing and how to fix it? Info: Established X client connection. ...

Can't allocate space for object '' in database 'tempdb',How can I do?
when I run system procedure,I got following messages : Can't allocate space for object '' in database 'tempdb' because the 'system'segment is full. If you ran out of space in syslogs, dump the transaction log. Otherwise, use ALTER DATABASE or sp_extendsegment to increase the size of thesegment. Failed to allocate disk space for a work table in database 'mydb'. You may be able to free up space by using the DUMP TRANsaction command, or you may want to extend the size of the database by using the ALTER DATABASE command. thanks. allan wrot...

Can't base report on stored procedure--'Can't create Datawindow'
I installed IM65 today to give it a try. I made a db config to our local ASE 11.9.2 engine via Sybase' odbc driver that came with 11.9.2. I start a new report, tell it to be tabular and to get data from a SP. It asks which SP and I tell it. The result is an odbc error: Cannot create DataWindow Intersolv SQL ODBC driver: Incorrect syntax near '='. 1 execute dbo.sp_si_addressbest_;0 RETURN_VALUE = :RETURN_VALUE' I can execute the SP fine from SQL Advantage or from Crytal Reports. Thanks. -- Frank Burleigh Indiana University School of Law Bloomi...

Web resources about - X client 'Can't open display' on OS11 - opensuse.org.network-internet

Resources last updated: 1/12/2016 2:12:00 AM