kmymoney: symbol lookup error: kmymoney: undefined symbol: _ZN13MyMoneyReport12setLineWidthEi

Hi,

I just upgraded to openSUSE 11.3, and switched KDE to 4.5 from 'Index
of /repositories/KDE:/Distro:/Factory/openSUSE_11.3'
(http://tinyurl.com/3azpfwj)

I added the Packman repo (as 'Index of /suse/11.3/'
(http://packman.inode.at/suse/11.3/)) and switched system packages to
it. Then I installed kmymoney 4.5-42.pm.42.1 from packman.

Now when I try to start kmymoney, all I get is this error:



Code:
--------------------
    KMyMoney reconciliation report plugin loaded
  KMyMoney printcheck plugin loaded
  QFSFileEngine::open: No file name specified
  KMyMoney iCalendar plugin loaded
  kmymoney: symbol lookup error: kmymoney: undefined symbol: _ZN13MyMoneyReport12setLineWidthEi
--------------------



Does anybody have an idea on what I could do about this? Or does
anybody else experience the same problem maybe?

Regards,
J�rg


-- 
jfrantzius
------------------------------------------------------------------------



0
jfrantzius
8/18/2010 9:36:02 PM
opensuse.org.help.applications 21533 articles. 1 followers. Follow

2 Replies
817 Views

Similar Articles

[PageSpeed] 5
Get it on Google Play
Get it on Apple App Store

[QUOTE=jfrantzius]
Hi,

I just upgraded to openSUSE 11.3, and switched KDE to 4.5 from 'Index
of /repositories/KDE:/Distro:/Factory/openSUSE_11.3'
(http://tinyurl.com/3azpfwj)

I added the Packman repo (as 'Index of /suse/11.3/'
(http://packman.inode.at/suse/11.3/)) and switched system packages to
it. Then I installed kmymoney 4.5-42.pm.42.1 from packman.

Now when I try to start kmymoney, all I get is this error:



Code:
--------------------
    KMyMoney reconciliation report plugin loaded
  KMyMoney printcheck plugin loaded
  QFSFileEngine::open: No file name specified
  KMyMoney iCalendar plugin loaded
  kmymoney: symbol lookup error: kmymoney: undefined symbol:
_ZN13MyMoneyReport12setLineWidthEi --------------------



Does anybody have an idea on what I could do about this? Or does
anybody else experience the same problem maybe?

Regards,
J�rg


[/QUOTE]
Hi
Not going to fix. From the packman mailing list;
[CODE]
openSuSE-11.3 ships with kde-4.4.4
if you updated to 4.5, you can't use our packages, as we compile and link 
against original SuSE-11.3 and/or packman packages.

So you can close your bug, I can't fix it, nor I can provide a kmymoney for 
kde-4.5 as we don't have the build-power to provide also all packages for 
factory.
[/CODE]

-- 
Cheers Malcolm ��� (Linux Counter #276890)
openSUSE 11.3 (x86_64) Kernel 2.6.34-12-default
up 15 days 7:04, 2 users, load average: 0.23, 0.21, 0.12
GPU GeForce 8600 GTS Silent - Driver Version: 256.44

0
malcolmlewis
8/18/2010 9:43:24 PM
Thanks for your answer. I managed to build kmymoney from sourcecode, but
either I don't know how to build the kmm_kbanking4 plugin from that
sourcecode, or its sourcecode is separate from kmymoney itself. Anyway,
when I try to run my self-built kmymoney against the kmm_kbanking4
plugin from packman, it crashes when trying to use HBCI.

Following up on https://mail.kde.org/mailman/listinfo/kmymoney kmymoney
users list...

Regards,
J�rg


-- 
jfrantzius
------------------------------------------------------------------------
jfrantzius's Profile: http://forums.opensuse.org/member.php?userid=22447
View this thread: http://forums.opensuse.org/showthread.php?t=444611

0
jfrantzius
8/19/2010 8:36:02 PM
Reply:

Similar Artilces:

Symbol lookup error
I'm using Inline->bind to bind to a static lib which has a few dependencies so I am setting LIBS to a series of 3 -L/-l pairs. Inline is successfully binding to the library and I go to make the call to the library but I'm failing with a Symbol lookup error - undefined symbol: bash-3.2$ /usr/local/bin/perl raid2 -load DbgSh.h Calling bind with libs set to -L/view/yfang_fp1.0_yfang_May24/vob/9200_packetcore/packetcore/infra/sysmgr/ipmi -lwiipmi -L/view/yfang_fp1.0_yfang_May24/vob/9200_packetcore/packetcore/infra/lib/src -lwinfra -L/vob/9200/software/common/debugshell ...

SOLVED: Want help-> symbol lookup error: libgdk-x11-2.0.so.0: undefined symbol: cairo_surface_flush
Just did "Online Update" of my openSUSE 11.4 64-bit installation (KDE) and non KDE apps are exiting with Code: -------------------- yogesh@linux-n1r6:~> firefox /usr/lib64/firefox/firefox: symbol lookup error: /usr/lib64/libgdk-x11-2.0.so.0: undefined symbol: cairo_surface_flush yogesh@linux-n1r6:~> gnucash gnc.bin-Message: main: binreloc relocation support was disabled at configure time. gnucash: symbol lookup error: /usr/lib64/libgdk-x11-2.0.so.0: undefined symbol: cairo_surface_flush -------------------- I don not remember w...

symbol lookup error: .../Parser.so: undefined symbol: Perl_Istack_sp_ptr
i'm not sure if the beginners list is the right place for this but i'll ask here anyway and someone can always point me elsewhere. i have a fully-updated, 64-bit ubuntu 11.04 system, with perl 5.10.1. i'm building a sizable software project that, from the top-level "make", downloads, patches and compiles numerous software packages. at one point, it tries to compile the "pacemaker" package (which is a high-availability cluster resource manager for what that's worth). part of the pacemaker build is to simply use "publican" to gen...

./ndsrepair: symbol lookup error: ./ndsrepair: undefined symbol: compute_paths
Hi. I cannot get any of the commands in /opt/novell/eDirectory/bin to run These includes ndsbackup, ndstrace, ndsrepair etc when i execute any of them e.g.ndsrepair i get ./ndsrepair: symbol lookup error: ./ndsrepair: undefined symbol: compute_paths Hi, 882 readme? ;) http://www.novell.com/documentation/edir88/readme/readme.txt 2.1.8 Older ConsoleOne Versions Break Nds Utilities If you install any version of ConsoleOne prior to ConsoleOne 1.3.6h on an OES2 server, many utilities do not function...

clear: symbol lookup error: clear: undefined symbol: _nc_free_tinfo
Code: -------------------- SoftHacker@linux-kuj3:~/Downloads> clear clear: symbol lookup error: clear: undefined symbol: _nc_free_tinfo SoftHacker@linux-kuj3:~/Downloads> -------------------- WTF!? :X:'( What is this and how to fix it??? :\:\ -- SoftHacker ------------------------------------------------------------------------ Run and compare this: Code: -------------------- $ which clear /usr/bin/clear -------------------- Code: -------------------- $ readelf -d $(which clear) | fgrep NEEDED 0x0000000000000001...

/usr/bin/perl: symbol lookup error: lib/i386-linux-thread-multi/auto/DBD/mysql/mysql.so: undefined symbol: is_prefix
Hi team, I tried to install the latest tar ball using bugzilla-4.2rc1.tar.gz on Linux and I ran the checksetup.pl, It prompted me to upgrade perl modules. I did one by one missing but finally it gave me an error as follows/ it needs DBD-mysql (v4.001) but found v3.0007. So, I ran that specific install perl and got this DBD up-todate. But now, when I run the ./checksetup.pl, I started getting the following error. This blocked my bugzilla installation now. /usr/bin/perl: symbol lookup error: lib/i386-linux-thread-multi/auto/DBD/mysql/mysql.so: undefined symbol: is_prefix Th...

symbol lookup error
I've installed a software named "COOT" under Opensuse11.1, but it alarmed when it started up each time.The error informations are following: INFO:: backup file coot-backup/_home_albert_Documents_bjdata_2_p41212_2_cns_1_bindividual.pdb_Tue_Feb_10_19:22:35_2009_modification_0.pdb.gz sh: symbol lookup error: /opt/CCP4/CCP4-Packages/Coot-0.4.1/lib/libreadline.so.5: undefined symbol: BC coot-exe: "/opt/CCP4/CCP4-Packages/Coot-0.4.1/bin/coot-real" coot-version: /opt/CCP4/CCP4-Packages/Coot-0.4.1/bin/coot-real /opt/CCP4/CCP4-Packages/Coot-0.4.1/bin/coot-real: ...

Cannot build symbol table
There have been a few similar posts, but this seems, to me, to be altogether different since this error is affecting my system quite adversely. Many important functions fail after an update from the openSuSE repositories (3rd time in as many days) and I have to reinstall the system from scratch. This most recent time, I disabled all experimental repos, in an attempt to prevent this from occurring again, but it happened nonetheless. The main things that I have noticed are failing: alsa and networkmanager (oddly I can still use ifup). This, which I've read about for other i...

pidgin: symbol lookup error
Pidgin won't start for me any more. Upon execution from the command line, this is the output: pidgin: symbol lookup error: /usr/lib/python2.6/site-packages/gst-0.10/gst/interfaces.so: undefined symbol: gst_stream_volume_format_get_type I've run sudo /sbin/ldconfig, but it didn't help. I've also reinstalled pidgin and libpurple. Is there anything else that will help? -- ArcticVanguard ------------------------------------------------------------------------ Hello ArcticVanguard and welcome to the community!:) I don't want to be rude but there...

Problem symbol lookup error
Hello everyone I try to lauch a program : PBAPro but when i got an error : symbol lookup error: /opt/PBApro-2.11.0/libppbase.so.2: undefined symbol: _ZN11QTreeWidget17setSelectionModelEP19QItemSelect ionModel I search on the web but i didn't find the answer. Can you help me ? Thanks ps i run an ldd pbapro > linux-a3dm:/opt/PBApro-2.11.0 # ldd pbapro > linux-gate.so.1 => (0xffffe000) > libppbase.so.2 => /opt/PBApro-2.11.0/libppbase.so.2 (0xb7869000) > libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0xb6f7f000) > libfreetype.so.6 => /usr/lib/libfreet...

Mason and undefined symbols error
Hello, I need some help troubleshooting an 'Undefined symbols' error.=20 I'm trying to get Mason/mod_perl/Apache to install and work properly. Currently I am running Mac OS X 10.2.8. I first installed Perl v5.8.4. (I still have the Perl 5.6 installation that comes from Apple.) I installed Apache 1.3.31 and mod_perl 1.29, which installed sucessfully and seem to work fine. (I explicitly used perl 5.8 to run Makefile.PL) Next I installed HTML::Mason and dependancies using the CPAN module. When I started up the CPAN shell, I also explicitly used perl 5.8. I then a...

Symbol lookup errors after updating libkdecore4
After updating libkdecore4 to version 4.5.1-297.7 from repository 'Index of /repositories/KDE:/Distro:/Factory/openSUSE_11.3' (http://tinyurl.com/3azpfwj), a lot of applications fail to start or crash shortly afterwards (Firefox, Thunderbird, Chrome). Especially kdm does not start, and startx with environment variable WINDOWMANAGER set to /usr/bin/startkde (the default value on my openSUSE 11.3) fails with: /usr/bin/kde4-config: symbol lookup error: /usr/lib/libkdecore.so.5: undefined symbol: _ZN9QListData11detach_growEPii /usr/bin/kde4-migrate: symbol lookup error: /usr/b...

Firefox does not start
Hi there! I recently updated via DVD: 11.1 → 11.2 Since that firefox won't start. When started in console, I get: Code: -------------------- /usr/lib64/firefox/firefox: symbol lookup error: /usr/lib64/libgdk-x11-2.0.so.0: undefined symbol: XRRGetScreenResourcesCurrent -------------------- The same with "cheese" by the way (but not too important for me): Code: -------------------- cheese: symbol lookup error: /usr/lib64/libgdk-x11-2.0.so.0: undefined symbol: XRRGetScreenResourcesCurrent -------------------- I tried to rei...

DBD-ODBC error: undefined symbol
Once upon a time, I successfully compiled and installed the DBI and DBD::ODBC modules to use with EasySoft's ODBC-ODBC-Bridge. But now I have a new Linux box, and although I tried to do everything the same way as before (within the limits of my memory), I get the following error when I try to use the new installation: perl: error in loading shared libraries: /usr/lib/perl5/site_perl/5.005/i386-linux/auto/DBD/ODBC/ODBC.so: undefined symbol: SQLAllocEnv For versions, I have odbc-odbc-bridge-1.0.0.25, DBI-1.14, and DBD-ODBC-0.28. Does anyone know what I might be missing, or can ...

Web resources about - kmymoney: symbol lookup error: kmymoney: undefined symbol: _ZN13MyMoneyReport12setLineWidthEi - opensuse.org.help.applications

Resources last updated: 1/22/2016 7:57:57 PM