MS11-100 2638420 2656351 Security Update for .NET Framework

This update continually tries to install on our Windows XP workstations
even though the deployment status shows "successful".  However,
Microsoft's Windows Updates site says it's not applicable (presumably
because it did install successfully).  The resulting multiple reboots
are becoming annoying.  And I can't remove it from the mandatory
baseline list because of the problem I posted about earlier today.

On the bright side, the various MS Office patches for versions we don't
have installed have finally, mysteriously, recently disappeared from the
list of applicable patches.  That's a relief.  They were always showing
up as the most unpatched vulnerabilities.


-- 
V. Wood
Endicott, NY
------------------------------------------------------------------------



0
vlwood
1/4/2012 6:06:02 PM
novell.zenworks.patch 2914 articles. 0 followers. Follow

11 Replies
1733 Views

Similar Articles

[PageSpeed] 36
Get it on Google Play
Get it on Apple App Store

Vlwood,

OK, this is what it's looking for:
System.Web.Extensions.dll with version (not file version) >= 
4.0.30319.272 in directory v4.0.30319 in the path specified by HKLM
\SOFTWARE\Microsoft\.NETFramework, InstallRoot and 
System.Web.dll with a version (not file version) >= 4.0.30319.272 in 
the same directory.

I'm running a test on one of my machines to see what I see...



-- 

Shaun Pond


0
Shaun
1/6/2012 4:05:05 PM
Vlwood,

I installed the .NET framework 4.0, then the patches for that, on my 
XPSP3 box, and I have no .net vulnerabilities showing.

-- 

Shaun Pond


0
Shaun
1/7/2012 8:24:24 AM
Path in registry is c:\WINDOWS\Microsoft.NET\Framework\ (yes, a lower
case c, if that matters)
There is no System.Web.Extensions.dll in folder
C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319
There is no System.Web.dll in folder
C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319
The deployment shows successful for the patch under Deployments.  In
the vulnerabilities screen for XP, six machines out of approx. 80
identified as needing the patch do show patched.  The 80 are the only
machines with dotNet 4 installed.  I think the six machines may actually
have asp.net installed, while the others do not, if that's any help.  I
know for sure that two of the machines showing as patched have software
that uses asp.net.


-- 
V. Wood
Endicott, NY
------------------------------------------------------------------------
vlwood's Profile: http://forums.novell.com/member.php?userid=1318
View this thread: http://forums.novell.com/showthread.php?t=450274

0
vlwood
1/9/2012 12:46:01 PM
Just connected remotely to one of the six machines that show as patched,
and sure enough it does have those two files as well as many other dlls
that are NOT found on the other 72 systems with dotNet 4 installed on
them.


-- 
V. Wood
Endicott, NY
------------------------------------------------------------------------
vlwood's Profile: http://forums.novell.com/member.php?userid=1318
View this thread: http://forums.novell.com/showthread.php?t=450274

0
vlwood
1/9/2012 12:56:01 PM
More wrinkles.  MS11-100 for dotNet 3.5 sp1 shows in ZPM as having
patched 98% of the systems, even in the Vulnerabilities window, but
Windows Updates shows this patch as not having been applied on those
same systems, at least on a random sampling of XP workstations.


-- 
V. Wood
Endicott, NY
------------------------------------------------------------------------
vlwood's Profile: http://forums.novell.com/member.php?userid=1318
View this thread: http://forums.novell.com/showthread.php?t=450274

0
vlwood
1/9/2012 1:06:02 PM
Vlwood,

sure these devices have the native scan option installed? They should 
show the same in that case

-- 

Shaun Pond


0
Shaun
1/9/2012 4:45:49 PM
Yes, they do.  I only show one system out of a couple thousand that
doesn't have it yet, an old laptop that was recently booted up.


-- 
V. Wood
Endicott, NY
------------------------------------------------------------------------
vlwood's Profile: http://forums.novell.com/member.php?userid=1318
View this thread: http://forums.novell.com/showthread.php?t=450274

0
vlwood
1/10/2012 12:26:02 PM
Vlwood,

didn't get chance to look through the logs yet, hopefully tomorrow...

-- 

Shaun Pond


0
Shaun
1/11/2012 5:23:58 PM
Vlwood,

got to be worth trying to deploy with the quiet switch off to see...

-- 

Shaun Pond


0
Shaun
1/11/2012 5:36:03 PM
Just to update this thread, I see that on 1/18/12 they released Rev. 2
which seems to have resolved this issue.


-- 
V. Wood
Endicott, NY
------------------------------------------------------------------------
vlwood's Profile: http://forums.novell.com/member.php?userid=1318
View this thread: http://forums.novell.com/showthread.php?t=450274

0
vlwood
1/23/2012 6:56:01 PM
Vlwood,

oh, good - someone else did our work for us :)

-- 

Shaun Pond


0
Shaun
1/24/2012 7:27:44 AM
Reply:

Similar Artilces:

Net Framework Patch Tuesday Update Failed
Hi Folks The patches: KB2898864 and KB2901118 Net Framework, failed to install with the unhelpful error code ff. I've been all round this problem for 2 days now and I haven't been able to fix it. I'm running Windows 7 SP1 and Net Framework V4. I was wondering if any of you knowledgeable folks could shed any light on this problem? Many thanks. regards -- Dakota Felixstowe UK On Thu, 13 Feb 2014 09:52:22 +0000, Dakota wrote: > Hi Folks > > The patches: KB2898864 and KB2901118 Net Framework, failed to install > with the unhelpful error code f...

Difference between asp.net security 2.0 & asp.net security 3.5 framework?
 HI, What are the difference between asp.net security 2.0 & asp.net security 3.5 framework? ASP.NET 3.5 security for me is almost the same as 2.0 as the former is built on top of the latter with the exceptions of framework specific libraries added to the newer framework. Most likely, your 2.0 applications will run well on 3.5 but not necessarily the other way around. The number of new classes added/improved from 2.0 to 3.5 is published and you may search them using your favorite search engine.  Patrick OliverosWeb Developer - Emerson Electric Asia, Ltd. - ROHQwebthinker.wor...

MS07-040 931212 928366 (2K, XP) Security Update for .NET Framework 1.1 SP1
MS07-040 931212 928366 (2K, XP) Security Update for .NET Framework 1.1 SP1 deployed successfully to most of our workstations. It failed on 6 workstations with the following Last Run Status "Failed 0x0000190C". When I click on the link for this error, the deployment results give a Last Run Result of Unable to execute the script. : PostScript1. Under the Deployment Details|Task: PostScript1, the Status is The script execution returned a non-zero error code from the operating system The script returned the following information: An error was returned from the MSI Installer whi...

Security Briefs: Security Enhancements in the .NET Framework 2.0
Security Briefs: Security Enhancements in the .NET Framework 2.0 http://msdn.microsoft.com/msdnmag/issues/05/01/SecurityBriefs/default.aspx *********************************************************** Quote *********************************************************** As I write this column, version 2.0 of the Microsoft .NET Framework is at Beta 1. When I got my bits, I hacked together a little program to dump all of the public members of all public types in the entire Framework and ran it on version 1.1 as well as 2.0. I then used WINDIFF.EXE to compare the two text files, and s...

How to update my .NET framework?
Hi all ASP.NET forum needs the updated version of .NET framework!! from where can i download it? thanksASP.NET Hosting (HostingFest) http://www.asp.net/download-1.1.aspx?tabindex=0&tabid=1...

Patching for security updates?
Is there any way to patch Firefox for these security updates, rather than deploying an entirely new (8M) installer? I've got a ton of computers I'd like to push it too, and I'm sure the fixes themselves can't be that huge... ...

Latest .net security update (KB 928365) breaking asp.net ajax?
Microsoft released a security update (KB 928365) to address some critical security issues in .net framework on july 10th. After installing the update, we found that some of the asp.net ajax related stuff are not working anymore. Specifically we use the Sys.WebForms.PageRequestManager.getInstance().add_endRequest feature of the ajax client side library and it is not working anymore after the patch is applied. Removing the patch brings everything back to normal. We found that the script used to initialize the scriptmanager Sys.WebForms.PageRequestManager._initialize is not being rendered after...

Zenworks patch management update server 6.3 server patch 6
--____DNNFMJENKMAMFEYVXCEU____ Content-Type: text/plain; charset=iso-8859-15 Content-Transfer-Encoding: quoted-printable Content-Disposition: inline; modification-date="Thu, 23 May 2007 12:16:37 -0400" Hello, Should I be seeing this patch in my vulnerabilities for my PL server? = Server agent version is 6.3.2.858. I don't see it. thanks Tom --____DNNFMJENKMAMFEYVXCEU____ Content-Type: multipart/related; boundary="____RAHTTLYUNHGCILCCFTGD____" --____RAHTTLYUNHGCILCCFTGD____ Content-Type: text/html; charset=iso-8859-15 Content-Transfer-Encodi...

Windows 2000 Security Patch: Security Update for Microsoft Virtual Machine (Microsoft VM)
This update helps resolve a vulnerability in the Microsoft virtual machine. After you install this item, you may have to restart your computer. Once this item is installed, it cannot be removed. http://makeashorterlink.com/?H58B62724 -- Regard: Joh@nnes "If U know neither the enemy nor yourself,U will succumb in every battle" ...

Problems while porting .Net framework 1.0 (VB.Net) application to .Net Framework 1.1
Hello,   I have a ASP.Net web application,written in VB.Net,developed on .Net Framework 1.0 .I am trying to port it on to .Net framework 1.1.   For achieving this,I follow the following steps-   1.Open the project using the .vbproj file. 2.I am prompted with the conversion message "Do you want to convert the solution and all projects to .Net framework  1.1....." 3.I click "Yes" 4.I assume that the project is now converted. 5.I build the project & try to run it. 6.I get the following error -     Server Error in '/Consert.Net' Application. ...

ASP.NET Extensions CTP and .NET Framework 3.5 SP1/.NET Framework 3.5 and vs2008 sp1?
Can someone explain the differences/relationships between asp.net extensions ctp, .net framework 3.5 sp1/.net framwork 3.5, and vs2008 sp1? I currently have a web app built with vs2008 RTM, .net framework 3.5 (no sp), and asp.net extensions ctp.  The system.web.extensions for framework 3.5 is version 3.5.0.0 and for .net extensions ctp it is 3.6.0.0.  Can I replace all web references with the ctp version 3.6?     CTP = Community Technology Preview; these are something like beta versions that are released so that they can be tested. these are generally...

Is it 100% sure that installing .NET 2.0 Framework will not affect V1.1 ASP.NET applications running on IIS6.0?
    Hi           I 've several important V1.1 ASP.NET application running on company 's production server running Windows 2003 .Now I 've developed Web application with .NET 2.0 Framework + ATLAST ( It's my mistake because I did not know that on production server doesn't have .NET 2.0 Framework installed before ).            So that I need to make sure to tell my company 's administrator to install .NET 2.0 Framework on production server( If .NET 2.0 Framework is installed and V...

Unable to update security patch
MY SYSTEM IS TRYING TO INSTALL A SECURITY UPDATE, BUT I GET THE FOLLOWING MESSAGE: A package could not that allows the task to complete. DETAILS ARE AS FOLLOWS patch:libfreebl3-2258.noarch conflicts with libfreebl3-32bit.x86_64 < 3.12.6-3.1.1 provided by libfreebl3-32bit-3.12.6-2.pm.6.2.x86_64 IS THIS A PROBLEM? SHOULD I IGNORE IT? DO I NEED TO INSTALL IT, IF SO HOW? -- Crossbone ------------------------------------------------------------------------ First, please try to repair your caps or caps-lock key. Second, please what level of openSUSEE are you usin...

NET Framework & .NET Framework Software Development Kit??
I know some regular HTML, just enough to get me in trouble if I'm not careful. So basically I am completley new to this stuff. I do some programming here at home for my own use but nothing Web style, my son has suggested this for me as another project to learn on. My question is I have downloaded and installed the 2 files referenced in the subject line. This is the question, is there susposed to be an Editer in there somewhere? If so where if not just say no. I did download WebMatrix and have looked at it. But a 508Mg SDK file surely has something in there. Thanks alot. I'm tring to learn....

Web resources about - MS11-100 2638420 2656351 Security Update for .NET Framework - novell.zenworks.patch

Framework - Wikipedia, the free encyclopedia
Text is available under the Creative Commons Attribution-ShareAlike License ;additional terms may apply. By using this site, you agree to the ...

Natasha Stott Despoja launches 'world first' framework to address domestic violence
Australia's first national, evidence-based domestic violence framework was launched at Parliament House on Tuesday.

Xposed framework for Android 6.0 Marshmallow could arrive this week
Towards the end of October we told you that Xposed framework for Android 6.0 Marshmallow would soon become available for all. While that's still ...

Safe Harbor 2.0 framework begins to capsize as January deadline nears
(credit: Andree Stephan ) Safe Harbour 2.0, currently being drawn up by the EU and US authorities, "will not provide a viable framework for ...

Frameworks releasing 'Time Spent' EP
by Andrew Sacher photo by Shauna Hundeby Gainesville's Frameworks became one of the more promising new bands in the current wave of screamo with ...

Cisco Announces New Skills Framework to Address Evolving Technology
Internet of Things (IoT), cloud, business transformation and network programmability will influence all Cisco Career Certifications.

Google engineers craft a Dart framework for iOS and Android
The UI framework uses its own rendering engine to draw widgets

Int'l groups launch new global framework to eliminate human rabies
... the worst rabies problem. Metro Manila (CNN Philippines) – International organizations launched on Thursday (December 10) a new global framework ...

The Complex Framework Of The UN Climate Talks, Demystified
As COP21 convenes this week in Paris, this data viz breaks down all you need to know about the history, key players, and big decisions. Yesterday, ...

Angular-Meteor links JavaScript frameworks
... build system improvements and ECMAScript compliance Angular-Meteor, Meteor's technology for using the Angular and Meteor JavaScript frameworks ...

Resources last updated: 12/14/2015 3:22:53 AM