iFolder and Active Directory LDAPS (LDAP over SSL)

I am looking for some insight in getting my iFolder server communicating
with an Active directory server over SSL for user Authentication.  I am
using iFolder 2.1.3 and Windows 2003SP1 on the servers for both iFolder
server OS and Active Directory OS.  I have installed the root cert for the
domain on the iFolder server.  When I use the iFolder installer I can
extend the schema of the directory structure over 636 using SSL without any
problems, it connects and looks good. 
When iFolder starts the logfile has the following entries

Starting iFolder server, version 2.1.3 [04/06/01]
Configured LDAP was found ready to use.
*MASTER[server.domain.com][-1] ldap_simple_bind : Server Down(81)
ldap *MASTER[server.domain.com] down
LDAP initialization failed. Check LDAP and restart apache.
iFolder Server Root: C:\iFolder
iFolder Host OS: Windows 2000
iFolder Host WebServer: Microsoft IIS

Followed by repeated entries of 

Configured LDAP was found ready to use.
*MASTER[server.domain.com][-1] ldap_simple_bind : Server Down(81)
ldap *MASTER[server.domain.com] down
LDAP initialization failed. Check LDAP and restart apache.

I have attempted different iterations of modifying the
\HKLM\system\CurrentControlSet\Services\W3SVC\iFolderServer\LdapRootCert
pointing to the root cert leaving it blank ect but it doesn�t seem to work.

In I perfect world I would have Novell and EDirectory already in place but
I had inherited a windows infrastructure so I need to work with this. 

0
adagenetworks
8/26/2005 6:39:31 PM
novell.support.ifolder 4327 articles. 0 followers. Follow

1 Replies
1124 Views

Similar Articles

[PageSpeed] 47

One thing to add, when I switch it from LDAPS(636) to non secure LDAP (389)
everything works fine, I know it problem has to do with the SSL communication

> I am looking for some insight in getting my iFolder server communicating
> with an Active directory server over SSL for user Authentication.  I am
> using iFolder 2.1.3 and Windows 2003SP1 on the servers for both iFolder
> server OS and Active Directory OS.  I have installed the root cert for the
> domain on the iFolder server.  When I use the iFolder installer I can
> extend the schema of the directory structure over 636 using SSL without any
> problems, it connects and looks good. 
> When iFolder starts the logfile has the following entries
> 
> Starting iFolder server, version 2.1.3 [04/06/01]
> Configured LDAP was found ready to use.
> *MASTER[server.domain.com][-1] ldap_simple_bind : Server Down(81)
> ldap *MASTER[server.domain.com] down
> LDAP initialization failed. Check LDAP and restart apache.
> iFolder Server Root: C:\iFolder
> iFolder Host OS: Windows 2000
> iFolder Host WebServer: Microsoft IIS
> 
> Followed by repeated entries of 
> 
> Configured LDAP was found ready to use.
> *MASTER[server.domain.com][-1] ldap_simple_bind : Server Down(81)
> ldap *MASTER[server.domain.com] down
> LDAP initialization failed. Check LDAP and restart apache.
> 
> I have attempted different iterations of modifying the
> \HKLM\system\CurrentControlSet\Services\W3SVC\iFolderServer\LdapRootCert
> pointing to the root cert leaving it blank ect but it doesn�t seem to work.
> 
> In I perfect world I would have Novell and EDirectory already in place but
> I had inherited a windows infrastructure so I need to work with this. 
> 

0
Adage
8/27/2005 6:54:47 PM
Reply: