Last week's issue, still no resolution - RIGHTS and other exe's don't function

Any further suggestions on the RIGHTS command in a DOS box?  Still does 
not work, even when I execute it from the directory with the NLS files.

The error is:

905: This utility was unable to initialize the country information.

TIA.

-S- 


0
Steve
5/14/2006 4:59:56 PM
novell.netware.6x.admin-tools 11680 articles. 0 followers. Follow

8 Replies
743 Views

Similar Articles

[PageSpeed] 51

Steve Freides,
> 905: This utility was unable to initialize the country information.
>
Try rights /ver

It will tell you what files it needs. Are they there?

- Anders Gustafsson, Engineer, CNE6, ASE
  NSC Volunteer Sysop
  Pedago, The Aaland Islands (N60 E20)

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

Using VA 5.51 build 315 on Windows 2000 build 2195

0
Anders
5/14/2006 5:11:29 PM
"Anders Gustafsson" <dalton@nomail.to.me> wrote in message 
news:VA.00001942.0addb721@nomail.to.me...
> Steve Freides,
>> 905: This utility was unable to initialize the country information.
>>
> Try rights /ver

C:\>g:

G:\>rights
905: This utility was unable to initialize the country information.
G:\>rights /ver

Z:\RIGHTS.EXE
Version:   4.22 (970314) PTF
(c) Copyright 1983-1997, Novell Inc.  All rights reserved.

Files required for this utility:
  RIGHTS.MSG (4.14)

Unicode files needed for country 1 and code page 437:
  UNI_437.001
  437_UNI.001
  UNI_MON.001
  UNI_COL.001

G:\>

>
> It will tell you what files it needs. Are they there?

Where should I be looking for these files?  Must they be on the 
workstation's PATH somehow?  Z: is a search mapping to SYS:PUBLIC\ and 
Y: is to a UTILS directory where we keep PKZIP and the like, see path 
below:

C:\>path
PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program 
Files\Sy
mantec\pcAnywhere\;C:\WINDOWS\system32\nls;C:\WINDOWS\system32\nls\ENGLISH;C:\Pr
ogram Files\Microsoft SQL Server\80\Tools\Binn\;Z:.;Y:.

C:\>


TIA.

-S- 


0
Steve
5/15/2006 1:45:09 PM
Steve Freides,
> Where should I be looking for these files?  Must they be on the 
> workstation's PATH somehow?  Z: is a search mapping to SYS:PUBLIC\ and 
> Y: is to a UTILS directory where we keep PKZIP and the like, see path 
> below:
>
They are usually under sys:public/nls

- Anders Gustafsson, Engineer, CNE6, ASE
  NSC Volunteer Sysop
  Pedago, The Aaland Islands (N60 E20)

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

Using VA 5.51 build 315 on Windows 2000 build 2195

0
Anders
5/15/2006 1:53:19 PM
"Anders Gustafsson" <dalton@nomail.to.me> wrote in message 
news:VA.0000194a.0009d6e5@nomail.to.me...
> Steve Freides,
>> Where should I be looking for these files?  Must they be on the
>> workstation's PATH somehow?  Z: is a search mapping to SYS:PUBLIC\ 
>> and
>> Y: is to a UTILS directory where we keep PKZIP and the like, see path
>> below:
>>
> They are usually under sys:public/nls

I think I can safely say this is not an issue of finding the appropriate 
files.  I also maintain F: as SYS:\, so I did this:

c:\> path 
c:\windows\system32;f:\public;f:\public\nls;f:\public\nls\english

which gives includes all the relevant files - still exactly the same 
error message.

Is this 1997 version of the file the most recent?  Perhaps it got copied 
from an older server inadvertently?

-S- 


0
Steve
5/15/2006 2:37:44 PM
And the files:

  UNI_437.001
  437_UNI.001
  UNI_MON.001
  UNI_COL.001
  
Are there? Do the other command like tools, like NLIST etc work? You 
are logged in?

- Anders Gustafsson, Engineer, CNE6, ASE
  NSC Volunteer Sysop
  Pedago, The Aaland Islands (N60 E20)

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

Using VA 5.51 build 315 on Windows 2000 build 2195

0
Anders
5/15/2006 2:52:06 PM
"Anders Gustafsson" <dalton@nomail.to.me> wrote in message 
news:VA.0000194d.003fa83e@nomail.to.me...
> And the files:
>
>  UNI_437.001
>  437_UNI.001
>  UNI_MON.001
>  UNI_COL.001
>
> Are there? Do the other command like tools, like NLIST etc work? You
> are logged in?

Fascinating!  SERV_D is our main production Netware 6.5 server, to which 
I am so attached I sometimes wonder if there is an umbilical cord 
between us. :)  If I right-click the Red N and go Novell Connections, I 
see 4 servers, all connected as one would expect, including SERV_D.

I am without a clue here - how can I think I am not connected?  Of 
course, I had to use NET USE because MAP gives the same problems as 
RIGHTS.  NLIST, by the way, without any additional arguments, displays 
its help screen just fine.

-S-

C:\>nlist server

NLIST-4.22-260: You are not attached to a server.

C:\>g:

G:\>net use g:
Local name        g:
Remote name       \\SERV_D\VOLUME1
Resource type     Disk
The command completed successfully.

G:\>nlist server

NLIST-4.22-260: You are not attached to a server.


G:\>


0
Steve
5/15/2006 3:44:16 PM
Steve,

> Any further suggestions on the RIGHTS command in a DOS box?  Still does 
> not work, even when I execute it from the directory with the NLS files.
> 
> The error is:
> 
> 905: This utility was unable to initialize the country information.

Have you been running a TCP Optimizer on the workstation?

TCP Optimizer messes with the security permission on the HKCU key, which 
can cause the error you're seeing. Fire up RegEdt32.exe, goto the HKCU 
window, Highlight HKCU, then From the toolbar, Security -> Permissions.

The Current User ID should have full control.
The Administrators group should have full control.
The SYSTEM Group should have full control.
The RESTRICTED group should have readonly.


-- 
Hamish Speirs
Novell Support Forums Volunteer Sysop.

http://haitch.net

(Please, no email unless requested. Unsolicited support emails will 
probably be ignored)
0
Hamish
5/16/2006 12:26:48 PM
"Hamish Speirs" <hamish@haitch.net> wrote in message 
news:cyjag.2701$3j4.945@prv-forum2.provo.novell.com...
> Steve,
>
>> Any further suggestions on the RIGHTS command in a DOS box?  Still 
>> does not work, even when I execute it from the directory with the NLS 
>> files.
>>
>> The error is:
>>
>> 905: This utility was unable to initialize the country information.
>
> Have you been running a TCP Optimizer on the workstation?

No.

> TCP Optimizer messes with the security permission on the HKCU key, 
> which can cause the error you're seeing. Fire up RegEdt32.exe, goto 
> the HKCU window, Highlight HKCU, then From the toolbar, Security -> 
> Permissions.

The problem happens on every workstation so far w/ C32 4.91 SP2 and psp 
patches, not just one.

I just tried RIGHTS on a 4.90/SP2 workstation at the same site, and 
RIGHTS works just fine.

-S-

> The Current User ID should have full control.
> The Administrators group should have full control.
> The SYSTEM Group should have full control.
> The RESTRICTED group should have readonly.



>
> -- 
> Hamish Speirs
> Novell Support Forums Volunteer Sysop.
>
> http://haitch.net
>
> (Please, no email unless requested. Unsolicited support emails will 
> probably be ignored) 


0
Steve
5/16/2006 1:20:24 PM
Reply:

Similar Artilces:

rules don't do what's intended, do do what's not intended
I have a user who regularly has 1000 unread messages in her box, plus thousands in her trash, etc., etc. She drives support techs crazy with complaints about functionality of GW 6.0.2 (well, duh!). One day when she was on vacation, I took it upon myself to create a bunch of folders and rules for her. An auto-delete of junk mail rule was deleting legit stuff for no discernible reason (nothing about the mail was listed in any part of the rule). So, I deleted that rule. In fact, IIRC, I deleted any auto-delete actions in the rules I created b/c of the "hinky" factor. I...

Repost: FF won't show gif's nor jpg's Red X's
XP sp2 FF 2.0.0.4 extentions: Adblock Plus Copy plain text Fasterfox Firebug FireFTP McAfee SiteAdvisor NoScript Talkback Video Downloader Pic's show red x's. These pics show just fine in Internet Explorer and Netscape. Anyone have any ideas????? Fasterfox, I guess. See what happens if you disable it (or just disable its pipelining feature). -- �Q� =============== Thank you Q. I disabled all of them, one at a time (restarting each time) and the problem still exists :-( digimomma On 7/12/2007 5:26 PM digimom inquired: > Thank y...

I don't know why my code don't work(it's for shopping cart)
I wrote this code for shopping cart.I used c lass for it and i want to store orders in cache.the customer username is in a session.customer select the product from a datalist.but and I want to show the orders in gridview .but when I select some product and go to the page that gridview is in it (shopping cart page)I could,t see any thing.please look at my code and see if I wrote my code incorrect.thanks for your helping me.-------------------------------------------------------------------------  //the code for add product to shopping cart(products are in data list)protected void order(o...

Replace 1's and 0's in a gridview column with Yes's and No's
Is it possible to change the display of a column in a gridview to show a Yes for all 1's and a No for 0's that display in a particular column of a gridview bound to a database?  If so, can someone share the way with me?  I am using ASP.NET 2.0 with VB Code Behind.  Thanks One way you can do is thrrough  CASE in your select statement: Select YesNoColumn= CASE yourColumn WHEN 1 THEN 'Yes' WHEN 0 THEN 'No' ELSE '' END FROM YourtableLimno <Columns>     <asp:TemplateField HeaderText="yourHeader" SortExpression="yourDataField"> ...

Some tags have asp: 'namespace', some don't. What's the difference?
Take this code for instance:<asp:ObjectDataSource>    <SelectParameters>        <asp:ControlParameter>Why does SelectParameters not have the asp: prefix?When you ask a question, remember to click "mark as answered" when you get a reply which answers your question; this ensures the right forum member gets credit below for being helpful (and makes search more relevant too). SelectParameters is basically property of ObjectDataSource so prefix is not needed, since it is used to get the information from where a control should b...

It's Linux !? No, it's BSD ! No, no, it's...
kFreeBSD http://wiki.debian.org/Debian_GNU/kFreeBSD a Debian distro using the FreeBSD kernel ! ObiWan wrote: > kFreeBSD > > http://wiki.debian.org/Debian_GNU/kFreeBSD > > a Debian distro using the FreeBSD kernel ! Why use a BSD kernel? I hope the reason is more than, just because they can. http://wiki.debian.org/Debian_GNU/kFreeBSD_why It's easy to understand why the would want to use Debian packages. :) -- Jimmy Johnson Registered Linux User #380263 >> kFreeBSD >> >> http://wiki.debian.org/Debian_GNU/kFreeBSD >> ...

''''''''''''''''''''
Name: haznen Email: haznenatyahoodotcom Product: Gran Paradiso Alpha 8 Summary: '''''''''''''''''''' Comments: '''''''''''''''''''''''''''''''''''' Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061204 UGES/1.7.2.0 GranParadiso/3.0a1 From URL: http://www.mozilla.org/projects/granparadiso/ Note to readers: Hendrix gives...

TWC's online DVR Manager's record options don't work?
Hello. Does any SeaMonkeyers else have a DVR, from TWC that can be accessed remotely through https://dvr.timewarnercable.com/tvListings/? If so, then are you able to click on all record options (change to don't delete and series)? They don't seem to work in two/2 of my SeaMonkey v2.26.1 web browsers on two/2 different machines (Debian and Windows XP Pro SP3). It worked fine in Internet Explorer v8.0 and Firefox/Iceweasel v31 though. Thank you in advance. :) -- "A centipede is an ant made to Canadian/government specs." --unknown /\___/\ Ant(Du...

why CSK's Admin Module didn't use CSK'S skin and SkinnedCommunityControl .
For example: EditUsers admin module is made by 3 .aspx "Default.aspx, EditRoles.aspx, EditUser.aspx" it did not divide to skin and SkinnedCommunityControl . Did the author think it 's too complex to write in this way? Why would you need the admin section to be themed? It isn't a user area of the site so there is little reason to have it skinnable on a per-community basis. Also, the admin tools do not require any of the standard controls used in the regular content areas of the site, so there was little incentive to use the theme design pattern on them. It would ...

DLL's obfuscated using DotFuscator when deployed don't work and the DLL's are easily decompiled. What to do?
I used DotFuscator Community edition that ships with VS2005 to obfuscate some of the DLL's from my PreCompiled website. When I deploy these obfuscated DLL's on the webserver, my site doesn't work. If I revert back to my old DLL's fo my precompiled website, it works fine. Secondly, the DLL's obfuscated with DotFuscator Community Edition are easily decompiled to the original source code using a decompiler like Salamander .NET decompiler (http://www.remotesoft.com/salamander/). Then, whats the use of this DotFuscator if it can't obfuscate the DLL's. Ple...

Help! I cannot access the DataGrid's ItemTemplate's LinkButton's Text Atrribute 's Value!!!!!!!!!!!
I write a datagrid's ItemDataBound method as follows:   private void dgTable_ItemDataBound(object sender, System.Web.UI.WebControls.DataGridItemEventArgs e)  {   if(e.Item.ItemType == ListItemType.Item || e.Item.ItemType == ListItemType.AlternatingItem)   {    if(!isRole("Manager"))    {     LinkButton tmp = (LinkButton)e.Item.FindControl("lbPassed");     if(tmp.Text == "Passed")     {      ((LinkBu...

'do' won't 'do' if '/'
Greetings to All from Au, Have a NetWare Perl 5.8.4 and wanted to tweak File\Spec\NW.pm to try and standardise on '/' separators. If I run a test script (t/uni/lower.t) with an unmodified NW.pm, it calls t/uni/case.pl, that, in case.pl, (when the path separators are '\'), the $file is '..\lib\unicore\To\Lower.pl' and the following code portion works, with $simple getting a returned table: sub casetest { my ($base, $spec, $func) = @_; my $file = File::Spec->catfile(File::Spec->catdir(File::Spec->updir, "lib", &qu...

Hyperlink's, ImageURL's, and OnError's
I created an ASP:Hyperlink and set the ImageURL attribute so the link will be the image.If the image is missing, I would like it to display a 'missing image' pic that I have.  I know you can use the OnError attribute of the <img> tag to run some javascript to change it.Unfortunately I can't find a way to access the Hyperlink's Image that is inside it, so I can add an Attribute so the resulting <img> tag will have an OnError attribute inside of it.Any help?If my Hyperlink is called 'foo'....would I do...  ((Image) foo.Controls[0]).Attributes.Add(&...

I don't see the 'ATLAS' tab in Visual Studio's ToolBox............
I've seen many video tutorials on ATLAS, I've seen a tab 'ATLAS' in the tolbox, that is not in my toolbox. How can I get it???????? Freelance Web Developer & HTML IntegratorASP.NET(1.1/2.0) == PHP Hi,1) right click on the Toolbox --> Add tab (give it the name "ATLAS")2) right click inside the new tab --> Choose Items --> Select the Microsoft.Web.Atlas.dll assembly  Alessandro Gallo | Blog | My book: ASP.NET AJAX In Action Friend I dont find " Microsoft.Web.Atlas.dll assembly " in the dialogue box..Do i have to install somet...

superreview requested: [Bug 238733] Components.classes['@mozilla.org/wallet/wallet-service;1'] has no properties in contentAreaClick.js : [Attachment 144811] don't call the function if it's going to
timeless@myrealbox.com (working) <timeless@bemail.org> has asked Boris Zbarsky <bzbarsky@mit.edu> for superreview: Bug 238733: Components.classes['@mozilla.org/wallet/wallet-service;1'] has no properties in contentAreaClick.js https://bugzilla.mozilla.org/show_bug.cgi?id=238733 Attachment 144811: don't call the function if it's going to fail https://bugzilla.mozilla.org/attachment.cgi?id=144811&action=edit ...

Web resources about - Last week's issue, still no resolution - RIGHTS and other exe's don't function - novell.netware.6x.admin-tools

Resources last updated: 12/11/2015 10:29:29 AM