Undocumented fix in Active Directory driver version 3.5.14 Patch 8 or 3.6.1 Remote Loader patch 3

Just in case anyone else experiences the same problem.

We resolved an issue at a client yesterday where some password change 
events from AD were discarded and never sent to the engine.

The resolution was to update to AD 3.5.14 Patch 8 and IDM 3.6.1 Remote 
Loader patch 3

The environment was previously running IDM 3.6.1 Active Directory Driver 
Patch 4 and IDM 3.6.1 Remote Loader patch 2. The domain controller was 
Windows 2008r2

A powershell script was used to mass set pre-determined passwords on 
approx 2000 AD users that had been provisioned previously by IDM.

A level 5 trace on the remote loader side showed the password change was 
sucessfully retrieved from the registry for an associated user and then 
removed from the registry but a modify-password event was never 
generated or sent to the engine.

This was performed several times and each time a percentage (10-20%) of 
modify-password events failed to be generated.

After applying the patches 100% of the password changes were published 
to the engine.

Reading through the bugs fixed in both AD 3.5.14 Patch 8 and IDM 3.6.1 
Remote Loader patch 3 I cannot see any mention of this type of bug.
0
Alex
1/24/2012 7:35:13 AM
novell.id-manager.drivers 10360 articles. 2 followers. Follow

2 Replies
1171 Views

Similar Articles

[PageSpeed] 13
Get it on Google Play
Get it on Apple App Store

alexmchugh;2170063 Wrote: 
> Just in case anyone else experiences the same problem.
> 
> We resolved an issue at a client yesterday where some password change
> events from AD were discarded and never sent to the engine.
> 
> The resolution was to update to AD 3.5.14 Patch 8 and IDM 3.6.1 Remote
> Loader patch 3
> 
> The environment was previously running IDM 3.6.1 Active Directory
> Driver
> Patch 4 and IDM 3.6.1 Remote Loader patch 2. The domain controller was
> Windows 2008r2
> 
> A powershell script was used to mass set pre-determined passwords on
> approx 2000 AD users that had been provisioned previously by IDM.
> 
> A level 5 trace on the remote loader side showed the password change
> was
> sucessfully retrieved from the registry for an associated user and
> then
> removed from the registry but a modify-password event was never
> generated or sent to the engine.
> 
> This was performed several times and each time a percentage (10-20%)
> of
> modify-password events failed to be generated.
> 
> After applying the patches 100% of the password changes were published
> to the engine.
> 
> Reading through the bugs fixed in both AD 3.5.14 Patch 8 and IDM 3.6.1
> Remote Loader patch 3 I cannot see any mention of this type of bug.


Alex,  I would swear David Gersic fought this bug a while back, and
finally got a fix for it.  Maybe he will remember which patch it was
fixed in for more info.


-- 
geoffc
------------------------------------------------------------------------
geoffc's Profile: http://forums.novell.com/member.php?userid=1904
View this thread: http://forums.novell.com/showthread.php?t=451247

0
geoffc
1/24/2012 2:26:01 PM
On Tue, 24 Jan 2012 14:26:01 +0000, geoffc wrote:

> Alex,  I would swear David Gersic fought this bug a while back, and
> finally got a fix for it.  Maybe he will remember which patch it was
> fixed in for more info.

Nope, not me. I don't recall having that problem here.


-- 
--------------------------------------------------------------------------
 David Gersic                                           dgersic_@_niu.edu
 Knowledge Partner                               http://forums.novell.com

 Please post questions in the forums.      No support provided via email.

0
David
1/24/2012 4:00:03 PM
Reply:

Similar Artilces:

Active Directory driver version 3.5.14 Patch 8 / pwfilter.dl
Hi, With the patch 8 there is the following instruction Code: -------------------- Password Filter Update: 1. On each DC rename the existing pwfilter.dll to pwfilter.old. 2. Copy the patched pwfilter.dll to the \Windows\System32 directory. -------------------- Is it allowed or why can't I just copy the pwfilter.dll to -\Novell\IDM_PassSync- directory, and then use the Password panel to deploy all the dlls to the DCs? Thanks KK -- kkas ------------------------------------------------------------------------ On 9/20/2011 4:56 AM, kkas wrote: ...

IDM 3.6.0/3.5.1 LDAP Driver Patch 1a 20081103
The environment: Novell eDirectory v8.8 sp2 Novell iManager v2.7.1 Novell Identity Manager 3.5.1 IDM 3.6.0/3.5.1 LDAP Driver Patch 1a 20081103 We're testing the LDAP Driver Patch 1a 20081103 released yesterday. We have the LDAP driver connecting to OID, subscriber channel only. Objects and groups are maintained on OID. The test causes a re-evaluation of all the groups maintained on OID. The problem we're seeing is that for each group modify event, the driver is listing the entire group membership twice. Some of our groups have over 20,000 members. This is a treme...

Help with 3.5.1 SOAP driver on SUSE 8.7.3 and eDir 8.7.3.10
I'm upgrading IDM system from v2.0 to 3.5.1 but stuck at a single point and that is SOAP driver for 3.5.1. It is not showing webservice URL and not getting the response. We are using SPML. The difference I see is the call made by the 2.0 driver and 3.5.1 driver. Here is what I see in the DSTrace for 2.0 driver which works fine and calls the webservice successfully -------------SOAP 2.0--------------------- 19:17:56 854D1BB0 Drvrs: MTV_SOAP PROD Test ST: Submitting document to subscriber shim: 19:17:56 854D1BB0 Drvrs: MTV_SOAP PROD Test ST: <soap-env:Envelope xmlns:soap...

IDM 3.6.1 Lotus Notes Remote Loader on AIX 5.3 / Domino 8.5
Trying to get the Lotus Notes Remote loader 3.6.1 started on AIX 5.3 / Domino 8.5 64bit but get the following error message: -java.lang.UnsatisfiedLinkError: lsxbe_r (Could not load module /opt/ibm/lotus/notes/latest/ibmpow/liblsxbe_r.a. The module has an invalid magic number.)- At first I thought it might have something to do with the LIBPATH environment variable not set correctly but this seems ok to me. The "invalid magic number" message leads me to think its a platform issue. This makes sense, according to the documentation the remote loader runs in 32bit mode. ...

IDM 3.5.1 / Ldap Driver 3.5.3
I am trying to set up an ldap driver to update an external ldap directory for just password updates, and I am running into issues I don't understand so I need some help. I am basically using an out of the box ldap driver with an added matching rule. By default the driver does not have one. The filter was changed to allow only the nspmDistributionPassword and uniqueID under User. User accounts already exist in the external ldap directory, so I just need to update their passwords. What I am running into is that the first time a password change comes across, the password is not upda...

selecting ? selecting of 1., 2. , 3., 4., 5., 6. is slow (1-3 second) then selecting of 7.,8.,9. go on is so fast (0.1 second or more fast).. how can i get fast for selecting of 1., 2. , 3., 4., 5., 6
hello friends selecting of 1., 2. , 3., 4.(sometime even 5., 6.) is slow (1-3 second) then selecting of 7.,8.,9.(sometimes 5., 6.,) go on is so fast (0.1 second or more fast).. how can i get fast for selecting of 1., 2. , 3., 4., 5., 6. is slow ?? recordcount is almost 1.050.000.. i do selecting 1.2.3. go on same page with treeview1.. treeview1 in masterpage.master.. gridview1 and datasource1 are in pagelist.aspx (it connets datasource1)..productnumber is primarykey for index.. kategori, kategori1 and kategori2, price, datemin are index from keys/index in table1 (right clicking menu)....

Remote Loader 3.5.1 with Engine 3.6.1
Hello, I was wondering if anybody installed and configured a Remote Loader v.3.5.1 on a Windows servers (NT4 and 2003) and have it working with Metadirectory engine v.3.6.1 running on Windows 2003 SP2 server. Password filters are also v.3.5.1 for Windows NT4 domains and v.3.6.1 for AD running on Windows 2008 R2. Slava. -- slavat ------------------------------------------------------------------------ -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 There were definitely quite a few customers who ran 3.5.1 on w2k3.... not so sure about NT 4 since it's older than ...

Importing userapp 3.5.1 driver config into 3.6.1?
This is a dumb question. Let's say I have my DAL and whatnot all setup for 3.5.1 But I wish to use 3.6.1 (Roles based, NON provisioning module) now What's the best way to "import" (for lack of a better word)? The docs indicate I can migrate it, but I'm just wanting to make sure that's the BEST way to do it. (I have a test lab so I can abuse it all I want). -- kjhurni ------------------------------------------------------------------------ Greetings Kevin, You can either do: 1) Migrate the driver from 3.5.1 to 3.6.1 (as outlined i...

Error when apply IDM JDBC driver version 3.5.5 Patch 1
Hi all! When I try to upgrade the Linux RPM I get this error: file /opt/novell/eDirectory/lib/dirxml/classes/JDBCUtil.jar from install of novell-DXMLjdbc-3.5.5-20100817.noarch conflicts with file from package novell-DXMLjdbcu-3.5.4-20090520.noarch If I use the command: "rpm -U novel-DXMLjdbcu.rpm --force" no error occurs but the driver version, showed in iManager, is 3.5.4 yet. Any idea? Thank you! -- *:cool: Alan Cota | Open Consult | Brazil, Novell Platinum Partner. CNE | ISM & Security Specialist. http://www.alancota.net* -------------------------...

[PATCH 1/3] buildperl.pl: add patches to support gcc 3.x and 4.x when compiling Perl 5.6.x
--- cpan/Devel-PPPort/devel/buildperl.pl | 144 ++++++++++++++++++++++++++++++++++ 1 files changed, 144 insertions(+), 0 deletions(-) diff --git a/cpan/Devel-PPPort/devel/buildperl.pl b/cpan/Devel-PPPort/devel/buildperl.pl index 49b7fbb..529c999 100644 --- a/cpan/Devel-PPPort/devel/buildperl.pl +++ b/cpan/Devel-PPPort/devel/buildperl.pl @@ -132,6 +132,32 @@ my @patch = ( [ \&patch_sysv ], ], }, + { + perl => [ + '5.6.0', + ], + subs => [ + [ \&patch_gcc_56 ], + [ \...

IDM 3.5.1 Engine and AD Driver 3.5.8 patch3 ?
We need to update the Windows servers to W2k8 R2. Question is, can I continue to run my existing IDM 3.5.1 Engine (on Netware server) and only update the AD Driver (and RL) to 3.5.8 patch3 for a period of time? Or is it absolutely necessary to upgrade the engine to 3.6.1 as well? -- T-MAN ------------------------------------------------------------------------ -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 You'll need a 3.6.1 Remote Loader on the w2k8 box, but otherwise you should be fine. Good luck. On 04/19/2010 08:16 AM, T-MAN wrote: > > We ...

NMAS Error after NMAS Patch 3.1.3.2 for eDir 8.7.3.3 OES Linux
--____NCKXBMMNONHUBRXUOGRT____ Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: base64 Content-Disposition: inline; modification-date="Thu, 11 Jul 2007 12:27:42 +0200" SnVsIDExIDA5OjU3OjQ5ICBNZXRob2QgbG9hZCBmYWlsZWQ6IC92YXIvbmRzL25tYXMtbWV0aG9k cy9MU01NRDVMSU4uU086IHVuZGVmaW5lZCBzeW1ib2w6IGxkYXBfeF91dGY4c190b193Y3MNCkp1 bCAxMSAwOTo1Nzo0OSAgTWV0aG9kIGxvYWQgZmFpbGVkOiAvdXNyL2xpYi8vbmRzLW1vZHVsZXMv bGlibm1hcy5zbzogdmVyc2lvbiBgTk1BU19WRVJTSU9OXzIuMC4yJyBub3QgZm91bmQgKHJlcXVp cmVkIGJ5IC92YXINCi9uZHMvbm1hcy1tZXRob2RzL1g1MDlMU01MSU4uU08pDQoNCklzIHRoaXMg b25s...

GroupWise driver version 3.5.3; Unable to start the driver
I have setup 2 SLES10 sp2, OES2 sp1b, IDM v3.6.1, eDir v8.8 sp5 and groupwise 8hp2 servers with all recommend patches, one 32-bit the other 64-bit. The GroupWise driver for Identity Manager on the 32-bit server starts and runs fine, but the 64-bit version is unable to start. I have included the last part of a level 3 trace that shows the error for the 64-bit server. The trace shows the error starting with "Code(-9010) An exception occurred: java.lang.NoClassDefFoundError: Could not initialize class") I am new to this but it looks like I am missing a java class. Any help i...

Migrate Option not appearing on UA Driver, moving from 3.5.1 to 3.6.1
Greetings, Afte successfully migrating a User Application from IDM 3.5.1 to 3.6.1 with RBPM in my lab, I am moving to production. Problems at Step 1: Migrate the UserApp Driver in the Designer project. When I right click my UserApp Driver, there is no "Migrate ..." option at the bottom, as there is in the lab. I first checked the Designer project for the IDM version on the servers. It erroneously reports 3.5.1. I changed that to 3.6.1, which is the version in production (verified.) Still no "Migrate...." option. I notice then that there is no driver v...

Web resources about - Undocumented fix in Active Directory driver version 3.5.14 Patch 8 or 3.6.1 Remote Loader patch 3 - novell.id-manager.drivers

Developer Tip: How to Tag Friends in Status Updates from Your App (Undocumented)
Earlier today, Facebook released its new “status tagging” feature to all users, a new way to tag friends, Pages, groups, and events in status ...

ED MARKEY THE UNDOCUMENTED CONGRESSMAN (ElectGerry.com) - YouTube
www.ElectGerry.com - Markey Unqualified to Serve in Congress; Dembrowski charges Markey as "Undocumented Congressman" Malden, MA. ... Today Dr. ...

'They have to go': Donald Trump would deport all undocumented immigrants as US president
Republican presidential contender Donald Trump would deport all undocumented immigrants and rescind U.S. President Barack Obama's executive orders ...

Mark Zuckerberg gives $5 million to scholarship for undocumented students
&#8203;Mark Zuckerberg and wife Priscilla Chan are donating $US5 million towards scholarships for hundreds of undocumented students.

Toronto prime destination for undocumented workers, committee told
A law professor says Toronto has the highest number of undocumented workers in Canada and that temporary immigration, especially for employment ...

Undocumented and Unafraid
The courageous self-declared &ldquo;Undocumented and Unafraid&rdquo; students in the United We Dream Network risk deportation, organize and speak ...

DPS to hire previously undocumented immigrants
DPS believes they're the first to actively seek out people who were initially brought to the U.S. illegally to now teach.

Undocumented U.S. residents face uncertainty over deferred action renewal - abc7news.com
Undocumented U.S. residents face uncertainty over deferred action renewal

HSI: Undocumented workers slept just inches apart and worked 18-hour days, 6 days a week
The owners of a popular Chinese buffet in Countryside have been sentenced for harboring, transporting, and exploiting illegal aliens after a ...

Quote of the Day: Undocumented Immigrants Are Now Totally Indistinguishable from the Class of 2011
Should undocumented immigrants be allowed to practice law if they’ve passed the bar exam? Continue reading » Follow Above the Law on Twitter ...

Resources last updated: 2/9/2016 8:30:05 AM