Mozilla 1.7/1.8a2, Thunderbird 0.6/0.7, Firefox 0.9 and Impos/2 2.1

All recent builds (Mozilla 1.7/1.8a2, Thunderbird 0.6/0.7, Firefox 0.9) 
crash Impos/2 2.1 as soon they are started, or the other way round 
(Impos/2 started afterwards)
06-22-2004  22:38:55  SYS3175  PID 002d  TID 0001  Slot 006e
D:\IMPOS21\IMPOS.EXE
c0000005
00069d94
P1=00000001  P2=0000000d  P3=XXXXXXXX  P4=XXXXXXXX
EAX=00000001  EBX=1c865dec  ECX=1c86866c  EDX=00000004
ESI=1c865dec  EDI=1c87ef80
DS=0053  DSACC=d0f3  DSLIM=7fffffff
ES=0053  ESACC=d0f3  ESLIM=7fffffff
FS=150b  FSACC=00f3  FSLIM=00000030
GS=2b43  GSACC=10f3  GSLIM=00003fff
CS:EIP=005b:00069d94  CSACC=d0df  CSLIM=7fffffff
SS:ESP=0053:00233b38  SSACC=d0f3  SSLIM=7fffffff
EBP=00233cdc  FLG=00012202
IMPOS.EXE 0001:00059d94

More detailed:
Impos/2 stays alive unless it doesn't have the focus, When I click into 
any Impos/2 window it takes a second or so and you can see collapsing 
each Impos/2 window after the other (nice animation ;-) but I don't 
wan't to have this one).
Mozilla 1.4.2 works fine and as far as I can remember FireFox 0.8 too.
My wild guess: As the same isn't seen on Warp4 with FP9 (says another 
user with same graphics driver, Matrox 2.58) it may be related to Kernel 
  in FP13 or later. With FP13 the color palette for Impos/2 was broken. 
IBM delivered later a fixed Kernel for that (all recent ones have the 
fix), so it may be related to this.
Klaus Staedtler
0
Klaus
6/23/2004 8:43:44 AM
📁 netscape.mozilla.os2
📃 2075 articles.
⭐ 0 followers.

💬 8 Replies
👁️‍🗨️ 1944 Views


Klaus Staedtler wrote:
> All recent builds (Mozilla 1.7/1.8a2, Thunderbird 0.6/0.7, Firefox 0.9) 
> crash Impos/2 2.1 as soon they are started, or the other way round 
> (Impos/2 started afterwards)
> 
Until now two other users on os2.org report the same for Mozilla 1.7, so 
the problem seems not related to my system only.
Klaus Staedtler
0
Klaus
6/23/2004 9:05:54 AM
Klaus Staedtler wrote:
> All recent builds (Mozilla 1.7/1.8a2, Thunderbird 0.6/0.7, Firefox 0.9) 
> crash Impos/2 2.1 as soon they are started, or the other way round 
> (Impos/2 started afterwards)
> 
> 06-22-2004  22:38:55  SYS3175  PID 002d  TID 0001  Slot 006e
> D:\IMPOS21\IMPOS.EXE
> c0000005
> 00069d94
> P1=00000001  P2=0000000d  P3=XXXXXXXX  P4=XXXXXXXX
> EAX=00000001  EBX=1c865dec  ECX=1c86866c  EDX=00000004
> ESI=1c865dec  EDI=1c87ef80
> DS=0053  DSACC=d0f3  DSLIM=7fffffff
> ES=0053  ESACC=d0f3  ESLIM=7fffffff
> FS=150b  FSACC=00f3  FSLIM=00000030
> GS=2b43  GSACC=10f3  GSLIM=00003fff
> CS:EIP=005b:00069d94  CSACC=d0df  CSLIM=7fffffff
> SS:ESP=0053:00233b38  SSACC=d0f3  SSLIM=7fffffff
> EBP=00233cdc  FLG=00012202
> 
> IMPOS.EXE 0001:00059d94
> 
   Same here. Impos2 works fine when Mozilla is not running.
   Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7) Gecko/20040617.
06-23-2004  09:56:27  SYS3175  PID 16c3  TID 0001  Slot 00eb
D:\IMPOS21\IMPOS.EXE
c0000005
00069d94
P1=00000001  P2=0000000d  P3=XXXXXXXX  P4=XXXXXXXX
EAX=00000001  EBX=1c779750  ECX=1c7763d0  EDX=00000003
ESI=1c779750  EDI=1c79ef80
DS=0053  DSACC=f0f3  DSLIM=ffffffff
ES=0053  ESACC=f0f3  ESLIM=ffffffff
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:00069d94  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:00233b38  SSACC=f0f3  SSLIM=ffffffff
EBP=00233cdc  FLG=00012202
IMPOS.EXE 0001:00059d94

-- 
jmm dash list at sohnen-moe dot com
(Remove DESPAMMZ for email)
0
James
6/23/2004 5:05:21 PM
James Moe wrote:
>   Same here. Impos2 works fine when Mozilla is not running.
There are some more affected. As one uses an IBM Thinkpad (and there is 
none with a matrox graphics card inside) I can tell for sure it's not 
related to the matrox drivers/card.
Klaus Staedtler
0
Klaus
6/23/2004 5:14:16 PM
Klaus Staedtler wrote:
> All recent builds (Mozilla 1.7/1.8a2, Thunderbird 0.6/0.7, Firefox 0.9) 
> crash Impos/2 2.1 as soon they are started, or the other way round 
> (Impos/2 started afterwards)
Another test: IBM Webbrowser 2.0.3 (based on Mozilla 1.6) using libc 
0.5.1 lets Impos/2 stay alive
Klaus Staedtler
0
Klaus
6/26/2004 1:58:30 PM
Sir:
Klaus Staedtler wrote:
> Klaus Staedtler wrote:
> 
>> All recent builds (Mozilla 1.7/1.8a2, Thunderbird 0.6/0.7, Firefox 
>> 0.9) crash Impos/2 2.1 as soon they are started, or the other way 
>> round (Impos/2 started afterwards)
> 
> 
> Another test: IBM Webbrowser 2.0.3 (based on Mozilla 1.6) using libc 
> 0.5.1 lets Impos/2 stay alive
> 
Hum.  It sounds like libc05.dll is at fault?  Try the 1.6 release of 
Mozilla.
-- 
Bill
Thanks a Million!
0
William
6/26/2004 3:27:08 PM
William L. Hartzell wrote:
> 
> Hum.  It sounds like libc05.dll is at fault? 
Why ? IBW 2.0.3 uses libc0.5.1, as Mozilla 1.7 does, as Firefox 0.9 
does, as ... does
With IBW 2.0.3 Impos/2 works, with the others not.
Klaus Staedtler
0
Klaus
6/26/2004 4:43:11 PM
Sir:
Klaus Staedtler wrote:
> William L. Hartzell wrote:
> 
>>
>> Hum.  It sounds like libc05.dll is at fault? 
> 
> 
> Why ? IBW 2.0.3 uses libc0.5.1, as Mozilla 1.7 does, as Firefox 0.9 
> does, as ... does
> 
> With IBW 2.0.3 Impos/2 works, with the others not.
> 
Then if Mozilla 1.6 works, you've proven that something in Mozilla 
itself and not the library is at fault.
-- 
Bill
Thanks a Million!
0
William
6/26/2004 7:42:12 PM
William L. Hartzell wrote:
> Then if Mozilla 1.6 works, you've proven that something in Mozilla 
> itself and not the library is at fault.
That was my intention (not to discover mozilla, firefox ... as to blame, 
but to find out where the malicious code sits).
Klaus Staedtler

0
Klaus
6/26/2004 7:52:39 PM
Reply: