bugzilla: undef error - Can't use string ("") as a HASH ref while "strict refs" in use at Bugzilla/BugMail.pm line 118

I'm encountering the problem described here:

https://bugzilla.mozilla.org/show_bug.cgi?id=300448

I'm running bugzilla 2.18.3 on fedora.

The problem seems to be that a line was added to this file:
template/en/default/bug/create/created.html.tmpl

So I commented out this line:
mailrecipients = item.mailrecipients

and restarted everything, but I'm still getting the same error.

I'm not sure that I understand the solution very well.  Any ideas?

Thanks,

Bryan
0
Bryan
11/9/2006 10:42:19 PM
mozilla.support.bugzilla 10182 articles. 0 followers. Post Follow

0 Replies
1610 Views

Similar Articles

[PageSpeed] 51

Reply:

Similar Artilces:

checksetup error migrating bugzilla mysql "The used table type doesn't support FULLTEXT indexes"
Hi all, I'm migrating bugzilla from version 3.0.2 to 3.2.3. I have 2 bugzilla instances running in the same server named "A" and "B". Now I created 2 new mysql db called "test.A" and "test.B" to check the migration. I successful migrated A to test.A (A is a very small DB because it is a bugzilla instance not used a lot) but when I was doing the same on B I got this error while I was running checksetup.pl Bugzilla now uses the InnoDB storage engine in MySQL for most tables. Converting tables to InnoDB: Converting table longdescs2... DBD:...

RFC: interactions between "use bytes", "use locale", and "use feature 'unicode_strings'
I am waiting for blead to reopen before I submit a patch for extending feature unicode_strings to matching \s, and \w. In documenting it, it occurred to me that the existing implementation is wrong, along with the existing interaction between use bytes and use locale. To refresh your memory, "use feature 'unicode_strings'" is supposed to mean that even non-utf8 data is to be considered to have Unicode semantics. In practice, this only affects the characters from 128-255. It is new in 5.12, and is implemented there only on functions that change case, such a...

"Using" or "With"
Hi all Please can someone enlighten to me as regards the difference with the "Using" and "With" statement when accessing data - which is better, what are the limitations and/or any pointers. Many thanks. Regards DaveDavid WinchesterPlease mark as answer if this is the solution.  using gives you the ability to use the connection and it closes the connection directlly after you finish using it. and there is no need to try- cach - finaly. there is no limitation on using USING keywordMuhanad YOUNISMCSD.NETMy Blog || My Photos || LinkedIn I have a dataobject the re...

Using "+" or "||"
Using SQLAnywhere 5.5.04, I've gotten into the habit of using "||" in ISQL to indicate a string concatenation. I needed to paste my SQL statement into the PowerBuilder script painter for some embedded SQL, and PB didn't like the "||" very much at all. I changed it to "+" and it seems to be ok. Do these two operators indicate ~exactly~ the same thing? moin, afaik these two's are not the same! if you're using "||" and any term is NULL then in the resultstring the term will be ignored if you use "+" then the resu...

Lot of error in error logs for "Use of uninitialized value in exists at Bugzilla/DB/Schema.pm line 1781"
Hi, I get a lot of bugs of this type "Use of uninitialized value in exist= s at Bugzilla/DB/Schema.pm line 1781" in my apache error log. I am running bugzilla version 3.6 and have not upgraded to any versio= n after this. Thanks Subodh Konhor ...

What to use instead of "cin" and "cout" which VCL doesn't use
I want to ask the user their name which I will then put on a label. There may be a better way but in the meantime I have used a TextOut message to Ask for their name and then put a memo box at the end of the sentence, which I find they can type into, I think. Question is How can I get or where to I find what they typed so I can put it in my label storage. I notice that there is a "Lines" property for Memo that say TString and if you click on it you get a code editor. I have been reading for days but I can figure out where to go from here. Any help would be greatly apprecia...

Using cdate function but got error "Conversion from string " " to type 'Date' is not valid."
I want to control user's input in Due date text box like below to make sure that user does not input date earlier than today: If Me.txtDueDate.Text <> "" Then      If (DateDiff("d", CDate(Me.txtDueDate.Text), (Date.Today)) > 0) Then     // Message: due day should not be earlier than today      exit sub End If  The problem is: if user did not input anything in txtDueDate box, I still got error: Conversion from string "  " to type 'Date' is not valid How to fix it? Help!!!   I'd use a RequireFie...

I'm getting an error using NavigateURL ='<%# Eval("Url") %>', it works when using NavigateURL="intro.aspx"
I'm getting an error using NavigateURL ='<%# Eval("Url") %>', it works when I use NavigateURL="intro.aspx" Server Error in '/orthoassist' Application. The resource cannot be found. Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. Requested URL: /orthoassist/intro.aspx <asp:HyperLink runat="server" ID="hl1" Text=...

Keep getting "Use of uninitialized value in pattern match (m//) at Bugzilla/Util.pm line 58" error
Hi, Does any one know if there is fix for this. I get this for [Sat Apr 3 10:19:20 2004] editkeywords.cgi: Use of uninitialized value in pattern match (m//) at Bugzilla/Util.pm line 58. Thanks, -shahriar ...

"Change columns" and "Remember search" doesn't work in Bugzilla
hi, "Change columns" and "Remember search" doesn't work in Bugzilla. Clicking on these buttons throws "Page cannot be displayed Technical Information (for support personnel) Error Code: 500 Internal Server Error. The request was rejected by the HTTP filter. Contact the server administrator. (12217) " I am using Bugzilla version 2.22.7, Bugzilla is hosted on Linux server. Any hint on this problem will be of great help. thanks & regards Dhananjaya Guten Tag chintu apr, am Freitag, 13. Juli 2012 um 07:23 schrieben ...

[ID 20020307.006] [BUG][use encoding] use encoding 'greek'; print "not" unless pack("U*", 0x3af) eq pack("C*", 0xdf) prints "not"!
This is a bug report for perl from "Anton Tagunov" <tagunov@motor.ru>, generated with the help of perlbug 1.33 running under perl v5.7.3. ----------------------------------------------------------------- Hello, developers! Hello, Jarkko! Please consider the following test being added: --- lib/encoding.t.orig Fri Feb 8 07:12:05 2002 +++ lib/encoding.t Thu Mar 7 19:38:39 2002 @@ -1,4 +1,4 @@ -print "1..19\n"; +print "1..20\n"; BEGIN { if (ord("A") == 193) { @@ -89,3 +89,7 @@ print "not " unless "\x...

"Hash as object attribute"-Problem with "use strict"
Hi, I have a problem. The following code results a "Can't use string ("1") as a HASH ref while "strict refs" in use at TestObject.pm line 21." Error if I include the "use strict" command. I don't understand why this error occures. Any suggestions?? First the object (TestObject.pm): ################################## package TestObject; use warnings; use strict; require Exporter; our @ISA = qw(Exporter); sub new { my ($package, $opt) = @_; my $self = bless { 'opt' => $opt, 'f...

RFC: Make "use 5.14" select "use re '/a' " ?
I have pushed to blead (with Jesse's permission) the last commits (besides doc and any bug fixes) that enable the /a regular expression modifier. Presuming it works ok, should this become the default method of operation, signified by a "use 5.014" ? On 1/17/11 11:02 AM, Karl Williamson wrote: > Presuming it works ok, should this become the default method of > operation, signified by a "use 5.014" ? So when I upgrade my code, I have to put "no re '/a'" in every file? Why, oh why? On Mon, 17 Jan 2011, Elliot Shank wrote: > ...

Using "New" for "Object reference not set to an instance of an object" error doesn't work...
Hi, I'm trying to build a sql insert statement by reading through each textbox the footer of a DataGrid control. Here's my datagrid code:<asp:DataGrid ID="Datagrid1" runat="server" OnPageIndexChanged="dgPersonnelType_PageChanger" AutoGenerateColumns="False" CellPadding="4" AlternatingItemStyle-BackColor="#FFFFBB" AllowPaging="True" PageSize="20" ShowFooter="True"> <ItemStyle BackColor="WhiteSmoke" Font-Names="verdana" Font-Size="10px" /> <Columns> <asp:TemplateColumn HeaderText="Insert"> <HeaderStyle BackColor="#CCCC99" Font-Bold="true" ...

<Bugzilla 2.18><Windows>Global symbol "$person" requires explicit package name at Bugzilla/BugMail.pm line
Hi all, I've just installed and configured Bugzilla 2.18 (Windows, Apache, MySql). Everything seems to be working fine, except the send email feature. I've modified the file BugMail as per installation notes: =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D= =3D=3D=3D=3D=3D=AD=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D= =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=AD=3D=3D=3D=3D=3D=3D=3D ..=2E... if ($enableSendMail =3D=3D 1) { # open(SENDMAIL, "|/usr/lib/sendmail $sendmailparam -t -i") || # die &q...

Web resources about - bugzilla: undef error - Can't use string ("") as a HASH ref while "strict refs" in use at Bugzilla/BugMail.pm line 118 - mozilla.support.bugzilla

Resources last updated: 1/21/2016 2:16:34 PM