Delphi 2007 on Vista SP1 (x64)?!

I have a pretty new Vista Ultimate SP1 x64 machine and on it I've install 
CodeGear RAD Studio 2007 + Dec 2007 Update + Apr 2008 Hotfix.  I can open my 
Win32 exe project in the IDE, but when I try to compile it, I get an error 
message indicating that it can't find a unit on my project's search path.  I 
can put the project's search path into the environment lib path, and then it 
will compile and run, but then if I get an exception, there is no debugging 
info.  In the output window, I noticed that it's not adding many switches in 
terms of the unit output, exe output, debug info, etc.

Has anyone else ran into this?  Or to put it another way, does anyone else 
run Delphi successfully on Vista x64 SP1?

When I compile on Vista SP1 x64, I get this in the output window:
----------------
c:\program files (x86)\codegear\rad studio\5.0\bin\dcc32.exe
-B
-I"c:\program files (x86)\codegear\rad 
studio\5.0\lib";"C:\Users\Troy\Documents\RAD Studio\5.0\Imports";"c:\program 
files (x86)\codegear\rad studio\5.0\Imports";"c:\program files 
(x86)\codegear\rad studio\5.0\Lib\Indy10";"C:\Users\Public\Documents\RAD 
Studio\5.0\Dcp";"c:\program files (x86)\codegear\rad studio\4.0qrstandard"
-LEc:\dev\bin\bpls
-LNc:\dev\bin\bpls
-O"c:\program files (x86)\codegear\rad 
studio\5.0\lib";"C:\Users\Troy\Documents\RAD Studio\5.0\Imports";"c:\program 
files (x86)\codegear\rad studio\5.0\Imports";"c:\program files 
(x86)\codegear\rad studio\5.0\Lib\Indy10";"C:\Users\Public\Documents\RAD 
Studio\5.0\Dcp";"c:\program files (x86)\codegear\rad studio\4.0qrstandard"
-R"c:\program files (x86)\codegear\rad 
studio\5.0\lib";"C:\Users\Troy\Documents\RAD Studio\5.0\Imports";"c:\program 
files (x86)\codegear\rad studio\5.0\Imports";"c:\program files 
(x86)\codegear\rad studio\5.0\Lib\Indy10";"C:\Users\Public\Documents\RAD 
Studio\5.0\Dcp";"c:\program files (x86)\codegear\rad studio\4.0qrstandard"
-U"c:\program files (x86)\codegear\rad 
studio\5.0\lib";"C:\Users\Troy\Documents\RAD Studio\5.0\Imports";"c:\program 
files (x86)\codegear\rad studio\5.0\Imports";"c:\program files 
(x86)\codegear\rad studio\5.0\Lib\Indy10";"C:\Users\Public\Documents\RAD 
Studio\5.0\Dcp";"c:\program files (x86)\codegear\rad studio\4.0qrstandard"
--no-config
ReleaseTool.dpr
----------------

But when I run the exact same project on Vista SP1 32-bit, I get this in the 
output window:
----------------
c:\program files\codegear\rad studio\5.0\bin\dcc32.exe
-B
-DDEBUG
-Ec:\dev\bin
-GD
-I"c:\program files\codegear\rad studio\5.0\Lib\Debug";"c:\program 
files\codegear\rad 
studio\5.0\Lib\Debug\Indy10";..\..\lib\JCL\source;..\..\lib\TntUnicodeVcl;..\..\lib\TntLX;..\..\lib\TntTrx;..\..\lib\msdata;..\..\TntVCL;.\WebPubApi;.\IconPro;"c:\program 
files\codegear\rad studio\5.0\lib";"C:\Users\Troy\Documents\RAD 
Studio\5.0\Imports";"c:\program files\codegear\rad 
studio\5.0\Imports";"c:\program files\codegear\rad 
studio\5.0\Lib\Indy10";"C:\Users\Troy\Documents\RAD 
Studio\5.0\Dcp";c:\dev\bin\bpls
-LE"C:\Users\Troy\Documents\RAD Studio\5.0\Bpl"
-LNc:\dev\bin\bpls
-N0c:\dev\bin\dcus
-NHc:\dev\bin\dcus
-NOc:\dev\bin\dcus
-O"c:\program files\codegear\rad studio\5.0\Lib\Debug";"c:\program 
files\codegear\rad 
studio\5.0\Lib\Debug\Indy10";..\..\lib\JCL\source;..\..\lib\TntUnicodeVcl;..\..\lib\TntLX;..\..\lib\TntTrx;..\..\lib\msdata;..\..\TntVCL;.\WebPubApi;.\IconPro;"c:\program 
files\codegear\rad studio\5.0\lib";"C:\Users\Troy\Documents\RAD 
Studio\5.0\Imports";"c:\program files\codegear\rad 
studio\5.0\Imports";"c:\program files\codegear\rad 
studio\5.0\Lib\Indy10";"C:\Users\Troy\Documents\RAD 
Studio\5.0\Dcp";c:\dev\bin\bpls
-R"c:\program files\codegear\rad studio\5.0\Lib\Debug";"c:\program 
files\codegear\rad 
studio\5.0\Lib\Debug\Indy10";..\..\lib\JCL\source;..\..\lib\TntUnicodeVcl;..\..\lib\TntLX;..\..\lib\TntTrx;..\..\lib\msdata;..\..\TntVCL;.\WebPubApi;.\IconPro;"c:\program 
files\codegear\rad studio\5.0\lib";"C:\Users\Troy\Documents\RAD 
Studio\5.0\Imports";"c:\program files\codegear\rad 
studio\5.0\Imports";"c:\program files\codegear\rad 
studio\5.0\Lib\Indy10";"C:\Users\Troy\Documents\RAD 
Studio\5.0\Dcp";c:\dev\bin\bpls
-U"c:\program files\codegear\rad studio\5.0\Lib\Debug";"c:\program 
files\codegear\rad 
studio\5.0\Lib\Debug\Indy10";..\..\lib\JCL\source;..\..\lib\TntUnicodeVcl;..\..\lib\TntLX;..\..\lib\TntTrx;..\..\lib\msdata;..\..\TntVCL;.\WebPubApi;.\IconPro;"c:\program 
files\codegear\rad studio\5.0\lib";"C:\Users\Troy\Documents\RAD 
Studio\5.0\Imports";"c:\program files\codegear\rad 
studio\5.0\Imports";"c:\program files\codegear\rad 
studio\5.0\Lib\Indy10";"C:\Users\Troy\Documents\RAD 
Studio\5.0\Dcp";c:\dev\bin\bpls
--drc
--no-config
-$O-
-$Q+
-$R+
-$T+
ReleaseTool.dpr
----------------

Thanks,
Troy
0
Troy
8/15/2008 4:33:45 AM
embarcadero.delphi.ide 3925 articles. 0 followers. Follow

3 Replies
1301 Views

Similar Articles

[PageSpeed] 16
Get it on Google Play
Get it on Apple App Store

I found the problem!  There was an environment variable on my machine called
"Platform" and it was set to "HPD".  This caused all of my project's "Debug"
and "Release" specific settings to be skipped because "Platform" was not set
to "AnyCPU".

<PropertyGroup Condition="'$(Configuration)|$(Platform)' ==
'Release|AnyCPU'">

Environment variables must apparently override these msbuild script
variables.  Once I deleted this environment variable, the problem went away.

(Now I just need to figure out what program put "Platform=HPD" there, and if
I broke something else.)

--Troy
0
Troy
8/17/2008 1:24:13 PM
Thank you for this thread!

Had a similar problem with Delphi2007 - could not compile code not lying in the same folder. The compiler threw a file not found message although the dcu was there and the browsing path has been set in Project Options! I had to delete the system variable Platform=MDC.

TK
0
T
9/14/2008 2:22:34 PM
> {quote:title=Troy Wolbrink wrote:}{quote}
> I have a pretty new Vista Ultimate SP1 x64 machine and on it I've install 
> CodeGear RAD Studio 2007 + Dec 2007 Update + Apr 2008 Hotfix.  I can open my 
> Win32 exe project in the IDE, but when I try to compile it, I get an error 
> message indicating that it can't find a unit on my project's search path.  I 
> can put the project's search path into the environment lib path, and then it 
> will compile and run, but then if I get an exception, there is no debugging 
> info.  In the output window, I noticed that it's not adding many switches in 
> terms of the unit output, exe output, debug info, etc.
> 
> Has anyone else ran into this?  Or to put it another way, does anyone else 
> run Delphi successfully on Vista x64 SP1?
> 
> When I compile on Vista SP1 x64, I get this in the output window:
> ----------------
> c:\program files (x86)\codegear\rad studio\5.0\bin\dcc32.exe
> -B
> -I"c:\program files (x86)\codegear\rad 
> studio\5.0\lib";"C:\Users\Troy\Documents\RAD Studio\5.0\Imports";"c:\program 
> files (x86)\codegear\rad studio\5.0\Imports";"c:\program files 
> (x86)\codegear\rad studio\5.0\Lib\Indy10";"C:\Users\Public\Documents\RAD 
> Studio\5.0\Dcp";"c:\program files (x86)\codegear\rad studio\4.0qrstandard"
> -LEc:\dev\bin\bpls
> -LNc:\dev\bin\bpls
> -O"c:\program files (x86)\codegear\rad 
> studio\5.0\lib";"C:\Users\Troy\Documents\RAD Studio\5.0\Imports";"c:\program 
> files (x86)\codegear\rad studio\5.0\Imports";"c:\program files 
> (x86)\codegear\rad studio\5.0\Lib\Indy10";"C:\Users\Public\Documents\RAD 
> Studio\5.0\Dcp";"c:\program files (x86)\codegear\rad studio\4.0qrstandard"
> -R"c:\program files (x86)\codegear\rad 
> studio\5.0\lib";"C:\Users\Troy\Documents\RAD Studio\5.0\Imports";"c:\program 
> files (x86)\codegear\rad studio\5.0\Imports";"c:\program files 
> (x86)\codegear\rad studio\5.0\Lib\Indy10";"C:\Users\Public\Documents\RAD 
> Studio\5.0\Dcp";"c:\program files (x86)\codegear\rad studio\4.0qrstandard"
> -U"c:\program files (x86)\codegear\rad 
> studio\5.0\lib";"C:\Users\Troy\Documents\RAD Studio\5.0\Imports";"c:\program 
> files (x86)\codegear\rad studio\5.0\Imports";"c:\program files 
> (x86)\codegear\rad studio\5.0\Lib\Indy10";"C:\Users\Public\Documents\RAD 
> Studio\5.0\Dcp";"c:\program files (x86)\codegear\rad studio\4.0qrstandard"
> --no-config
> ReleaseTool.dpr
> ----------------
> 
> But when I run the exact same project on Vista SP1 32-bit, I get this in the 
> output window:
> ----------------
> c:\program files\codegear\rad studio\5.0\bin\dcc32.exe
> -B
> -DDEBUG
> -Ec:\dev\bin
> -GD
> -I"c:\program files\codegear\rad studio\5.0\Lib\Debug";"c:\program 
> files\codegear\rad 
> studio\5.0\Lib\Debug\Indy10";..\..\lib\JCL\source;..\..\lib\TntUnicodeVcl;..\..\lib\TntLX;..\..\lib\TntTrx;..\..\lib\msdata;..\..\TntVCL;.\WebPubApi;.\IconPro;"c:\program 
> files\codegear\rad studio\5.0\lib";"C:\Users\Troy\Documents\RAD 
> Studio\5.0\Imports";"c:\program files\codegear\rad 
> studio\5.0\Imports";"c:\program files\codegear\rad 
> studio\5.0\Lib\Indy10";"C:\Users\Troy\Documents\RAD 
> Studio\5.0\Dcp";c:\dev\bin\bpls
> -LE"C:\Users\Troy\Documents\RAD Studio\5.0\Bpl"
> -LNc:\dev\bin\bpls
> -N0c:\dev\bin\dcus
> -NHc:\dev\bin\dcus
> -NOc:\dev\bin\dcus
> -O"c:\program files\codegear\rad studio\5.0\Lib\Debug";"c:\program 
> files\codegear\rad 
> studio\5.0\Lib\Debug\Indy10";..\..\lib\JCL\source;..\..\lib\TntUnicodeVcl;..\..\lib\TntLX;..\..\lib\TntTrx;..\..\lib\msdata;..\..\TntVCL;.\WebPubApi;.\IconPro;"c:\program 
> files\codegear\rad studio\5.0\lib";"C:\Users\Troy\Documents\RAD 
> Studio\5.0\Imports";"c:\program files\codegear\rad 
> studio\5.0\Imports";"c:\program files\codegear\rad 
> studio\5.0\Lib\Indy10";"C:\Users\Troy\Documents\RAD 
> Studio\5.0\Dcp";c:\dev\bin\bpls
> -R"c:\program files\codegear\rad studio\5.0\Lib\Debug";"c:\program 
> files\codegear\rad 
> studio\5.0\Lib\Debug\Indy10";..\..\lib\JCL\source;..\..\lib\TntUnicodeVcl;..\..\lib\TntLX;..\..\lib\TntTrx;..\..\lib\msdata;..\..\TntVCL;.\WebPubApi;.\IconPro;"c:\program 
> files\codegear\rad studio\5.0\lib";"C:\Users\Troy\Documents\RAD 
> Studio\5.0\Imports";"c:\program files\codegear\rad 
> studio\5.0\Imports";"c:\program files\codegear\rad 
> studio\5.0\Lib\Indy10";"C:\Users\Troy\Documents\RAD 
> Studio\5.0\Dcp";c:\dev\bin\bpls
> -U"c:\program files\codegear\rad studio\5.0\Lib\Debug";"c:\program 
> files\codegear\rad 
> studio\5.0\Lib\Debug\Indy10";..\..\lib\JCL\source;..\..\lib\TntUnicodeVcl;..\..\lib\TntLX;..\..\lib\TntTrx;..\..\lib\msdata;..\..\TntVCL;.\WebPubApi;.\IconPro;"c:\program 
> files\codegear\rad studio\5.0\lib";"C:\Users\Troy\Documents\RAD 
> Studio\5.0\Imports";"c:\program files\codegear\rad 
> studio\5.0\Imports";"c:\program files\codegear\rad 
> studio\5.0\Lib\Indy10";"C:\Users\Troy\Documents\RAD 
> Studio\5.0\Dcp";c:\dev\bin\bpls
> --drc
> --no-config
> -$O-
> -$Q+
> -$R+
> -$T+
> ReleaseTool.dpr
> ----------------
> 
> Thanks,
> Troy


I had a problem where I couldn't debug anything on Vista 64, but everything would compile.  It ended up being an error with webcams.  See this if you are still having problems: http://www.justtext.com/messageboards/20090216182012.html
0
Jeff
2/17/2009 1:42:52 AM
Reply:

Similar Artilces:

Delphi 2007 on Vista SP1 (x64)?! #2
I have a pretty new Vista Ultimate SP1 x64 machine and on it I've install CodeGear RAD Studio 2007 + Dec 2007 Update + Apr 2008 Hotfix. I can open my Win32 exe project in the IDE, but when I try to compile it, I get an error message indicating that it can't find a unit on my project's search path. I can put the project's search path into the environment lib path, and then it will compile and run, but then if I get an exception, there is no debugging info. In the output window, I noticed that it's not adding many switches in terms of the unit output, exe output, de...

Delphi 2007 to Delphi 7
I've written a class in Delphi 2007 that is not supported in Delphi 7. What would be the best way to achive what I've done in Delphi 2007 in Delphi 7? Thanks, Tom type BondConstants = class { Bond Types } type BondType = record const TREASURY = 3; AGENCY = 0; CORP = 1; MUNI = 2; SBA = 5; MBS = 4; CMO = 6; end; { Day Count Methods } type DayCount = record const ACTUAL_360 = 2; ACTUAL_365 = 1; ACTUAL_ACTUAL = 1; d30_360 = 0; ...

Delphi 4 to Delphi 2007
Hello, I will have to port a D4 application (with source) to D2007. what kind of problem could I face ? I will have to go to customer site tommorow to analyse its source code to quote the work, what should I care of to hestimate the porting time ? Thanks John Terry wrote: > Hello, > I will have to port a D4 application (with source) to D2007. > what kind of problem could I face ? > I will have to go to customer site tommorow to analyse its source code > to quote the work, what should I care of to hestimate the porting time ? You can probably do it by just changi...

is there a Delphi 2007
Would be nice to have a bundle of the latest Delphi packages. Gilbert Padilla wrote: > Would be nice to have a bundle of the latest Delphi packages. > I expect Delphi 2007 will only be on sale until the full RAD Studio 2009 edition is published, including Delphi 2009.net. W ...

Delphi 2009 alongside Delphi 2007
Hi all, I am about to install Delphi 2009 on the same development system as Delphi 2007, before I embark is there anything I should be aware of so as to not break my Delphi 2007 installation and projects ? Thanks JT John Taylor wrote: > Hi all, > > I am about to install Delphi 2009 on the same development system > as Delphi 2007, before I embark is there anything I should be aware > of so as to not break my Delphi 2007 installation and projects ? As long as you install into a separate folder there is no problem with the two versions getting into each other...

Delphi 2010 w Delphi 2007
I have D2007 installed on my laptop (XP sp3 running on dual core Athlon). Can I install D2010 on this machine without it affecting D2007? Will D2010 affect D2007 in any way? Thanks, Randall Carpenter > {quote:title=Randall Carpenter wrote:}{quote} > I have D2007 installed on my laptop (XP sp3 running on dual core Athlon). > Can I install D2010 on this machine without it affecting D2007? Will D2010 > affect D2007 in any way? Won't hurt a thing. I have D7, RAD Studio 2007, RAD Studio 2009, and RAD Studio 2010 all on my desktop system and they coexist fine. Jus...

Moving from Delphi 7 to Delphi 2007
Is there any compelling reason to move (quite a large project) from Delphi 7 to Delphi 2007? Specifically, is there better Vista/Win7/Win8 integration provided by Delphi 2007? (In the project I am already using a custom manifest file for Vista/Win7 etc.. and not the std XPMan component) Does 2007 add any new bugs to the scene? Thanks Rael Rael wrote: > Is there any compelling reason to move (quite a large project) from > Delphi 7 to Delphi 2007? If you are going to upgrade, why not upgrade to something newer? > In the project I am already using a custom man...

Delphi 2007 to Delphi 2009 Conversion
CharArrayPtr = ^CharArray; CharArray = array[0..MaxInt-1] of Char; How to convert to Delphi 2009? Bill Bill Miller wrote: > CharArrayPtr = ^CharArray; > CharArray = array[0..MaxInt-1] of Char; > > How to convert to Delphi 2009? > > Bill it depends heavelly on how it is used fearther down in your project and what you want to convert it to. I you want to simple convert the declarations ignoring UNicode altogether then the only think you have to change is the CharArray declaratin from a Char to an AnsiChar eg CharArrayPtr = ^CharArray; CharArray =...

Migrate from Delphi 2007 to Delphi 2010
Hi All, Thanks in advance for your help. Below is my query, Currently I am using Delphi 2007 and i want to migrate to Delphi 2010. 1. What all things i need to take care while doing this? 2. What all third party components will get impacted? 3. Any known issues in Delphi 2010 which might impact the cause? 4. Any changes in database operation required as i am using Oracle? Hope I have post this query under correct category. If not sorry for the trouble and could you please suggest me the correct category for this? Looking forward for your response. Have a great day. Th...

Delphi 2007 RTL in Delphi 7
I read somewhere that it is possible to use Delphi 2007's (or for that matter Delphi 2006's) RTL in Delphi 7 by just recompiling the source of RTL. Is this really possible? What are the benefits that we can derive using a higher version's RTL? TIA Yogi Yang Yogi Yang wrote: > I read somewhere that it is possible to use Delphi 2007's (or for > that matter Delphi 2006's) RTL in Delphi 7 by just recompiling the > source of RTL. If it actually compiles in Delphi 7, I guess it would be possible. OTOH, if one has Delphi 2007 already, I don't s...

Code Porting
Hi people, Basically, I am moving an app from Delphi 5 to Delphi 2009 which is all great (yeah right!) and I am having a couple of issues with some thirdparty components that we have the source code for. Being that I wanted to make the task as easy as possible, I was able to download the component in Delphi 2007 format. I have now managed to port that to 2009 so it compiles only with warnings and no errors. So all is good at this moment. Now I am trying to install the component into the IDE by using the install menu option from the project manager. This is where I run into errors. ...

Migrate from Delphi 2007 for Win32 to Delphi XE
we use Delphi 2007 for Win32 to support legacy (32Bit) OWL-based pascal applications (yes i know it was a mistake not to switch to VCL 15 years ago). could our applications still be opened and compiled with Delphi XE? The existing projects are all plain Pascal-Code, coming back from the times of Turbo Pascal for Windows and later on Borland Pascal. Are there any improvements we could profit from (i.e IDE, Debugger)? Thanks Andrej > {quote:title=Andrej Dimic wrote:}{quote} > could our applications still be opened and compiled with Delphi XE? I'm not sure, but I guess ...

Delphi and Delphi for .Net
It seems that Delphi for .Net is slower than Delphi Win32 native applicaiton. I would like to know is it true all .Net application is slower than Win32 native applicaiton or it is Delphi for .Net only. Your information is great appreciated, Inung On 2011-06-21 18:20:17 +0100, Inung Huang said: > It seems that Delphi for .Net is slower than Delphi Win32 native applicaiton. > I would like to know is it true all .Net application is slower than > Win32 native applicaiton or it is Delphi for .Net only. If you are only running the code in the application once then, yes, yo...

What we need to learn as we migrate from Delphi 2007 to Delphi 2012
As we prepare to move from Delphi 2007 to the Delphi of next summer/fall, and 64bit some day, we are looking for a list of improvements to Delphi (from IDE to the language) that have been done from Delphi 2007 to Delphi XE, as well as any planned ones for the next version. We understand the daunting migration to Unicode that awaits us but know that we have missed some "new and improved" items where we have to get all our developers up to speed on that may not be related to Unicode. So, we will need to plan some training before we jump in. Is there such a list out ...

Web resources about - Delphi 2007 on Vista SP1 (x64)?! - embarcadero.delphi.ide

Delphi - Wikipedia, the free encyclopedia
... an archaeological site and a modern town in Greece on the south-western spur of Mount Parnassus in the valley of Phocis . The site of Delphi ...

Delphi Automotive (@DelphiAuto) on Twitter
Log in Sign up You are on Twitter Mobile because you are using an old version of Internet Explorer. Learn more here Delphi Automotive @ DelphiAuto ...

Delphi Connect for Verizon on the App Store on iTunes
Get Delphi Connect for Verizon on the App Store. See screenshots and ratings, and read customer reviews.


Audi working with Delphi to develop autonomous car tech
Audi is developing an iPad-sized device that will pack all the necessary computing power for a self-driving car

US approves China company's acquisition of Delphi biz
The Committee on Foreign Investment in the United States has formally approved the acquisition of Delphi's global production of braking systems ...

Verizon And Delphi Officially Launch Vehicle Diagnostics Service - $250 For The Module, $5 A Month On ...
If you're a car nut, a paranoid parent, or a small business owner looking to do a little, uh, company vehicle economy analysis, Verizon's teamed ...

Watch out Google: Delphi gives Ars a ride in its self-driving car
The automotive components maker gave Ars a preview ride around the neighborhood. MOUNTAIN VIEW, CA—On Thursday morning I met with Delphi at its ...

The skinny on Delphi's autonomous road trip across the United States
Filed under: Green , Videos , Autonomous Last week, Delphi's autonomous car became the first to complete a coast-to-coast trip across the United ...

Delphi partners with WiTricity on automated wireless charging system
One could easily argue that parking between the white lines at any local hangout presents a challenge for some inexperienced drivers. So, why ...

Resources last updated: 1/23/2016 6:59:39 AM