Installation error in FireMonkey-ios.pkg on XCode 4.2 ios 5.0 [Update 3]

Hello

I waited for Delphi Xe2 Update 3, hoping that ios5.0 installation problem will be solved. But I couldnt managed again to install the firemonkey on MacOs side. 

The release notes for Update3 declare that:
*Note: This installer is now compatible with Xcode 4.2. Note that while Xcode 4.2 includes the iOS 5.0 SDK, the new features of iOS 5 are not supported. FireMonkey applications can be deployed to devices running iOS 5.* 

I have Xcode 4.2 in Lion machine. XCode has got only ios 5.0 SDK. So How should I consider above note? Does it mean I can use Firemonkey with XCode4.2 and ios5.0sdk without ios5.0 specific features? OR. Doest it mean I should have an ios4.3sdk in anyway?

In some older posts someone suggested to make a manual parse, however even I followed the document I couldnt make a manual parse either. So can someone suggest me a way to be able to install firemonkey-ios?

Here is my error report:

Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: AnonClassDefinitionsUikit.o AnonClassDefinitionsUikit.ppu to a directory in your FPC unit path.
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: Applying iOS 5 patches...
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSEnumerator.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSArray.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSSet.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSDictionary.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSFileHandle.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSKeyValueCoding.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSKeyValueObserving.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSPropertyList.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file UIView.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file UIViewController.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file UIAccessibilityElement.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file UIBarItem.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file UIColor.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file UIImage.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file UIPopoverController.inc
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: Hunk #1 FAILED at 55.
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: 1 out of 1 hunk FAILED -- saving rejects to file UIPopoverController.inc.rej
Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: Building iOS headers for devices...
Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: Free Pascal Compiler version 2.5.1 [2011/12/29] for arm
Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: Copyright (c) 1993-2011 by Florian Klaempfl and others
Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: Target OS: Darwin for ARM
Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: Compiling iPhoneAll.pas
Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: Compiling AnonClassDefinitionsUikit.pas
Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: Assembling (pipe) AnonClassDefinitionsUikit.s
Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: UIPopoverController.inc(58,84) Error: Identifier not found "UIAppearanceContainerProtocol"
Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: UIPopoverController.inc(58,84) Error: Objective-C protocol type expected, but got "<erroneous type>"
Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: iPhoneAll.pas(95,1) Fatal: There were 2 errors compiling module, stopping
Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: Fatal: Compilation aborted
0
Mehmed
12/29/2011 4:03:12 PM
embarcadero.delphi.firemonkey 4901 articles. 4 followers. Follow

1 Replies
1396 Views

Similar Articles

[PageSpeed] 51
Get it on Google Play
Get it on Apple App Store

Hello All

The problem was solved by uninstalling XCode and reinsatalling it again. FireMonkey is installed without error on Xcode 4.2 with ios 5.0.

Regards

> {quote:title=Mehmed Ali Caliskan wrote:}{quote}
> Hello
> 
> I waited for Delphi Xe2 Update 3, hoping that ios5.0 installation problem will be solved. But I couldnt managed again to install the firemonkey on MacOs side. 
> 
> The release notes for Update3 declare that:
> *Note: This installer is now compatible with Xcode 4.2. Note that while Xcode 4.2 includes the iOS 5.0 SDK, the new features of iOS 5 are not supported. FireMonkey applications can be deployed to devices running iOS 5.* 
> 
> I have Xcode 4.2 in Lion machine. XCode has got only ios 5.0 SDK. So How should I consider above note? Does it mean I can use Firemonkey with XCode4.2 and ios5.0sdk without ios5.0 specific features? OR. Doest it mean I should have an ios4.3sdk in anyway?
> 
> In some older posts someone suggested to make a manual parse, however even I followed the document I couldnt make a manual parse either. So can someone suggest me a way to be able to install firemonkey-ios?
> 
> Here is my error report:
> 
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: AnonClassDefinitionsUikit.o AnonClassDefinitionsUikit.ppu to a directory in your FPC unit path.
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: Applying iOS 5 patches...
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSEnumerator.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSArray.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSSet.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSDictionary.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSFileHandle.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSKeyValueCoding.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSKeyValueObserving.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file NSPropertyList.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file UIView.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file UIViewController.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file UIAccessibilityElement.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file UIBarItem.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file UIColor.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file UIImage.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: patching file UIPopoverController.inc
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: Hunk #1 FAILED at 55.
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: 1 out of 1 hunk FAILED -- saving rejects to file UIPopoverController.inc.rej
> Dec 29 17:04:22 Organic-Apple installd[31210]: ./postflight: Building iOS headers for devices...
> Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: Free Pascal Compiler version 2.5.1 [2011/12/29] for arm
> Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: Copyright (c) 1993-2011 by Florian Klaempfl and others
> Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: Target OS: Darwin for ARM
> Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: Compiling iPhoneAll.pas
> Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: Compiling AnonClassDefinitionsUikit.pas
> Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: Assembling (pipe) AnonClassDefinitionsUikit.s
> Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: UIPopoverController.inc(58,84) Error: Identifier not found "UIAppearanceContainerProtocol"
> Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: UIPopoverController.inc(58,84) Error: Objective-C protocol type expected, but got "<erroneous type>"
> Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: iPhoneAll.pas(95,1) Fatal: There were 2 errors compiling module, stopping
> Dec 29 17:04:23 Organic-Apple installd[31210]: ./postflight: Fatal: Compilation aborted
0
Mehmed
12/29/2011 6:13:46 PM
Reply:

Similar Artilces:

after success update from 3.1.1 to 3.2, I test my site to update from 3.2 to 4.0, and I got this error
  Server Error in '/wpatest' Application. Parser Error Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately. Parser Error Message: Stream is not a valid resource file.Source Error: Line 1: <?xml version="1.0" encoding="UTF-8" ?> Line 2: <root> Line 3: <language name="English" key="en-US" fallback=""/>Source File: /wpatest/App_GlobalResources/Locales.xml.resources    Line: 1 Version Informatio...

Re-installation of FireMonkey iOS on Mac with Xcode 4.3.1
Hi, I had to upgrade my Xcode to support iOS 5.1 - however it wouldn't compile my Firemonkey apps which were previously working. So I've now uninstalled Xcode, reinstalled FPC and finally on trying to install FireMonkey IOS XE2 (it's the Update 4 version), it says "FireMonkey can't be installed on this disk. FireMonkey required iOS 4.2 or 4.3 on your system". The version of Xcode I have is definitely 4.3.1. Do I need to wait for an update from Embarcadero? Thanks, Martyn > {quote:title=Martyn Williams wrote:}{quote} > Hi, > > I h...

Error when updating 2.0.0.4 to 2.0.0.5
Name: Romain Email: romanolematfreedotfr Product: Firefox Summary: Error when updating 2.0.0.4 to 2.0.0.5 Comments: I had an error when updating 2.0.0.4 to 2.0.0.5 (french version). Some files where not found and the install program launched itself in loop. I had to download new version from website and install it to fix the problem. Firefox rocks ! Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5 ...

[ANN] Security Advisory for Bugzilla 3.0.10, 3.2.5, 3.4.4, and 3.5.2
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Summary ======= Bugzilla is a Web-based bug-tracking system, used by a large number of software projects. This advisory covers two security issues that have recently been fixed in the Bugzilla code: + Some files stored on the web server are not correctly protected against external access and can be viewed from a web browser. + Restricting a bug to a group while moving the bug to another product has no effect if the group is not used by both products. The bug may become public if no other group restriction applies. All...

ERROR:RedHat9.0+sybase-11.9.2-3(or 12.5)+httpd-2.0.47.tar.gz(apache)+php-4.3.2.tar.gz
Error Message: /sybase/OCS/lib/libintl.so: undefined reference to "__ctype_b" it may be caused by glibc-2.3.2-11.9,someone says it would be fine with glibc-2.3.2-5,but I don't know how to resolve this problem. May someone help me!!! On Fri, 25 Jul 2003 11:43:16 -0400, fl wrote: > Error Message: > > /sybase/OCS/lib/libintl.so: > undefined reference to "__ctype_b" > > it may be caused by glibc-2.3.2-11.9,someone says it would be fine with > glibc-2.3.2-5,but I don't know how to resolve this problem. May someone > help m...

When updating from 3.0.15, Firefox updated to 3.5.4 instead of 3.5.5
Name: Product: Firefox Summary: When updating from 3.0.15, Firefox updated to 3.5.4 instead of 3.5.5 Comments: Possibly by design, but when autoupdating from 3.0.15, Firefox updated to 3.5.4 instead of 3.5.5. I would assume this is known, but it seems strange and was the case across a wide number of systems that I updated today. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729) From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback but...

Installation error in FireMonkey-ios.pkg on MacOs [Edit]
Hello When I want to install Firemonkey package on Macos I got an installation failure after *'running package scripts'* phase. I first install fpc package succesfully, however could not complete the firemonkey installation with success. When I look at the folders, I see */fmi* and */fpc* folder copied with their content. And also when I check the fpc compiler with the */usr/local/lib/fpc/2.5.1/ppcross386 -iDVTOTP* command I get the proper answer as *2011/09/16 2.5.1 darwin i386*. You can think that everything is ok. But when I try to compile the exported code in XCode I get ...

Update 3 FireMonkey-iOS-XE2 Failed Install
Hi all, I've just installed Delphi XE2 and also installed the packages on my Mac from the FireMonkey-iOS dmg file which all went ok. I've since installed the Update 3 patch and tried to install the latest FireMonkey-iOS packages and the Free Pascal package installs ok but the FireMonkey-iOS install fails for some reason. Since I had the files installed prior to Update 3 I've tried to compile my test iOS app anyway but I receive the following error in XCode: /usr/local/lib/fpc/2.5.1/ppcross386: No such file or directory I'm sure this must be as a result of the FileMo...

FireMonkey-iOS-XE2 pkg returns error on install
A script fails when trying to install Firemonkey on Macbook Pro running snow leopard. This was the last stage after re-installing Delphi XE2 and update 4. My target is an iPhone running OS 5.1 when I can install Firemonkey correctly. I have managed to copy device support and SDKs for 5.1. I successfully installed XCode 4.2. When I Xcode compile a project I get "file is universal but does not contain a(n) arm slice for architecture arm" error message. Does anyone have any idea how I can fix the problem? Uninstalled Xcode 4.2 Reinstalled Xcode 4.2 Installed fpc 2.6 Installed FireM...

Firemonkey XE2 Update 4 and IOS 5.1
I have XCode 4.2 and Firemonkey from the XE2 update 4, installed and working on Mac. I know that the IOS 5.1 isn't supported yet. But I have an iPad with IOS 5.1, and reading this http://blogs.embarcadero.com/ao/2012/03/16/39235 , I decide to try to install the new XCODE 4.3.2, Everything is fine, I can build my IOS firemonkey with IOS 5.1 and test it on iPhone, but the iPad Simulator IOS 5.1 doesn't show up the application. I also have a warning about change de GDB to LLCB. Now I have two xcode installed, both are working. The only issue is the iPad IOS 5.1 not...

selecting ? selecting of 1., 2. , 3., 4., 5., 6. is slow (1-3 second) then selecting of 7.,8.,9. go on is so fast (0.1 second or more fast).. how can i get fast for selecting of 1., 2. , 3., 4., 5., 6
hello friends selecting of 1., 2. , 3., 4.(sometime even 5., 6.) is slow (1-3 second) then selecting of 7.,8.,9.(sometimes 5., 6.,) go on is so fast (0.1 second or more fast).. how can i get fast for selecting of 1., 2. , 3., 4., 5., 6. is slow ?? recordcount is almost 1.050.000.. i do selecting 1.2.3. go on same page with treeview1.. treeview1 in masterpage.master.. gridview1 and datasource1 are in pagelist.aspx (it connets datasource1)..productnumber is primarykey for index.. kategori, kategori1 and kategori2, price, datemin are index from keys/index in table1 (right clicking menu)....

FF Update to 2.0.0.4, 2.0.0.5
I finally got the courage ( as I am not of the computer generation) to update FF 1.5.0.12 to 2.0.0.4, then to 2.0.0.5 at the invitation almost insistence of Mozilla every time I use Firefox. Only 3 extensions not possible to update at this point, only really useful extension is Auto Fill, wish the author might update for 2.0.0.5. The update was flawless, Firefox continues to operate as before with, as I notice while typing this message, an automatic spell checker, very useful. Firefox is the best, continues to get better. "pixturesk" wrote ... > I finally got the coura...

Upgrade 12.5.3 and 15.0
Pardon my probable denseness but...I have 12.5.3 DE and 15.0 DE running on a Centos host to keep my sysadmin/dba skills (such as they are) from complete atrophy whilst I earn some wedge in the elsewhere zone! I am looking to upgrade to 12.5.4 and 15.0.2 but having scoured sybase.com have not seen any IR EBF files, and when following the DE download route I get ase1500de.tar.gz proffered!?!?! I was expecting ase1502de.tar.gz for the latter and/or EBFs! Please enlighten me on where to get 'em - ideally before I forget I posted this question :-). Cheers, Frank. 15.0.2 ...

Xcode 4.2 , iOS 5 beta7 & FPC compiler error ... [Edit]
To Mr. Phil Hess, Advanced Developers... I want to writng App FMX with IOS native... ( iPhone 3GS, iOS 5 beta7, Xcode 4.2 , FPC 2.5.1 ) Here is my steps... #1. Install Xcode 4.1 #2. Install Xcode 4.2 #3. Install provisioning profiles #4. Test Xcode 4.2 app with real iphone -> It's OK ( simulator & real iphone ) #5. Install FPC 2.4.4 & upgrade 2.5.1 using method ( http://web.me.com/macpgmr/ObjP ) #6. Install templates ( http://web.me.com/macpgmr/ObjP/Xcode4/Xcode4PascalTemplates_20110905.zip ) #7. Using template ( Objective Pascal / Windows-Based Applicat...

Web resources about - Installation error in FireMonkey-ios.pkg on XCode 4.2 ios 5.0 [Update 3] - embarcadero.delphi.firemonkey

Resources last updated: 1/14/2016 2:03:33 PM