Remote debugging problems C++ builder 2007

I am unable to get the remote debugger to work in C++ builder 2007.

I have the remote debugger installed and running as a service on the 
remote machine. Using Run->Attach to Process I can view the running 
processes on the remote machine and attach to the desired process 
however I can only view machine code.

The event log window shows:
Module load: xxx.exe. No debug info ...

I can debug the process when running locally with no problems.
I have copied the exe and tds files to the same folder on the remote 
machine. In the project options -> Linker -> Linking I have Full debug 
information selected.

What else needs to be done to get remote debugging to work?

Regards

Stuart
0
Stuart
8/25/2008 5:37:46 AM
embarcadero.cppbuilder.ide 2180 articles. 1 followers. Follow

4 Replies
1376 Views

Similar Articles

[PageSpeed] 9
Get it on Google Play
Get it on Apple App Store

Hello!

we have the same problem with the remote debugger. More information you can 
find on report 61360 on codegear quality central. Unfortunately there are no 
resolutions for the problem.

Regards
Sören Seyfert
StarragHeckert
Germany
0
Soren
8/26/2008 6:53:15 AM
Soren Seyfert wrote:
> Hello!
> 
> we have the same problem with the remote debugger. More information you can 
> find on report 61360 on codegear quality central. Unfortunately there are no 
> resolutions for the problem.
> 
> Regards
> Sören Seyfert
> StarragHeckert
> Germany

Hi,

Thankyou for your reply, I will view that report and update with my 
details. Hopefully we arrive at a resolution soon.

Regards,
Stuart Street
0
Stuart
8/27/2008 12:21:18 AM
Stuart Street wrote:
> Soren Seyfert wrote:
>> Hello!
>>
>> we have the same problem with the remote debugger. More information you can 
>> find on report 61360 on codegear quality central. Unfortunately there are no 
>> resolutions for the problem.
>>
>> Regards
>> Sören Seyfert
>> StarragHeckert
>> Germany
> 
> Hi,
> 
> Thankyou for your reply, I will view that report and update with my 
> details. Hopefully we arrive at a resolution soon.
> 
> Regards,
> Stuart Street

A fix has been posted at quality central:

Set the registry value „Disable Multiple Evaluators” in the Windows 
Registry under the hive
HKEY_CURRENT_USER\Software\Borland\BDS\5.0 Debugging\Borland Debuggers
from "1" to "0"

(This applies only to C++Builder 2007; RAD Studio 2007 with C++Builder 
Personality is not affected)
0
Stuart
9/15/2008 12:26:36 AM
> {quote:title=Stuart Street wrote:}{quote}
> Stuart Street wrote:
> > Soren Seyfert wrote:
> >> Hello!
> >>
> >> we have the same problem with the remote debugger. More information you can 
> >> find on report 61360 on codegear quality central. Unfortunately there are no 
> >> resolutions for the problem.
> >>
> >> Regards
> >> Sören Seyfert
> >> StarragHeckert
> >> Germany
> > 
> > Hi,
> > 
> > Thankyou for your reply, I will view that report and update with my 
> > details. Hopefully we arrive at a resolution soon.
> > 
> > Regards,
> > Stuart Street
> 
> A fix has been posted at quality central:
> 
> Set the registry value „Disable Multiple Evaluators” in the Windows 
> Registry under the hive
> HKEY_CURRENT_USER\Software\Borland\BDS\5.0 Debugging\Borland Debuggers
> from "1" to "0"
> 
> (This applies only to C++Builder 2007; RAD Studio 2007 with C++Builder 
> Personality is not affected)

Hi,

Thankyou it works fine.

Best Regards
Sören Seyfert
0
Soren
9/15/2008 11:31:23 AM
Reply:

Similar Artilces:

problem of converting from C++ Builder 6 to C++ Builder 2007
Hi, A program which was developed by our partner was built fine with C++ Builder 6. Now I need to make some changes to it. We bought C++ Builder 2007 a few weeks ago. When I open the program with C++ Builder 2007, I was told that the project needs to be converted. I agreed. Then when I compile it, some errors happen: [BCC32 Error] ComCtrls.hpp(435): E2272 Identifier expected [BCC32 Error] ComCtrls.hpp(3880): E2272 Identifier expected [BCC32 Error] ComCtrls.hpp(4658): E2272 Identifier expected ...... Anybody has any idea how to fix it? Thanks, Allen In article <14040@f...

Upgrading Code from C++ Builder 4 to C++ Builder 2007
I am working on project written in C++ Builder 4, it uses TMS Component pack. Now the TMS Component pack has been upgraded so i do not find any compatible version of TMS Component to use with C++ Builder 4. I need to upgrade my code from C++ Builder 4 to C++ Builder 2007. I want to know whether code written in C++ Builder 4 is feasible with C++ Builder 2007. Thanks Arshdeep wrote: > I want to know whether code written in C++ Builder 4 is feasible > with C++ Builder 2007. Feisible, but do take into account that there have been RTL/VCL changes between BCB4 and CB2007, so y...

Convert to C++ Builder XE from C++ Builder 6 and 2007
Any information regarding the roadblocks of converting the code build in C++ Builder 6,2007 to C++ Builder XE? On 6/20/2012 8:20 AM, Girish Duddu wrote: > Any information regarding the roadblocks of converting the code build in C++ Builder 6,2007 to C++ Builder XE? The big change is the default string in XE is UnicodeString rather than AnsiString. All VCL String properites (Text, etc.) are Unicode in XE. There are good white papers regarding making this transition on the Embarcadero EDN site. I found that most of the changes I had to make fell into two categories: 1) Places...

C++Builder 2010 Remote Debugging
Hi, I am able to get remote debugging working so I can start up the process on the other box. However, I can't seem to set breakpoints and have the program stop. I copied the .tds file to the remote program. I presume I am missing some setting somewhere. Any pointers on where to look? Thanks, Shawn ...

How to Debug a package C++Builder 2007
I've read the documentation on how to debug a package: Set the 'Host' to bds.exe and then run the package. When the second bds.exe starts, install the package and the debugging should happen in the first (running) instance. But I never get the blue dots showing that I am debugging. I did add OutputDebugString commands in various places and can see it is installing it. I've also checked my package project options and debugging is enabled. Any suggestions? I am debugging on a Windows 7 Pro, 32 bit, VM. Thanks, Brian ...

c++ builder 2007 ATL problem
I converted an activex project from bcb6 to c++ builder 2007 but when I try build the project I get error messages pertaining to the use of macro of ATL in c++ builder 2007. Sample of error code: class ATL_NO_VTABLE TSevenSegXImpl: VCLCONTROL_IMPL(TSevenSegXImpl, SevenSegX, TSevenSeg, ISevenSegX, DIID_ISevenSegXEvents) { Atlwin.h code(From c++ builder 2007) // VCLCONTROL_IMPL // This macro is used to encapsulate the various base classes an ActiveX VCL Control derives from. // #define VCLCONTROL_IMPL(cppClass, CoClass, VclClass, intf, EventID) \ public TVclControlImpl...

Problem installing ToolBar2000 under C++ Builder 2007
Hello I am trying to install ToolBar2000 under Builder 2007 but can't get to first base. I am following the help file but when I try to load up tb2k_d11.dproj, like it says, I get this error of "Unable to load project......" Has anyone tried to install this under C Builder 2007 ? regards david ...

Problem with Variant::Exec in C++ Builder 2007/2009
Hello, I've hit a problem when upgrading an application from C++ Builder 6 to 2007. The previous code used to work under C++ Builder 6: Variant excel = Variant::CreateObject("Excel.Application"); excel.OlePropertyGet("Workbooks").OleProcedure("Open", "test.xls"); Function macro("Run"); excel.OlePropertyGet("Application").Exec(macro << WideString("my_macro")); Now, I get an Access Violation with C++ Builder 2007 during the execution of Variant::Exec. I've tracked down the problem to these...

Debug in CPU mode in codegear c++ builder 2007 [Edit]
Why debug is occuring in CPU mode? I need to debug my program by lines. Like in c++ builder 6. When I push "F7", assembler code appears in CPU mode. What option should I check to make debugging mode in programm lines? I have activated Debug mode in Project manager, but it didn't help me. :( Please help Edited by: омар Хазам on Apr 19, 2009 5:51 AM ...

C++ Builder 2007 problem with Windows 7 64-bit
I was using C++ Builder 2007 for quite a while now. I was developing on Windows 7 32-bit which worked quite well but now i moved to new machine which has Windows 7 64-bit OS. Now whenever i run something it compiles and executes fine but when i try to close the program it gives me error with message: {code} Assertion failure: "(!"SetThreadContext failure ")" in ..\win32src\thread32.cpp at line 412 Continue execution? {code} If i click No C++ Builder IDE disappears with program and it doesn't matter what project I run even Demo project which comes with IDE. F...

Problem on starting C++ Builder XE (several minutes before showing IDE)
Hi all, without apparent reason suddenly my c++ builder XE presents the problem in subject. I tried to repair, unistall and reinstall without fix it. Also the setup application remains several minutes before starting. Is there a mode/way to erase/clear really all the previous installation data? In fact after unistalling/installing the C++ Builder shows me all previous settings and register components. I wouldn't format my PC/OS, please can anyone help me? my environment: C++ Builder XE Windows 7/32bit premium TMS Components pack COMODO firewall AVIRA antivirus (no virus f...

How do I install Delphi 2007 components into C++Builder 2007?
Hi Folks, I have a Delphi component that installs into Delphi 2007, and it then appears in the tool palette. That's all fine. When I then run C++Builder 2007, I can see that my component package is already installed, and can even uninstall and re-install it, but the component doesn't appear in the tool palette. What must I do to get it to appear in the palette for C++Builder? -- Simon <Simon Armstrong> wrote in message news:5932@forums.codegear.com... > What must I do to get it to appear in the palette for C++Builder? Did you enable the "Generate all...

Problem with remote debug
Hello, I'm debugging an ASP.NET Application in a remote server with Windows 2003 Server and it runs correctly when there's only one user debugging. The problem is the multiuser remote debug because it shows me an error message and I can't continue the debug in more hosts. Can somebody help me? Thanks....

Remote Debugging Problem
I've deployed my PB objects to Jag and indicated that they will be remote debugged. However, when I connect to Jag from the remote debugger and it lists the packages, I cannot get my package to open to show the three objects I just put into the package. I can open other packages and see the components in each of them, but not mine. Probably a very simple novice error - Any pointers? BTW - I can see the package and the components from JagManager in both the Packages and Installed Packages. Phil Yandel Consultant Business Systems Analyst Global Objects Team Household Technol...

Web resources about - Remote debugging problems C++ builder 2007 - embarcadero.cppbuilder.ide

Debugging - Wikipedia, the free encyclopedia
... here. For the shell command, see debug (command) . For the German magazine, see Debug (magazine) . For the 2014 film, see Debug (film) . Debugging ...

Debugging - Wikipedia, the free encyclopedia
... here. For the shell command, see debug (command) . For the German magazine, see Debug (magazine) . For the 2014 film, see Debug (film) . Debugging ...


The Remote Agent Experiment: Debugging Code from 60 Million Miles Away - YouTube
Google Tech Talk February 14, 2012 Presented by Ron Garret. ABSTRACT The Remote Agent Experiment: Debugging Code from 60 Million Miles Away The ...

Taking the pain out of debugging with live programming
"Everyone knows that debugging is twice as hard as writing a program in the first place," Brian Kernighan once wrote (adding: "So if you're as ...

Microsoft acquires software for debugging Unity games
... Visual Studio's capabilities for game builders, Microsoft is acquiring SyntaxTree, creator of a widely used Visual Studio plug-in for debugging ...

Agile Learning, Debugging and Mikado Method in Methods & Tools Fall 2013 issue
Methods & Tools – the free e-magazine for software developers, testers and project managers – has just published its Fall 2013 issue with the ...

Apple releases Xcode 6.3.1 with bug fixes for debugging
Apple today released Xcode 6.3.1 with bug fixes . According to the release notes, the release includes fixes for debugging, Interface Builder, ...

Chrome Beta for Android brings debugging tools to mobile web developers
YouTube link for mobile viewing Chrome Beta for Android brings a lot of cool features for users like you and me, but it also has a handy one ...


Resources last updated: 1/24/2016 1:37:37 AM