Application was unable to start correctly

Hi,

I have a 64 bit C++ app, built using XE6.  It all compiles and links ok, but when it runs I get the message, 'The Application was unable to start correctly (0xC000007b) click OK to close the application.'

This appears just after cc64150mt is loaded.

If I step into it I get the same thing happens.

How can I find out more about what is going wrong?

Thanks Tim
0
Tim
6/4/2014 12:40:32 PM
embarcadero.cppbuilder.ide 2180 articles. 1 followers. Follow

3 Replies
1525 Views

Similar Articles

[PageSpeed] 9
Get it on Google Play
Get it on Apple App Store

Tim wrote:

> I have a 64 bit C++ app, built using XE6.  It all compiles and links
> ok, but when it runs I get the message, 'The Application was unable
> to start correctly (0xC000007b) click OK to close the application.'

Error 0xC0000007B is STATUS_INVALID_IMAGE_FORMAT.  One of your app's dependancies 
is likely trying to load a 32bit DLL instead of a 64bit DLL, and thus failing.

--
Remy Lebeau (TeamB)
0
Remy
6/4/2014 5:39:09 PM
> {quote:title=Remy Lebeau (TeamB) wrote:}{quote}
> Tim wrote:
> 
> > I have a 64 bit C++ app, built using XE6.  It all compiles and links
> > ok, but when it runs I get the message, 'The Application was unable
> > to start correctly (0xC000007b) click OK to close the application.'
> 
> Error 0xC0000007B is STATUS_INVALID_IMAGE_FORMAT.  One of your app's dependancies 
> is likely trying to load a 32bit DLL instead of a 64bit DLL, and thus failing.
> 
> --
> Remy Lebeau (TeamB)

Remy,

Thanks for the help.  Is there a way to determine what DLL the app is having a problem loading.  I have a number of static libraries and as far as I can tell all the dependecies point to 64 bit libraries, (but obviously there is a problem somewhere), so it will help if I can determine what the specific issue is.

Thanks,

Tim.
0
Tim
6/5/2014 11:33:33 AM
On 2014/06/05 07:33 AM, Tim Frost wrote:
>
> Thanks for the help.  Is there a way to determine what DLL the app is having a problem loading.  I have a number of static libraries and as far as I can tell all the dependecies point to 64 bit libraries, (but obviously there is a problem somewhere), so it will help if I can determine what the specific issue is.
>

Dependency Walker (FREE!) may help:

http://www.dependencywalker.com/
0
Eliot
6/5/2014 4:59:46 PM
Reply:

Similar Artilces:

The Application was unable to start correctly (0xc00007c)
I have started to get this error after reinstalling my Operating System (Windows 8.1 64 bit) from a backup. It occurs when I compile and run a new application - (just a Form and nothing else). The old projects compile and run ok. I have run the repair option with no effect. Can anyone help? Regards Richard http://stackoverflow.com/questions/10492037/the-application-was-unable-to-start-correctly-0xc000007b dependency walker worth a try... (64bit vs 32bit dll)... "richard rotheroe" <home> wrote in message news:698484@forums.embarcadero.com... >I have ...

"The application was unable to start correctly (0xc0000142)"
Hi ! I installed d2007 on a Windows 7 64bit PC, for some month ago. I have worked on an old project for a while without any problems so I assume that d2007 is installed correct. However, yesterday, I implemented an old Dll, which I have made longtime ago. I have used this dll many times on our old Windows XP d2007 installation without any problems, but I cannot get it to work on my new d2007/Windows 7 64bit installation. I can compile the application without any problems/errors/warnings, but when I try to execute the application, I get following error “The application was unable to start...

Since a few days, I am unable to run Firefox correctly; the application (French version) closes each time I want to start it.
Name: Gerhard SCHULZ Email: gerharddotschulzatyahoodotfr Product: Firefox Summary: Since a few days, I am unable to run Firefox correctly; the application (French version) closes each time I want to start it. Comments: Although I downloaded the latest version of Mozilla, I am still kicked out each time. Is there any special reason why Firefox no longer works with Windows XP? Browser Details: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727) ...

Debug console application: Unable to start debugging, the workstation service has not been started
Hi,This is probably a very dumb question, but how do I enable debugging for a console application? I keep getting this error message saying "the workstation service has not been started". How do I start that service?I never had this in VS2003, so I don't really know what to do :)Thanks!Dave All of the forums at forums.asp.net are for topics related to ASP.NET (web sites / web applications). For questions related to windows and console application development we recommend you post at the MSDN Forums.Mike Banavige~~~~~~~~~~~~Need a site code sample in a different language...

Unable to start Delphi IDE
Hi all, All of a sudden I'm no longer to start Delphi 2010 if have started it once before Upon starting the second time (after closing the first time) I get this error Cannot create file "C:\Users\[USERNAME]\AppData\Local\Temp\EditorLineEnds.ttr". The process cannot access the file because it is being used by another process. The file is definitely not being used by another process. At this point only restarting Windows allows re-starting Delphi 2010. Any idea what may be causing this? Thanks in advance, Gerrit Beuze ModelMaker Tools > > maybe this ...

Unable to start Web Applications
I'm running .NET on Windows 2000 Pro. While starting new Project-> Web Applications.. not able to save to http://local host/ . Do you have IIS installed in your machine and so port 80 is open?Sreedharhttp://www.w3coder.orgweblog http://weblogs.asp.net/skoganti...

Unable to start a web application.
Hi, I recently upgraded to visual studio .net 2003 and when I attempt to start a web application, I get this error: Error while trying to run project: Unable to start debugging on the web server. I have went through several checks, such as aspnet_regiis -i , debugging is set to true in the web.config file. When I start the application without debugging, I get this error: Object reference not set to an instance of an object. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error an...

I am using Vista professional, and firefox 3.6 doe s not start correctly. When I hit several times, it starts with several copies of firefox in the applications. Thats why I am unabkle use it.
Name: firefox 3,6 Email: nedimalbayrak2atyahoodotcom Product: Firefox Summary: I am using Vista professional, and firefox 3.6 doe s not start correctly. When I hit several times, it starts with several copies of firefox in the applications. Thats why I am unabkle use it. Comments: I am using Windows Vista professional, and firefox 3.6 does not start correctly. When I hit several times, it starts as one copy but with several copies of firefox in the applications (I saw them when I hit ctrl+alt+del). Thats why I am unable use it. generally it works slower than previous version...

Starting the server application and stopping the server application from the client application
Hi , How do I do it ? I want to start the server application from my client app. After all my jobs are over , when I disconnect from the server, I want to close the server application. Both the client and server applications will be running on the desktop under NT or win95 environment. If the client app is abc.exe and the server app is pqr.exe when the user starts the client app from his desktop, the client should start pqr.exe . Now after finishing all the process when the user closes the client, I want to disconnect from server and close the server pqr then close abc...

Application on start and session on start
Hello friends, I got a basic question for you all.Can some one explain to me when exactly are the application on start and session on start are used , with a simple example.Thanks in advance. Ashok. I have been curious of the very same thing. From what Ive read, application_start is fired the first time a request is made and the application hasnt been started yet. Now Im still not sure when the application ends though. I know it ends if IIS stops. It also ends if a recompile is done in the /bin folder. But Ive also read that it is supposed to also die after a certain amount of time o...

Application Error; unable to start Mozilla Firefox
hi, I am unable to start the Mozilla Firefox version 1.5.02 on Windows XP SP2. I am getting an Application Error saying "instruction at location 0x14.... referenced memory 0x000000 which cannot be read." I tried reinstalling but still gettting the error. Regards, Tarun tarun.telang@gmail.com wrote: > I am unable to start the Mozilla Firefox version 1.5.02 on Windows XP > SP2. I am getting an Application Error saying "instruction at location > 0x14.... referenced memory 0x000000 which cannot be read." > > I tried reinstalling but still ...

Unable to connect, unable to start
Hello everyone! If anybody experienced this problem or knows how to get over it! After fresh install of dbclient5.5.4 #1956 on Windows2000 server and trying to connect via ASPage (IIS) getting an error: "Microsoft OLE DB Provider for ODBC Drivers error '80004005' [Sybase][ODBC Driver]Unable to connect to database server: unable to start database engine /folder/anotherfolder/aspname.asp, line 123" Never had that issue on NT4Server before. Also we are running IIS on that server(may be conflicts?) Start command in Startup Options: dbclient -Z -y -x tcpip...

Unable to start debugging with web application add in
I am using the new project type of Web Application and IIS. In IIS I have a site labled as devbox.host.com, which answers to only that host header. In my HOSTS file I have devbox.host.com assigned to 127.0.0.1. In the web project properties I have Use IIS Web server and project url as http://devbox.host.com/webapplication1When I try to debug the application I receive the following error:Unable to start debugging on the web server. Logon failure: unknown user name or bad password.if I change the devbox.host.com to localhost all works fine. I need to have the header as I have to have mutliple ...

Unable to acess network shares when running application from the IDE
I recently switched to XE5 and Windows 8 at the same time. I have my application running fine outside the IDE. When I run from inside the IDE and I need to access an INI file on a network share, I get a file not found as if there is a permissions error. Example - try to read \sharename\myfile.ini works from inside IDE and running application standalone \\server\sharename\myfile.ini only works standalone Any suggestions? Maybe you are loading IDE with admin privilege...

Web resources about - Application was unable to start correctly - embarcadero.cppbuilder.ide

Application - Wikipedia, the free encyclopedia
Text is available under the Creative Commons Attribution-ShareAlike License ;additional terms may apply. By using this site, you agree to the ...

Second visa application 'likely' to be approved
The family of a terminally ill Pakistani student can 'hopefully come to Australia sooner rather than later' says Immigration Minister Peter Dutton. ...

Tashfeen Malik's visa application under scrutiny - Business Insider Deutschland
The US government has released the visa application for Tashfeen Malik, who along with her husband killed 14 people in an attack in San Bernardino, ...

Panasonic Develops a Stretchable Resin Film and Its Application Materials for Stretchable Electronics ...
A stretchable film is developed. This film stretches to 2.5 times the original length and then returns to the original form. A conductive paste ...

MBA: Mortgage Applications Increase in Latest MBA Weekly Survey, Purchase Applications up 37% YoY
From the MBA: Refinance, Purchase Applications Both Up in Latest MBA Weekly Survey Mortgage applications increased 7.3 percent from one week ...

Lawmaker: Immigration Officials Didn’t Fully Vet Tashfeen Malik’s Visa Application
"It’s unacceptable that U.S. Citizenship and Immigration Services did not fully vet Malik’s application and instead sloppily approved her visa," ...

German-Based Spirea Promotes Decentralized PV Applications In Uruguay
... Its technical operations specialist, Laurie Lawrence, pointed out that Uruguay [&hellip German-Based Spirea Promotes Decentralized PV Applications ...

Visa application of San Bernardino shooter released
CNN Visa application of San Bernardino shooter released CNN (CNN) The visa application of one of the San Bernardino shooters was released ...

ZTE to develop smartphone application processors in house
ZTE has stepped up its efforts to internally develop smartphone chipset solutions, aiming to re-capture the title as one of the top-three smartphone ...

IBM Takes on AT&T Managed Application, Hosting Services
AT&T’s networking, security and mobility solutions coupled with IBM Cloud offers companies a fully managed IT environment.

Resources last updated: 1/6/2016 5:27:54 AM