Cannot get the 'Design' or 'Split' feature to work in VWD 2008 Express

I have XP Pro SP3.  

Downloaded VWD 2008 Express from the MSN site. There was no problem in installation.
Now, I want to start programming. But I cannot get the designer / split view to work.

Here are the steps:

1. Double-click on VWD icon on the desktop.
2. Click on File\NewFile
3. In the New File dialog box, click on C# and Web Form items.
4. Hit the Open button at the bottom.
5. IDE opens with Default1.aspx
6. In the toolbox, click on HTML to expand it.
7. In the Server Objects & Events pane; place the cursor on the empty line between the <div> and </div> lines
8. In the same pane, at the bottom left hand corner; we have "Designer" and "Split". Click on "Split".
9. IDE freezes. No further action is possible.
Same result if we click on "Design" instead of "split". Actual ResultsIDE freezes up. No further action is possible.Expected ResultsI expect to see the split screen, when I hit "Split". (And the designer screen when I hit the "Design").

Thanks

Hopeful1 

 

0
hopeful1
2/7/2009 12:44:14 PM
asp.net.web-dev-2008-express 1205 articles. 0 followers. Follow

11 Replies
911 Views

Similar Articles

[PageSpeed] 27
Get it on Google Play
Get it on Apple App Store

Also, I am using XP Pro (not Vista) - so am not certain if the graphics you have provided translates 100% to a XP environment.

In any case, I have used the following: Control Panel\ Add or Delete Programs. I can find the entry "Microsoft Visual Studio Web Authoring Component".   I cannot find any entry for KB 945140.

How to “check that KB 945140 update is installed”..??

 

Thanks

 

0
hopeful1
2/7/2009 1:21:06 PM

You can verify if update is installed if you click 'Show installed updates' - I believe there is a checkbox on XP. If you installed latest VWD download, it comes with SP1 and already includes the update. Another way to verify is to check version of fpeditax.dll in C:\Program Files\Microsoft Web Designer Tools\VWD, it should be 12.0.63xx.5000.

Now, do you have Office installed and if so, which version?


Thanks

------------------------------------------------------------

This posting is provided "AS IS" with no warranties, and confers no rights.
0
Mikhail
2/7/2009 4:18:06 PM

Yes, there is a check box to show Installed Updates (guess I learnt something new..:)  ).

Nevertheless, I was unable to find KB945140. (Also,  the version for the dll is: 12.0.4518.1066)

I have Office 2002. As per your logic, I have the incorrect versions... How do I go about correcting it without affecting MS-OFFICE?

Thanks for the prompt response,
Hopeful1

0
hopeful1
2/8/2009 12:13:52 AM

Before we look for the update, let's make sure you have VWD SP1 installed. If you click Help | About, there should be information if it is with SP1. I will assume it is SP1.If it is not, please uninstall VWD and Web Authoring Component and install VWD SP1 version (see download link below).

Now if you do have VWD SP1 and yet fpeditax.dll is still xxxx.1066 it means that SP1 update for the designer is not installed, which is not good. Before we consider any conflict with installed Office, we need to make sure binaries are correct and SP1 is installed. If you do not have CD or DVD with VWD SP1, download it here

http://www.microsoft.com/eXPress/download

Go to the bottom of the page and download DVD image. Mount ISO as disk or open it in WinRAR or any other archiver capable of opening ISO images. In the root there should be WebDesignerCore_KB945140.msp file. Run it by double-clicking on it. Verify that fpeditax.dll version is now 12.0.6319.5000

 

 


Thanks

------------------------------------------------------------

This posting is provided "AS IS" with no warranties, and confers no rights.
0
Mikhail
2/8/2009 1:47:49 AM

Yes, I did as per your recommendations.. everything is working OK. The dll is also of the right version. 

Many thanks, my friend.

Hopeful1

0
hopeful1
2/8/2009 9:52:32 PM

Cool, glad you are all set Smile Forums are the best place if you need immediate help.


Thanks

------------------------------------------------------------

This posting is provided "AS IS" with no warranties, and confers no rights.
0
Mikhail
2/9/2009 1:45:07 AM

I am having a very similar problem.  I used VWD 2008 happily for the past 9 months.  I installed Visio 2007 last week, and since then I haven't been able to get the Design view to work in VWD 2008. 

The rest of 'Office' is 2002, except for Visio which is 2007. 

I tried uninstalling VWD and reinstalling, but that didn't help. 

All of the .dll's in C:\program files\microsoft web designer tools\vwd are  v. 12.0.6319.5000

I can't find the KB 945140 as installed under VWD2008 in Control Panel/Add-Remove Progs, but there are numerous other KB installs listed there. It is listed as SP1 in the Add-Remove Progs list.

From within VWD - Help - About VWD, it says I am running v. 9.0.30729.1 SP.

I have placed "C:\Program Files\Microsoft Web Designer Tools\vwd" as the first item in the 'Path' system variable under 'My Computer'.

I am running WinXP Pro SP3.

I am running .NET 3.5 SP1.

I can't find the  WebDesignerCore_KB945140.msp file you mentioned after mounting the .iso to a drive.

I have checked the registry, and the appropriate key is there according the the troubleshooting blog entry.

I'm pretty much clueless at this point.  Any ideas?

0
CJones79
2/13/2009 10:35:11 PM

You case is not related to SP1 install or compat with older Office. First, you already have 6319.5000 component which is SP1 and hence you don't need to run any additional MSP files. Second, it worked with older Office before you installied Visio, therefore conflict in PATH is unlikely.

Most probably install of Visio either change or somehow removed one of the Office components shared with VWD designer. Reinstalling VWD won't help, it is better to reinstall designer manually. Try this

1. In Control Panel, uninstall Microsoft VS Web Autoring Component

2. Reinstall Web Autoring Component by running WebToolsCore.exe or WebDesignerCore.exe from the CD/DVD. It can be found in WCU folder.

3. If fpeditax is not 12.0. 6319.5000, apply SP1 to the designer by running WebDesignerCore_KB945140.msp (if it is missing you may not have SP1 ISO, perhaps you have stock RTM image?)

 


Thanks

------------------------------------------------------------

This posting is provided "AS IS" with no warranties, and confers no rights.
0
Mikhail
2/14/2009 9:18:36 PM

I am at a loss.  I uninstalled Web Authoring Component and reinstalled via the downloaded/mounted iso image of \\VWDExpress\WCU\WebDesignerCore\WebDesignerCore.exe.  I then ran WebDesignerCore_KB945140.  Now all of the DLLs in C:\program files\microsoft web designer tools\VWD are at 12.0.6319.5000

The Desgin/Split view in VWDExpress 2008 still doesn't work.

Anything else I should try, or should I just uninstall Visio and work back from there?

0
CJones79
2/16/2009 5:19:40 PM

I apologize.  I am an idiot.  The lack of anything being visible in the "Design" view was related to something completely separate from this issue.  It is working now.  Thanks for the help.

DOH!

0
CJones79
2/16/2009 7:13:52 PM

Hi I also have this problem and tried everything you have written.

I have VS2008 3.5 SP1, office 2007 and visio 2007.

I uninstalled Web Authoring Component and reinstalled via the downloaded/mounted iso image of \\VWDExpress\WCU\WebDesignerCore\WebDesignerCore.exe.  I then ran WebDesignerCore_KB945140.  Now all of the DLLs in C:\program files\microsoft web designer tools\VWD are at 12.0.6319.5000

The Desgin/Split view still doesn't work.

Anything else I should try?

Please help me, I am desperate.

0
ukiany
3/16/2009 11:46:41 AM
Reply:

Similar Artilces:

Cannot get the 'Design' or 'Split' feature to work in VS 2008
Hi I  tried everything which is written in the past posts but still design get stuck. I have VS2008 3.5 SP1, office 2007 and visio 2007. I uninstalled Web Authoring Component and reinstalled via the downloaded/mounted iso image of \\VWDExpress\WCU\WebDesignerCore\WebDesignerCore.exe. I then ran WebDesignerCore_KB945140. Now all of the DLLs in C:\program files\microsoft web designer tools\VWD are at 12.0.6319.5000 The Desgin/Split view still doesn't work. Anything else I should try? Please help me, I am desperate. checkout this article its resolved here. http://forums...

''''''''''''''''''''
Name: haznen Email: haznenatyahoodotcom Product: Gran Paradiso Alpha 8 Summary: '''''''''''''''''''' Comments: '''''''''''''''''''''''''''''''''''' Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061204 UGES/1.7.2.0 GranParadiso/3.0a1 From URL: http://www.mozilla.org/projects/granparadiso/ Note to readers: Hendrix gives...

'''''
Name: mario Email: ramar17atfastwebnetdotit Product: Gran Paradiso Alpha 2 Summary: ''''' Comments: K: Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2) Gecko/20070206 GranParadiso/3.0a2 ...

'do' won't 'do' if '/'
Greetings to All from Au, Have a NetWare Perl 5.8.4 and wanted to tweak File\Spec\NW.pm to try and standardise on '/' separators. If I run a test script (t/uni/lower.t) with an unmodified NW.pm, it calls t/uni/case.pl, that, in case.pl, (when the path separators are '\'), the $file is '..\lib\unicore\To\Lower.pl' and the following code portion works, with $simple getting a returned table: sub casetest { my ($base, $spec, $func) = @_; my $file = File::Spec->catfile(File::Spec->catdir(File::Spec->updir, "lib", &qu...

'''
Name: L Lachowsky Email: e2brutus_10atyahoodotcom Product: Firefox Summary: ''' Comments: why duddn this surprise me... I change default server from IE to Mozilla, and then i get error messages. well, shud I decide to not get on my computer with Mozilla..or shud I risk security breeches with IE....hmmm at least i can get on the internet with IE Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this fee...

Cast from type ''''DBNull'''' to type ''''String'''' is not valid.
How do I avoid getting this error: Cast from type ''''DBNull'''' to type ''''String'''' is not valid. I am trying to get values from the database into a form for updating using a Datareader, SQL is set to allow nulls for certain fields as they are not required but the only way I can get the form to display is by adding a space in SQL. Is there another way around this? Check if it is equal to DBNull.Value first and if it is, don't do the cast.Stanley Tan theSpoke Blog Where in the code does it need to go? I am using the following and it's the profile that isn't always requi...

Need desperate help with installing Microsoft Visual C++ 2008 Express ''ENU has encountered''
Im gonna cut right to the chase i want to install Microsoft Visual C++ 2008 Express Edition but every time i try to install it i get a message saying:  ''Microsoft Visual C++ 2008 express Edition - ENU has encountered a problem during setup. Setup did not complete correctly.''   Then i get another message saying what it did not manage to install Setup could not install the following component:Microsoft .NET Framework 3.5   Ive done some ''research'' around the internet and it seems this problem occurs a bit. I have to admit im kinda noob...

table_info('','','','%') cannot return any types
I was recently confirming table_info special cases and discovered the case for getting table_types cannot work. table_info('','','','%') should return a list of table types but it returns a list of empty strings instead: my @types = $h->tables('', '', '', '%'); print "all types:\n", join("xxx\n", @types), "\n"; # should output something like: # "dbo" # "INFORMATION_SCHEMA" # "sys" # and actually outputs: xxx xxx It seems to be down to the following ...

What should ''.split('') return?
Hi, what should ''.split('') return? The empty list, or a list with one null string? Moritz -- Moritz Lenz http://moritz.faui2k3.org/ | http://perl-6.de/ On Fri, Sep 19, 2008 at 05:58:59PM +0200, Moritz Lenz wrote: : Hi, : : what should ''.split('') return? The empty list, or a list with one null : string? Empty list would make more sense as a degenerate case. In 'a'.split('') we don't return the null strings before or after 'a', just ('a'). Larry Larry Wall wrote: > On Fri, Sep 19...

'IN' Clause or 'OR'
Hello, [1]: select * from TABLEA where COL1 IN('value1','value2''valu3'....) [2]:select * from TABLEA where COL1 = 'value1' OR COL1= 'value2' OR COL1='valu3'. TABLEA is a huge table and it has non-clustered index on COL1. Among the above 2 queries, which query will give me the better performance or fast response and WHY? What is the difference between 'IN' and 'OR' clauses as for as Sybase Optimization is concerned. Which is the better one to be used on huge tables. Thanks. Mac An IN list is treated ...

'b'..'a'
Hello. I'm using defferent 5.6.0's for Win32. I wonder wheter following behaviour is intentional or not: d:\>perl -e "print 'b'..'c'" bc d:\>perl -e "print 'b'..'a'" bcdefghijklmnopqrstuvwxyz I expected empty list in latter case, like in perl -e "print 'bb'..'a'" <!ENTITY Vadim REALLIFE "Vadim V.Konovalov, St.Petersburg, Russia"> &Vadim; On Wed, Sep 20, 2000 at 03:14:41PM +0400, Konovalov, Vadim wrote: > Hello. > > I'm using defferent 5.6.0'...

'or' or 'union'
Hello I was just wondering, in general what is better to use, an 'or' clause in a select or a 'union' to join two selects together. Do both statements create work tables? Many thanks Alex I think OR will be better than union. because suppose u have 3 tables and using OR u can join table a and table b and table c so each table will have only one read. but using union you will join table a and table b and in another query of union u will use table (a or b) and table c so ur one read is more in union . Ramdas Alex Cheung wrote: > Hello > >...

vwd 2008 express 'save website as'
I know I can save a copy of the file I am working on, but how can I save a copy of the entire website (project) I am working on for the purpose of backing up? I am using visual web developer 2008 express  Thanks, Sam  Are you referring to the website or to the database beind it?Don't forget to click "Mark as Answer" on the post that helped you.This credits that member, earns you a point and marks your thread as Resolved so we will all know you have been helped. I'm referring to the entire project including all of the files in the solution explorer. So basi...

EXEC sp_msforeachtable 'sp_spaceused ''?'''
What does the following SQL code mean?  EXEC sp_msforeachtable 'sp_spaceused ''?'''Johan TheunissenMCPD, MCSE, MCTS BizTalk 2006==============================Please mark the most helpful reply/replies as "Answer". JohanNL:sp_msforeachtable This is the name of the SP that resides in the master database.  This SP executes one or more commands for a table. JohanNL:sp_spaceused This is the command that you want to run for each of the tables residing in your current database.  As you might have understood so far, that this is again a...

Web resources about - Cannot get the 'Design' or 'Split' feature to work in VWD 2008 Express - asp.net.web-dev-2008-express

Resources last updated: 12/16/2015 6:43:27 PM