Need desperate help with installing Microsoft Visual C++ 2008 Express ''ENU has encountered''


Im gonna cut right to the chase
i want to install Microsoft Visual C++ 2008 Express Edition but every time i try to install it i get a message saying:
 ''Microsoft Visual C++ 2008 express Edition - ENU has encountered a problem during setup. Setup did not complete correctly.''
Then i get another message saying what it did not manage to install
Setup could not install the following component:
Microsoft .NET Framework 3.5
Ive done some ''research'' around the internet and it seems this problem occurs a bit.
I have to admit im kinda noobish so i need help from someone ''un-noobish'' :)
I would be very very very very very grateful for help :)
0
bkf_94
6/16/2008 9:19:29 PM
📁 asp.net.visual-studio-2008
📃 3408 articles.
⭐ 0 followers.

💬 5 Replies
👁️‍🗨️ 590 Views



Maybe you should just trying installing the .NET 3.5 framework first.
Download it from here:
http://www.microsoft.com/downloads/details.aspx?FamilyID=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
If that doesn't work, try to log/capture as many errors as possible to help debug (i.e. Google) the issue.
BTW - make sure you're logged in with administrative privileges.
One other thing - make sure you've uninstalled any beta versions of the .NET 3.5 framework that you may have previously installed.
Good luck!
0
corkwatchr
6/16/2008 9:37:25 PM

It didnt work :(
When you say ''try to log/capture as many errors as possible'' do you mean like finding the txt file of the problem?
btw i have .NET Framework 1 and 2 installed. If I uninstall these will i THEN manage to install .NEt Framework 3.5?
Thx for helping me :)
 
0
bkf_94
6/16/2008 9:50:18 PM

Bummer - you can't install the .NET 3.5 framework! You are logged in to Windows with an account that has administrative privileges (rights) on your machine, right?
One of the easiest ways to install any version of .NET is through the Windows Update/Microsoft Update screen. Microsoft .NET Framework will be located under the Optional Components section.
You may want to try and download the entire 197 MB redistributable for .NET 3.5 and install it locally. It is here: http://download.microsoft.com/download/6/0/f/60fc5854-3cb8-4892-b6db-bd4f42510f28/dotnetfx35.exe
If that doesn't work, you may want to try uninstalling .NET 2.0, since .NET 3.0 and .NET 3.5 rely on a successful installation of .NET 2.0. The .NET 3.5 installation (above) include .NET 2.0 and .NET 3.0.
Here's a link with some tips about installing .NET 3.5 http://download.microsoft.com/download/9/a/e/9ae0f6cc-7032-408e-9ca7-989f9e4af4ec/dotNetReadMe.htm
I hope you get it to work!
 
 
0
corkwatchr
6/17/2008 2:24:19 AM

Hey :)
Thc for the tips but once again, it didnt work :(
Administrive priviliges :P ? i dont know what they do or how i turn them on but im using my Admin profile
I tried to uninstall .Net Framework 2.0 and then install .NET Framework 3.5 but i still got that ''a problem has occured'' but do i need .NET Framework 2.0 and 3.0 to install 3.5?
On my parent's computer it worked and they have .NET 2.0 and 3.0 and since you say i need to reinstall 2.0
thx for helping me =)
0
bkf_94
6/17/2008 9:15:11 PM

.NET 3.5 includes .NET 2.0 and .NET 3.0.
Another tip - make sure you have the latest service pack isntalled on your machine (Windows XP SP3 or Vista SP1).
As another last resort, you could manually remove and reinstall .NET 2.0 following these instructions: (http://support.microsoft.com/kb/908077)  Actually, I'd just remove .NET 2.0 and let the full 197MB redistributable install .NET 2.0/3.0/3.5
If this doesn't work, you may just need to rebuild the machine.
 
0
corkwatchr
6/18/2008 3:55:14 AM
Reply: