Application created in new version of .NET (3.0 or 3.5) can use the library created in older version of .NET(i.e.-1.0 or 2.0)?


Hi All,
I am using Visual Studio .NET compiler for compiling my application . We have plugins (as library) which the user can write by their own in .NETย . We are building our code in Visual Studio 2005 but we have already some plug-ins which are written in previous versions of Visual Studio (i.e. 2002 and 2003). Is these plug-ins will work with the new build of the application or I need to build these plug-ins as well in Visual Studio .NET 2005. These plugins are created as library.
Is their any differences between .NET 1.0, 2.0 and 3.0 because of which the old libraries (created in old .NET version, i.e 1.0 and 2.0) will not work with the application created in new verion(3.0 or 3.5)
ย Any help will be highly appreciated.
ย Thanks.

darshi
0
darshi
2/27/2008 12:05:00 PM
๐Ÿ“ asp.net.visual-studio-2005
๐Ÿ“ƒ 7760 articles.
โญ 0 followers.

๐Ÿ’ฌ 1 Replies
๐Ÿ‘๏ธโ€๐Ÿ—จ๏ธ 3088 Views



No prob it will work.
Framework 3 will have all the namespaces of the version 1 and 2.
0
easydeepan
3/5/2008 12:17:34 PM
Reply: