can't find the procedure 'aspnet_CheckSchemaVersion''?

 I pick out  the zip files from the starter kit,and  open it with visual studio 2005, then create the database TimeTracker in sql server 2005 CTP manually. I also change the web.config file ,but when i login ,an error occurs like this:

 System.Data.SqlClient.SqlException: can't find the procedure  'dbo.aspnet_CheckSchemaVersion'。

source errors:

line 11:          if (Roles.Enabled)
line 12:         {
line 13:            if (!Roles.RoleExists("ProjectAdministrator"))
line 14:             {
line 15:                 Roles.CreateRole("ProjectAdministrator");

why?
thanks.
0
rodmanabc
11/26/2005 1:04:01 AM
asp.net.time-tracker-kit 398 articles. 0 followers. Follow

3 Replies
967 Views

Similar Articles

[PageSpeed] 41
Get it on Google Play
Get it on Apple App Store

successed! I know how to do it now !
1 pick up the zip file from the starter kit, unzip it and open it in visual stuion 2005.
2 create an empty database named TimeTracker in Sql Server 2005
3 run the tool asapnet_regsql.exe under C:\WINDOWS\Microsoft.NET\Framework\<version 2>, config your database TimeTracker
4 execute the script timetracker-add.sql (under <work directory>\time_finalbeta_cs\App_Data) in Sql Server 2005
5 change the web.config like this:
 <connectionStrings>
  <add name="aspnet_staterKits_TimeTracker" connectionString="server=HOMISWEBSERVER\SQLSERVER2005;uid=sa;pwd=homis2005;database=TimeTracker"/>
  <!--"Data Source=.\SQLExpress;Integrated Security=True;AttachDBFilename=|DataDirectory|TimeTracker.mdf;User Instance=true" />
  -->
  <remove name="LocalSqlServer"/>
  <add name="LocalSqlServer" connectionString="server=HOMISWEBSERVER\SQLSERVER2005;uid=sa;pwd=homis2005;database=TimeTracker"/>
  <!--
  Data Source=.\SQLExpress;Integrated Security=True;AttachDBFilename=|DataDirectory|TimeTracker.mdf;User Instance=true" />
  -->
 </connectionStrings>
6 before login,you should create a new user on the login page at first,do you see the linklabe "Create new user"?
7 enjoy it.

0
rodmanabc
11/26/2005 3:07:24 AM
0
sajidpk
3/13/2007 4:49:01 AM
Check whether proper DB installed or not..??
Chetan Sarode
Software Engineer,
Approva Systems Pvt Ltd,
Pune, India.
0
chetan
4/17/2007 5:08:04 AM
Reply:

Similar Artilces:

''''''''''''''''''''
Name: haznen Email: haznenatyahoodotcom Product: Gran Paradiso Alpha 8 Summary: '''''''''''''''''''' Comments: '''''''''''''''''''''''''''''''''''' Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061204 UGES/1.7.2.0 GranParadiso/3.0a1 From URL: http://www.mozilla.org/projects/granparadiso/ Note to readers: Hendrix gives...

'''''
Name: mario Email: ramar17atfastwebnetdotit Product: Gran Paradiso Alpha 2 Summary: ''''' Comments: K: Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2) Gecko/20070206 GranParadiso/3.0a2 ...

'do' won't 'do' if '/'
Greetings to All from Au, Have a NetWare Perl 5.8.4 and wanted to tweak File\Spec\NW.pm to try and standardise on '/' separators. If I run a test script (t/uni/lower.t) with an unmodified NW.pm, it calls t/uni/case.pl, that, in case.pl, (when the path separators are '\'), the $file is '..\lib\unicore\To\Lower.pl' and the following code portion works, with $simple getting a returned table: sub casetest { my ($base, $spec, $func) = @_; my $file = File::Spec->catfile(File::Spec->catdir(File::Spec->updir, "lib", &qu...

Can't base report on stored procedure--'Can't create Datawindow'
I installed IM65 today to give it a try. I made a db config to our local ASE 11.9.2 engine via Sybase' odbc driver that came with 11.9.2. I start a new report, tell it to be tabular and to get data from a SP. It asks which SP and I tell it. The result is an odbc error: Cannot create DataWindow Intersolv SQL ODBC driver: Incorrect syntax near '='. 1 execute dbo.sp_si_addressbest_;0 RETURN_VALUE = :RETURN_VALUE' I can execute the SP fine from SQL Advantage or from Crytal Reports. Thanks. -- Frank Burleigh Indiana University School of Law Bloomi...

'''
Name: L Lachowsky Email: e2brutus_10atyahoodotcom Product: Firefox Summary: ''' Comments: why duddn this surprise me... I change default server from IE to Mozilla, and then i get error messages. well, shud I decide to not get on my computer with Mozilla..or shud I risk security breeches with IE....hmmm at least i can get on the internet with IE Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this fee...

Again with the 'reset' and 'can't be found' stuff...
Name: William Jones Email: jbillyjonesatyahoodotcom Product: Firefox Summary: Again with the 'reset' and 'can't be found' stuff... Comments: Hello Again FireFox, Listen...I'm just a simple guy, a 'dial-up baby boomer' who's had to learn the hard way all the way through. I recently sent a similar e-mail requesting assistance with this ridiculous and incessant 'pop up' that informs me that 'my connection has been reset', and/or, 'a problem locating page'....huh? I was just on the damn thing and even switching from one ...

Cast from type ''''DBNull'''' to type ''''String'''' is not valid.
How do I avoid getting this error: Cast from type ''''DBNull'''' to type ''''String'''' is not valid. I am trying to get values from the database into a form for updating using a Datareader, SQL is set to allow nulls for certain fields as they are not required but the only way I can get the form to display is by adding a space in SQL. Is there another way around this? Check if it is equal to DBNull.Value first and if it is, don't do the cast.Stanley Tan theSpoke Blog Where in the code does it need to go? I am using the following and it's the profile that isn't always requi...

table_info('','','','%') cannot return any types
I was recently confirming table_info special cases and discovered the case for getting table_types cannot work. table_info('','','','%') should return a list of table types but it returns a list of empty strings instead: my @types = $h->tables('', '', '', '%'); print "all types:\n", join("xxx\n", @types), "\n"; # should output something like: # "dbo" # "INFORMATION_SCHEMA" # "sys" # and actually outputs: xxx xxx It seems to be down to the following ...

I can't get no cache, I can't get no cache. 'Cause I try and I try and I try and, I can't get no, I can't get no cache.
I have fiddled out for days tinkering with the setting in about:config trying to get FireFox 12 to use the disk cache. I have NOT found the trick. This One Trick Pony ain't doing it like it used to up until recently. Pray tell anyone, What information can I share that will point a knowledgeable person to aid me in getting FF to disk.cache? I have also tried restarting FF with add-ons disabled, (There were NOT too many to do this to, so it was quick and easy) Here is my stab at trying to convey the information that MIGHT govern matters Using about:cache Informatio...

Re: I can't get no cache, I can't get no cache. ' Cause I try and I try and I try and, I can't get no, I can't get no cache.
<div>please com e see me about htis<br /> <br /> ------- Original Message f= rom the Global Relay Archive -------<br /> From: Hp &lt;ferd@farkel.net&gt;= <br /> To: "support-firefox@lists.mozilla.org" &lt;support-firefox@lists.mo= zilla.org&gt;<br /> Sent: Sun, 27 May 2012 18:30:18 -0700<br /> Subject: I = can't get no cache, I can't get no cache. 'Cause I try and I try and I try = and, I can't get no, I can't get no cache.<br /> <br /></div> <pre class=3D"gr-maex-body-pre&qu...

'NMDayTim', 'Psock' , 'NMTime' , 'NMFtp' can not be opened.
hello, my colleague have developed an application under c++ builder 5. so now i should undertake it and optimize it. last days i have installed the C++ Builder 2010 testversion to get some experience on it, because i have not used it before. when i try to compile the old project in C++ builder 2010, comes some Compile errors. Also, there are some Includes like 'NMDayTim', 'Psock' , 'NMTime' , 'NMFtp' in this old Project. they can be found and compiled in the old c++ Builder 5. but not in c++ builder 2010. so i want to know do i solve this problem or go...

Can't allocate space for object '' in database 'tempdb',How can I do?
when I run system procedure,I got following messages : Can't allocate space for object '' in database 'tempdb' because the 'system'segment is full. If you ran out of space in syslogs, dump the transaction log. Otherwise, use ALTER DATABASE or sp_extendsegment to increase the size of thesegment. Failed to allocate disk space for a work table in database 'mydb'. You may be able to free up space by using the DUMP TRANsaction command, or you may want to extend the size of the database by using the ALTER DATABASE command. thanks. allan wrot...

'IN' Clause or 'OR'
Hello, [1]: select * from TABLEA where COL1 IN('value1','value2''valu3'....) [2]:select * from TABLEA where COL1 = 'value1' OR COL1= 'value2' OR COL1='valu3'. TABLEA is a huge table and it has non-clustered index on COL1. Among the above 2 queries, which query will give me the better performance or fast response and WHY? What is the difference between 'IN' and 'OR' clauses as for as Sybase Optimization is concerned. Which is the better one to be used on huge tables. Thanks. Mac An IN list is treated ...

'or' or 'union'
Hello I was just wondering, in general what is better to use, an 'or' clause in a select or a 'union' to join two selects together. Do both statements create work tables? Many thanks Alex I think OR will be better than union. because suppose u have 3 tables and using OR u can join table a and table b and table c so each table will have only one read. but using union you will join table a and table b and in another query of union u will use table (a or b) and table c so ur one read is more in union . Ramdas Alex Cheung wrote: > Hello > >...

Web resources about - can't find the procedure 'aspnet_CheckSchemaVersion''? - asp.net.time-tracker-kit

Resources last updated: 1/6/2016 11:06:09 AM