can't get edit mode from Web Partts

Hello, 
Is anyone can help mw with this?
I tried the Web Parts workthrough from MSDN( searchusercontrolvb.ascx, webpartsdemo.aspx, and displaymodemenu.ascx), and the code works OK in VB.Net 2005 Beta2, I can add or edit web parts into the Web page.
But with 2005 professional version, my Web parts only allow me to browse instead of edit, delete and add.

Is there anyway I can get the edit and delete back?

Thanks a lot!

Web Parts Demonstration Page

 Display Mode Browse Reset User State

Links 
ASP.NET site
GotDotNet
Contoso.com
Search 


Content 

Welcome to My Home Page

Use links to visit my favorite sites!





0
VivianWang
12/29/2005 3:07:26 PM
asp.net.personalization 3779 articles. 0 followers. Follow

6 Replies
500 Views

Similar Articles

[PageSpeed] 6

Does your website have anonymous access enabled? WebPart personalization (i.e. edit, delete, add WebParts) only works with authenticated users.

-Jennifer

0
jenlouie
12/29/2005 4:10:13 PM
Hello! Jennifer,

That's what I thought! I must change some settings to get my Web parts work.

Could you please tell me where I can have anonymous access enabled?

Thanks a lot!

0
VivianWang
12/29/2005 7:25:39 PM

You just need to make sure that you're authenticated in some way before the WebParts personalization will work. So, if you're using forms authentication, that means being logged in. If you're using windows authentication (which I think the walkthroughs assume), disabling anonymous access on the website in IIS (you can do this using inetmgr).

0
jenlouie
12/29/2005 9:15:51 PM

Jenlouie,

Thank you for your help. I tried to disable anonymous access on the website in IIS, and run the code again, and found this error message below. Do you have any idea why it will happen?

Again, I run this code in VB.Net 2005 Beta 2 , it works very well; but when I run the code in VB.Net 2005 professional edition, it shows this error.

I think maybe there is some difference between this two versions, but the code given by MSDN in this two versions are the same.

Thanks a lot for your help and happy new year!

Vivian Wang

Server Error in '/VB2005Beta2' Application.

Procedure or Function 'aspnet_PersonalizationPerUser_GetPageSettings' expects parameter '@TimeZoneAdjustment', which was not supplied.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.SqlClient.SqlException: Procedure or Function 'aspnet_PersonalizationPerUser_GetPageSettings' expects parameter '@TimeZoneAdjustment', which was not supplied.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[SqlException (0x80131904): Procedure or Function 'aspnet_PersonalizationPerUser_GetPageSettings' expects parameter '@TimeZoneAdjustment', which was not supplied.]
   System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection) +95
   System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection) +82
   System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj) +346
   System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj) +3244
   System.Data.SqlClient.SqlDataReader.ConsumeMetaData() +52
   System.Data.SqlClient.SqlDataReader.get_MetaData() +130
   System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString) +371
   System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async) +1121
   System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result) +334
   System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method) +45
   System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method) +162
   System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior) +87
   System.Web.UI.WebControls.WebParts.SqlPersonalizationProvider.LoadPersonalizationBlob(SqlConnection connection, String path, String userName) +443
   System.Web.UI.WebControls.WebParts.SqlPersonalizationProvider.LoadPersonalizationBlobs(WebPartManager webPartManager, String path, String userName, Byte[]& sharedDataBlob, Byte[]& userDataBlob) +255
   System.Web.UI.WebControls.WebParts.PersonalizationProvider.LoadPersonalizationState(WebPartManager webPartManager, Boolean ignoreCurrentUser) +162
   System.Web.UI.WebControls.WebParts.WebPartPersonalization.Load() +459
   System.Web.UI.WebControls.WebParts.WebPartPersonalization.LoadInternal() +40
   System.Web.UI.WebControls.WebParts.WebPartManager.OnInit(EventArgs e) +397
   System.Web.UI.Control.InitRecursive(Control namingContainer) +460
   System.Web.UI.Control.InitRecursive(Control namingContainer) +272
   System.Web.UI.Control.InitRecursive(Control namingContainer) +272
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1746


Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42

0
VivianWang
12/30/2005 1:31:21 PM

Jenlouie,

I tried to run the code again, and it works in my 2005 professional version too!

Thanks!

0
VivianWang
12/30/2005 1:44:10 PM

FYI, the error was caused by a version mismatch between the installed framework and the stored procedures in the database.

-Mike


http://blogs.msdn.com/mharder

This posting is provided "AS IS" with no warranties, and confers no rights.
0
mharder
1/4/2006 1:41:05 AM
Reply:

Similar Artilces:

I can't get no cache, I can't get no cache. 'Cause I try and I try and I try and, I can't get no, I can't get no cache.
I have fiddled out for days tinkering with the setting in about:config trying to get FireFox 12 to use the disk cache. I have NOT found the trick. This One Trick Pony ain't doing it like it used to up until recently. Pray tell anyone, What information can I share that will point a knowledgeable person to aid me in getting FF to disk.cache? I have also tried restarting FF with add-ons disabled, (There were NOT too many to do this to, so it was quick and easy) Here is my stab at trying to convey the information that MIGHT govern matters Using about:cache Informatio...

Re: I can't get no cache, I can't get no cache. ' Cause I try and I try and I try and, I can't get no, I can't get no cache.
<div>please com e see me about htis<br /> <br /> ------- Original Message f= rom the Global Relay Archive -------<br /> From: Hp &lt;ferd@farkel.net&gt;= <br /> To: "support-firefox@lists.mozilla.org" &lt;support-firefox@lists.mo= zilla.org&gt;<br /> Sent: Sun, 27 May 2012 18:30:18 -0700<br /> Subject: I = can't get no cache, I can't get no cache. 'Cause I try and I try and I try = and, I can't get no, I can't get no cache.<br /> <br /></div> <pre class=3D"gr-maex-body-pre&qu...

Two things,Why do I keep getting emails that I don't want. can't get rid of them? Why can't I get my email when I am out of town? Or can I?
Name: Ed Leech Email: ELCraftatzoominternetdotnet Product: Thunderbird Summary: Two things,Why do I keep getting emails that I don't want. can't get rid of them? Why can't I get my email when I am out of town? Or can I? Comments: I am getting frusted with all the emails coming in that I do not want, I am using the tools to get thme out but they keep coming. They just use different names or whatever. I have been thinking of just switching to something else but my business intrusts know this email and it is tooo confusing to change. Every time I go out of town on bu...

2010: Can't register - can't download the software - can't register until I have the software
I have active maintenance on Rad Studio: From: Vicky Rassmisaengthong [mailto:Vicky.Rassmisaengthong@EMBARCADERO.COM] Sent: Wednesday, February 25, 2009 1:58 PM To: rgrossman Cc: amer.supportadmin@codegear.com; Ashley Cosentino Subject: Software Assurance Support for Tech III Inc PO# Credit Card Dear Embarcadero Technologies Support Customer, Welcome! You have been registered as the primary contact on support account number AM####### Herewith we confirm your Embarcadero Technologies support agreement covering: Qty 1 RAD Studio Enterprise Named User licens...

It's all very fuzzy now...can make web request(?) but definately can't get web response from web service
Alas...trying to get a web service response from a web service that is part of the web site in Visual Studio.Net 3.5 appears to be impossible.  Infact, I've been ALL over the internet over the past couple of days looking at all types of fragmentory examples in all types of Microsoft languages to no avail. =========QUESTION:=========1.  How do I call a web service (the function to call is "WebService_BulkData") so that my aspx page will send it a SOAP request and print out the web service response data to the page?  The aspx page AND the web service are part of t...

Can't get it to work. Can't get help.
Name: Tony Clarke Email: minionataondotat Product: Thunderbird Summary: Can't get it to work. Can't get help. Comments: Installed T'bird. Had to change defunct server that T'bird selected by default. Kept asking for passwords associated with previous email (Outlook Express ), when passwords entered then got error messages saying aon responded with 're-authentification failure'. Searched your knowledge base & help forums to no avail. Found them very user-unfriendly & ended up more confused than before. Would like to try T'bird, but I think ...

Trying to edit web form, can't get database updated with newly edited values.
 This is my code:  when I try to update any of the fields, the update statement retains the old values retrieved from the database.  Could you tell me where my code is bad? -Thanks, Mark   <%@ Page Language="VB" %><%@Import Namespace="System.Data"%><%@Import Namespace="System.Data.SqlClient"%><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><script runat="server"> Protected Sub Page_Load(ByVa...

update fails, can't get out of it and now can't get my email
Name: martha Email: mjhartleyatchampmaildotcom Product: Thunderbird Summary: update fails, can't get out of it and now can't get my email Comments: The directions about bugging aren't helpful to me because I don't know what you're talking about. You offered an update, I tried it, now it is in an endless loop of trying to install, failing, and trying again. It is very frustrating because I can't even get into my old email files to get addresses, photos, etc. I have turned off my firewall and have rebooted the computer, per some of the suggestions in the...

Can't get label value in edit mode
I have a datagrid with 2 columns. Each column has several controls imbedded. One of the controls in the second column is a label. Each row is editable and this is where my problem exists. While in edit mode, when I execute the dg_UpdateCommand I need to get the value of the label. Here is the code that I am using to do that: Dim sCaseID As String = CType(e.Item.FindControl("lblCaseID"), Label).Text However, the value is always an empty string. I know that a value exists for the label but I just can't get it. Any ideas?? Thanks enak Post the html of the grid dec...

Can't get through init 3 from init 5 and can't get through init 5 from init 3.
I tried opensuse 12.1 Gm today. Installation was perfect with xfce 4.8 until I tried installing the nvidia driver. In runlevel 5 as superuser I tried to shift to runlevel 3 and was welcome with a black screen, I have to use ctrl-alt-delete to reboot. During the reboot I used runlevel 3 and I was able to install the nvidia driver. After the nvidia driver installation I tried to shift to runlevel 5 and there, I was welcome with a black screen with a stationary blinking x cursor. I rebooted once again wiith runlevel 5 to get the gui. Any one had seen this happened? This installation is...

[Resolved] Gridview: Can't get edit mode to appear
Hi, I am converting some DataGrids into GridViews.  I have the AutoGenerateEditButton="True" set in the GridView but when i click on the the Edit button, it does not show the Update button and Cancel button. I am not using a DataSource control because my code-behind gets the data and places it into a DataSet.  From the DataSet, I populate the GridView. I am posting a condensed version of my codes.  Again, I am trying to get the "Update" and "Cancel" buttons when the user clicks "Edit" on the GridView. Could someone tell me what ...

Can't get GV out of Edit Mode in Update Panel
I've got a GridView inside a UpdatePanel (upOrderHdrs). The GV has an Edit Mode using the <asp:CommandField>. I am able to put the GV in Edit Mode and update the items just fine but I can't seem to get the GV out of Edit Mode. I know the Update is working and so is the upOrderHdrs.Update() on the UpdatePanel because I can can see the values changing. However, I just can't get the GV out of Edit Mode. I even tried setting the e.KeepInEditMode=False in the gvOrderHdrs_RowUpdated event. It seems like this is not firing off though because I put in some code to update a label and displ...

Editing the web address in the tool bar can't then get it.
Name: Ian McCarthy Email: idmatvirtensysdotcom Product: Firefox Summary: Editing the web address in the tool bar can't then get it. Comments: If i have an address of a site in the toolbar address field and I edit this address, or replace one which is already there with a pasted one I can then not invoke firefox to fetch it be either hitting enter or clicking on the fetch arrow. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008051206 Firefox/3.0 From URL: http://hendrix.mozilla.org/ ...

Can not get Pickup Directory... .net can't access metabase maybe??? Need to get working ASAP
I am using 2.0 to try to send an email to the IisPickup directorySystem.Net.Mail.MailMessage message = new System.Net.Mail.MailMessage(test@testing.com, "test@test.com", "Testing " + DateTime.Now.ToString(), "Testing the Mail Drop Folder");System.Net.Mail.SmtpClient client = new System.Net.Mail.SmtpClient("127.0.0.1");client.DeliveryMethod = System.Net.Mail.SmtpDeliveryMethod.PickupDirectoryFromIis; client.Send(message);Example Site : www.andrewworral.com (hit the button)This code worked on our old deployment server but not on our new server.  I s...

Web resources about - can't get edit mode from Web Partts - asp.net.personalization

Resources last updated: 12/24/2015 2:33:49 AM