Oracle Provider for OLE DB 9.2.0.2.0

Hello,

we have a strange behavior with the oledb driver for
Oracle; sometime, the driver is not able to format the
DATE/TIME field; we just reboot the machine (the client,
not the database) and it's back working.
For example we do this: DataReader.GetDateTime(index) and sometimes this break...
The data is ok in the database; we exported it and try to have the same
error on another machine and everything is ok. In the doc they said:
For Oracle Provider for OLE DB, NLS_DATE_FORMAT is fixed for the session to 'YYYY-MM-DD HH24:MI:SS' by the provider. So I don't think that its the problem.
Here is the error stack; have you seen this before? Thanks!
Exception Type: System.ArgumentOutOfRangeException
Message: Specified argument was out of the range of valid
values.
Parameter name: Hour, Minute, and Second parameters
describe an unrepresentable DateTime.
ActualValue: NULL
ParamName: Hour, Minute, and Second parameters describe an
unrepresentable DateTime.
TargetSite: Int64 TimeToTicks(Int32, Int32, Int32)
HelpLink: NULL
Source: mscorlib
StackTrace Information
*********************************************
at System.DateTime.TimeToTicks(Int32 hour, Int32
minute, Int32 second)
at System.Data.OleDb.DBBindings.Get_DBTIMESTAMP(IntPtr
buffer)
at System.Data.OleDb.DBBindings.get_Value_DBTIMESTAMP()
at System.Data.OleDb.DBBindings.get_Value()
at System.Data.OleDb.OleDbDataReader.GetValues(Object[]
values)
at System.Data.Common.SchemaMapping.LoadDataRow(Boolean
clearDataValues, Boolean acceptChanges)
at System.Data.Common.DbDataAdapter.FillLoadDataRow
(SchemaMapping mapping)
at System.Data.Common.DbDataAdapter.FillFromReader
(Object data, String srcTable, IDataReader dataReader,
Int32 startRecord, Int32 maxRecords, DataColumn
parentChapterColumn, Object parentChapterValue)
at System.Data.Common.DbDataAdapter.Fill(DataSet
dataSet, String srcTable, IDataReader dataReader, Int32
startRecord, Int32 maxRecords)
at System.Data.Common.DbDataAdapter.Fill(Object data,
Int32 startRecord, Int32 maxRecords, String srcTable,
IDbCommand command, CommandBehavior behavior)
at System.Data.Common.DbDataAdapter.Fill(DataSet
dataSet, Int32 startRecord, Int32 maxRecords, String
srcTable, IDbCommand command, CommandBehavior behavior)
at System.Data.Common.DbDataAdapter.Fill(DataSet
dataSet)
0
SebRob
4/23/2003 5:21:39 PM
asp.net.oracle 2269 articles. 0 followers. Follow

2 Replies
1071 Views

Similar Articles

[PageSpeed] 8
Get it on Google Play
Get it on Apple App Store

HI,

Did you get the solution to this problem?
We are also struck up due to this?
regards,
sujay
0
thepelicanbrief
10/13/2004 9:34:17 AM
Hi,

Upgrading to the latest oledb provider should resolve it. 9.2.0.4.10
Better yet, use ODP instead of OLEDB.
Cheers,
Greg
0
greg
10/13/2004 2:14:16 PM
Reply:

Similar Artilces:

Strange Oracle Issue with 9.2.0.2 and 9.2.0.3
I wonder if anyone has seen this issue ... We have a successfully compiled DBD 1.12 and 1.14 running on a RedHat 7.2 server -- when setting RowCacheSize to a number more that 1000 we garbled data -- Also using the -1000 value does the same. I have seen a few tidbits of data on the net and Oracle's Metalink talking about a possible bug with >= 9.2.0.2 Oracle but to patches and no bugs reported. The problem disappears with setting RowCacheSize to something small like 100 or 0. Also the problem is not seen <= 9.2.0.1 Oracle Client. I am about to write up a TAR on this with Ora...

Does ODAC 9.2.0.7.0 work with Oracle database version 9i 9.2.0.6.0 using VS2005?
I am using VS2005 and need to connect to an Oracle database. The Oracle database version is Oracle 9i 9.2.0.6.0 I have taken a look at the Oracle site (http://www.oracle.com/technology/software/tech/windows/odpnet/index.html). I can download the Oracle Data Access Component - Oracle9i Release 2 ODAC 9.2.0.7.0, but will this work with our current Oracle database version 9i 9.2.0.6.0 ? Any help appreciated. Regards, Paul. Apsolutely.Install it, it will work w/o problems. Regards,Dejan VesićMCAD for .Net technologies | http://www.vesic.org/english/ | Blog: http://www.vesic.org...

DBD:Oracle for Oracle 9.0.2 and 9.2 ?
------_=_NextPart_001_01C2F2A5.306833FA Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable Hi all, =20 Currently in a project to convert our existing 7.3.4 and 8.1.7 Databases to Oracle9i.( Either the 9.0.1 or 9.2 version ) Now I'm having some problems connecting to some test databases I have setup. Do I need to upgrade my perl version or Dbi / DBD version to be able to connect? I keep getting the :=20 =20 DBI->connect(servwhDBMET) failed: ORA-03113: end-of-file on communication channel (DBD: login failed) =20 ...

Make error: DBD-Oracle-1.14 , DBI-1.39, Oracle rdbms 9.2.0.0.0 , solaris 9
------=_NextPart_000_0025_01C3BE5A.4F6A0C70 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: 7bit Hi, When I make DBD-Oracle 1.14 , Makefile.PL generates a Makefile with "-o build" in the compiler string before blib/arch/auto/DBD/Oracle/Oracle.so and prevents Oracle.so from being built correctly. demo_rdbms.mk appears to be to supplying this: Attempting to discover Oracle OCI build rules^M gcc -B/usr/ccs/bin/ -c DBD_ORA_OBJ.c^M by executing: (make -f /export/home/oracle/ora9idbms/rdbms/demo/demo_rdbms.mk bu ild ECHODO=echo EC...

Fixes for DBD::Oracle 1.14 Makefile.PL using Oracle 9.2.0.0.0 on HP-UX
------_=_NextPart_001_01C367AC.DC7002F0 Content-Type: text/plain; charset="iso-8859-1" Hi, When running 'perl Makefile.PL' "out of the box", perl complained that the version of Oracle was a string, but was being compared as a number. This is because the program assumes that the version has only 3 parts, when in fact it has 5. This was fixed by: Line 182: ($inspdver{rdbms_ver} = $inspdver{RDBMS}) =~ s/^(\d+\.\d+)\.(\d+)/${1}0$2/; # Added the following two lines $inspdver{rdbms_ver} =~ s/^(\d+\.\d+)\.(\d+)/${1}0$2/; $inspdver{rdbms_ver} =~ s/^...

Oracle 9.2.0.2.0 is supported by PBO9080.DLL ?
Hi, using Powebuilder 8.0.3, build 9704, connecting with oracle native driver PBO9080.dll, oracle 9.2.0.2.0 Database and Oracle cliente 9.2.0.1.0 is supported ? Thanks, Edu. Officially only 901 is supported. -- Terry Dykstra (TeamSybase) Please state PB / OS / DB versions in your post. http://powerbuilder.codeXchange.sybase.com/ http://www.pb9books.com "Eduardo Marques" <Nelio.Marques@sybase.pt> wrote in message news:eds3VKIQDHA.348@forums-2-dub... > Hi, using Powebuilder 8.0.3, build 9704, connecting with oracle native > driver PBO9080.dll, oracl...

RE: Fixes for DBD::Oracle 1.14 Makefile.PL using Oracle 9.2.0.0.0 on HP-UX
Hi Tim, Thanks. As expected, your changes are a bit more elegant. This is what I got from the new Makefile.PL after running 'make': LD_RUN_PATH="/apps/oracle/Ora920/lib32:/apps/oracle/Ora920/rdbms/lib32" /usr/bin/ld -b -s -a shared Oracle.o dbdimp.o oci7.o oci8.o -o build -L/apps/oracle/Ora920/rdbms/lib32/ -L/apps/oracle/Ora920/lib32/ /apps/cobol2010/coblib:/psoft/HE76DM/bin:/apps/pt76/tux65j12/lib32:/apps/ora cle/Ora920/lib32 -lclntsh -lnbeq9 -lnhost9 -lnus9 -lnldap9 -lldapclnt9 -lnsslb9 -lnoname9 -lntcp9 -lntcps9 -lnsslb9 -lntcp9 -lntns9 -l:libcl.sl ...

PB803/PB9 and offical support oracle 9.2.0.2.0
Hello, 1) is Sybase offical supporting Oracle 9.2.0.2.0 with PB 8.0.3 and/or PB 9.0 2) are there know problems with PB and Oracle 9.2 ... (till now we use PB 8.0.3 with 9.0.1) TIA Heino Hellmers Leader Engineering S&F Datentechnik, Germany Officially 9.2 is not supported. But it does work. http://www.sybase.com/detail?id=1011566 -- Terry Dykstra (TeamSybase) http://powerbuilder.codeXchange.sybase.com/ http://www.pb9books.com product enhancement requests: http://www.isug.com/cgi-bin/ISUG2/submit_enhancement "Heino Hellmers" <heino@hellmers...

ADO.NET 2.0 provider for ASA 9.0.2 build 3476
Hi, I'm trying to link in my Visual Studio 2005 project the ADO.NET 2.0 provider installed with the ASA 9.0.2 patch 3476 (the latest patch available), but it doesn't appear in the reference list. The assembly is correctly registered in the GAC. If I try to Browse for the assembly ('iAnywhere.Data.AsaClient), then at runtime I got the following error: Could not load file or assembly 'iAnywhere.Data.AsaClient, Version=9.0.2.3476, Culture=neutral, PublicKeyToken=f222fc4333e0d400' or one of its dependencies. The located assembly's manifest definition does ...

Linux & Redhat & Oracle 9.2.0.1.0 #2
Hello list, Sorry for reposting this, but I am really at a loss. Thank you for your help. I am pretty new in the Linux area and I am trying to install DBD:Oracle on this platform. It tries to reach a 9i database (all tests were directed to 9i on Linux and/or win2k). I can connect directly in sqlplus to the remote platform as well as to the local one. Thank you for your help. I posted a small amount of output, i could post more in case I omitted relevant facts. Regards, Radu Caulea Some output of the compilation is here: --- test sqlplus sqlplus owa/owa@gate.taf...

Urgent
PB generate funny embedded statements when encounter '->' in the string when using native driver. ############################ When using ODBC Driver ###################### (2296108): DIALOG CONNECT TO TRACE ODBC: (2296108): DBPARM=ConnectString='DSN=fp68odbc;UID=;PWD=' (4146 MilliSeconds) (2296108): COMPILE: (2296108): update spx_tariff_table set description = 'STG-M-TS-FCL-20''->22D' where tariff_code = '75500' (0 MilliSeconds) (2296108): EXECUTE: (0 MilliSeconds) (2296108): CANCEL: (0 MilliSeconds) (2296108): COMPILE: (2296108):...

DBD::Oracle 1.12 on Oracle 9iR2 9.2.0.2 test errors (again)
Hello again, I am still not having any luck in getting the tests to pass. It appears to be the CLOB re-reading that is failing. I have checked all the usual places for help. I have also tried creating a test stub that does a similar thing to the failed tests. Below is the full set of information from the build and test as requested (note this is long). Anyone any ideas? Ben. > perl Makefile.PL -v Using DBI 1.32 installed in /usr/local/lib/perl5/site_perl/5.8.0/sun4-solaris/auto/DBI Duplicate specification "S=s" for option "s" Configuring D...

DBD::Oracle 1.12 on Oracle 9iR2 9.2.0.2 test errors
Hello. I am having some problems testing DBD-Oracle-1.12 in the following environment: Solaris 9 Perl 5.8.0 Oracle 9.2.0.2.0 DBI 1.32 Compilation is fine. Output from test stage is: PERL_DL_NONLAZY=1 /usr/local/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/base.......ok t/general....ok t/long.......Unexpectedly had to drop old test table 'dbd_ora__drop_me' t/long.......ok 97/143Use of uninitialized value in numeric eq (==) at t/long.t line 230. # failed test 98 at line 230...

2.0.0.2 to 2.0.0.3 update failure #2
Name: firefox_fan Product: Firefox Summary: 2.0.0.2 to 2.0.0.3 update failure Comments: The new update fails to install other than in admin mode (Windows XP SP2). Now every time I start Firefox (other than admin mode), it tries to update but fails due to lack of privileges. Let me know how to over come this problem. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2 ...