unable to start debugging on the web server. the web server did not respond in a timely manner. this may be because another debugger is already attached to the web server.

When i start debugging, it looks like it's going to work and the VS toolbars change to show the debugging toolbar options. However the cursor changes to the "busy" cursor and vista 'ghosts out' VS 2008 indicates that it's "not responding" in the title bar. The web browser never starts up and if you I it several minutes I get the following error:

"Unable to start debugging on the web server. The web server did not respond in a timely manner. This may be because another debugger is already attached to the web server."

HOWEVER, if you then immediately debug the project again following this error, sometimes it works straight away! But the first time you debug after loading Visual Studio you always get the irritating delay and error message described above.

Any ideas what might be causing this?

0
pjcontractor
4/28/2009 11:15:18 AM
📁 asp.net.installation-setup
📃 5668 articles.
⭐ 1 followers.

💬 2 Replies
👁️‍🗨️ 8032 Views

I had the same issue with VS2008, i donno cause but  hit Shift+F5, and then F5, this stop current debugging

and starts new session,if you can access the tool bar, then goto-> debug, hit Terminate All.

this terminates all previous debug sessions and creates new one.

 


MARK AS ANSWER IF MY POST HELPED YOU!
THIS REDUCES TIME FOR OTHERS..!
0
SurendraKishore
4/28/2009 12:20:39 PM

I am not sure about the exact error but what I will suggest and I always do is, I attach the process after the application is loaded. There is no need to click start with debugging mode even if the code is not changed.

Soumen, India

0
Rimbik
4/28/2009 1:10:34 PM
Reply:

Similar Posts: