Can't install version 2.0 besides 1.1: dotnetfx.exe will only install 1.1

Hi,

 I'm trying to install version 2.0 beside version 1.1 on a Win2000 server. First I download the correct version of dotnetfx.exe (for version 2.0), but when I run this, I'm asked if I want to install version 1.1 (which is already present). It does not help to uninstall 1.1 first, I'm still prompted to install 1.1, even if dotnetfx.exe is the one for version 2.0! Could this be due to any settings on the server?

 Huh?

 

RGDS

a newbe...

0
OddBob
6/11/2007 1:02:06 PM
asp.net.installation-setup 5668 articles. 1 followers. Follow

2 Replies
1432 Views

Similar Articles

[PageSpeed] 43
Get it on Google Play
Get it on Apple App Store

 Check carefully for every copy of DOTNETFX.COM on the machine (check every folder including system ones), and rename them according to the version number. Then try installing again.


Don't forget to click "Mark as Answer" on the post that helped you.
This credits that member, earns you a point and marks your thread as Resolved so we will all know you have been helped.
0
TATWORTH
6/11/2007 1:56:30 PM

Hi and thanks for the suggestion.

I searched the server and did only find those dotnetfx.exe-files I had put there. But then I checked the file properties and my dotnetfx.exe file was really the one for version 1.1........! ("Do you feel stupid?").  I'm pretty shure that the correct verson 2.0 install file was downloaded from Microsoft (if then for some reason they uploaded the older version to me). But somewhere along the line of copying, I must have grabbed an older version present on one of the servers.

Anyhow, running the correct dotnetfx.exe did install framework 2.0, indeed...!

Once again thanks for the input, and for the rest of you: Learn from this mistake before you waste a day or two.

RGDS

OddBob 

 

0
OddBob
6/13/2007 5:07:29 AM
Reply:

Similar Artilces:

Installed VS.NET 2002. That installed 1.0, but I HAD 1.1 installed. How to remove 1.0?
I haven't seen this anywhere, so I figured I would add it here. First of all, it is incorrect to recommend to anyone that who has VS.NET 2002 to do ANYTHING but first install VS.NET 2002. The installl order for VS.NET 2002 and .Net Framwork 1.1 SHOULD BE: 0. Install ALL windows updates for your pc EXCEPT FOR .NET Framwork 1.1 1. Install VS.NET 2002 2. Install MSDE that comes w/VS.NET 2002 (USE A NAMED INSTANCE! Never usee the default instance) 2. Install MDAC 2.8 3. Install .Net Framework 1.1 4. SOMEHOW GET RID OF .NET Framework and get VS.NET and IIS 5.x to work w...

superreview requested: [Bug 283181] installer version text needs to be upgraded from 1.0 to 1.0.1 : [Attachment 175188] Bump version in installers to 1.0.1/1.7.6
Chase Phillips <cmp@mozilla.org> has asked Ben Goodger <bugs@bengoodger.com> for superreview: Bug 283181: installer version text needs to be upgraded from 1.0 to 1.0.1 https://bugzilla.mozilla.org/show_bug.cgi?id=283181 Attachment 175188: Bump version in installers to 1.0.1/1.7.6 https://bugzilla.mozilla.org/attachment.cgi?id=175188&action=edit ...

superreview granted: [Bug 283181] installer version text needs to be upgraded from 1.0 to 1.0.1 : [Attachment 175188] Bump version in installers to 1.0.1/1.7.6
Ben Goodger <bugs@bengoodger.com> has granted Chase Phillips <cmp@mozilla.org>'s request for superreview: Bug 283181: installer version text needs to be upgraded from 1.0 to 1.0.1 https://bugzilla.mozilla.org/show_bug.cgi?id=283181 Attachment 175188: Bump version in installers to 1.0.1/1.7.6 https://bugzilla.mozilla.org/attachment.cgi?id=175188&action=edit ...

superreview granted: [Bug 283224] mail installer version text needs to be bumped from 1.0 to 1.0.1 : [Attachment 175211] Bump Tb Windows installer to version 1.0.1
Scott MacGregor <mscott@mozilla.org> has granted Chase Phillips <cmp@mozilla.org>'s request for superreview: Bug 283224: mail installer version text needs to be bumped from 1.0 to 1.0.1 https://bugzilla.mozilla.org/show_bug.cgi?id=283224 Attachment 175211: Bump Tb Windows installer to version 1.0.1 https://bugzilla.mozilla.org/attachment.cgi?id=175211&action=edit ------- Additional Comments from Scott MacGregor <mscott@mozilla.org> thanks chase ...

superreview requested: [Bug 283224] mail installer version text needs to be bumped from 1.0 to 1.0.1 : [Attachment 175211] Bump Tb Windows installer to version 1.0.1
Chase Phillips <cmp@mozilla.org> has asked Scott MacGregor <mscott@mozilla.org> for superreview: Bug 283224: mail installer version text needs to be bumped from 1.0 to 1.0.1 https://bugzilla.mozilla.org/show_bug.cgi?id=283224 Attachment 175211: Bump Tb Windows installer to version 1.0.1 https://bugzilla.mozilla.org/attachment.cgi?id=175211&action=edit ...

installing .net 1.1 framework after .net 2.0 framework has already been installed
I am configuring my server 2003 (standard edition) to host a service application that will be accessed with mobile devices. The requirement for the mobile licenses to work properly is that I install the 1.1 framework. I downloaded the redistributable file and went to install it and was prompted, "The product you are trying to install has already been installed with your operating system. Use Windows update to install the latest updates." Through the "add/remove programs" window there is no indication the .net 1.1 framework is installed. When I navigate to C:\WINDOWS\Microsoft .NET...

Install 1.0 and 1.1 side-by-side and use the 1.1 csc to compile a 1.0
Hi, I have the following (tricky) questions: 1. Can I install the 1.0 and 1.1 .NET Framework side-by-side with NO drawbacks on MY PC where I develop the .NET applications? (I do NOT use VS.NET) 2. After installing the 1.1 version, am I STILL ABLE to compile a 1.0 version, since our production web-server still runs on 1.0 (our development web-server was upgraded to 1.1) ?? thx Eau .... as long as you compile DLLs with the right csc.exe/vbc.exe from 1.0 or 1.1 Free ASP.NET Version Switcher may interest you.DNN skins ForumTressleworks modulesDNN & webhostingIEWCtrls...

Can I install dot net framework 2 if 1.1 is already installed?
I notice my development laptop has dot net Framework (presume 1.0) and dot net Framework 1.1 installed. I'd like to start gettting familiar with dot net Framework 2. Can I add this in or do I need to uninstall the 1.x versions first? I presume that my previous dot net framework 1.x apps will still function if I install dot net Framework 2. Is this the case? Thanks, For sure you can have both on one machine. Just install the .NET framework 2.0, then you will have an additional tab in the IIS  MMC, which allows you to specify the framework each application would under. Regards ...

how to install .ner framework 1.1 after .net framework 2.0 has been installed?
hello everyone!I got a problem, I have installed .net framework 2.0 in my computer, but now I need to install .net framework 1.1.The install process of .net framework 1.1 halt when it is stoping the IIS Admin.Can I install .net framework 1.1 after .net framework 2.0 has been installed?Or I have to remove 2.0 and install 1.1 and 2.0 in sequence?Thank you very much! There is no sequence in .net framework 1.1 and 2.0 installation.You can look into the installation log and check what's the problem.Can you post your installation errors?Maybe I can help you to fix the error through your...

can't install kernel-desktop-3.1.9-1.4.1.x86_64 in opensuse 12.1
Good day eveyone: Long story short, after running "zypper update"command, there's a particular update called kernel-desktop-3.1.9-1.4.1.x86_64 which for some strange reason won't install. All other updates install without hiccups, but this particular one has the following output: > Retrieving: kernel-desktop-3.1.9-1.4.1.x86_64.rpm [done (731.3 KiB/s)] > Digest verification failed for kernel-desktop-3.1.9-1.4.1.x86_64.rpm. > Expected > 34158356c78aa4fd42d74d4aea850d8f15a6bd0d5f5e765e703ff211eca9ad66, found > fd5a5fee9eca8a89317d3cce413a486c3d717e6...

Installation of both .net framework 1.0 & 1.1
I've already installed .net Visual Studio 2002 into my server and by installing this it was also installed 1.0 .net framework SDK into my server I have already download the .net framework 1.1 not the SDK pack and installed it to my server.And my problem is that when I'm trying to open an ASP page to my server which have to do with database let's say MS ACCESS database it bring me this error: The page cannot be displayed There is a problem with the page you are trying to reach and it cannot be displayed. ------------------------------------------------------------------------------...

Installation of both .net framework 1.0 & 1.1
I've already installed .net Visual Studio 2002 into my server and by installing this it was also installed 1.0 .net framework SDK into my server I have already download the .net framework 1.1 not the SDK pack and installed it to my server.And my problem is that when I'm trying to open an ASP page to my server which have to do with database let's say MS ACCESS database it bring me this error: The page cannot be displayed There is a problem with the page you are trying to reach and it cannot be displayed. -----------------------------------------------------------------------------...

Version 1.1.1 Hosed on Install
Name: handily Email: handily1athotmaildotcom Product: SeaMonkey Summary: Version 1.1.1 Hosed on Install Comments: I tried to update to the latest ver 1.1.1. It did not install, kept getting 239 chrome error. Did an uninstall, looked up solution on mozilla.org for chrome error. Tried everything-nothing works. Did a system restore using xppro. Still nothing works, even the previous version. You had a perfectly good working program till this update. I do not believe you were ready to release it. How do I completely remove any and all references to SeaMonkey on my system? I wou...

Never done upgrade before. Have a 2.1.2 site w/many custom (purchased) modules, some of which are no longer supported. Don't see *any* info in 3.1 install docs for 2.1.2 upgrade?
Hey folks: I'm about to try something very scary, and I've spent the last 5 or so hours reading DNN 3.1 docs and doing searches here (sure which the search worked better, like allowed sort by date??).  Anyway, I don't see *any* info on updating a 2.1.2 site to a 3.1 site.  The only examples all have machine key stuff and other stuff that's not an issue (or is it?) w/2.1.2 Here's the situation: 1 I have localhost access to the site via remote desktop 2. I have disconnected backed up data and log files and reconnected 3. I have made a copy of the virtual folder. No...

Web resources about - Can't install version 2.0 besides 1.1: dotnetfx.exe will only install 1.1 - asp.net.installation-setup

Resources last updated: 12/11/2015 6:44:52 AM