Edit item don't show on context menu on my custom module

module url : http://ploufs.europe.webmatrixhosting.net/Default.aspx?tabid=32 

My dnn file :
<?xml version="1.0" encoding="utf-8" ?>
<dotnetnuke version="2.0" type="Module">
<folders>
<folder>
<name>DailyComic</name>
<description>Daily comic</description>
<version>02.00.00</version>
<modules>
<module>
<friendlyname>Daily comic</friendlyname>
<controls>
<control>
<src>DailyComic.ascx</src>
<type>View</type>
</control>
<control>
<key>Edit</key>
<title>Edit daily comic</title>
<src>EditDailyComic.ascx</src>
<type>Edit</type>
</control>
</controls>
</module>
</modules>
<files>
<file>
<name>DailyComic.ascx</name>
</file>
<file>
<name>EditDailyComic.ascx</name>
</file>
<file>
<name>DailyComic.xslt</name>
</file>
<file>
<name>DailyComic.dll</name>
</file>
</files>
</folder>
</folders>
</dotnetnuke>
How show item editdailycomic.ascx in context menu ?

0
franck
6/2/2004 11:57:27 PM
asp.net.dotnetnuke 25171 articles. 0 followers. Follow

2 Replies
693 Views

Similar Articles

[PageSpeed] 2
Get it on Google Play
Get it on Apple App Store

Did you add the code for the edit page in the Web Form Designer Generated Code Region in the codebehind?  It goes right after InitializeComponent.  Is should be something like 

MyBase.Actions.Add(GetNextActionID, "Edit Daily Comic", "", URL:=EditURL(), secure:=SecurityAccessLevel.Edit, Visible:=True)
0
scottrait
6/3/2004 6:55:23 PM
I am add this code in main form dailycomic.aspx and work in edit_dailycomic.aspx don't work
0
franck
6/8/2004 1:05:58 AM
Reply:

Similar Artilces:

Edit item don't show on context menu
Module Name: DailyComic Module Function: show daliy comic URL to Module: http://ploufs.europe.webmatrixhosting.net/Default.aspx?tabid=32 Additional Notes: My dnn file : <?xml version="1.0" encoding="utf-8" ?> <dotnetnuke version="2.0" type="Module"> <folders> <folder> <name>DailyComic</name> <description>Daily comic</description> <version>02.00.00</version> <modules> <module> <friendlyname>Daily comic</fri...

Getting a strange error when trying to edit a module. See bottom post. No 'Edit Webfilter Settings' menu option is showing up in the Actions Menu either...
Hey folks: Well, I've been working on a module for my writers' website.  I created a dnn file, went to Module Definitions, browsed and added it, and then went to upload it.  Got this error: StartJob Reading files Info Loading ewriters.WebFilter.dllì< Failure ExceptionICSharpCode.SharpZipLib.ZipException: System.IndexOutOfRangeException: Index was outside the bounds of the array. at ICSharpCode.SharpZipLib.Zip.Compression.DeflaterHuffman.BitReverse(Int32 toReverse) at ICSharpCode.SharpZipLib.Zip.Compression. InflaterHuffmanTree.BuildTree(Byte[] codeLengths) at I...

Todo items won't dismiss and don't show up
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> <html> <head> <style type="text/css"> body { font: Helvetica, Arial, sans-serif; } p { font: Helvetica, Arial, sans-serif; } ..standout { font-family: verdana, arial, sans-serif; font-size: 12px; color: #993333; line-height: 13px; font-weight: bold; margin-bottom: 10px; } ..code { border-top: 1px solid #ddd; border-left: 1px solid #ddd; border-right: 2px solid #000; border-bottom: 2px solid #000; padding: 10px; ma...

Can't see the 'Move Up', 'Move Down', Move to Top' etc. Module Menu items.
Hey all: I've just started finally putting my first website together. But I've noticed something strange. When I'm on the Admin or Host menu, the module menus show the 'move up' move down', move top', etc menu items. However, *none* of my other tabs with multiple modules in a pane show any way of moving the module up or down. It's very disconcerting, because once I place a module, I have no way of moving it up or down, like I normally could. I *can* move it from pane to pane, if the skin for that tab is a multi-pane skin. But I can't move a module up or down. Also, I added an Eve...

Dynamic Menu items don't display when hovering over a static menu item.
Hello,   I created various <div> boxes beneath eachother. One of upper divboxes (one line in height) contains a <menu>  control with horizontal orrientation. When I hover over the static menu items, the dynamic menu items beloning to the static menu item do not display. That is, I see only the upper part of the first dynamic menu item. It seems like the rest is "hidden" under the divbox which is placed right under the divbox containing the menu control.  I played a bit with the CSS arguments for the divboxes and t...

Menu Control don't show the selected Item
Hello, I have inserted a menu control in my masterpage. How can I get the menu control to select the item, with an other color or an arror. Also when the mouse is not over the item. Thanks Andreas This can be fixed by binding the Menu control to a datasource.James Hearst.NET Application Developer Andreas,  The Menu control provides a "StaticSelectedStyle" and a "DynamicSelectedStyle" that modify the styles applied to the selected item.  You can set these properties to modify the look of your selected items.  Please note that selection and navigation or two distin...

Flash don't show up/youtube don't work
Name: Alexandre Torres Product: Minefield Summary: Flash don't show up/youtube don't work Comments: I'm using the windows 64 bits version of firefox 3, and flash plugin don't seem to work...even restarting firefox. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.2 x64; en-US; rv:1.9a1) Gecko/20061007 Minefield/3.0a1 ...

XE6 & 7, Main menu shortcuts don't display when using a Custom Style [Edit]
In XE6 and XE7, main menu shortcuts (accelerator keys) on the drop down menus of a TMainMenu don't display if you use one of Delphi's built-in styles such as Luna or Light. Shortcuts for the main menu items display correctly: File, Edit, Window, etc. Shortcuts in drop down menus always displayed in previous versions. Is this intentional or a bug? Is there some code that can be called to force accelerators to display when using Custom Styles? Edited by: Barry Dirks on Oct 15, 2014 11:28 AM ...

superreview requested: [Bug 291099] context menu menuitems are inconsistently selected using keyboard for menupopup context menu : [Attachment 191845] Don't attach multiple listeners
Aaron Leventhal <aaronleventhal@moonset.net> has asked David Baron <dbaron@mozillafoundation.org> for superreview: Bug 291099: context menu menuitems are inconsistently selected using keyboard for menupopup context menu https://bugzilla.mozilla.org/show_bug.cgi?id=291099 Attachment 191845: Don't attach multiple listeners https://bugzilla.mozilla.org/attachment.cgi?id=191845&action=edit ...

superreview granted: [Bug 291099] context menu menuitems are inconsistently selected using keyboard for menupopup context menu : [Attachment 191845] Don't attach multiple listeners
David Baron <dbaron@mozillafoundation.org> has granted Aaron Leventhal <aaronleventhal@moonset.net>'s request for superreview: Bug 291099: context menu menuitems are inconsistently selected using keyboard for menupopup context menu https://bugzilla.mozilla.org/show_bug.cgi?id=291099 Attachment 191845: Don't attach multiple listeners https://bugzilla.mozilla.org/attachment.cgi?id=191845&action=edit ...

I don't care if 'The document has moved here', and CAPTCHA doesn't show up
Name: Charles Green Email: CharlesWGreenJrataimdotcom Product: Minefield Summary: I don't care if 'The document has moved here', and CAPTCHA doesn't show up Comments: I've suddenly started to get a lot of screens saying 'The document has moved here' and so forth. I do NOT have 'Warn me when web sites try to redirect or reload the page' checked. Also, the CAPTCHA "Humanness Check" is not shown on the Hendrix page, so I had to use Internet Explorer (gak!) to enter this feedback... Mozilla/5.0 (Windows NT 5.1; rv:2.0b4pre) ...

Certain sites don't load; certain menu scripts don't work
Bundling two issues in one post here. WindowsXP machine Netscape 7.0 One of three computers in home network Shared DSL connection 1) Some Web sites inexplicably don't open in Netscape, but do open in IE6 on the same computer, and IE on the home's other computers. I don't remember all sites that never open in Netscape, but three of them are emusic.com, travelocity.com, and expedia.com. I get "Sending request to www.emusic.com..." indefinitely. Closing the program and reopening it doesn't work. 2) Certain menu scripts don't work in Netscape. Two sit...

Top menu listings: shadows don't repaint over once mouse is off menu item
Name: daexus Product: Firefox Release Candidate Summary: Top menu listings: shadows don't repaint over once mouse is off menu item Comments: I was visiting one Google's About page. Pointed and clicked on the Tools menu then released the mouse and navigated left to the Bookmarks & History menu items. As expected, expanded menu items appear (the Tools one, then Bookmarks...) but as the menu item loses mouse focus and the expanded menu correctly disappears, their actual shadows remain and won't disppear, even when switching to another app. Browser Details: Mozil...

cpan>install NET::SSH ----> Can't install NET::SSH don't know what it is?
Good day! This is the first time I'll be using the cpan to install modules. I run: perl -MCPAN -e shell and answer the questions one by one. When its done, I issued install NET::SSH at the cpan> prompt and I got the message: Can't install NET::SSH Don't know what it is. Question: How will I make cpan> know what NET::SSH is? Is there something I have to update first? How can I search for some useful modules using cpan> rather than using cpan search in www.cpan.org? What is auto bundle? And what does 'cpan -a' does? When I ran it, I can some...

Web resources about - Edit item don't show on context menu on my custom module - asp.net.dotnetnuke

Resources last updated: 12/28/2015 12:06:56 AM