ASE 12.0/kernel error on reading table w/ text column

Hi - anyone seen this before?

00:00000:00020:2000/06/15 11:16:27.91 kernel  current process (0x1f001f) infected with 10
00:00000:00020:2000/06/15 11:16:27.91 kernel  Address 0x00204948 (sendtext+0x92c), siginfo (code, address) = (1, 0x6579276e)
00:00000:00020:2000/06/15 11:16:27.91 kernel  ************************************
00:00000:00020:2000/06/15 11:16:27.91 kernel  SQL causing error : select * from devcontent..eC_articleBody where articleId > 3459

00:00000:00020:2000/06/15 11:16:27.91 kernel  ************************************
00:00000:00020:2000/06/15 11:16:27.91 server  SQL Text: select * from devcontent..eC_articleBody where articleId > 3459
00:00000:00020:2000/06/15 11:16:27.91 kernel  curdb = 7 pstat = 0x10000 lasterror = 0 
00:00000:00020:2000/06/15 11:16:27.91 kernel  preverror = 0 transtate = 1
00:00000:00020:2000/06/15 11:16:27.91 kernel  curcmd = 193 program = sqsh                          
00:00000:00020:2000/06/15 11:16:27.91 kernel  pc: 0x00633b84 pcstkwalk+0x24(0xfa999510, 0x00000000, 0x0000270f, 0x00000002, 0xfffffff8)
00:00000:00020:2000/06/15 11:16:27.91 kernel  pc: 0x00633a90 ucstkgentrace+0x194(0x001f001f, 0xfb68a0cc, 0xfb68a0cc, 0xfaf2f058, 0x00000000)
00:00000:00020:2000/06/15 11:16:27.91 kernel  pc: 0x00603748 ucbacktrace+0xa8(0xfaf2f058, 0x00000001, 0x001f001f, 0xfb5de338, 0x00000000)
00:00000:00020:2000/06/15 11:16:27.91 kernel  pc: 0x000f4460 terminate_process+0xcf8(0x00bc2024, 0x000054e8, 0x000054e4, 0xffffffff, 0x00005000)
00:00000:00020:2000/06/15 11:16:27.91 kernel  pc: 0x00617b20 kisignal+0x90(0x0000000a, 0xfa999fc8, 0xfa999d10, 0x0000000a, 0x00000000)
00:00000:00020:2000/06/15 11:16:27.91 kernel  pc: 0xff36b920 _getfp+0x220(0x0000000a, 0xfa999fc8, 0xfa999d10, 0x00617a90, 0x00bc63fc)
00:00000:00020:2000/06/15 11:16:27.91 kernel  pc: 0xff36830c _fork+0x898(0x0000000a, 0xfa999fc8, 0xfa999d10, 0xff37c524, 0x00000028)
00:00000:00020:2000/06/15 11:16:27.91 kernel  pc: 0x00204940 sendtext+0x924(0x65636175, 0x73652074, 0x68657920, 0x68616420, 0x6c657373)
00:00000:00020:2000/06/15 11:16:27.91 kernel  end of stack trace, spid 20, kpid 2031647, suid 5


This is with:

Adaptive Server Enterprise/12.0/P/SWR 8859 ESD 2/Sun_svr4/OS 5.6/1581/32bit/FBO/Wed Jan 26 02:45:02 2000

under solaris 7.

The eC_articleBody table has an articleId numeric(9,0) and body text.

The DBA will probably open a case with tech support, but maybe someone here has
an idea of what may be going on...

Michael
-- 
Michael Peppler         -||-  Data Migrations Inc.
mpeppler@peppler.org    -||-  http://www.mbay.net/~mpeppler
Int. Sybase User Group  -||-  http://www.isug.com
Sybase on Linux mailing list: ase-linux-list@isug.com
0
Michael
6/15/2000 8:29:23 PM
sybase.sqlserver.unix 1493 articles. 0 followers. Follow

5 Replies
555 Views

Similar Articles

[PageSpeed] 57

Michael Peppler wrote:
> 
> Hi - anyone seen this before?

	Nope :-) But I seem to recall a problem with text in ASE 11.9.2
	that wasn't fixed until a later EBF. This could be a carry over
	into ASE 12 of it. I'm not sure now if it had something to do
	with the locking model on the table. A search thru the ASE 11.9.2
	coverletters might reveal something.

-am
0
Anthony
6/17/2000 2:34:17 PM
Anthony Mandic wrote:
> 
> Michael Peppler wrote:
> >
> > Hi - anyone seen this before?
> 
>         Nope :-) But I seem to recall a problem with text in ASE 11.9.2
>         that wasn't fixed until a later EBF. This could be a carry over
>         into ASE 12 of it. I'm not sure now if it had something to do
>         with the locking model on the table. A search thru the ASE 11.9.2
>         coverletters might reveal something.

Turns out it was something completely different (but still highly bizare!)

I get this error if I try to run the query from sqsh (or sybperl) through
a TCP/IP tunnel over a slow (56k) ssh connection. If I run the query localy
it works just fine.

I now have a related problem.

A similar query, with several varchar() columns, returns the first 10 or 20 rows
very quickly, and then starts returning these rows *very* *slowly* (as in 10, 20,
30 seconds for *each* row).

Anyone seen anything like that before???

Michael
-- 
Michael Peppler         -||-  Data Migrations Inc.
mpeppler@peppler.org    -||-  http://www.mbay.net/~mpeppler
Int. Sybase User Group  -||-  http://www.isug.com
Sybase on Linux mailing list: ase-linux-list@isug.com
0
Michael
6/19/2000 2:46:20 PM
Michael Peppler wrote:

> Turns out it was something completely different (but still highly bizare!)

	Is it always the way?

> I get this error if I try to run the query from sqsh (or sybperl) through
> a TCP/IP tunnel over a slow (56k) ssh connection. If I run the query localy
> it works just fine.

	Hmmm ... curious. Does it also happen with isql?

> A similar query, with several varchar() columns, returns the first 10 or 20 rows
> very quickly, and then starts returning these rows *very* *slowly* (as in 10, 20,
> 30 seconds for *each* row).
> 
> Anyone seen anything like that before???

	Nope. Is that thru the tunnel as well?

-am
0
Anthony
6/20/2000 11:27:09 AM
Anthony Mandic wrote:
> 
> Michael Peppler wrote:
> > A similar query, with several varchar() columns, returns the first 10 or 20 rows
> > very quickly, and then starts returning these rows *very* *slowly* (as in 10, 20,
> > 30 seconds for *each* row).
> >
> > Anyone seen anything like that before???
> 
>         Nope. Is that thru the tunnel as well?

No - that's on the local network. Further testing seem to point to a network
problem, though, as running a query returning a lot of narrow rows will start
to slow down aftera relatively large number of rows have been returned. I'm not
sure where to look for this, though...

Michael
-- 
Michael Peppler         -||-  Data Migrations Inc.
mpeppler@peppler.org    -||-  http://www.mbay.net/~mpeppler
Int. Sybase User Group  -||-  http://www.isug.com
Sybase on Linux mailing list: ase-linux-list@isug.com
0
Michael
6/20/2000 2:37:26 PM
Michael Peppler wrote:
> 
> Anthony Mandic wrote:
> >
> > Michael Peppler wrote:
> > > A similar query, with several varchar() columns, returns the first 10 or 20 rows
> > > very quickly, and then starts returning these rows *very* *slowly* (as in 10, 20,
> > > 30 seconds for *each* row).
> > >
> > > Anyone seen anything like that before???
> >
> >         Nope. Is that thru the tunnel as well?
> 
> No - that's on the local network. Further testing seem to point to a network
> problem, though, as running a query returning a lot of narrow rows will start
> to slow down aftera relatively large number of rows have been returned. I'm not
> sure where to look for this, though...

Turns out it was a network card setup on the Solaris box that
hosts the server...

Michael
0
Michael
6/21/2000 4:17:19 PM
Reply:

Similar Artilces:

ASE 12.0 Text columns
Sybase Guru's, I have a need to combine many varchar(255) rows into one singular text column. I am using ASE 12.0 so I cannot take advantage of ASE 12.5's varchar(255+) ability. Is there any way to append to an existing text column???? I have been all over the newsgroups... Surely there must be a way to do this. If I combine multiple local variables it truncates them down to 255 characters! Somebody please help me! :) Shawn Nesser, ENS USCG shawnnesser@yahoo.com Shawn_N. wrote: > > Sybase Guru's, > > I have a need to combine many va...

text columns in ASE 12.0
Are text columns in ASE 12.0 problematic? We are creating a new ASE 12.0 database that will reside on a RS6000 box running AIX 4.3.2. We've avoided using text columns in SqlServer databases because of incidents of database corruption related to: - text data that exceeds 2K page - text data moved to data cache with pools that are larger than 2K Are there any known bugs or issues related to text columns in ASE 12.0 databases? thanks, Mike AFAIK, the difference with 11.9 is that text/image columns are now stored differently so that the contents can be a...

ASE 12.0.0.0 / SWR 8775 UPGRADE TO ASE 12.0.0.6/EBF 10628 PERFORMANCE PROBLEM
Hi All, We recently upgraded ASE 12.0.0.0/SWR 8775 to ASE 12.0.0.6/EBF 10628. Some queries stopped returning resultsets. Recompiled the stored procs which fixed the issue. But the queries are running slower now. The overall performance of the app has become sluggish. The CPU is generally running higher as well! Have also set LD_LIBRARY_PATH_64 to include the new Solaris 8 threads library. Anybody any insights into this? How can we get back to the pre-upgrade performance levels short of rolling back the EBF. Regards Perry Perry, I guess 12.0.0.6 requires some Solaris ...

ASE 12.0.0.4 Error 216 followed by Error 1204
I am running on ASE 12.0.0.4 EBF 10048, on AIX 4.3.3. Last week I received a Error 216 (temp table failed to clean up) and from that point on occassional out of lock messages (error 1204), even though I have 90K locks configured. The number of locks had been increase from 40K to 90K quite awhile ago for a previous out of lock support case. (It wasn't the problem, but I couldn't get tech support to look any further into my issue without increasing the number of locks. The actual error was caused by the LPM manager, but as the memory used by the extra locks is small, I went a...

ASE 12.0.0.6 to ASE 12.5 and Rep Server 12.1
We are planning the upgrade of our ASE 12.0.0.6 64bit on AIX 4.3.3 to ASE 12.5 64bit on AIX 4.3.3. We are also using Rep Server 12.1 with these two servers. My question is do I need to upgrade Rep Server as well, or will 12.1 Rep Server Work with ASE 12.5. Also, we will be upgrading AIX to 5.1 as well. Any advice is appreciated. Thanks, Troy It will work, however you wont be able to use any of the 12.5 new datatypes, and the rep_agents will spit out annoying error/warning messages everytime they are restarted. Our production system has been running that way for about ye...

Upgrade ASE 12.0.0.4 to 12.0.0.8
I upgraded my ASE to version 12.0.0.8. Now one of the application get a permanent error: "Not enough procedure cache". I increased the proc cache to 40% (total memory: 1 GB) - no success. When I rolled back to 12.0.0.4 everything works fine (with less procedure cache). The ASE is running on Solaris 7. The application connects thru the Merant ODBC driver. I gave the application already back to development to check. Any help how this can be avoided by a change on the host/server is appreciated. Bernd I always recommend dropping/recreating all of the stored...

Can't construct query plan in ASE 12.0
Error 325 is being returned when trying to execute a stored procedure on version : Adaptive Server Enterprise/12.0/P/SWR 8773 ESD 1/RS6000/AIX 4.3.2/1580/64bit/FBO/Tue Dec 7 03:29:32 1999 ... this is the code causing the error when running on version listed above... it's a sub-query within a stored proc AND SBSB.HIST_ROW_ID = (select MAX(SBSB2.HIST_ROW_ID) FROM Massive_db.audit.CMC_SBSB_SUBSC SBSB2 WHERE SBSB2.SBSB_CK = SBSB.SBSB_CK AND CONVERT(CHAR(10),SBEL.SBEL_INSQ_DT,101) = CONVERT(CHAR 10),SBSB2.HIST_CREATE_DTM,101)) When executing same stored procedure on AS...

Migrating from ASE 12.0 32-bit to ASE 12.0 64-bit
Has anyone run into any problems migrating from 32-bit to 64-bit? ...

Migrating from ASE 12.0 32-bit to ASE 12.0 64-bit
Has anyone run into any problems migrating from 32-bit to 64-bit? ...

ASE patch 12.5.0.3 ebf10980 but still meet "kernel timeslice -501, current process infected" error!
Hi all, kernel: 2.4.9-e.9,glibc:2.2.4-29.1,ASE 12.5.0.3 EBF10980. When ct try to create a talbe, dataserver meet "kernel timeslice -501, current process infected", and all the client cannot connect to server . I had ask ct to add -T1639 traceflag and increase 'cpu grace time' parameter. But the problem cannot be resolved. Any help will be appreciated 00:00000:00012:2003/06/25 10:30:42.40 kernel ************************************ 00:00000:00012:2003/06/25 10:30:42.40 kernel SQL causing error : create TABLE wzg_temp_tab ( D_JiZhang_Date datetime, ...

Error 11051 on ASE 12.0.0.3 NT
When I try to execute this command: alter table tablename modify birthday null I get this error: Server Message: Number 11051, Severity 16 ALTER TABLE 'documentos_extraviados' failed. Table is currently being used by one or more other tasks. I'm find in manuals, web, forums and I'm can get information. Whats happends? Is this on a system that is currently being used? Shawn Torkelson EGR wrote: > When I try to execute this command: > > alter table tablename modify birthday null > > I get this error: > > Server Message: ...

any issues to restore dump file of ASE 12.0 (32bit) to a ASE 12.0 (64bit) system ?
Hi, Does anyone know whether there is an issue that we restore the dump file (not master and system db) of ASE 12.0 (32bit) to a ASE 12.0 (64bit) system ? Assume that both system DBs are the same. Cheers paul > Hi, > > Does anyone know whether there is an issue that we restore > the dump file (not master and system db) of ASE 12.0 > (32bit) to a ASE 12.0 (64bit) system ? Assume that both > system DBs are the same. > > Cheers > paul If you have a recent ebf of ASE 12.0 (say 12.0.0.4 or later) than no problem. Earlier ebfs had a few problems....

Concatenating values in a column: ASE 12.0 vs 12.5
Has anyone else encountered a change in behaviour of the following code to concatenate all the values from a column and return a single row, when going from ASE 12.0 to 12.5? declare @temp varchar(255) select @temp = "" set rowcount 22 select @temp = @temp + station_number from location_tbl /* select @temp = @temp + (case 1 when 1 then station_number end) from location_tbl */ set rowcount 0 select @temp Both selects do what we need under 12.0, but only return the last station number under 12.5. Is this a configuration problem? Is there a workaround not involvin...

PB 8 and ASE 12.0.0.3. return error
We currently are using powerscript to execute a stored proc in sybase and don't appear to be getting any results back from the database. If we run the stored proc through another tool, we get the results expected. Through powerbuilder we are getting a return value of 0 for anything we check coming back from the stored proc. sqlca.sqlcode sqlca.sqldbcode Also here is our declaration, are we doing something wrong? ----------------------------------------------------------------- DECLARE DeleteCartonHdr PROCEDURE FOR @return_value = pldDeleteCartonHdr @carton_id ...

Web resources about - ASE 12.0/kernel error on reading table w/ text column - sybase.sqlserver.unix

Resources last updated: 11/30/2015 8:10:45 AM