SET OPTION PUBLIC.DATABASE_AUTHENTICATION problem

When I execute the following statement (all on one line)
against a version 12 database in Sybase Central it seems to
execute with no errors.

SET OPTION PUBLIC.DATABASE_AUTHENTICATION='Company=Carillon
Financials Corporation;Application=Carillon
ERP;Signature=Not included in this post';

We then stop and restart the database and execute the
following statement which returns 'no'.

select DB_PROPERTY('Authenticated')

Am I missing something?  I expected it to return 'yes'.
0
Larry
1/10/2011 4:41:13 PM
sybase.sqlanywhere.general 32637 articles. 4 followers. Follow

3 Replies
967 Views

Similar Articles

[PageSpeed] 48

Can you verify that the database engine is in fact an OEM edition - the 
edition is displayed on the engine console window. If the database 
engine is not an OEM, this property would not get set.

-chris


On 1/10/2011 11:41 AM, Larry R. Pettit wrote:
> When I execute the following statement (all on one line)
> against a version 12 database in Sybase Central it seems to
> execute with no errors.
>
> SET OPTION PUBLIC.DATABASE_AUTHENTICATION='Company=Carillon
> Financials Corporation;Application=Carillon
> ERP;Signature=Not included in this post';
>
> We then stop and restart the database and execute the
> following statement which returns 'no'.
>
> select DB_PROPERTY('Authenticated')
>
> Am I missing something?  I expected it to return 'yes'.

0
Chris
1/10/2011 7:13:54 PM
This was being attempted on a machine installed with the
commercial version key so I guess that's why it wasn't
working.  We do have a machine installed using the OEM key
but it is getting an Authentication Failed error when trying
to connect to the database.
[Sybase][ODBC Driver][SQL Anywhere]Authentication failed
                SQLCODE=-218
                SQLSTATE=08001

Connection parameters:
                User=dba
                Password=***
                DBF=C:\Runsheet_laptop\tracteval10.db
                LINKS=ShMem
                ENC=NONE

I uninstalled SQL Anywhere 12, then re-installed SQL
Anywhere 12, 32 bit only and still get this error.


> Can you verify that the database engine is in fact an OEM
> edition - the  edition is displayed on the engine console
> window. If the database  engine is not an OEM, this
> property would not get set.
>
> -chris
>
>
> On 1/10/2011 11:41 AM, Larry R. Pettit wrote:
> > When I execute the following statement (all on one line)
> > against a version 12 database in Sybase Central it seems
> > to execute with no errors.
> >
> > SET OPTION
> > PUBLIC.DATABASE_AUTHENTICATION='Company=Carillon
> > Financials Corporation;Application=Carillon ERP
> ;Signature=Not included in this post'; >
> > We then stop and restart the database and execute the
> > following statement which returns 'no'.
> >
> > select DB_PROPERTY('Authenticated')
> >
> > Am I missing something?  I expected it to return 'yes'.
>
0
Larry
1/10/2011 8:06:45 PM
The engine console on both machines (referenced below) says
OEM Edition.

> This was being attempted on a machine installed with the
> commercial version key so I guess that's why it wasn't
> working.  We do have a machine installed using the OEM key
> but it is getting an Authentication Failed error when
> trying to connect to the database.
> [Sybase][ODBC Driver][SQL Anywhere]Authentication failed
>                 SQLCODE=-218
>                 SQLSTATE=08001
>
> Connection parameters:
>                 User=dba
>                 Password=***
>                 DBF=C:\Runsheet_laptop\tracteval10.db
>                 LINKS=ShMem
>                 ENC=NONE
>
> I uninstalled SQL Anywhere 12, then re-installed SQL
> Anywhere 12, 32 bit only and still get this error.
>
>
> > Can you verify that the database engine is in fact an
> > OEM edition - the  edition is displayed on the engine
> > console window. If the database  engine is not an OEM,
> > this property would not get set.
> >
> > -chris
> >
> >
> > On 1/10/2011 11:41 AM, Larry R. Pettit wrote:
> > > When I execute the following statement (all on one
> > > line) against a version 12 database in Sybase Central
> > > it seems to execute with no errors.
> > >
> > > SET OPTION
> > > PUBLIC.DATABASE_AUTHENTICATION='Company=Carillon
> > > Financials Corporation;Application=Carillon ERP
> > ;Signature=Not included in this post'; >
> > > We then stop and restart the database and execute the
> > > following statement which returns 'no'.
> > >
> > > select DB_PROPERTY('Authenticated')
> > >
> > > Am I missing something?  I expected it to return
> 'yes'. >
0
Larry
1/10/2011 8:14:44 PM
Reply:

Similar Artilces:

Problems with the option 78 set through global settings
I have the problem with the option 78 being set through the global setting when it doesn't work even though options 5,6,44 and 46 are being distributed through the global settings for a long time. On the other hand, when I set it through the subnet, it works! So, why it is not working when the option 78 is set through the global setting? Sinisa Sinisa, setting option 78 at the global option list is working fine here. What dhcpsrvr.nlm and dns/dhcp management console are you running? Did you unload and reload the dhcpsrvr.nlm after setting the option? Joerg > Wha...

[PATCH] GNU Public General Public General GNU Public License License
--- pod/perlgpl.pod 2003/08/13 18:07:09 1.1 +++ pod/perlgpl.pod 2003/08/13 18:07:14 @@ -1,7 +1,7 @@ =head1 NAME -perlgpl -- the GNU Public General Public License, version 2 +perlgpl - the GNU General Public License, version 2 =head1 SYNOPSIS --- pod/perlartistic.pod 2003/08/13 18:07:30 1.1 +++ pod/perlartistic.pod 2003/08/13 18:07:31 @@ -1,7 +1,7 @@ =head1 NAME -perlartistic -- the Perl Artistic License +perlartistic - the Perl Artistic License =head1 SYNOPSIS -- Michael G Schwern schwern@pobox.com http://www.pobox.com/~schwern/ It'...

option set problem
I've got a project that I need to compile with different #defines defined, in order to produce different but similar programs. I thought that the way to do this was having different build configurations. What I did was to save my normal debug and release option sets, create new build configurations (DebugQQ and ReleaseQQ) and apply the appriate option sets, and then add the defines as needed. I also had to set new output directories (but was unable to change the application name, so I guess I'll have to do that by hand). My problem is, when I was compiling these new bu...

Firefox problems setting Options
Hi all: I just grabbed FireFox and am having some problems setting up anything under the Tools > Options menu. It seems like the OK button is flaky: 9 times out of 10 I press it and it does nothing, the window just stays open. I can Cancel, but of course my changes aren't saved. If the OK button doesn't work, I have to Cancel out, go back to Tools > Options, make my changes again, and hit OK again, hoping it works this time. Anyone else experiencing this? Other than that, it's very nice. The new icon looks like a fetus on the taskbar, and my favorite theme (Cryst...

SELECT failed because the following SET options have incorrect settings: 'ANSI_NULLS, QUOTED_IDENTIFIER'. Verify that SET options are correct for use with indexed views and/or indexes on computed colu
Hi, I am using Sql server 2005 as database server. I got this error. "SELECT failed because the following SET options have incorrect settings: 'ANSI_NULLS, QUOTED_IDENTIFIER'. Verify that SET options are correct for use with indexed views and/or indexes on computed columns." so can you help me. Thanks in advance Nirav Nayak...

set remote ftp option problem
hi this statement doesn't work: SET REMOTE ftp OPTION web.user= 'web'; "syntax error near "user" " but this works: SET REMOTE ftp OPTION web.password='web'; Why ? User is a keyword in the database, so you need to enclose it in double quotes. SET REMOTE ftp OPTION web."user"= 'web'; -- Reg Domaratzki, Sybase iAnywhere Solutions Certified SQL Anywhere Associate Please reply only to the newsgroup ASA Patches and EBFs : http://downloads.sybase.com/swx/sdmain.stm -> Choose SQL Anywhere Studio ->...

Possible problems setting client options
--____HAKATGBAHCPLZUIFBDPZ____ Content-Type: text/plain; charset=iso-8859-15 Content-Transfer-Encoding: quoted-printable Greetings, We are on GroupWise 6.5.7. I want to restrict the size of an e-mail = within a POA and am concerned about using the client options in C1. I = have made changes in client options in the past, testing on my own = account, and I ended up having to reset my GroupWise password. The = problem may have been complicated by my using caching, because that is = where I seemed to run into the password problem. My cached mailbox would = not update. Any t...

PROBLEMS, PROBLEMS, PROBLEMS.
Name: Product: Firefox Summary: PROBLEMS, PROBLEMS, PROBLEMS. Comments: Does Google's Chrome browser block out Firefox? Am having a lot of trouble getting Firefox to run after I run Chrome. No trouble what-so- ever before running Chrome. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1064 Safari/532.5 From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback but if you wish to provide one you must BCC (not CC) the sender for them to see ...

Options, options, options...
hello all, two questions: First: I was wondering if a component exists to handle options exactly like the grid component you see when you open "Projects | Options" in Delphi 2010. The component should be the same, i.e. with the same aspect and behaviour, so with a column for the option name on the left and the other column where you type the value or edit it with an embedded component on the right. Option groups should be collapsible/expandable and their name's row must have a different colour than the other columns. Ok, the same as the Delphi dialog. It would be...

Problems, problems, problems
Name: Product: Firefox Summary: Problems, problems, problems Comments: I use FF all the time for work - I'm a software tester - the add-ons are invaluable. But v3.5 really has been a disappointment. It just keeps hanging all the time. And when Internet Explorer windows pop up, FF often just dies. It can't even restart itself - I have to manually kill the process every time; every update, every add-on that updates, "restart" fails - it's so frustrating. I hope v3.6 will be addressing this - PLEASE! Browser Details: Mozilla/4.0 (compatible; MSIE 7....

Problems problems and problems.
Name: A.A. Product: Firefox Summary: Problems problems and problems. Comments: I am not specific, but in short I can not use This site to listen music anymore, while I can in IE explorer. Just to let you guys know, new version messed something up. http://hypem.com/ Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback but if you wish to provide one you must BCC (not CC) the sender for them to see it. ...

Problems Problems Problems
So, I have OpenSUSE installed on my laptop and everything is working well, except the wireless. It almost seems that every time I run a KDE distro I can not get the internet to work. I've run YaST and used iwconfig. nothing is working for me. Please help -ZAD -- zadnik18 ------------------------------------------------------------------------ someone is going to tell you to supply some more information 'My wireless doesn't work - a primer on what I should do next - openSUSE Forums' (http://tinyurl.com/6peanc) this is one of the stick...

Problems, problems, problems
Name: Hans Halvorsen Email: capricorn_at_online.no Product: Thunderbird Summary: Problems, problems, problems Comments: Hi, I downloaded Thunderbird some time ago, and I was over-satisfied whit it and how well it worked. In fact it worked 100% PERFECTLY UNTIL I got an newer update version of it. Since then I' ve had nothing BUT trouble! I've checked adresses, notes, password, deleted accounts and made new one's, checked sign-ins and sign-outs, passwords inside and out, upside and down, so many times that my frustration now is about to turn into pure and major ...

DotNetNuke 3.0
It was running in localhost. Once it is assigned to a public IP, all the links doesn't work. I have try changing the HostURL in HostSettings, adding the ip/dotnetnuke in PortalAlias. But no avail. Clicking on Logoff also will cause an error. Please help.. Thanks. Just embedded links or all the links including tabs?Chris Paterra All the links including tabs. When I click on the Admin -> Pages, it will not go anywhere, showing the main default.aspx. That error means the portal alias is not set to the one you are trying to access. Chris Paterra view post 837266Scott WillhiteIt is ...

Web resources about - SET OPTION PUBLIC.DATABASE_AUTHENTICATION problem - sybase.sqlanywhere.general

Resources last updated: 11/26/2015 6:30:54 AM