How do I determine database version?

When upgrading a product installation, I need to call "ALTER
DATABASE UPGRADE" on 10.0.x databases. What is the best way
to figure out the Sybase version of a database (which
version of Sybase created the database)?
0
Dave
1/14/2011 12:34:48 AM
sybase.sqlanywhere.general 32637 articles. 4 followers. Follow

3 Replies
2494 Views

Similar Articles

[PageSpeed] 39

Dave,

I think this could do:
SELECT version FROM SYSHISTORY WHERE operation = 'INIT'

HTH
Reimer


Dave wrote:
> When upgrading a product installation, I need to call "ALTER
> DATABASE UPGRADE" on 10.0.x databases. What is the best way
> to figure out the Sybase version of a database (which
> version of Sybase created the database)?

0
R
1/14/2011 1:21:33 PM
This is true for 9.0.1 or later database files.  Prior to that, there is 
no documented mechanism to determine the file version.

-chris


On 1/14/2011 8:21 AM, R. Pods wrote:
> Dave,
>
> I think this could do:
> SELECT version FROM SYSHISTORY WHERE operation = 'INIT'
>
> HTH
> Reimer
>
>
> Dave wrote:
>> When upgrading a product installation, I need to call "ALTER
>> DATABASE UPGRADE" on 10.0.x databases. What is the best way
>> to figure out the Sybase version of a database (which
>> version of Sybase created the database)?
>

0
Chris
1/14/2011 1:48:25 PM
Reimer,
Thank you. that worked well combined with operations INIT
and UPGRADE accordingly.

> Dave,
>
> I think this could do:
> SELECT version FROM SYSHISTORY WHERE operation = 'INIT'
>
> HTH
> Reimer
>
>
> Dave wrote:
> > When upgrading a product installation, I need to call
> > "ALTER DATABASE UPGRADE" on 10.0.x databases. What is
> > the best way to figure out the Sybase version of a
> > database (which version of Sybase created the database)?
>
0
Dave
1/14/2011 7:17:48 PM
Reply:

Similar Artilces:

Determining database version
Does anyone know what the mapping between the value contained in the database_version field of sys.sysinfo is to the release versions of SQLAnywhere (e.g. 5.5.04, ASA 6.02, etc.) ? Is there a tech doc or any source that lists this information? I'd like to be able to tell what version a database is before running the dbupgrad utility. I have used isql to look at the contents of sys.sysinfo for a couple of the sample dbs, but I'm hoping there's a better source somewhere. Thanks in advance. The database version will never be higher than the engine version. (No wise cra...

Database File Version vs Database Engine Version
Hi. I was recently visiting a customer site and noticed, from Sybase Central, that the customer's database file displayed a 5.x version number, even though the ASA engine was version 7.0.2. This customer is running our pb6.5 / ASA 7 application under Citrix and is having problems which are not appearing at other customer sites. I would like to rule-out any possibility of these problems being generated by our application. Has anyone eliminated problems by upgrading the database file to the same version as the database engine? Does Sybase recommend that the file be kept &quo...

How to upgrade/convert version 8.1 database to version 10 database
Hi, I would like to upgrade a 8.1 version into version 10 database. Could you please tell me, how to go about it ? regards Venu "venu" <venuc@hotmail.com> wrote: > I would like to upgrade a 8.1 version into version 10 database. > > Could you please tell me, how to go about it ? Have you heard about the SA manual ;)? Start from the following: -------------------------------------------------- SQL AnywhereR 10 - Changes and Upgrading Upgrading to SQL Anywhere 10 Upgrading SQL Anywhere .... --------------------------------------...

Checking a .db file to determine database version
I am upgrading our app from using Watcom4 databases to Adaptive Server Anywhere. There are quite a few problems in using the Watcom .db files with the ASA engine. I need to do a 'rebuild' on all the .dbs I encounter that are of the Watcom version before connecting with ASA (otherwise the server hangs). My question is does anyone know how to determine the version of the ..db file. (for example any binary header information I can look at) I've had a look but it doesn't seem to be that obvious! TIA, Monica PS. Any alternative workarounds greatly apreciated.. ...

The assembly version does not match the database version
Hi, everybody, My name's thuantam and I'm very interested in using DNN to study with my PC. I want to install the DNN 2.0 Beta with the OS: Windows 2003 Server, SQL server 2000 and IIS 6.0 on my PC. but IE noted me with the page "The assembly version [ASSEMBLYVERSION] does not match the database version [DATABASEVERSION]", I think the error caused by my SQL Server. What can I do to fix this error. Thanks, thuantam In there are two places in your web.config that you need to set your own<appSettings><add key="connectionString"....... ensure both plac...

Assembly version does not match Database version
I'm trying for the first time to open DotNetNuke in my browser and get the following error:   DotNetNuke Upgrade Error The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] ) ERROR: Could not connect to database.Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection. Any suggestions? Thanks in advance   it looks like theres a problem with your connection string...Wessam Zeidan Is that the first time you try to install dotnetnuke ? Is it a local installation. What Version of DNN What o...

Database version vs. Server version
I am running the SQL Anywhere 5.5.02 server/engine and when I inspect the properties for my database object within SQL central it says that my database version is 5.0.03. Does anyone know what exactly the database version means? Do I need to update my database? If so, How? -Scott scharris@worldnet.att.net >I am running the SQL Anywhere 5.5.02 server/engine and when I inspect the >properties for my database object within SQL central it says that my >database version is 5.0.03. Does anyone know what exactly the database >version means? Do I need to update my ...

Converting a database from version 6 to version 7
I am working with a site that has ASA 7 installed but the database version is still 6. Will a backup and restore upgrade the database from 6 to 7? If not, what do I need to do to perform the upgrade? Thanks. -- ..Bill. You can simply run the database on an ASA7 server. If you want to move to an ASA7 format database file, use dbunload to rebuild the database. -- Chris Keating Sybase Adaptive Server Anywhere Professional Version 8 ***************************************************************************** Register now for TechWave 2006 August 6-10 in Las Vegas. New! 2...

The Assembly Version does not match the Database Version #2
When navigating to the DotNetNuke site, I get this error: DotNetNuke Upgrade Error The Assembly Version ( [ASSEMBLY VERSION] ) does not match the Database Version ( [DATABASE VERSION] ) ERROR: Could not connect to database specified in connectionString for SqlDataProvider It worked when using the default MsAccess database. Then I tried to switch to use MSDE. By for example using ODBC, I can connect to the Database with the user and password provided in the connectionString in Web.Config. This is the only change done: applying sa as uid and a password as pwd in the connecti...

Version 8 database with version 7 engine
Can I create a database file with version 8 client and run the database using a version 7 engine on a Novell server? I don't need any of the fancy new features added to version 8, we are okay with version 7 features. Thanks. I found the answer. Thanks anyway. The answer: Adaptive Server Anywhere servers can manage databases created with earlier versions of the software, but old servers cannot manage newer databases. > Can I create a database file with version 8 client and run > the database using a version 7 engine on a Novell server? > > I don't need a...

how can I determine the GroupWise version from the NLM version?
I am new in this environment (large 2700+ users, 50+ POS, etc), the GroupWise version is supposed to be GW 5.5 EP SP 4. However the NLMs vary, some are 5.56e and some are 5.56.05 Also, we are seeing a problem with poa logs that is supposed to be fixed by have the up-to-date version of the language files: gwpoa1us.fil and gwpoa1us.hlp. (see TID 10058227) The dates on these files are: gwpoa1us.fil 12/18/2001 gwpoa1us.hlp 7/27/1999 The software distribution directories are now consistent, so I can not trust them to have everything up to date. I appreciate your time ...

Database Painter Does not let me create SqlAnywhere Database
My PC was upgraded to Win NT 4.0 I am using PowerBuilder 6.5 When I open the database Painter I no longer have the option to create a SqlAnywhere database. The ODBC drivers are there and I can connect to existing SqlAnywhere databases. I did notice that I am not able to drop any tables from these dbs in the database painter. Any Info Appreciated. Bob Make sure that the file dbtl50t.dll exists in the sqlanywhere\win32 directory. -- Terry Dykstra (TeamSybase) Please state PB / OS / DB versions in your post. Techwave 20002 www.sybase.com/techwave2002 Session E179 - Advanc...

The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] )
Yesterday I download DNN v2 and followed the setup instructions. - unzip package into C:\DotNetNuke - create Virtual Directory in IIS called DotNetNuke which points to the directory where the DotNetNuke.sln file exists - manually create SQL Server database named DotNetNuke ( using Enterprise Manager or ... ) - change connectionstring settings in web.config to match your system (This is the option that I have choosen). - browse to localhost/DotNetNuke - the application will automatically execute the necessary database scripts The following error appear: ERROR: Could no...

The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] )
Hello, I wanted to upgrade my DNN 1.0.... version to DNN version 2. Therefore I renamed the Version 1 DNN to an "OLD" directory, and I created a new directory with the name of the old one. In this way I had not to change the links in my other webpages. Futhermore, I deleted the Verion 1 database (MSDE 2000). I downloaded the version 2 DNN and unzipped it to the destined directory. When I started up for the first time in order to let the database be generated I got the following errormessage: The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Ve...

Web resources about - How do I determine database version? - sybase.sqlanywhere.general

Five points determine a conic - Wikipedia, the free encyclopedia
In Euclidean, non-projective geometry , just as two (distinct) points determine a line (a degree-1 plane curve), five points determine a conic ...

How To Determine Whether Your Facebook Customer-Service Efforts Are Effective
Social media analytics provider Crowdbabble added customer support to its mix, launching a new set of social customer service reports that allow ...

How does Facebook determine whether posts from pages are high-quality?
... for Business page on all things News Feed. The newest installment , posted Friday, aims to clarify for page administrators how it determines ...

Twitter Blog: Let your Tweets determine the 2012 Sprite Slam Dunk champi
Twitter Blog Let your Tweets determine the 2012 Sprite Slam Dunk champion 3366100333679041124 Thursday, February 23, 2012 This Saturday, four ...

How does the NYT determine which articles have comments? - Quora
On the The New York Times website, some articles have comment sections, and others don't. It seems like in general higher profile articles have ...

How to determine what Herbs and Spices go best with what dishes - YouTube
Grandma Storn's Herb Wheel is the essential tool for cooking delicious, healthy meals using Herbs and Spices!

Why rising demand will determine the oil price
The lessons of 1986 tell us that the demand surge to be expected – and it is already visible – will be too much for Saudis to handle, writes ...

Pussy Riot punks may determine Russia's future
Pussy Riot punks may determine Russia's future

App to use 'facial age' to determine health
A new app will use &quot;facial age&quot; images to help doctors identify ageing behaviours in patients.

NFL, San Francisco 49ers, Houston Texans: Jarryd Hayne’s key dates to determine NFL future, starting ...
JARRYD Hayne will take his first competitive snap against NFL opposition this Sunday at 10am (AEST) when the San Francisco 49ers take on the ...

Resources last updated: 1/21/2016 10:28:41 AM