Help TeamSybase: Cannot use ASA with Delphi via ADO #2

Hello,

I just installed ASA 60 days trial and I am testing with Delphi 6 and ADO,
using TADODataset components. I am getting the following problems: when I
post any record, trailing blanks are inserted in every TStringField (VARCHAR
in ASA). When I post records with TMemoField or TBlobField (LONG VARCHAR),
it raises a "Count field incorrect".

I did't see this behaviour in other servers.

Regards,

Frank




0
Frank
6/26/2003 8:14:29 PM
sybase.sqlanywhere.general 32637 articles. 4 followers. Follow

0 Replies
459 Views

Similar Articles

[PageSpeed] 49

Reply:

Similar Artilces:

Help TeamSybase: Cannot use ASA with Delphi via ADO
Hello, I just installed ASA 60 days trial and I am testing with Delphi 6 and ADO, using TADODataset components. I am getting the following problems: when I post any record, trailing blanks are inserted in every TStringField (VARCHAR in ASA). When I post records with TMemoField or TBlobField (LONG VARCHAR), it raises a "Count field incorrect". I did't see this behaviour in other servers. Regards, Frank What are the version and build number of your server? Are you using the sample database or a database you created? If you created it, did you use the BLANK...

Problem using ASA 7.0 to connect to ASE 11.9.2 via ASA ODBC DSN
Hi: I downloaded ASA 7.0.2 to evaluate it as a Client to connect to a databse which is installed on an ASE 11.9.2. system (first of all, can this be done?). I am running Win 2K Professional. I have already set up an ODBC DSN which I have used successfully for creating a linked server to the ASE database in MS SQL Server 2000. I also have used this DSN to create a successful ODBC link to MS Access 2000 In this case I created an ASA 7.0 DSN using the same configuration parameters that I used for the the above DSN, but when I test the connection in Sybase Central 4.0 (or in the ODBC ...

Problem using ASA 7.0 to connect to ASE 11.9.2 via ASA ODBC DSN
Hi: I downloaded ASA 7.0.2 to evaluate it as a Client to connect to a databse which is installed on an ASE 11.9.2. system (first of all, can this be done?). I am running Win 2K Professional. I have already set up an ODBC DSN which I have used successfully for creating a linked server to the ASE database in MS SQL Server 2000. I also have used this DSN to create a successful ODBC link to MS Access 2000 In this case I created an ASA 7.0 DSN using the same configuration parameters that I used for the the above DSN, but when I test the connection in Sybase Central 4.0 (or in the ODBC ...

Problem on ASA with Delphi via ADO
Hello, I just installed ASA 60 days trial and I am testing with Delphi 6 and ADO, using TADODataset components. I am getting the following problems: when I post any record, trailing blanks are inserted in every TStringField (VARCHAR in ASA). When I post records with TMemoField or TBlobField (LONG VARCHAR), it raises an "Count field incorrect". I did't see this behaviour in other servers. Regards, Frank Hi, mybe it's help: //Procedure tForm1.SaveBtnClick(Sender:TObject); // //var // fs : TFileStream; // bs : TBlobStream; // //Begin //with Table1...

Want Delphi Prism in MonoDevelop? We could use your help! #2
Hi. As some of you might know from past messages and teasers, we've always been interested in getting Delphi Prism integrated into MonoDevelop, the open source .NET IDE from the Mono team. As a matter of fact, we've had a pretty functional base integration for Mono Develop working and usable for a while now, but we have been unable to ship it (and in fact still are unable to ship it, as of right now), because currently MonoDevelop is licensed under the GPL (which would mean, if we build and deploy our IDE integration against it, which in turn is linked against out compile...

Help Help Help Sending mail from pb10.2 using SMTP
Hi all I am really having difficulty sending email from my pb application the code below sends email when executed from my computer but not on other computers ( i get a message "error accesing external object property fields") I would realy like to use SMTP but do not know the class name Also this code will send email to an internal address from may machine only. Please help integer li_ret OLEObject objEmail objEmail = create OLEObject li_ret = objEmail.ConnectToNewObject("CDO.Message") if li_ret < 0 then destroy objEmail return end if objEma...

ASA 7.0.2/ 1462 replicating vias RS 12.5 to ASA 7.0.2 / 1462
Greetings group, I need your help. Working on setting up Subscription based replication in the following manner: ASA 7.0.2 / 1462 (aka PDB) | | Repserver 12.5 ...

Help with retrieving ASA 6.0 user privileges using VB6 and ADO
We are developing a front end using VB6 and ADO which feeds into ASA6.0. Can anyone tell us how we can retrieve the user privileges (select, update, insert etc) on the tables and columns. Thanks John Aney >We are developing a front end using VB6 and ADO which feeds into ASA6.0. >Can anyone tell us how we can retrieve the user privileges (select, update, >insert etc) on the tables and columns. THis is available in the system tables, described in chapter 15 of the online reference manual. The table "systableperm" is a good place to start. Leo Tohil...

Updating fields with NULL values using ADO 2.5 and ASA 6.03
Hi I've seen numerous references in this newsgroup about the following problem but no solutions. Surely someone is sitting on a solution out there that they'd like to share with the rest of us - particularly me! If the following ADO syntax is used from within Visual Basic to update an Adaptive Server Anywhere varchar field a '' (zero-length) string results: MyRecordset.Fields("MyVarchar") = NULL This syntax works OK in Microsoft SQL Server but that's using a native OLEDB provider. I suspect it would also work with ASA 7 as it also have a nati...

Help Help Help #2
I have created two transaction objects, one source and one destination, I have also created a pipeline object between the source and destination databases. Some of the fields in the source database contain blank spaces for values; after a successful pipeline the destination database fields that should contain spaces are now NULL. My PowerBuilder version is 7.0.3, my Sybase version is 6.0.4. Is this a simple setting change? Thank you in advance... I'm not sure if this is related or not, but, I've discovered what I think is a major bug in PB in that when a dw retrieves ...

Problem using ASA 7.0 connecting to ASE 11.9.2 via ODBC DSN
Hi: I downloaded ASA 7.0.2 to evaluate it as a Client to connect to a databse which is installed on an ASE 11.9.2. system (first of all, can this be done?). I am running Win 2K Professional. I have already set up an ODBC DSN which I have used successfully for creating a linked server to the ASE database in MS SQL Server 2000. I also have used this DSN to create a successful ODBC link to MS Access 2000 In this case I created an ASA 7.0 DSN using the same configuration parameters that I used for the the above DSN, but when I test the connection in Sybase Central 4.0 (or in the ODBC ...

Unable To Connect To ASA database via MS Embedded Tools for VB using sysbase OLEDB (ASAProv) #2
We haven't been able to connect to ASA database via MicroSoft Embedded Tools for VB. The message I get back is that "ADOCE unable to find the provider". I have ensured that provider is registered and installed. One interesting thing is when I run the same code from Visual Studio using VB (with one change that I'm using ADO instead of ADOCE 3.1) I'm able to connect. I did find references to the same problem, and its resolution on the Newsgroup. But in my case all the suggested resolutions did not work. Any help will be greatly appreciated. Thanks. ...

HELP CONFIGURATION ASA 10.0.1 with PHP 5.2.0 and APACHE 2.2.3 on DEBIAN
hello, I need help with ASA 10.0.1 with PHP5.2.0 common in Apache 2.2.3 environment Debi 4.03 I can not connect to travez of odbc, I followed the steps outlined in the installation manuals and fails to connect tells me the following error : Fatal error: Call to undefined function sqlanywhere_connect () in / var/www/apache2-default/connect.php on line 2 I need to indicate to me step by step more detailed installation and configuration with sqlanywhere10.0.1 odbc, php5.2.0, apache2.2.6 environment in debian Thank you The steps in the manual provide all of the information you sho...

ASA7 ADO & Delphi ADO ?? Anyone is using it?
Any comments? Is it working? Any Problems? Thanks Hi, PR <noemail@no.com> schrieb in im Newsbeitrag: BoTThJaq$GA.89@forums.sybase.com... > Any comments? Is it working? Any Problems? I tried to connect to ASA7 via the new OLE DB - Provider and ADOExpress from Delphi 5.01. No chance. Only the error message 'Invalid Enum Value'. About the new provider I haven't heard anything good until now... Regards Frank Frank, I've experienced the same problem with the ASA 7 OLEDB Provider. I'm not sure if this is a bug in the AsaProvider or Delp...

Web resources about - Help TeamSybase: Cannot use ASA with Delphi via ADO #2 - sybase.sqlanywhere.general

resources last updated: 11/20/2015 5:18:12 PM