Delphi&5.5

Hello!
I try to implement SQL-query using TQuery componenet

SELECT count(*)
FROM dba.M_F
where id_f=6 and date_now > '01.01.2000'

Then I get an error message
General SQL error
[Sybase][ODBC driver]: cannot convert 01.01.2000 to a date/time.

What's a matter (I tried any different variants of date kind)? Does anyone 
this problem encounter?
0
Nicolay_A
3/13/2001 9:53:52 AM
sybase.sqlanywhere.general 32637 articles. 4 followers. Follow

2 Replies
551 Views

Similar Articles

[PageSpeed] 53

Alter your SELECT statement to the following :
SELECT count(*) from dba.M_F
where id_f = 6 and date_now > '2000-01-01'

note that date picture is 'yyyy-mm-dd' for SQL Anywhere.

<Nicolay_A._Vasiliev> wrote in message
news:8E319D1BB60BF32300365ED885256A0E.00365EFF85256A0E@webforums...
> Hello!
> I try to implement SQL-query using TQuery componenet
>
> SELECT count(*)
> FROM dba.M_F
> where id_f=6 and date_now > '01.01.2000'
>
> Then I get an error message
> General SQL error
> [Sybase][ODBC driver]: cannot convert 01.01.2000 to a date/time.
>
> What's a matter (I tried any different variants of date kind)? Does anyone
> this problem encounter?


0
Ian
3/13/2001 10:28:39 AM
Thank you, it works.
0
Nicolay_A
3/13/2001 12:15:20 PM
Reply:

Similar Artilces:

Outlook & GW 5.5.5 (NW 6.5.5)
We have GW 5.5.5 for interoffice email & 50% of my employees have Outlook Express (or Outlook) for their internet email. My problem is whenever I upgrade a user from Outlook Express to Outlook I generally run into problem with GW or Outlook or both. My latest user I finally got her up on Outlook (2003), she had been running OE without any problems. After I finally created a 2nd profile for her because Outlook obviously didn't like her default Novell settings I got that to work. Now her GW will not open at all. Her notify works but that has been the case before with other...

SQLAnywhere 5.5.04ebf(1868), 5.5.05
Hello! I have recieved message from "owner-inews-tech-sqlanywhere@sybase.com" with Subject "Delphi users". Where can I obtain new ebf(s)? I found only 5.5.03 in the Software library. (http://support.sybase.com/esd/sqlany.html) ==== Subject: Bug Fix / Enhancement (PTrack 479443) - .... Summary: Delphi can't insert Blobs > 32k - SQLBindParameter only inserted the first 32k of a given buffer. Versions affected: 5.5.x Versions fixed: 5.5.04ebf(1868), 5.5.05 P4 change number: 52135, 52298 Modules affected: wod50 .... === You'll have to contact Tech ...

Upgrading 5.5.5 to 6.5.5
I am going to be upgrading from GW 5.5.5 to GW6.5.5 Anybody aware of any gotcha's or have any advice? LauraB@itdynamics.co.za wrote: > I am going to be upgrading from GW 5.5.5 to GW6.5.5 Anybody aware of > any gotcha's or have any advice? Not really. Before you upgrade rebuilt the post offices and domains or do at least a validate of the databases. If you are not really experienced I recommend to purchase the caledonia upgrade guide. -- Cheers, Edward ...

storing graphics problem in 5.5.2 & 5.5.3
we are running delphi 2.01 and SQLAny 5.5.01; We store small graphics (pictures of real people) in the data base as a long binary... everything works well; When we upgraded to 5.5.02, the maximum amount of bytes that the DB will store of the SAME pictures that were being store previously is 7,420 bytes; the graphic is 15,478. I have logged many hours trying to decipher what may be happening and have not a clue... No errors are reported, the onyl thing that I know for sure is that everything worked under 5.5.01 and does not under 5.5.02 + 3; any clues or suggestions would be most a...

Upgrading from NW5 & GroupWise 5.5 to NW65 & GroupWise6.5
Hello! I'm looking for some opinions and advice. I am currently looking for the most painless way to upgrade to GroupWise6.5 from GroupWise 5.5 EP. I have GroupWise 5.5 EP running on a Netware5 server at the moment. I also have a Netware6.5 installed in the same tree as the Netware5 server and have done all the necessary schema stuff to have NW65 and NW5 in the same tree using DS v7.62b for NW5. Long term I plan on ditching NW5 for NW65. I plan on upgrading to GroupWise 6.5 in the following way. 1. Move current GroupWise 5.5 EP domain and post office to NW65 server. ...

NW 5 & GW 5.5 --> W2K & GW7
As if that's not enough acronyms! I've searched around this place with little to no results, so here goes nothing! Currently in place: Netware 5 server GroupWise 5.5 POA, MTA, Webaccess looking to go to: Windows 2000 Server GroupWise 7.0 POA, MTA, Webaccess I attended the local launch event for GW7 and asked a few questions that I thought would help me in my journey down the upgrade road. Currently all of our GroupWise clients connect to GroupWise via a direct IP. The Novell client is not installed on any of our end-user machines. At the event I was informed that I ...

IIS 4 & SQLAnywhere 5.5
Has you ever tried to connect to a SQLAnywhere 5.5 Database from IIS (through ASP pages) ? It works perfectly well with all other major SGBDs (Microsoft SQL Server, Oracle,....). It seems to be a security conflict between the profile "Anonymous User" choosen in the virtual directory web site and the profile used to install SQLAnywhere 5.5. Any idea ? Thanks. -- Xavier BENVENISTE Met@Data Team Leader L e o n a r d ' s | L o g i c / H u m m i n g b i r d What version and build number are you using? There was a problem relating to this exact thing that was fix...

Help! Delphi 4 and SqlAnywhere 5.5
Help! We have some apps that worked fine with Delphi 3 but now they don't work any more. We have some Table components and if you start the app, an error occurs. It says, that e.g. an string is expected by an unknown datatyp is found. Although it works fine in design mode! Can anybody help??? Chris 1. Dbl.click on your TQuery's and TTable components. 2. Mark all data fields (not the calculated once) 3. Delete them (DEL) 4. Add them back again. 5. Save. Peter. ...

SQLAnywhere 5.5
We are running SQLAnywhere on a Novell 4.11 server. The DBSRV50.NLM is version 5.5.00 Build #1073. I am assuming this is the version of the database we are running of SQLAnywhere? Does this version support SMP? We are thinking of ordering another processor for the server, but don't want to waste money is the version of SQLAnywhere is not SMP aware or capable of using the extra processor? Thanks, Keith I already answered this in the general newsgroup. Please do not cross post. -- Jim Egan [TeamSybase] Houston, TX I only crossed posted because this group has al...

SQLAnywhere 5.5
We are running SQLAnywhere on a Novell 4.11 server. The DBSRV50.NLM is version 5.5.00 Build #1073. I am assuming this is the version of the database we are running of SQLAnywhere? Does this version support SMP? We are thinking of ordering another processor for the server, but don't want to waste money is the version of SQLAnywhere is not SMP aware or capable of using the extra processor? Thanks, Keith SQL Anywhere does not support SMP, ASA does but not on Novell. But, it won't hurt to add another processor. The OS will continue to use one and SQL Anywhe...

Delphi and 5.5
Hello! I work with Delphi5 and SQL Anywhere 5.5 for DBMS-applications developing. There are 2 questions. 1. For desktop application. I'd like to include necessary files of SQL Anywhere into distribution to make installation procedure most simpler for user. Which files of SQL Anywhere should I put into installational package and also which additions should I make in Windows registry? 2. How can I register DB alias in ODBC? 3. The same for CS-application. Is it possible at all? TIA I believe all your questions about SQL Anywhere can be answered by reading the on-...

Merging 2 GroupWise 5.5 & 6.5 domains & moving to new hardware & tree
--____HUUGUAJLOXECDNBRZZJF____ Content-Type: text/plain; charset=iso-8859-1 Content-Transfer-Encoding: quoted-printable I have two GroupWise domains, which I wish to merge into one. At the same = time, we are moving one to new hardware and a new tree... here's the = details: Domain #1 is the primary domain. It is GroupWise v6.5sp3, and all = components reside on a NetWare v6.5 box. It only has one post office. The = GroupWise objects reside in eDirectory tree #1. There are about 30 users = here. Domain #2 is a secondary (external) domain. It is GroupWise v5.5 (not sure = ...

5.5.03 OR 5.5.04 ?
I've just installed the 5.5.04 maint release. On opening my database (created in 5.5), its properties state that the version is 5.5.03. As many have no doubt upgraded to 5.5.04, could someone pls advise if this is 'correct' behaviour? Many thanks in advance -- MAX HUGEN Hugen Enterprises Pty Ltd Email: maxhugen@ozemail.com.au Tel: +612 9560 3061 Fax: +612 9564 5073 >I've just installed the 5.5.04 maint release. On opening my database >(created in 5.5), its properties state that the version is 5.5.03. >As many have no doubt upgraded to 5.5.04, could...

Upgrade to 5.4.5 or 5.5
Hi, Currently we are running eBiz version 5.4.2.5 under Winodw2000. We are having cluster died issue since the beginning. Now we are planning to move to 5.4.6 or 5.5. Would someone help me to share if there are any serious issues with new versions (for windows)? Should we go with Win2000 or Win2003. Thanks Aftab Aftab,.. Our advise for this moment is to run impact 5.4.6. under Win2003. (See also your earlier replay on Carl's post) We do have some problems with startin a cluster from a earlier ersion of impact. The cluster won't start always correct or won't...

Web resources about - Delphi&5.5 - sybase.sqlanywhere.general

Resources last updated: 12/24/2015 8:24:01 PM