Error calling pbdom in deployment

I'm getting "Error calling method of a PBNI object" on
pbdom_document.getcontent().

Not too much info to go on from that error message.  This is only in the
deployed version.  I picked up all deployment/runtime files that I thought I
was supposed to.  Here is my list:

pbvm90.dll
pbdwe90.dll
libcc.dll
libsybheap.dll
pbdom90.dll
pbdom90.pbd
pbxerces90.dll
xerces-c_1_5_1.dll

This also only seems to appear on a machine without pb9 loaded...

-chris


0
Chris
5/15/2003 6:56:08 PM
sybase.powerbuilder.xml 546 articles. 0 followers. Follow

3 Replies
983 Views

Similar Articles

[PageSpeed] 41

Are you wrapping your PBDOM operations in a block as follow?

TRY
    ...
CATCH (PBDOM_Exception pbde)

Also, try calling PBDOM_Builder.GetParseErrors() before processing the
document -- if the document did not parse successfully, you should be
careful with any operation you try against it.

-- 
<hopethishelps/>
Roy Kiesler [TeamSybase]
SDN CodeXchange -- http://codexchange.sybase.com


"Chris" <schtoo@schtoo.com> wrote in message
news:%23Kt9mTxGDHA.358@forums-2-dub...
> I'm getting "Error calling method of a PBNI object" on
> pbdom_document.getcontent().
>
> Not too much info to go on from that error message.  This is only in the
> deployed version.  I picked up all deployment/runtime files that I thought
I
> was supposed to.  Here is my list:
>
> pbvm90.dll
> pbdwe90.dll
> libcc.dll
> libsybheap.dll
> pbdom90.dll
> pbdom90.pbd
> pbxerces90.dll
> xerces-c_1_5_1.dll
>
> This also only seems to appear on a machine without pb9 loaded...
>
> -chris
>
>


0
Roy
5/15/2003 7:28:49 PM
Yeah I'm doing all that.  An exception is NOT being thrown.  And it is
parsing the document.  Its getting a bunch of parsing errors related to the
document but they are all because I don't have a DTD (Unknown element,
undeclared attributes).  I can parse the exact file successfully on my
computer (i.e. with PB9 installed).

-Chris

"Roy Kiesler [TeamSybase]" <SPAM_FREE_roy.kiesler@teamsybase.com> wrote in
message news:ON7dUkxGDHA.329@forums-2-dub...
> Are you wrapping your PBDOM operations in a block as follow?
>
> TRY
>     ...
> CATCH (PBDOM_Exception pbde)
>
> Also, try calling PBDOM_Builder.GetParseErrors() before processing the
> document -- if the document did not parse successfully, you should be
> careful with any operation you try against it.
>
> --
> <hopethishelps/>
> Roy Kiesler [TeamSybase]
> SDN CodeXchange -- http://codexchange.sybase.com
>
>
> "Chris" <schtoo@schtoo.com> wrote in message
> news:%23Kt9mTxGDHA.358@forums-2-dub...
> > I'm getting "Error calling method of a PBNI object" on
> > pbdom_document.getcontent().
> >
> > Not too much info to go on from that error message.  This is only in the
> > deployed version.  I picked up all deployment/runtime files that I
thought
> I
> > was supposed to.  Here is my list:
> >
> > pbvm90.dll
> > pbdwe90.dll
> > libcc.dll
> > libsybheap.dll
> > pbdom90.dll
> > pbdom90.pbd
> > pbxerces90.dll
> > xerces-c_1_5_1.dll
> >
> > This also only seems to appear on a machine without pb9 loaded...
> >
> > -chris
> >
> >
>
>


0
Chris
5/15/2003 7:38:51 PM
Can you send me the document in question? I'd like to try it.

-- 
<hopethishelps/>
Roy Kiesler [TeamSybase]
SDN CodeXchange -- http://codexchange.sybase.com

"Chris" <schtoo@schtoo.com> wrote in message
news:OJMOerxGDHA.222@forums-2-dub...
> Yeah I'm doing all that.  An exception is NOT being thrown.  And it is
> parsing the document.  Its getting a bunch of parsing errors related to
the
> document but they are all because I don't have a DTD (Unknown element,
> undeclared attributes).  I can parse the exact file successfully on my
> computer (i.e. with PB9 installed).
>
> -Chris
>
> "Roy Kiesler [TeamSybase]" <SPAM_FREE_roy.kiesler@teamsybase.com> wrote in
> message news:ON7dUkxGDHA.329@forums-2-dub...
> > Are you wrapping your PBDOM operations in a block as follow?
> >
> > TRY
> >     ...
> > CATCH (PBDOM_Exception pbde)
> >
> > Also, try calling PBDOM_Builder.GetParseErrors() before processing the
> > document -- if the document did not parse successfully, you should be
> > careful with any operation you try against it.
> >
> > --
> > <hopethishelps/>
> > Roy Kiesler [TeamSybase]
> > SDN CodeXchange -- http://codexchange.sybase.com
> >
> >
> > "Chris" <schtoo@schtoo.com> wrote in message
> > news:%23Kt9mTxGDHA.358@forums-2-dub...
> > > I'm getting "Error calling method of a PBNI object" on
> > > pbdom_document.getcontent().
> > >
> > > Not too much info to go on from that error message.  This is only in
the
> > > deployed version.  I picked up all deployment/runtime files that I
> thought
> > I
> > > was supposed to.  Here is my list:
> > >
> > > pbvm90.dll
> > > pbdwe90.dll
> > > libcc.dll
> > > libsybheap.dll
> > > pbdom90.dll
> > > pbdom90.pbd
> > > pbxerces90.dll
> > > xerces-c_1_5_1.dll
> > >
> > > This also only seems to appear on a machine without pb9 loaded...
> > >
> > > -chris
> > >
> > >
> >
> >
>
>


0
Roy
5/16/2003 2:57:14 PM
Reply:

Similar Artilces:

deploy error:Deployment Error Deploying PBDs To Host Repository Location 'n_cst_fhbp0400' EAServer error code: SystemException: CORBA::COMM_FAILURE, exception code: 7
Sir, I deployed my PB components to EAServer 4.2.3.There are over 500 pbl files which would be deployed to EAServer. Most of them were deployed well.But there were some error about last 10 deployed pbl files. The error message like : Deployment Error Deploying PBDs To Host Repository Location 'n_cst_xxxxxx' EAServer error code: SystemException: CORBA::COMM_FAILURE, exception code: 7 I ued command line to deploy my application. Ex: c:\pb80 /workspace d:\cdshop\cdshop.pbw /deploy /output d:\tmp\cdshop.out I think OS socket numbers are not enough. ...

Error with PBDom in deployed application
Hi, Run my deployed application I get this error: "Unresolvable external pbdom_builder when linking reference at line 50 in function of_setoutputdata of object u_cst_step_webdatabank" where the referenced line is: lx_XmlBuilder = Create PBDOM_Builder lx_XmlBuilder has been declared in following way: PBDOM_Builder lx_XmlBuilder I get no error with this code when I run it from the PB9 IDE. I'm using PB 9.0.1 build 6533 and in the application directory I've copied the following files: libjcc.dll pbdom90.dll pbdwe90.dll pbdwr90.dll pbjag90.dll pbjvm90.dll ...

superreview granted: [Bug 297814] Report XML parsing errors to the error (JS) console : [Attachment 186991] Report XML parsing errors to the console, rev. 1
Mike Shaver <shaver@mozilla.org> has granted Benjamin Smedberg [:bs] (formerly bsmedberg@covad.net) <benjamin@smedbergs.us>'s request for superreview: Bug 297814: Report XML parsing errors to the error (JS) console https://bugzilla.mozilla.org/show_bug.cgi?id=297814 Attachment 186991: Report XML parsing errors to the console, rev. 1 https://bugzilla.mozilla.org/attachment.cgi?id=186991&action=edit ------- Additional Comments from Mike Shaver <shaver@mozilla.org> I don't _really_ like using nsScriptError for this, because of the JavaScript references in...

superreview requested: [Bug 297814] Report XML parsing errors to the error (JS) console : [Attachment 186991] Report XML parsing errors to the console, rev. 1
Benjamin Smedberg [:bs] (formerly bsmedberg@covad.net) <benjamin@smedbergs.us> has asked Mike Shaver <shaver@mozilla.org> for superreview: Bug 297814: Report XML parsing errors to the error (JS) console https://bugzilla.mozilla.org/show_bug.cgi?id=297814 Attachment 186991: Report XML parsing errors to the console, rev. 1 https://bugzilla.mozilla.org/attachment.cgi?id=186991&action=edit ...

errors errors errors..
Name: harun Email: harunbjk1903hrnatgmaildotcom Product: Firefox Summary: errors errors errors.. Comments: first of all when i launch firefox (3) i cant enter websites via writing.. for example when I type "google" and then press ctrl and enter, it crashes.. and i take lots of error reports. firefox 2 was better.. see you again , harun Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; tr; rv:1.9) Gecko/2008052906 Firefox/3.0 From URL: http://hendrix.mozilla.org/ ...

error error error
These are the 2 new errors i am getting now:   1).  Server Error in '/' Application. Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.Source Error: Line 53: ...

deploy error with no error message
Please someone help me .... Suddenly I can't deploy my web application, and the bad news is,.. there is no error message for me to find what the problem is. I attach screen capture from the error. thank you begin 666 deployerror.JPG M_]C_X `02D9)1@`!`0$`8 !@``#_VP!#``@&!@<&!0@'!P<)"0@*#!0-# L+ M#!D2$P\4'1H?'AT:'!P@)"XG("(L(QP<*#<I+# Q-#0T'R<Y/3@R/"XS-#+_ MVP!#`0D)"0P+#!@-#1@R(1PA,C(R,C(R,C(R,C(R,C(R,C(R,C(R,C(R,C(R M,C(R,C(R,C(R,C(R,C(R,C(R,C(R,C+_P `1" "U`<8#`2(``A$!`Q$!_\0` M'P```04!`0...

Error, Error and more errors
Okay, all I wanted to do was test this app out and it has been a nightmare. 1.) Didn't install the sql database. I had to manually install it. 2.) I get errors when trying to add a picture to an album. "Procedure or function ngUpdatePicture has too many arguments specified" Any ideas? I've gotten more errors than this, but there is no use in bitchin. Are you using the v1.6.1 installer? Also, did you select to install the SQL Server db and give it a valid admin login? What were some of the error messages? Did you have an existing DB from a previous install? ...

Function Call Overload Deploy Error Anomoly
Greetings all, I have a problem that is more annoying than anything else. I have some webform applications (11.2) and when I try to deploy them, the deploy fails telling me that I cannot overload the function and that it takes X arguments. But of course I am calling the function with the correct number of arguments. The solution is to open the function, add or change a space, save it, rebuild all and then deploy. Then it works. The next time I try to deploy, I get the same goofy error and have to open, change, save, close and rebuild all to deploy. Can someone sugges...

Internal Error
I'm getting a PowerBuilder Runtime Error which says, ' Internal RunTime Engine Failure Contact PowerSoft Tech SUpport (NOOP)'. The error no. is R0011. I get this error when I try to call a function of an nvo from a window function. And the most strange thing is that this is not really a new code, this same code used to work before. I guess this problem started happening after regenerating the application. I'm not sure if the given info wil be helpful, but if u need a full info and feel that u could help then please do send me an e- mail. Thanks a lot , Swai Chand...

GPF error when I call a DLL compiled from PowerBuilder...
I have this problem using PB 7.03 in Windows 2000: Compile from PB a DLL with 2 functions. In PB painter function's names are f_getkey() and f_setkey(string as_key) with described parameters. From another PB application I want to call with local external functions in nonvisualonject nuo_key the previous functions. I use the declaration: Function string f_getkey() Library "KEY.DLL" Alias For _getVtableInfo_f_getkey@12 Function string f_setkey(string as_key) Library "KEY.DLL" Alias For _getVtableInfo_f_setkey@12, using the exactly DLL export function's na...

Error encounter while calling Powerbuilder NV object
I don't know why I always encounter the RollBack error while I calling the PowerBuilder NV Jaguar component from Powersite. The NV object is a very simple function just return the value get from the function parameter. I have checked the error log of the Jaguar server, found the error is: PB Unable to create session for uo_test2. Does this error cause by some setting error or some step I miss to do? The PowerBuilder and the Jaguar sever not installed at the same machine pls give me some advice. the error log as following: Dec 04 10:02:01 2000: HTMLDW: Remote DataWindow Co...

Calling C++ dll in Powerbuilder giving error
Hi, I have created a C++ dll with a simple ADD function. The header file is: #if defined DLL_EXPORT #define DECLDIR __declspec(dllexport) #else #define DECLDIR __declspec(dllimport) #endif extern "C" { double Add( short a, short b ); } #endif The .cpp file contains: extern "C" { double Add( short a, short b ) { return (a+b); } } ---------------------------------------------------------------------------------------------------------------------------------------------------------- I have tried using int, long and double ...

Error deploying in Powerbuilder 9.0.1
Hi!! I'm trying to deploy a web app to EAServer 4.2.2 and happens: 1. Deployment JAR initialization failed ---------- Deploy: Deploy of target OIDVHome OIDVHomeDeployDesa: Building... OIDVHome - 0 error(s), 0 warning(s) Deploying... Generating WAR File... Delivering WAR File... Error: Deployment JAR initialization failed. OIDVHome Deployed - 2 error(s), 0 warning(s) ---------- Finished Deploy of target OIDVHome 2. Powerbuilder close automatically... What's wrong? Where Can I see the cause problem, log, etc.? Any Ideas??? T...