We recently migrated a PB6.5 application to PB 9 (Ver 9.0.1 Build 6533) and when we run the app in interactive mode, it runs fine but upon exiting the app - it always generates the following message:

We recently migrated a PB6.5 application to PB 9 (Ver 9.0.1
Build 6533) and when we run the app in interactive mode, it
runs fine but upon exiting the app - it always generates the
following message:
   PB90.exe has generated errors and will be closed by
Windows.
   You will need to restart the program.
   An error log is being created.
If we run the app through the debugger, there is never any
such error upon closing out of the application.

I can never find any error log file that gets created.
We are running the PB code on a Novell network against an
Oracle 8 database.

Any suggestions?
0
Bob
12/10/2003 2:27:01 PM
sybase.powerbuilder.general 62418 articles. 18 followers. Follow

2 Replies
905 Views

Similar Articles

[PageSpeed] 56

My WAG: something is being referred to after it has been destroyed. The
debugger is intrusive, and is changing the order of events. Try PBTRACE and
see what the app is actually doing.

<Bob Dingwell> wrote in message news:3fd72d35.1609.846930886@sybase.com...
> We recently migrated a PB6.5 application to PB 9 (Ver 9.0.1
> Build 6533) and when we run the app in interactive mode, it
> runs fine but upon exiting the app - it always generates the
> following message:
>    PB90.exe has generated errors and will be closed by
> Windows.
>    You will need to restart the program.
>    An error log is being created.
> If we run the app through the debugger, there is never any
> such error upon closing out of the application.
>
> I can never find any error log file that gets created.
> We are running the PB code on a Novell network against an
> Oracle 8 database.
>
> Any suggestions?


0
Jerry
12/10/2003 4:10:30 PM
> We found that once we set the option of Just In Time
Debugging we no longer got the error upon closing the
application

My WAG: something is being referred to after it has been
> destroyed. The debugger is intrusive, and is changing the
> order of events. Try PBTRACE and see what the app is
> actually doing.
>
> <Bob Dingwell> wrote in message
> > news:3fd72d35.1609.846930886@sybase.com... We recently
> > migrated a PB6.5 application to PB 9 (Ver 9.0.1 Build
> > 6533) and when we run the app in interactive mode, it
> runs fine but upon exiting the app - it always generates
> > the following message:
> >    PB90.exe has generated errors and will be closed by
> > Windows.
> >    You will need to restart the program.
> >    An error log is being created.
> > If we run the app through the debugger, there is never
> > any such error upon closing out of the application.
> >
> > I can never find any error log file that gets created.
> > We are running the PB code on a Novell network against
> > an Oracle 8 database.
> >
> > Any suggestions?
>
>
0
Bob
1/9/2004 7:51:19 PM
Reply: