Problem running in PowerBuilder 9.03 IDE vs. compile version

We are expierencing a problem running an object in the IDE but when the 
application is compiled it runs successfully.  We have a cursor in a 
function and the variables do not get populated within the fetch statement 
when run in the IDE.

We use StarTeam and PowerGen to build the application.  We can take the .pbl 
build from PowerGen and overlay the .pbl in the source.  The application 
will run in the IDE until we make any modifications to the object.  Even 
adding a blank line to the function causes the IDE to no longer run.

Any ideas would be appreciated. 


0
Bonnie
1/15/2008 9:21:25 PM
sybase.powerbuilder.general 62418 articles. 17 followers. Follow

7 Replies
676 Views

Similar Articles

[PageSpeed] 14

I'd optimize all the PBLs and do a full rebuild or two.
Of course, I wouldn't have used a cursor - datastores are more efficient in 
retrieval and give you all those other functions...

"Bonnie Stoick" <bstoick@fsisolutions.com> wrote in message 
news:478d23d5$1@forums-1-dub...
> We are expierencing a problem running an object in the IDE but when the 
> application is compiled it runs successfully.  We have a cursor in a 
> function and the variables do not get populated within the fetch statement 
> when run in the IDE.
>
> We use StarTeam and PowerGen to build the application.  We can take the 
> .pbl build from PowerGen and overlay the .pbl in the source.  The 
> application will run in the IDE until we make any modifications to the 
> object.  Even adding a blank line to the function causes the IDE to no 
> longer run.
>
> Any ideas would be appreciated.
> 


0
Jerry
1/15/2008 10:59:12 PM
There's a free utility called Process Explorer from SysInternals (now 
aka Microsoft) that lets you see which DLLs are being loaded by which 
processes. I'd use that to determine which versions of DLLs are being 
loaded from where. Your symptoms are consistent with running under 
different DLL versions.

Good luck,

Terry [TeamSybase] and Sequel the techno-kitten

Bonnie Stoick wrote:
> We are expierencing a problem running an object in the IDE but when the 
> application is compiled it runs successfully.  We have a cursor in a 
> function and the variables do not get populated within the fetch statement 
> when run in the IDE.
> 
> We use StarTeam and PowerGen to build the application.  We can take the .pbl 
> build from PowerGen and overlay the .pbl in the source.  The application 
> will run in the IDE until we make any modifications to the object.  Even 
> adding a blank line to the function causes the IDE to no longer run.
> 
> Any ideas would be appreciated. 
> 
> 

-- 
*********************************
Build your vocabulary and feed the hungry
http://www.freerice.com
*********************************
Newsgroup User Manual
=====================
TeamSybase <> Sybase employee
Forums = Peer-to-peer
Forums <> Communication with Sybase
IsNull (AnswerTo (Posting)) can return TRUE
Forums.Moderated = TRUE, so behave or be deleted
*********************************

Sequel's Sandbox: http://www.techno-kitten.com
Home of PBL Peeper, a free PowerBuilder Developer's Toolkit.
Version 4.0.3 now available at the Sandbox
PB Futures updated Jan 2/2008
See the PB Troubleshooting & Migration Guides at the Sandbox
^ ^
o o
=*=
0
Terry
1/16/2008 3:58:42 PM
Thanks Jerry,
We did optimize and then did a full build but the IDE still does not run 
successfully.

I copied the pbl build from PowerGen and overlayed the source and it runs. 
Then did a full build without changing any code, and it no longer runs.

We are using a cursor because of the large volume of data that is being 
processed.  It could be up to 1/2 million rows.  Is there a better way to do 
this?

Thanks.
"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com> wrote in message 
news:478d3ac0$1@forums-1-dub...
> I'd optimize all the PBLs and do a full rebuild or two.
> Of course, I wouldn't have used a cursor - datastores are more efficient 
> in retrieval and give you all those other functions...
>
> "Bonnie Stoick" <bstoick@fsisolutions.com> wrote in message 
> news:478d23d5$1@forums-1-dub...
>> We are expierencing a problem running an object in the IDE but when the 
>> application is compiled it runs successfully.  We have a cursor in a 
>> function and the variables do not get populated within the fetch 
>> statement when run in the IDE.
>>
>> We use StarTeam and PowerGen to build the application.  We can take the 
>> .pbl build from PowerGen and overlay the .pbl in the source.  The 
>> application will run in the IDE until we make any modifications to the 
>> object.  Even adding a blank line to the function causes the IDE to no 
>> longer run.
>>
>> Any ideas would be appreciated.
>>
>
> 


0
Bonnie
1/16/2008 5:09:55 PM
See Terry's comment as well.
That may be a reason to use a cursor - you will avoid memory problems. But 
why do you need to move that much data to the client? Clearly too much for a 
human to look at. I would have tried to do it as a stored procedure on the 
server.

"Bonnie Stoick" <bstoick@fsisolutions.com> wrote in message 
news:478e3a63$1@forums-1-dub...
> Thanks Jerry,
> We did optimize and then did a full build but the IDE still does not run 
> successfully.
>
> I copied the pbl build from PowerGen and overlayed the source and it runs. 
> Then did a full build without changing any code, and it no longer runs.
>
> We are using a cursor because of the large volume of data that is being 
> processed.  It could be up to 1/2 million rows.  Is there a better way to 
> do this?
>
> Thanks.
> "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com> wrote in message 
> news:478d3ac0$1@forums-1-dub...
>> I'd optimize all the PBLs and do a full rebuild or two.
>> Of course, I wouldn't have used a cursor - datastores are more efficient 
>> in retrieval and give you all those other functions...
>>
>> "Bonnie Stoick" <bstoick@fsisolutions.com> wrote in message 
>> news:478d23d5$1@forums-1-dub...
>>> We are expierencing a problem running an object in the IDE but when the 
>>> application is compiled it runs successfully.  We have a cursor in a 
>>> function and the variables do not get populated within the fetch 
>>> statement when run in the IDE.
>>>
>>> We use StarTeam and PowerGen to build the application.  We can take the 
>>> .pbl build from PowerGen and overlay the .pbl in the source.  The 
>>> application will run in the IDE until we make any modifications to the 
>>> object.  Even adding a blank line to the function causes the IDE to no 
>>> longer run.
>>>
>>> Any ideas would be appreciated.
>>>
>>
>>
>
> 


0
Jerry
1/16/2008 5:18:35 PM
Thanks Terry,
I did download the utility.  The dlls are the same when I run the 
application in the IDE or the compiled version.  However, since the compiled 
application actually completes the process, additional dlls are used futher 
in the process.


"Terry Voth [TeamSybase]" <sequel@techno-kitten.com> wrote in message 
news:478e29b2@forums-1-dub...
> There's a free utility called Process Explorer from SysInternals (now aka 
> Microsoft) that lets you see which DLLs are being loaded by which 
> processes. I'd use that to determine which versions of DLLs are being 
> loaded from where. Your symptoms are consistent with running under 
> different DLL versions.
>
> Good luck,
>
> Terry [TeamSybase] and Sequel the techno-kitten
>
> Bonnie Stoick wrote:
>> We are expierencing a problem running an object in the IDE but when the 
>> application is compiled it runs successfully.  We have a cursor in a 
>> function and the variables do not get populated within the fetch 
>> statement when run in the IDE.
>>
>> We use StarTeam and PowerGen to build the application.  We can take the 
>> .pbl build from PowerGen and overlay the .pbl in the source.  The 
>> application will run in the IDE until we make any modifications to the 
>> object.  Even adding a blank line to the function causes the IDE to no 
>> longer run.
>>
>> Any ideas would be appreciated.
>
> -- 
> *********************************
> Build your vocabulary and feed the hungry
> http://www.freerice.com
> *********************************
> Newsgroup User Manual
> =====================
> TeamSybase <> Sybase employee
> Forums = Peer-to-peer
> Forums <> Communication with Sybase
> IsNull (AnswerTo (Posting)) can return TRUE
> Forums.Moderated = TRUE, so behave or be deleted
> *********************************
>
> Sequel's Sandbox: http://www.techno-kitten.com
> Home of PBL Peeper, a free PowerBuilder Developer's Toolkit.
> Version 4.0.3 now available at the Sandbox
> PB Futures updated Jan 2/2008
> See the PB Troubleshooting & Migration Guides at the Sandbox
> ^ ^
> o o
> =*= 


0
Bonnie
1/16/2008 7:30:46 PM
Bonnie,
Can you explain your PowerGen build process to me a little better?  I think 
the problem is in here somewhere.

What's a "PBL" build?  Do you mean a "PBD" build?  Why are you overlaying 
the source?  Overlaying it from where and with what?
This all sounds very strange and non-standard to me...

Paul Horan[TeamSybase]

"Bonnie Stoick" <bstoick@fsisolutions.com> wrote in message 
news:478e3a63$1@forums-1-dub...
> Thanks Jerry,
> We did optimize and then did a full build but the IDE still does not run 
> successfully.
>
> I copied the pbl build from PowerGen and overlayed the source and it runs. 
> Then did a full build without changing any code, and it no longer runs.
>
> We are using a cursor because of the large volume of data that is being 
> processed.  It could be up to 1/2 million rows.  Is there a better way to 
> do this?
>
> Thanks.


0
Paul
1/16/2008 11:37:09 PM
Problem has been solved.

The problem was that the cursor used an ODBC connection and when the 
function was compiled, it was compiled with an OLEDB connection.  Therefore 
when the IDE was run it was giving errors during the cursor routine.


"Paul Horan[TeamSybase]" <phoran AT sybase DOT com> wrote in message 
news:478e9525@forums-1-dub...
> Bonnie,
> Can you explain your PowerGen build process to me a little better?  I 
> think the problem is in here somewhere.
>
> What's a "PBL" build?  Do you mean a "PBD" build?  Why are you overlaying 
> the source?  Overlaying it from where and with what?
> This all sounds very strange and non-standard to me...
>
> Paul Horan[TeamSybase]
>
> "Bonnie Stoick" <bstoick@fsisolutions.com> wrote in message 
> news:478e3a63$1@forums-1-dub...
>> Thanks Jerry,
>> We did optimize and then did a full build but the IDE still does not run 
>> successfully.
>>
>> I copied the pbl build from PowerGen and overlayed the source and it 
>> runs. Then did a full build without changing any code, and it no longer 
>> runs.
>>
>> We are using a cursor because of the large volume of data that is being 
>> processed.  It could be up to 1/2 million rows.  Is there a better way to 
>> do this?
>>
>> Thanks.
>
> 


0
Bonnie
1/17/2008 2:02:20 PM
Reply:

Similar Artilces:

Compiled (exe) vs. Running within the Powerbuilder IDE
I have a problem when trying to run a report outside of the Powerbuilder IDE. When I run it within the IDE the data window works fine. If I run it from the compiled version (exe), I receive an error that states Retrieve Error - No rows found. Any Ideas? Thanks, SKeller How are you compiling the app? To one large EXE file, to separate DLLs (machine code), or to PBDs? -- Paul Horan[TeamSybase] VCI Springfield, MA www.vcisolutions.com TechWave2002 www.sybase.com/techwave2002 Session E177 - Best Practices in Source Code Control with PowerBuilder <Skelle...

Powerbuilder 9.0 vs. Powerbuilder 8.0
What is the difference in Powerbilder 9.0 and 8.0? I would like to point out that the Appeon newsgroup is monitored by Sybase and Appeon engineering staff who are very knowledgeable about Appeon issues. Question that are purely PowerBuilder-related are best answered by the staff and users of the PowerBuilder newsgroup: sybase.public.powerbuilder.XXXX. Please post to the appropriate newsgroup so you receive the help you desire. Thanks, Julie Jiang Appeon Corporation <dburris@onesolution.com> wrote in message news:40589011.2717.846930886@sybase.com... > What is the diffe...

Compiled vs. Running within Powerbuilder
I have a problem when trying to run a report outside of the Powerbuilder IDE. When I run it within the IDE the data window works fine. If I run it from the compiled version (exe), I receive an error that states Retrieve Error - No rows found. Any Ideas? Thanks, SKeller Is the database and login the same as the active profile in the IDE? Are you assigning the datawindow object in code? If so, either list in the PBR or build the deployment with PBDs. Skeller wrote in message <44DF7713355BDDAB004F622385256BF7.004F623085256BF7@webforums>... >I have a problem when t...

Powerbuilder 9.0 Migration from powerbuilder 7.0.3 problem
Hi all, i was trying an migrate an powerbuilder 7.0.3 application to powerbuilder 9.0(PFC BASED APPLICATION (PFC objects version PB 6.5) ) during migration i am getting this error. tcmborrower.pbl(w_cursor_check).w_cursor_check.open.2: Error C0163: The definition of referenced global variable sqlca was improperly compiled in object trcomps Did anybody faced this kind of error? Thx Ashok JPMORGAN ---== Posted via the PFCGuide Web Newsreader ==--- http://www.pfcguide.com/_newsgroups/group_list.asp First error message which i got during the migration is : tcmappl.pb...

OLE problems between WORD 2003 and Powerbuilder 9.03
Hi All, I have a PowerBuilder application that opens my own existing template in word and fills it (using bookmarks)with data. This worked fine until I recently migrated from Powerbuilder 6.5 on NT to Powerbuilder 9.03 on XP using Office 2003. For the most part, it still works fine. But if there is a word document already open on the users machine, at the point where I make the ConnectToNewObject('application.word') call, the following message is thrown back at me "Word cannot save this file because it is already open elsewhere. C:\Documents and Settings\...\normal....

Problem connecting to oracle database in powerbuilder 9.0 desktop version
I am not able to connect to oracle database using odbc in powerbuilder 9.0 desktop version.I am getting error message which says 'Inavlid or unsupported datasource' Ershad, Have you verified that you have the required Oracle ODBC drivers? The latest set of drivers is available at: http://www.oracle.com/technology/software/tech/windows/odbc/index.html\ Could you also please post the attributes of the transaction object (except the password) that you use to try and connect to the oracle db? Sanjiv. <Ershad Ali Mohammad> wrote in message news:41aea458.51d5...

Powerbuilder after migration from 9 version to 11 version
Hi All, After migration from Powerbuilder 9 to Powerbuilder 11.1 version. I'm facing below errors. Errors: ====== DSEAPSRV.PBL(dse_n_cst_filesrvmac).2: Error C0001: Illegal data type: n_cst_filesrvmac DSEAPSRV.PBL(dse_n_cst_filesrvwin16).2: Error C0001: Illegal data type: n_cst_filesrvwin16 DSEAPSRV.PBL(dse_n_cst_platformmac).2: Error C0001: Illegal data type: n_cst_platformmac DSEAPSRV.PBL(dse_n_cst_platformwin16).2: Error C0001: Illegal data type: n_cst_platformwin16 DSEAPSRV.PBL(dse_w_changepassword).dse_w_changepassword.dse_changepassword. 7...

Compiled version vs Dev. Running version
Hi I have a question : Why in dev. running my windows have border and when i compiled and execute, the same borders disappear. My windows are differents types : Main, response but all are not resizable. Thanks, Raynald MESSIE (MailTo:r.messie@ltp.fr) La T�lerie Plastique France All plastics boxes you need Visit our web site�: http://www.ltp.fr ...

Upgrade to PowerBuilder 9 or PowerBuilder 10?
Hi, Our company is going to upgrade PowerBuilder. Currently we are using version 7, and we are going to upgrade either to version 9 or 10. Does anyone have any recommendations if we should go for version 9 or 10? What is the current release of version 10, and is it stable or is there a lot of bugs? Best regards, Ronald Ommundsen e-mail: ronald.ommundsen@gard.no Ron; If you have any hope of running the applications in the future on XP, W2003 or soon to be W2006 (LongHorn) you will have to jump over to UniCode - ie PB10. So personally, I would recommend starting with P...

PowerBuilder 9 problem
I am not sure if this is the newsgroup to public this message. I am gettin the following Error message box in PB9 3519: No-charge evaluation period has expired. Please contact Sybase to purchase. I installed PB9 evaluaiton (test,beta) version a few days ago. I am getting this message when I work with web targest. I am trying to create a JSP and in one stage after choosing EAS component I am getting the message. Or if I import an existing JSP and try to open. I really wanted to sea this new PB feature, that is why I downloaded it. It is very important for me to see how it works in...

PowerBuilder 9.0 and PowerBuilder 10.0
Hello NG ,,, I have a strange problem , installed both versions of PowerBuilder on the same machine having Windows XP. under Program files\Sybase9 - > PB9.0 was installed . under Program files\Sybase10- > PB10.0 was installed, I was working on XML workspace in PB9.0 where in the library list PBDOM90.PBD was included. By mistake , I opened the same workspace in PB10.0 and the application was migrated completed. Later coming back to PB9.0 and opening the same workspace , found that , in the system tree PDB files has zero object, It is not showing anything and the appl...

Version of PowerBuilder (ref: Creating database for PowerBuilder)
I'm using PowerBuilder v8.0 and would like to create a notification system for my practiculum project. I'd like to use Access to create the database. Please enlighten me on what should I create (e.g. tables, queries) for the usage of it. Thank You. Regards, Yang Ashra Don't double post, it's bad etiquette. Unless you have a very good reason to do so, we recommend you don't use Access. Use SQL Anywhere instead - it's more stable - and a far better database in my opinion. PowerBuilder (enterprise) supports just about every database out there, so if you...

Running VS 03 and VS 05 with MS SQL 2000 and 2005 alongside each other with problems
I've recently installed the VS 2005 and MS SQL Server 05 alongside to VS 2003 and  MSDE 2000.I had no problems connecting to the SQL server before I installed the new versions, but now I get:[DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied. The server is running, the SA account has a password and it's set to Mixed Authentication.The connection string I use is:Provider=sqloledb;Network Library=DBMSSOCN;Data Source=127.0.0.1,1433;Initial Catalog=HD58;User ID=sa;Password=password;What needs to be changes in order to connect again ? I've tried everything I c...

Run function Problem In PowerBuilder
I have a problem with "run" function. When I use this function to call an external program, it runs the external program, but does not wait external program to end -- MEANING THE FOCUS DOES NOT STAY ON THE EXTERNAL APPLICATION BUT GOES BACK TO THE CALLER APPLICATION. Is there a way to make make the focus stay on the external application until it finishes? You need to use the CreateProcess API function. Check out this link for an excellent example: http://www.topwizprogramming.com/ Search the free code for RunandWait. Brad Ben @ TQM wrote: > I have a pr...

Web resources about - Problem running in PowerBuilder 9.03 IDE vs. compile version - sybase.powerbuilder.general

PowerBuilder - Wikipedia, the free encyclopedia
PowerBuilder is an integrated development environment owned by Sybase , a division of SAP . It has been in use since 1991, peaking around 1998 ...

Sybase PowerBuilder tool readied for Microsoft's .Net
... Win32 or newer style .Net development After several years of work, Sybase is ready to deliver on the final step in its plan to move PowerBuilder ...

Jim O'Neil (@jimoneil) on Twitter
Sign in Sign up To bring you Twitter, we and our partners use cookies on our and other websites. Cookies help personalize Twitter content, tailor ...

Open Directory - Computers: Programming: Languages
about dmoz - dmoz blog - report abuse/spam - help the entire directory only in Programming/Languages Description Top : Computers : Programming ...

The HP Booth Staff (Goons) Owe Me an Apology
... when you might need to use it. For instance, when I was in the WinRunner world there were plugins for driving terminal emulators and powerbuilder ...

Contact Us - Sybase Inc
Thanks for visiting the 主页 section of Sybase.com. Here you will find information about Contact Us. For more information about Business Intelligence, ...

热门搜索 - 我的异常网
... 我的异常网 » 热门搜索 sdpnet2 移动【A111】其它用户原因鉴权失败,是什么意思啊 http:// 192.168.1.102:22578 本网站服务器位于美国,受美国法律保护 MiniUI js 破解 http://192.168.1.103:8080/ powerbuilder ...

Mobile app security: Always keep the back door locked
The best way to keep mobile apps safe is to secure the services they connect to.

10 Tech Skills That Will Instantly Net You A $100,000+ Salary
... that let's developers run Java applications. Java is highly popular language for writing web apps and custom enterprise apps. No. 8: PowerBuilder ...

Top Ranked Articles
Top Ranked Articles - Free source code and tutorials for Software developers and Architects.; Updated: 23 Feb 2013

Resources last updated: 1/2/2016 2:37:46 AM