Powerbuilder application "crashing" another powerbuilder application

This is a repost of the above subject since there has been some problem for 
messages posted on the 19th - 22nd July 2002.
***************

Hi All,

I have an application (App A)built using PB7.0.3 build 10077 and it
seems to work fine. However, recently, another application (App B)
built using PB 7.0.3 build 10047 as well was installed and it seems to
trigger Dr Watson on App A.

There is an embedded OCX on a "main" window on App A, which receives
triggers from external applications. The OCX will then call another
function sitting on another main window. That function will then
"post" (ie not trigger) certain activities on the application.

Dr Watson on App A appears when there is a trigger to the OCX and when
the focus of the windows is on App B. However, if the focus is on App
A, no Dr Watson is observed.

There has also been cases of Dr Watson appearing when
1) Toggling between applications
2) Performing update activies on App B

App A works fine if App B is not launched.

Please advise as to which area I should look into to identify the
problem.

Could the problem lie within the OCX? or could there have be a
conflict of Powerbuilder dlls? If it is the dlls, is there a
workaround?

The Dr Watson message generated was : "Access Violation"

Thanks.

Regards,
Li Lin
NB: There are other powerbuilder applications built on PB version 6.0
running on the same PC and they seem to be pretty stable.

0
Li_Lin
7/24/2002 4:41:09 PM
sybase.powerbuilder.general 62418 articles. 14 followers. Follow

8 Replies
945 Views

Similar Articles

[PageSpeed] 54

There is a document on my.sybase that may help:

my.sybase.com/detail?id=47783

This describes how to set up multiple versions of PB on the same machine.

--
Regards,
Millard[TeamSybase]
Power3, LLC
http://www.power3.com

Useful links:
NEW PB9 Book Information: http://www.pb9book.com
My Sybase:  http://my.sybase.com
SDN:  http://www.sybase.com/developer
Google search:  http://groups.google.com



<Li_Lin> wrote in message
news:A19E19ED552FD5EB005BA87B85256C00.005BA89085256C00@webforums...
> This is a repost of the above subject since there has been some problem
for
> messages posted on the 19th - 22nd July 2002.
> ***************
>
> Hi All,
>
> I have an application (App A)built using PB7.0.3 build 10077 and it
> seems to work fine. However, recently, another application (App B)
> built using PB 7.0.3 build 10047 as well was installed and it seems to
> trigger Dr Watson on App A.
>
> There is an embedded OCX on a "main" window on App A, which receives
> triggers from external applications. The OCX will then call another
> function sitting on another main window. That function will then
> "post" (ie not trigger) certain activities on the application.
>
> Dr Watson on App A appears when there is a trigger to the OCX and when
> the focus of the windows is on App B. However, if the focus is on App
> A, no Dr Watson is observed.
>
> There has also been cases of Dr Watson appearing when
> 1) Toggling between applications
> 2) Performing update activies on App B
>
> App A works fine if App B is not launched.
>
> Please advise as to which area I should look into to identify the
> problem.
>
> Could the problem lie within the OCX? or could there have be a
> conflict of Powerbuilder dlls? If it is the dlls, is there a
> workaround?
>
> The Dr Watson message generated was : "Access Violation"
>
> Thanks.
>
> Regards,
> Li Lin
> NB: There are other powerbuilder applications built on PB version 6.0
> running on the same PC and they seem to be pretty stable.
>


0
Millard
7/24/2002 8:14:05 PM
There was a similar problem listed by Dale Fox (see URL as below)

<a 
href="http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&threadm=pL0vCVrxAHA.205%40forums.sybase.com&rnum=2&prev=/groups%3Fq%3D%2522treeview%2522%2B%252B%2B%2522response%2Bwindow%2522%26hl%3Den%26lr%3D%26ie%3DUTF-8%26oe%3DUTF-8">URL
</a>

Terry Voth(from TeamSybase)was replying to that problem.

Was there any resolution to that problem?

Regards,
Li Lin




0
Li_Lin
7/25/2002 5:29:36 AM
Make sure that the PB runtime DLLs of the appropriate version are in the
same directory as each of the applications.

--
All views expressed in this message are my own and not necessarily those of
my employer


<Li_Lin> wrote in message
news:A19E19ED552FD5EB005BA87B85256C00.005BA89085256C00@webforums...
> This is a repost of the above subject since there has been some problem
for
> messages posted on the 19th - 22nd July 2002.
> ***************
>
> Hi All,
>
> I have an application (App A)built using PB7.0.3 build 10077 and it
> seems to work fine. However, recently, another application (App B)
> built using PB 7.0.3 build 10047 as well was installed and it seems to
> trigger Dr Watson on App A.
>
> There is an embedded OCX on a "main" window on App A, which receives
> triggers from external applications. The OCX will then call another
> function sitting on another main window. That function will then
> "post" (ie not trigger) certain activities on the application.
>
> Dr Watson on App A appears when there is a trigger to the OCX and when
> the focus of the windows is on App B. However, if the focus is on App
> A, no Dr Watson is observed.
>
> There has also been cases of Dr Watson appearing when
> 1) Toggling between applications
> 2) Performing update activies on App B
>
> App A works fine if App B is not launched.
>
> Please advise as to which area I should look into to identify the
> problem.
>
> Could the problem lie within the OCX? or could there have be a
> conflict of Powerbuilder dlls? If it is the dlls, is there a
> workaround?
>
> The Dr Watson message generated was : "Access Violation"
>
> Thanks.
>
> Regards,
> Li Lin
> NB: There are other powerbuilder applications built on PB version 6.0
> running on the same PC and they seem to be pretty stable.
>


0
Simon
7/25/2002 8:37:58 AM
....also ensure that there aren't any PB DLLs elsewhere in the path, eg
Windows or Windows/System.

--
All views expressed in this message are my own and not necessarily those of
my employer


"Simon Caldwell [TeamSybase]" <simonDOTcaldwellATbigfootDOTcom> wrote in
message news:GATlyg7MCHA.317@forums.sybase.com...
> Make sure that the PB runtime DLLs of the appropriate version are in the
> same directory as each of the applications.
>
> --
> All views expressed in this message are my own and not necessarily those
of
> my employer
>
>
> <Li_Lin> wrote in message
> news:A19E19ED552FD5EB005BA87B85256C00.005BA89085256C00@webforums...
> > This is a repost of the above subject since there has been some problem
> for
> > messages posted on the 19th - 22nd July 2002.
> > ***************
> >
> > Hi All,
> >
> > I have an application (App A)built using PB7.0.3 build 10077 and it
> > seems to work fine. However, recently, another application (App B)
> > built using PB 7.0.3 build 10047 as well was installed and it seems to
> > trigger Dr Watson on App A.
> >
> > There is an embedded OCX on a "main" window on App A, which receives
> > triggers from external applications. The OCX will then call another
> > function sitting on another main window. That function will then
> > "post" (ie not trigger) certain activities on the application.
> >
> > Dr Watson on App A appears when there is a trigger to the OCX and when
> > the focus of the windows is on App B. However, if the focus is on App
> > A, no Dr Watson is observed.
> >
> > There has also been cases of Dr Watson appearing when
> > 1) Toggling between applications
> > 2) Performing update activies on App B
> >
> > App A works fine if App B is not launched.
> >
> > Please advise as to which area I should look into to identify the
> > problem.
> >
> > Could the problem lie within the OCX? or could there have be a
> > conflict of Powerbuilder dlls? If it is the dlls, is there a
> > workaround?
> >
> > The Dr Watson message generated was : "Access Violation"
> >
> > Thanks.
> >
> > Regards,
> > Li Lin
> > NB: There are other powerbuilder applications built on PB version 6.0
> > running on the same PC and they seem to be pretty stable.
> >
>
>


0
Simon
7/25/2002 8:39:02 AM
Dale's problem seemed to be specifically related to treeviews. I'm not
aware of whether or not he came up with a solution.

In your case, my first inclination would be to suspect that it's a
poorly behaved OCX. However, proving that will be quite a challenge.

Good luck,

Terry [TeamSybase] and Sequel the techno-kitten

On Thu, 25 Jul 2002 01:29:36 -0400, Li_Lin wrote:

>There was a similar problem listed by Dale Fox (see URL as below)
>
><a 
>href="http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&threadm=pL0vCVrxAHA.205%40forums.sybase.com&rnum=2&prev=/groups%3Fq%3D%2522treeview%2522%2B%252B%2B%2522response%2Bwindow%2522%26hl%3Den%26lr%3D%26ie%3DUTF-8%26oe%3DUTF-8">URL
></a>
>
>Terry Voth(from TeamSybase)was replying to that problem.
>
>Was there any resolution to that problem?


Sequel's Sandbox: http://www.techno-kitten.com
Home of PBL Peeper, a PowerBuilder Developer's Toolkit. 
Version 2.1.01 now available at the Sandbox
^ ^
o o
=*=
0
Terry
7/25/2002 5:56:14 PM
I was advised to upgrade to build 10160 for PB 7.0.3.

However, I can't seem to locate it on the Sybase Developer website.

Would appreciate it if you could direct me to the correct location.

Regards,
Li Lin


"Terry Voth" <sequel@techno-kitten.com> wrote in message
news:sqe0kukt1lhi6296nk9e85a8pqqt67990f@4ax.com...
> Dale's problem seemed to be specifically related to treeviews. I'm not
> aware of whether or not he came up with a solution.
>
> In your case, my first inclination would be to suspect that it's a
> poorly behaved OCX. However, proving that will be quite a challenge.
>
> Good luck,
>
> Terry [TeamSybase] and Sequel the techno-kitten
>
> On Thu, 25 Jul 2002 01:29:36 -0400, Li_Lin wrote:
>
> >There was a similar problem listed by Dale Fox (see URL as below)
> >
> ><a
>
>href="http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&threadm=p
L0vCVrxAHA.205%40forums.sybase.com&rnum=2&prev=/groups%3Fq%3D%2522treeview%2
522%2B%252B%2B%2522response%2Bwindow%2522%26hl%3Den%26lr%3D%26ie%3DUTF-8%26o
e%3DUTF-8">URL
> ></a>
> >
> >Terry Voth(from TeamSybase)was replying to that problem.
> >
> >Was there any resolution to that problem?
>
>
> Sequel's Sandbox: http://www.techno-kitten.com
> Home of PBL Peeper, a PowerBuilder Developer's Toolkit.
> Version 2.1.01 now available at the Sandbox
> ^ ^
> o o
> =*=


0
Li
7/25/2002 6:41:57 PM
If you were advised by Sybase support, they should be pointing you to
the right place. However, the latest public build is 10135 (under the
label "PowerBuilder Enterprise - 7.0.3 Release for EAServer 4.1.1").
Ever teach your kids not to take candy from strangers? Well, I'd
consider suggestions to take private builds from someone other that
tech support in the same light, unless there was pretty good evidence
that this build documented that it solved your problem and a public
build didn't.

Good luck,

Terry [TeamSybase] and Sequel the techno-kitten

On Fri, 26 Jul 2002 02:41:57 +0800, "Li Lin Ng"
<li_lin_ng@hotmail.com> wrote:

>I was advised to upgrade to build 10160 for PB 7.0.3.
>
>However, I can't seem to locate it on the Sybase Developer website.
>
>Would appreciate it if you could direct me to the correct location.
>
>Regards,
>Li Lin
>
>
>"Terry Voth" <sequel@techno-kitten.com> wrote in message
>news:sqe0kukt1lhi6296nk9e85a8pqqt67990f@4ax.com...
>> Dale's problem seemed to be specifically related to treeviews. I'm not
>> aware of whether or not he came up with a solution.
>>
>> In your case, my first inclination would be to suspect that it's a
>> poorly behaved OCX. However, proving that will be quite a challenge.
>>
>> Good luck,
>>
>> Terry [TeamSybase] and Sequel the techno-kitten
>>
>> On Thu, 25 Jul 2002 01:29:36 -0400, Li_Lin wrote:
>>
>> >There was a similar problem listed by Dale Fox (see URL as below)
>> >
>> ><a
>>
>>href="http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&threadm=p
>L0vCVrxAHA.205%40forums.sybase.com&rnum=2&prev=/groups%3Fq%3D%2522treeview%2
>522%2B%252B%2B%2522response%2Bwindow%2522%26hl%3Den%26lr%3D%26ie%3DUTF-8%26o
>e%3DUTF-8">URL
>> ></a>
>> >
>> >Terry Voth(from TeamSybase)was replying to that problem.
>> >
>> >Was there any resolution to that problem?


Sequel's Sandbox: http://www.techno-kitten.com
Home of PBL Peeper, a PowerBuilder Developer's Toolkit. 
Version 2.1.01 now available at the Sandbox
^ ^
o o
=*=
0
Terry
7/25/2002 9:41:59 PM
Hi,

The problem has been solved when i put in PB7.0.3 build 10160.

http://info.sybase.com/CGI-BIN/OM_ISAPI.DLL?clientID=163285&advquery=10160&i
nfobase=tstex4.nfo&record={D5E}&recordswithhits=on&softpage=Document

The case description is similar to the problem that I had.

Case Description:
PB 7.0.3 10079 (Build). Dr Watson error appears when clients go from one
apps to another. If they open windows in Apps A and switch to Apps B prior
to apps A window actually displaying, it causes Dr. Watson in apps A.

and the reason provided was "PFC crash".

Hope this helps others who face the same problem.

Regards,
Li Lin


0
Li
9/1/2002 1:58:14 PM
Reply:

Similar Artilces:

ConnectToNewObject( "PowerBuilder.Application" )
The following code runs without problem on development workstation, but fails when deployed to workstation with only runtime files deployed. PBObject = Create oleObject iResult = PBObject.ConnectToNewObject( "PowerBuilder.Application" ) iResult returns -2 Search of registry found that "PowerBuilder.Application" is registered on workstations with PowerBuilder deployed on, but is not on workstations with runtime deployed. Have tried registering pbvm90.dll, but get error message pbvm90.dll was loaded, but the DllRegisterServer entry point was not found. Not...

pbobj.connectToNewObject("Powerbuilder.Application")
I am using this to create a GUID. OLEObject pbobj string ls_guid long ll_rc pbobj = create OLEObject pbobj.connectToNewObject("Powerbuilder.Application") ll_rc = pbobj.generateguid(ref ls_guid) When I run locally it works, I get a GUID every time. If I build my application and deploy it I don't get the GUID. Is there any powerbuilder dll that I need to include in my deployment for this to work. The rpcrt4.dll is in the path in the C:\WINNT\System32 directory. When deployed the application is running through citrix would this cause an ...

Error on server.create object ("powerbuilder.application")
ERROR server.createobject ("powerbuilder.application") fails with the deployment dlls only installed. ERROR MESSAGE IS "Automation Error The object invoked has disconnected from it's client" OR "invalid callee" WORKS FROM Stripped down powerbuilder install. By stripped down we mean just the deployment DLLs (ex. pbvm70.dll, pbaen.tbl, libjcc.dll, pbdwe70.dll). No other Powerbuilder DLLS or EXEs (cleared Sybase directories). DOESN'T WORK FROM Doing standard deployment, running pbappl.reg and other basic tasks. Will run a pb.exe. HAV...

PowerBuilder 7 Error "The application failed to initialize properly"
Hi, I am using PowerBuilder 7.0.02 on MS Window XP Professional Version 2002 Service Pack 2. When I start PowerBuilder application (PB70.exe), the error msg "The application failed to initialize properly (0xc0000005). Click on OK to terminate the application" (pls see the attach for reference). When I click OK, the PowerBuilder terminates, and I cannot start the PowerBuilder. Re-installing cannot solve this problem. Anyone got the same problem before?? Is there any solutions/workaround?? Thanks very much. Eric begin 666 PB70Error.JPG M_]C_X `02D9)1@`!`0$`...

Different behavior of " encrypt.dll " in PowerBuilder 8 and in Powerbuilder 10.2
Different behavior of " encrypt.dll " in PowerBuilder 8 and in Powerbuilder 10.2 1.. Will PB 10.2 support encrypt.dll ? 2.. My code was working in PB 8 but in PB 10 it is not working I don't know what is issue Like if I give password in PB 8 "mike_" it is working fine but same password I give in PB 10 then it is not working. Is any issue with Unicode ? code of declaration of external fn. private function ulong n_cst_ssisecurity32_CPP_CONSTRUCTOR() library 'encrypt.dll' private subroutine n_cst_ssisecurity...

Different behavior of " encrypt.dll " in PowerBuilder 8 and in Powerbuilder 10.2
Different behavior of " encrypt.dll " in PowerBuilder 8 and in Powerbuilder 10.2 1.. Will PB 10.2 support encrypt.dll ? 2.. My code was working in PB 8 but in PB 10 it is not working I don't know what is issue Like if I give password in PB 8 "mike_" it is working fine but same password I give in PB 10 then it is not working. Is any issue with Unicode ? code of declaration of external fn. private function ulong n_cst_ssisecurity32_CPP_CONSTRUCTOR() library 'encrypt.dll' private subroutine n_cst_ssisecurity32_C...

I say "build", PowerBuilder says "nah"
I'm trying to deploy a project for use in Jaguar. I've done it a hundred times... I open the project, change some properties, click the "build" button, and all goes smoothly. Sometimes. Other times everything looks good - it deploys fine, I see a new Cx folder in the Jaguar repository with a new pbd file as usual... but Jaguar can't find it. Jaguar says ERROR: OBJECT_NOT_EXIST in it's log, and that's that. What's also disturbing (but not surprising) is that I can delete that folder and the OS doesn't complain... Jaguar is *not* using the pbd I ...

How To Set "Trial Application" and "Bound To This Machine" .NET application only
Hi, This is the first time I made a web application for a client. Since he has not paid me, what should I do so that the application will terminate within x days starting from the day I install the application in his server ? And is it possible to make application works on his server only ? I don't want the files copied without my permission.   Thank you very much for your attention.  ===================================Don't Quote And Flame Me If I Am Wrong===================================...

Hash arrays ("associative arrays" / "dictionaries") for PowerBuilder
One thing I miss in PowerBuilder development is something like a hash array. Are there any good* implementations/solutions out for PB? (I use PB9/PB11 for "normal applications" - no JAVA/.NET/Web targets) *good means for me: - no special runtime requirements like additional OLE components or special Windows components (like the .NET framework) - it shouldn't have much overhead Is there a PBNI implementation? Hi JKorth, it should not be that hard to implement using datastore. Have you checked pfc if it contains what you need ? Regards JKorth pisze: >...

Can we call Powerbuilder objects from "C" or "C++" or Java
Hi, We are moving our application to Web. We are using Java and Java beans. Our current application is running on Powerbuilder 6.5. We have very good reports generated in Powerbuilder. We want to call these reports from other middleware and also We want to call powerbuilder objects(business layers written in Userobjects) from C or Java. Please can you suggest me. Can you tell me how can call powerbuilder objects will be usefull in web development. Thanks If you put the NVO's into CORBA components in a Jaguar transaction server, any CORBA complient client can g...

I want add "Application" & "Application Version" to Bugzilla 2.22rc1
RGVhciBhbGwsCgpIZWxwIG1lLgpJIHdhbnQgYWRkICJBcHBsaWNhdGlvbiIgJiAiQXBwbGljYXRp b24gVmVyc2lvbiIgZmllbGQgdG8gbXkgYnVnemlsbGEKc3lzdGVtLgpUaGUgIkFwcGxpY2F0aW9u IiAmICJBcHBsaWNhdGlvbiBWZXJzaW9uIiBpcyB0YWcgYWxvbmcgIkNvbXBuZW50Igp2YWx1ZS4K Q2FuIHlvdSB0ZWxsIG1lIGhvdyB0byBhZGQgdHdvIEZpZWxkIG9yIGdpdmUgbWUgZXhhbXBsZS4K Cqfat1GmYqfaqrpidWd6aWxsYaRXvFelW6jirdPE5qbsrLAiQXBwbGljYXRpb24iICYKIkFwcGxp Y2F0aW9uIFZlcnNpb24iCrNvqOKt08TmpuxteXNxbKVEweStyKxPuPLASFByb2RjdXSkuqq6Q29t cG9uZW50cwqn2rjTpnCm87dzvFep0qazrNvD9qq6pmGk6G9yvdav4LW5p9rD/qb8qrq9ZKjSCgpU aGFua3MhCkJSLApTaGVuCg== SXQncyBub3QgaGFyZCBhdCBhb...

superreview cancelled: [Bug 207306] plugin host should be destoryed on Observe() "NS_XPCOM_SHUTDOWN_OBSERVER_ID" rarther than on "quit-application" : [Attachment 178831] remove "quit-application"
timeless@myrealbox.com (working) <timeless@bemail.org> has cancelled Justin Wood (Callek on irc) <116057@bacon.qcc.mass.edu>'s request for superreview: Bug 207306: plugin host should be destoryed on Observe() "NS_XPCOM_SHUTDOWN_OBSERVER_ID" rarther than on "quit-application" https://bugzilla.mozilla.org/show_bug.cgi?id=207306 Attachment 178831: remove "quit-application" https://bugzilla.mozilla.org/attachment.cgi?id=178831&action=edit ------- Additional Comments from timeless@myrealbox.com (working) <timeless@bemail.org> don&...

superreview requested: [Bug 207306] plugin host should be destoryed on Observe() "NS_XPCOM_SHUTDOWN_OBSERVER_ID" rarther than on "quit-application" : [Attachment 178831] remove "quit-application"
Justin Wood (Callek on irc) <116057@bacon.qcc.mass.edu> has asked Johnny Stenback <jst@mozilla.org> for superreview: Bug 207306: plugin host should be destoryed on Observe() "NS_XPCOM_SHUTDOWN_OBSERVER_ID" rarther than on "quit-application" https://bugzilla.mozilla.org/show_bug.cgi?id=207306 Attachment 178831: remove "quit-application" https://bugzilla.mozilla.org/attachment.cgi?id=178831&action=edit ...

superreview requested: [Bug 207306] plugin host should be destoryed on Observe() "NS_XPCOM_SHUTDOWN_OBSERVER_ID" rarther than on "quit-application" : [Attachment 181065] remove "quit-application" [co
Justin Wood (irc: Callek) <bugspam.Callek@gmail.com> has asked Johnny Stenback <jst@mozilla.org> for superreview: Bug 207306: plugin host should be destoryed on Observe() "NS_XPCOM_SHUTDOWN_OBSERVER_ID" rarther than on "quit-application" https://bugzilla.mozilla.org/show_bug.cgi?id=207306 Attachment 181065: remove "quit-application" [correctly] https://bugzilla.mozilla.org/attachment.cgi?id=181065&action=edit ------- Additional Comments from Justin Wood (irc: Callek) <bugspam.Callek@gmail.com> This actually removes the AddObserve...

Web resources about - Powerbuilder application "crashing" another powerbuilder application - sybase.powerbuilder.general

Resources last updated: 12/8/2015 9:53:00 AM