Powerbuilder 11.1 using WebServices .net 3.5 Framework

Hi All,

I've created a "Hello World" web service using Visual Studio 2008 with
3.5 .net Framework, tested the web service and it works fine. Deployed
the web service to a IIS 5.0 Web server on Windows XP Pro; now I'm
trying to generate the WebService proxy in PB 11.1. I've set the WSDL
engine to ".Net", point to the IIS server for the ".asmx" file for the
WSDL location. When I try to deploy the project, I keep getting the
following error.

"Cannot access the WSDL or the WSDL file is invalid. (file://bla bla
bla)

Is PB compatiable with the 3.5 .NET framework, or is there something
else that I may be missing?

Thanks in advance for any help.
0
TGJunkie
7/2/2009 11:04:19 PM
sybase.powerbuilder.general 62418 articles. 18 followers. Follow

2 Replies
628 Views

Similar Articles

[PageSpeed] 56

Did you add the ?wsdl to the url? Is the WSDL shown when you call the
URL in a browser?

Arthur
TGJunkie wrote:

> Hi All,
> 
> I've created a "Hello World" web service using Visual Studio 2008 with
> 3.5 .net Framework, tested the web service and it works fine. Deployed
> the web service to a IIS 5.0 Web server on Windows XP Pro; now I'm
> trying to generate the WebService proxy in PB 11.1. I've set the WSDL
> engine to ".Net", point to the IIS server for the ".asmx" file for the
> WSDL location. When I try to deploy the project, I keep getting the
> following error.
> 
> "Cannot access the WSDL or the WSDL file is invalid. (file://bla bla
> bla)
> 
> Is PB compatiable with the 3.5 .NET framework, or is there something
> else that I may be missing?
> 
> Thanks in advance for any help.

0
Arthur
7/3/2009 3:40:03 AM
There seems to be a problem in PB 11 with the .Net Framework
3.5. A few days ago before I had installed the .Net
Framework 3.5 and 3.5 SP1, I was able to generate the proxy
for a .Net web service of our partner, but I got the error
"The definition of
the method signature in Web Service proxy is wrong." I
searched the Sybase news group site for this error and found
two pages that say this bug was fixed in 10.5 on 4/16/2008.
Since I had installed PB 11 on 8/27/2007, I thought that I
needed the 11.2 patches. I did apply all those 11.2 patches.
But now I am getting the same error as you do. Worse for me,
PB gets stucked at SoapConnection.createInstance(), forever,
indefinitely, no return! I also have a proxy for a Java web
service and it used to work in 11, now with the 11.2
patches, this does not work either and gets stucked at the
exact same place!

Ben
> Did you add the ?wsdl to the url? Is the WSDL shown when
> you call the URL in a browser?
>
> Arthur
> TGJunkie wrote:
>
> > Hi All,
> >
> > I've created a "Hello World" web service using Visual
> > Studio 2008 with 3.5 .net Framework, tested the web
> > service and it works fine. Deployed the web service to a
> > IIS 5.0 Web server on Windows XP Pro; now I'm trying to
> generate the WebService proxy in PB 11.1. I've set the
> > WSDL engine to ".Net", point to the IIS server for the
> > ".asmx" file for the WSDL location. When I try to deploy
> > the project, I keep getting the following error.
> >
> > "Cannot access the WSDL or the WSDL file is invalid.
> > (file://bla bla bla)
> >
> > Is PB compatiable with the 3.5 .NET framework, or is
> > there something else that I may be missing?
> >
> > Thanks in advance for any help.
>
0
Ben
7/7/2009 3:04:09 AM
Reply:

Similar Artilces:

PowerBuilder 10.5.2 Build 7826 differs from PowerBuilder 11.5.1 Build 4675
Apparently there's some data conversion issues that differ from PowerBuilder 10.5.2 and 11.5.1 (builds listed in subject). The following mini scrip results in different returned values: Byte lb_test Decimal ld_test lb_test = 48 ld_test = Dec(lb_test) MessageBox("Test", String(ld_test)) In PowerBuilder 10.5.2, the messagebox displays the value "48". In PowerBuilder 11.5.1 the messagebox displays the value "0.48". It appears that in PB 11.5.1, it's dividing the result by 100 for some reason. It appears to be a bug, just wanted to ve...

using .net framework 1.1 and 2.0 and 3.5 on same server
 i recently created application in 2.0 framework which is asp.net (C#) application ,i have old application running on same server (asp.net 1.1 C#),and in feature i want to deploy my asp.net C#  3.5 application on same server how to achieve all my application working on same server  with out stopping any of the application. thank you  Hi, you cannot run more than one framework within the same Application Pool.  How to fix problem? It’s pretty easy and can be done inside IIS 6.0 alone. Here’s the step by step procedure.http://www.kiko-santos.com/2006/06/runn...

Proplem with..Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Name: Tony Email: Accuscopeathotmaildotcodotuk Product: Firefox Summary: Proplem with..Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729) Comments: I have used Firefox for many years but I am not happy with latest version. You can set options such as home page and security and privacy settings but as soon as you close the browser and re start it remembers none of the settings??? Very frustrating! I have re-installed several times and rebooted every time but it always goes back to a default page as though I had just do...

ASP.NET Extensions CTP and .NET Framework 3.5 SP1/.NET Framework 3.5 and vs2008 sp1?
Can someone explain the differences/relationships between asp.net extensions ctp, .net framework 3.5 sp1/.net framwork 3.5, and vs2008 sp1? I currently have a web app built with vs2008 RTM, .net framework 3.5 (no sp), and asp.net extensions ctp.  The system.web.extensions for framework 3.5 is version 3.5.0.0 and for .net extensions ctp it is 3.6.0.0.  Can I replace all web references with the ctp version 3.6?     CTP = Community Technology Preview; these are something like beta versions that are released so that they can be tested. these are generally...

Smoke [5.11.3] v5.11.3-3-gc3c0aa2 FAIL(XF) netbsd 5.0.1 (i386/1 cpu)
Automated smoke report for 5.11.3 patch c3c0aa283b73660f84ae7e190dcbbd607facb512 v5.11.3-3-gc3c0aa2 p5netbsd: Intel 686-class (i386/1 cpu) on netbsd - 5.0.1 using cc version 4.1.3 20080704 prerelease (NetBSD nb2 20081120) smoketime 6 hours 47 minutes (average 50 minutes 57 seconds) Summary: FAIL(XF) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (after miniperl), t = ma...

Smoke [5.11.3] v5.11.3-5-g27bca32 FAIL(XF) netbsd 5.0.1 (i386/1 cpu)
Automated smoke report for 5.11.3 patch 27bca3226281a592aed848b7e68ea50f27381dac v5.11.3-5-g27bca32 p5netbsd: Intel 686-class (i386/1 cpu) on netbsd - 5.0.1 using cc version 4.1.3 20080704 prerelease (NetBSD nb2 20081120) smoketime 6 hours 44 minutes (average 50 minutes 37 seconds) Summary: FAIL(XF) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (after miniperl), t = ma...

Automated cleanup tool to remove the .NET Framework 1.0, 1.1, 2.0, 3.0 and 3.5
"I have posted an updated version of the .NET Framework cleanup tool that now contains support for automatically cleaning up the .NET Framework 1.0, the .NET Framework 1.1, the .NET Framework 2.0, the ..NET Framework 3.0 and the .NET Framework 3.5. This tool automates the manual cleanup steps for the .NET Framework 2.0 that I posted a while ago. These steps have helped solve most of the known .NET Framework 2.0 beta uninstall issues that I know of. In addition, the tool can be useful to return your system to a known (relatively clean) state in case you run into any .NET Framew...

Can we replace Microsoft .Net framework 3.5 with Microsoft .NET Compact Framework 3.5
Hi, I have installed vs2008 in C drive and removed it from there  including Microsoft .Net framework 3.5, due to space crunch, then I started installing it in D drive, in this case it did not install .Microsoft .Net framework 3.5 and now it does not show me Microsoft .Net framework 3.5 it shows .NET Compact Framework 3.5 in Add remove program list. My question is will VS2008 work fine with .NET Compact Framework 3.5. apart from it it also has .NET Framework 3.5 SP1 in the list, all what is missing is microsoft .net framework 3.5  Please let me know ...

Problem using Wine 1.1.49_1 on 11.3 and Wine 1.3.12-3.4 11.4
I have a problem using Wine on openSUSE 11.3 and 11.4 Not this used to work fine for opensuse 10.2 i think i should explain a scenario here first. I am using self contained encrypted usb memory stick which is primarily design for windows XP. they way i used it on 10.2 is as follows: - plug in usb device and mount it to a folder (mount -t vfat /dev/sda1 /media/temp) - goto that particular folder and run exe file using wine. - it displays an explorer window to input password - when password is typed in press enter and it will display the usb memory stick contents. Now on ...

powerbuilder 11.5 install and dotnet .net framework
Hi. I am seeing the error text pasted below when I start to install pb 11.5. Even on the phone with Microsoft, I have been unable to install .net so that pb is satisfied. This problem is occurring on a new 64 bit vista machine, but when I started to install 11.5 on my old 32 bit xp, the same error displayed. Another developer also mentioned seeing this error--but just continued with the installation. He does not need .net or web services. Does anyone know how to install .net when .net is apparently not properly installed (broken) and... cannot be uninstalled, and cannont be re...

Things for consideration while migrating a ASP.Net application from framework 1.1 to framework 3.5
  Hi Friends, I am working on a ASP.Net Intranet application.We have to migrate  that from framework 1.1 to framework 3.5. Can anybody tell me what are the things that I will have to consider at the time of migration or what could be the possible errors. Also plz let me know migrating the application to framework 3.5 ,will that help in increasing the performance also ? Thanks ,waiting for the reply.  Pritam hi my friend, It is really depend on  the project some time you need to change some namesapce and code. let me give you an example I can remmber in...

Version beforeMozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Name: James Kiekow Email: jamesdotkiekowathotmaildotcom Product: Firefox Summary: Version beforeMozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729) Comments: Dear Excellent Developers, I share a passion for the same in IT and I wanted to mention that I have the previous version of Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729) installed and it was extremely slow surfing the web so I upgraded and my assumption was correct it was the install I believe of th...

Plans for PowerBuilder 11.1 and 11.1.1
I want to announce that we are planning an 11.1 release for November of this year and the new features will be Incremental compile for .NET targets, Informix 10 support, and completion of our QA testing on Vista Then in February of 2008 we plan to release 11.1.1 that adds AJAX Support for Web Forms applications (to minimize postbacks), EAServer ..NET Client support, RAD controls for Web Form applications, to replace the IE Web Controls. Regards, Dave Fish Sybase Good grief ! Informix 10 finally !!! ... Now that version 11 is almost out there. Well That's good news. ...

Can I use all the Classes of .NET Framework 3.0 and 3.5 with ASP.NET 2.0?
Can I use all the Classes of .NET Framework 3.0 and 3.5 with ASP.NET 2.0?  If I can, then how can use? No you con't use them... If you are using Visual Studio 2008 try to create a WebSite with .netFrameWork 2.0 ... after creating the website try to add the reference... when add reference dialog box open you can see that all the 3.0 and 3.5 namespaces will be disabled .. you con't add the reference to the 3.0 and 3.5Chinna_sv...   parco:Can I use all the Classes of .NET Framework 3.0 and 3.5 with ASP.NET 2.0?  If I can, then how can use? I think you can, all you ...

Web resources about - Powerbuilder 11.1 using WebServices .net 3.5 Framework - sybase.powerbuilder.general

PowerBuilder - Wikipedia, the free encyclopedia
PowerBuilder is an integrated development environment owned by Sybase , a division of SAP . It has been in use since 1991, peaking around 1998 ...

Sybase PowerBuilder tool readied for Microsoft's .Net
... Win32 or newer style .Net development After several years of work, Sybase is ready to deliver on the final step in its plan to move PowerBuilder ...

Jim O'Neil (@jimoneil) on Twitter
Sign in Sign up To bring you Twitter, we and our partners use cookies on our and other websites. Cookies help personalize Twitter content, tailor ...

Open Directory - Computers: Programming: Languages
about dmoz - dmoz blog - report abuse/spam - help the entire directory only in Programming/Languages Description Top : Computers : Programming ...

The HP Booth Staff (Goons) Owe Me an Apology
... when you might need to use it. For instance, when I was in the WinRunner world there were plugins for driving terminal emulators and powerbuilder ...

Contact Us - Sybase Inc
Thanks for visiting the 主页 section of Sybase.com. Here you will find information about Contact Us. For more information about Business Intelligence, ...

热门搜索 - 我的异常网
... 我的异常网 » 热门搜索 sdpnet2 移动【A111】其它用户原因鉴权失败,是什么意思啊 http:// 192.168.1.102:22578 本网站服务器位于美国,受美国法律保护 MiniUI js 破解 http://192.168.1.103:8080/ powerbuilder ...

Mobile app security: Always keep the back door locked
The best way to keep mobile apps safe is to secure the services they connect to.

10 Tech Skills That Will Instantly Net You A $100,000+ Salary
... that let's developers run Java applications. Java is highly popular language for writing web apps and custom enterprise apps. No. 8: PowerBuilder ...

Top Ranked Articles
Top Ranked Articles - Free source code and tutorials for Software developers and Architects.; Updated: 23 Feb 2013

Resources last updated: 12/6/2015 1:56:20 AM