PB12 Classic - Web Service - "could not get TCP protocol struct"

Hello,
We recently upgraded to PB12 (Classic), and are having an odd problem.

When we deploy the application, our web services are working for every
terminal except for one.  It throws an error: "Could not get TCP protocol
struct."

I believe the problem line is when we call CreateInstance on the
SoapConnection object.

Has anyone seen this before, or do you know how to resolve it?  We've gone
through the same installation on each machine, including installing the PB12
runtimes.

(I tried posting in the webservice group, but I got an error saying I didn't 
have permissions to do so)

Thanks,
-Ricky


0
Ricky
1/13/2011 9:13:39 PM
sybase.powerbuilder.general 62418 articles. 11 followers. Follow

0 Replies
1130 Views

Similar Articles

[PageSpeed] 43

Reply:

Similar Artilces:

Getting (Bad protocol 'tcp') errors under Solaris
--nextPart5592645.ZYMlcV9hof Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable Content-Disposition: inline I've got a small script that uses LWP::UserAgent that all of a sudden, or s= o=20 it seems, just stopped working. It simply takes a file and tries to upload = it=20 to a CGI. It works under Linux and some of my other Solaris boxes, but this= =20 one particular machine gives me this error: dnmcimincw13:web# ./foo.pl moo.zip CONTENT: 500 (Internal Server Error) Can't connect to rt.innocent.com:443 (= Bad=20 protoc...

Anyone Using ThirdParty Tool for TCP/IP in PB12 Classic?
Comm is not my forte. An entire suite of apps I support are stuck in PB8 because the third-party OLE that does the TCP/IP comm won't work in PB12. The vendor, Dart, has a new object I've tried, but it doesn't work either, and "the market for PB dev is too small for us to figure out why, unless you pay us." This is an app that is sending trxns to a clearinghouse and expecting confirmation messages back. This is not the #1 priority at this company, and they are rewriting the whole system in VC# .Net because PB took too long to get its s**y back, but I'm ...

RE: Getting (Bad protocol 'tcp') errors under Solaris
Michael J. Freeman wrote: > I've got a small script that uses LWP::UserAgent that all of a > sudden, or so it seems, just stopped working. It simply takes a file > and tries to upload it to a CGI. It works under Linux and some of my > other Solaris boxes, but this one particular machine gives me this > error:=20 >=20 > dnmcimincw13:web# ./foo.pl moo.zip > CONTENT: 500 (Internal Server Error) Can't connect to > rt.innocent.com:443 (Bad protocol 'tcp') > Content-Type: text/plain Hmmm... Well, 443 is the default port for https traffic....

pb12 classic to PB12.net translation
Hi, I'm currently trying to bring our application to pb12.net but have encountered an error which I can't seem to trace. The call is ambiguous between the following methods or properties: 'Sybase.Powerbuilder.PBSystemFunctions.PBCheckNull(Sybase.Powerbuilder.PBPowerObject)' and 'Sybase.Powerbuilder.PBSystemFunctions.PBCheckNull(Sybase.Powerbuilder.PBAny)' line 15 column 218 The error is not linked to any particular object in the solution. I have a feeling that this happens during the conversion to C#, but not certain how that could be verified....

TCP/IP Protocol Stack Zero Window Size Remote Denial Of Service Vulnerability
Bugtraq ID: 31545 Class: Unknown CVE: CVE-2008-4609 KB967723 Remote: Yes Local: No Published: Oct 02 2008 12:00AM Updated: Sep 08 2009 06:01PM Credit: Robert E. Lee and Jack C. Lewis Not Vulnerable: http://www.securityfocus.com/bid/31545 -- "If U know neither the enemy nor yourself,U will succumb in every battle" ==> Hmm, XP not listed as vulnerable. -- PhilGreg pgregory@fairepointe.net "parad0X" <parad0X@lupa.cc> wrote in message news:h868lj$8g3$1@ne...

Calling a PB12.Net NVO in PB12 Classic.
I have created a PB12 dot net nvo that accesses a wshttpwebservice and would like to call it from PB12 classic any suggestions and/or expamples on how to do that? run regasm on the assembly, and then call it from the classic app using COM. I've got an upcoming article in PBDJ that goes through all the steps in more detail. The good thing is that PB12 creates the assembly as COM visible automatically. Prior versions of PB marked them non-COM visible. Youl'll need to make sure your passing data to and from the assembly in rather simple datatypes, sinve you'll be go...

How to get Sysam service to start before Jaguar service
Any suggestions on how to get the sysam service to start before the jaguar service, so that jaguar starts up in AdvancedEdition mode, and not developer mode? Has anyone been able to setup the service dependencies in WIN2k? (if so, can you give me a hint!) Thanks, David I put the following line in my user_setenv.bat file: REM ** -- Start the CIM Repository -- call "C:\Program Files\Sybase\CIMRepository-3_0_0\bin\repository.bat" Jonathan -- Jonathan Baker eBusiness Division Sybase, Inc. "David Renton" <drenton_nospamme_@winmill....

POST GET GET GET GET... WTH?
Hi, I'm at a loss to explain this... I have an ASPX page that I can't always navigate to. When I developed the app (it's Starter Kit Portal-based), I did it on my LAN and have had no trouble accessing the page. However, upon deployment, I see the following behavior: 1. POST request goes out looking for MyForm.aspx 2. GET request for MyForm.aspx 3. GET request for MyForm.aspx 4. ... X. GET request Sometimes, the page finally loads. Other times, it just ends up blank. Many times, it doesn't load at ALL the first POST - I just get a "The pa...

Getting Error : While hosting WCF service over Window Service
 Hi,I created one window service project in visual studio 2005 and added following filesafter adding dll of system.ServiceModel and system.ServiceProcessnamespace CheckingWcFApplication{    [ServiceContract]    public interface IService    {        [OperationContract]        void ModifyServiceData();    }}namespace CheckingWcFApplication{    public class Service : IService    {        public voi...

TCP.NLM TCP General Memory growing 1MB/hour
After upgrade from BM 3.7 to 3.8, we have problems with droping NATed and Proxied connections, today I realized that "TCP General Memory" resoursces are growing constantly with about 1MB per hour till server is in low memory. I tried to upgrade to BM3.8 SP1 (Beta) without help (only problem with NAT was corrected) I'm using TCP.NLM 6.18.17 (domestic) on NW 6 SP4, server is working as VPN Master (S2S&C2S) and PROXY cache server, reverse proxy. Can somebody point me what I shoul check or analyze to get it stop growing. Thanks Ales Why don't you try t...

Service Protocols
I am attempting to rectify a problem with a Sybase SQL Anywhere v5.5.04 Network Server. The Server has the following parameters: ========================== -n ServiceName -c 128M -tl 600 (Database file location) ========================== No protocol is specified. The Service starts and informs me that the following have started successfully. NAMEDPIPES NETBIOS IPX TCPIP NETDG Generally, the service can be connected to via DBCLIENT.EXE without specifying the protocol. No problem here. However, on occasions, when the service is stopped and restarted, we are unable t...

What generals generally do
Reading a McChrystal thread elsewhere, I came across someone quoting a US general http://en.wikipedia.org/wiki/Smedley_Butler > I spent 33 years and four months in active military service and > during that period I spent most of my time as a high class thug for > Big Business, for Wall Street and the bankers. In short, I was a > racketeer, a gangster for capitalism. I helped make Mexico and > especially Tampico safe for American oil interests in 1914. I helped > make Haiti and Cuba a decent place for the National City Bank boys to > collect revenues in. I ...

How to getting custom protocol custom-protocol://some-uri-path to act like http to support page browser?
For example. custom-protocol://some-uri-path/test.html I want the test.html works like http://some-web-site/test.html That I can navigate in the html page. On 6/24/15 1:10 PM, Yonggang Luo wrote: > For example. > custom-protocol://some-uri-path/test.html > > I want the test.html works like > > http://some-web-site/test.html > That I can navigate in the html page. > Check out nsIProtocolHandler Here is an implementation that directly forwards to http(s): http://mxr.mozilla.org/comm-central/source/calendar/base/src/calProtocolHandler.js Ph...

Inline::Struct structs within structs
------_=_NextPart_001_01C11AA6.44BC50D0 Content-Type: text/plain; charset="iso-8859-1" Neil, I was playing with Inline::Struct today and noticed that it doesn't support nested structs. Here's a script to illustrate the point: use Inline C => <<'END' => STRUCTS => 1; struct POINT {int x; int y;}; struct RECT {POINT a; POINT b;}; END my $a = Inline::Struct::POINT(1,2); my $b = Inline::Struct::POINT(3,4); printf("a: [%d, %d]\n", $a->x, $a->y); printf("b: [%d, %d]\n", $b->x, $b->y); my $r = Inline::S...

Powerbuilder Service Program
Is it possible to write a powerbuilder program as a service program? For example, the master program will work as a 'add' service program. I write another program and send parameter 1 & 2 to the master program and it will return 3 (1 + 2). I know that it is possible to write a web service but I don't want to implement IIS on the client site. Thanks John Smith http://www.topwizprogramming.com/pbniserv.html Report Bugs to Sybase: http://case-express.sybase.com/cx/welcome.do Product Enhancement Requests: http://my.isug.com/cgi-bin/1/c/submit_enhancement ...

Web resources about - PB12 Classic - Web Service - "could not get TCP protocol struct" - sybase.powerbuilder.general

Resources last updated: 12/18/2015 10:53:43 PM