Migrate/Upgrade from PB 5.0.xx to PB 8.0/9.0

Hi,

I am having the PB 5.0.xx Applications running on my pc at this moment.

I have to Migrate/Upgrade them to PB 8/9.

What is the best way to get this?

Can any one give me some guidance on this?

Thanks for your Help in Advance

Regards


0
Srinivasa
10/27/2003 6:53:11 PM
sybase.powerbuilder.general 62418 articles. 17 followers. Follow

12 Replies
692 Views

Similar Articles

[PageSpeed] 44

Migrating:
- Backup
- Optimize in PB5
- Full Rebuild in PB5, with Information and Warning messages turned on
- Backup, send it offside
- Run Migration Assistant (File / New / Tools in PB8/9)
- Fix the identified issues using PB5
<doublechecking>
- Optimize in PB5
- Full Rebuild in PB5, with Information and Warning messages turned on
- Run Migration Assistant (File / New / Tools)
</doublechecking>
- Backup
- File / New / Workspace in PB8/9
- File / New / Target / Existing Application in PB8/9

Keep in mind that Sybase's support for PB8 will end 60-90 days after
the release of PB10, if the historical pattern prevails. PB10 is due
out 2004H1. That means you could get as little as six months before
PB8 is unsupported. Given the targeted release cycle that Sybase has
announced, moving to PB9 will give you an extra 12-18 months.

Good luck,

Terry [TeamSybase] and Sequel the techno-kitten

On 27 Oct 2003 11:53:11 -0700, "Srinivasa Rao Surabathini"
<srinivasa.rao@ntlworld.com> wrote:

>I am having the PB 5.0.xx Applications running on my pc at this moment.
>
>I have to Migrate/Upgrade them to PB 8/9.
>
>What is the best way to get this?
>
>Can any one give me some guidance on this?


Sequel's Sandbox: http://www.techno-kitten.com
Home of PBL Peeper, a free PowerBuilder Developer's Toolkit. 
Version 2.2.06 now available at the Sandbox
See the PB Troubleshooting Guide at the Sandbox
^ ^
o o
=*=
0
Terry
10/27/2003 8:24:57 PM
BTW, if you want to see everything that has changed in PB since PB5,
http://www.techno-kitten.com/Changes_to_PowerBuilder/changes_to_powerbuilder.html

Good luck,

Terry [TeamSybase] and Sequel the techno-kitten

On 27 Oct 2003 13:24:57 -0700, Terry Voth <sequel@techno-kitten.com>
wrote:

>Migrating:
>- Backup
>- Optimize in PB5
>- Full Rebuild in PB5, with Information and Warning messages turned on
>- Backup, send it offside
>- Run Migration Assistant (File / New / Tools in PB8/9)
>- Fix the identified issues using PB5
><doublechecking>
>- Optimize in PB5
>- Full Rebuild in PB5, with Information and Warning messages turned on
>- Run Migration Assistant (File / New / Tools)
></doublechecking>
>- Backup
>- File / New / Workspace in PB8/9
>- File / New / Target / Existing Application in PB8/9
>
>Keep in mind that Sybase's support for PB8 will end 60-90 days after
>the release of PB10, if the historical pattern prevails. PB10 is due
>out 2004H1. That means you could get as little as six months before
>PB8 is unsupported. Given the targeted release cycle that Sybase has
>announced, moving to PB9 will give you an extra 12-18 months.
>
>Good luck,
>
>Terry [TeamSybase] and Sequel the techno-kitten
>
>On 27 Oct 2003 11:53:11 -0700, "Srinivasa Rao Surabathini"
><srinivasa.rao@ntlworld.com> wrote:
>
>>I am having the PB 5.0.xx Applications running on my pc at this moment.
>>
>>I have to Migrate/Upgrade them to PB 8/9.
>>
>>What is the best way to get this?
>>
>>Can any one give me some guidance on this?
>
>
>Sequel's Sandbox: http://www.techno-kitten.com
>Home of PBL Peeper, a free PowerBuilder Developer's Toolkit. 
>Version 2.2.06 now available at the Sandbox
>See the PB Troubleshooting Guide at the Sandbox
>^ ^
>o o
>=*=


Sequel's Sandbox: http://www.techno-kitten.com
Home of PBL Peeper, a free PowerBuilder Developer's Toolkit. 
Version 2.2.06 now available at the Sandbox
See the PB Troubleshooting Guide at the Sandbox
^ ^
o o
=*=
0
Terry
10/28/2003 5:48:46 AM
Thanks for the Info.

So, I can migrate from PB 5.0 to PB 9.0 directly with out
migrating to the intermediate versions?

Please could any one clarify me on this?

Where can I find some documentation on the Migrations?

Regards
Srini

> BTW, if you want to see everything that has changed in PB
> since PB5,
>
http://www.techno-kitten.com/Changes_to_PowerBuilder/changes_to_powerbuilder.html
>
> Good luck,
>
> Terry [TeamSybase] and Sequel the techno-kitten
>
> On 27 Oct 2003 13:24:57 -0700, Terry Voth
> <sequel@techno-kitten.com> wrote:
>
> >Migrating:
> >- Backup
> >- Optimize in PB5
> >- Full Rebuild in PB5, with Information and Warning
> messages turned on >- Backup, send it offside
> >- Run Migration Assistant (File / New / Tools in PB8/9)
> >- Fix the identified issues using PB5
> ><doublechecking>
> >- Optimize in PB5
> >- Full Rebuild in PB5, with Information and Warning
> messages turned on >- Run Migration Assistant (File / New
> / Tools) ></doublechecking>
> >- Backup
> >- File / New / Workspace in PB8/9
> >- File / New / Target / Existing Application in PB8/9
> >
> >Keep in mind that Sybase's support for PB8 will end 60-90
> days after >the release of PB10, if the historical pattern
> prevails. PB10 is due >out 2004H1. That means you could
> get as little as six months before >PB8 is unsupported.
> Given the targeted release cycle that Sybase has
> >announced, moving to PB9 will give you an extra 12-18
> months. >
> >Good luck,
> >
> >Terry [TeamSybase] and Sequel the techno-kitten
> >
> >On 27 Oct 2003 11:53:11 -0700, "Srinivasa Rao
> Surabathini" ><srinivasa.rao@ntlworld.com> wrote:
> >
> >>I am having the PB 5.0.xx Applications running on my pc
> at this moment. >>
> >>I have to Migrate/Upgrade them to PB 8/9.
> >>
> >>What is the best way to get this?
> >>
> >>Can any one give me some guidance on this?
> >
> >
> >Sequel's Sandbox: http://www.techno-kitten.com
> >Home of PBL Peeper, a free PowerBuilder Developer's
> Toolkit.  >Version 2.2.06 now available at the Sandbox
> >See the PB Troubleshooting Guide at the Sandbox
> >^ ^
> >o o
> >=*=
>
>
> Sequel's Sandbox: http://www.techno-kitten.com
> Home of PBL Peeper, a free PowerBuilder Developer's
> Toolkit.  Version 2.2.06 now available at the Sandbox
> See the PB Troubleshooting Guide at the Sandbox
> ^ ^
> o o
> =*=
0
Srini
10/28/2003 9:58:52 AM
<Srini> wrote in message news:3f9e4bec.5cca.846930886@sybase.com...

> So, I can migrate from PB 5.0 to PB 9.0 directly with out
> migrating to the intermediate versions?
  
   Yes.

> Where can I find some documentation on the Migrations?

   Terry's answers contains everything :).

Dmitri.
0
Dmitri
10/28/2003 12:39:50 PM
Try the ReadMe files and the online documentation.

Good luck,

Terry [TeamSybase] and Sequel the techno-kitten

On 28 Oct 2003 02:58:52 -0700, Srini wrote:

>Thanks for the Info.
>
>So, I can migrate from PB 5.0 to PB 9.0 directly with out
>migrating to the intermediate versions?
>
>Please could any one clarify me on this?
>
>Where can I find some documentation on the Migrations?
>
>Regards
>Srini
>
>> BTW, if you want to see everything that has changed in PB
>> since PB5,
>>
>http://www.techno-kitten.com/Changes_to_PowerBuilder/changes_to_powerbuilder.html
>>
>> Good luck,
>>
>> Terry [TeamSybase] and Sequel the techno-kitten
>>
>> On 27 Oct 2003 13:24:57 -0700, Terry Voth
>> <sequel@techno-kitten.com> wrote:
>>
>> >Migrating:
>> >- Backup
>> >- Optimize in PB5
>> >- Full Rebuild in PB5, with Information and Warning
>> messages turned on >- Backup, send it offside
>> >- Run Migration Assistant (File / New / Tools in PB8/9)
>> >- Fix the identified issues using PB5
>> ><doublechecking>
>> >- Optimize in PB5
>> >- Full Rebuild in PB5, with Information and Warning
>> messages turned on >- Run Migration Assistant (File / New
>> / Tools) ></doublechecking>
>> >- Backup
>> >- File / New / Workspace in PB8/9
>> >- File / New / Target / Existing Application in PB8/9
>> >
>> >Keep in mind that Sybase's support for PB8 will end 60-90
>> days after >the release of PB10, if the historical pattern
>> prevails. PB10 is due >out 2004H1. That means you could
>> get as little as six months before >PB8 is unsupported.
>> Given the targeted release cycle that Sybase has
>> >announced, moving to PB9 will give you an extra 12-18
>> months. >
>> >Good luck,
>> >
>> >Terry [TeamSybase] and Sequel the techno-kitten
>> >
>> >On 27 Oct 2003 11:53:11 -0700, "Srinivasa Rao
>> Surabathini" ><srinivasa.rao@ntlworld.com> wrote:
>> >
>> >>I am having the PB 5.0.xx Applications running on my pc
>> at this moment. >>
>> >>I have to Migrate/Upgrade them to PB 8/9.
>> >>
>> >>What is the best way to get this?
>> >>
>> >>Can any one give me some guidance on this?
>> >
>> >
>> >Sequel's Sandbox: http://www.techno-kitten.com
>> >Home of PBL Peeper, a free PowerBuilder Developer's
>> Toolkit.  >Version 2.2.06 now available at the Sandbox
>> >See the PB Troubleshooting Guide at the Sandbox
>> >^ ^
>> >o o
>> >=*=
>>
>>
>> Sequel's Sandbox: http://www.techno-kitten.com
>> Home of PBL Peeper, a free PowerBuilder Developer's
>> Toolkit.  Version 2.2.06 now available at the Sandbox
>> See the PB Troubleshooting Guide at the Sandbox
>> ^ ^
>> o o
>> =*=


Sequel's Sandbox: http://www.techno-kitten.com
Home of PBL Peeper, a free PowerBuilder Developer's Toolkit. 
Version 2.2.06 now available at the Sandbox
See the PB Troubleshooting Guide at the Sandbox
^ ^
o o
=*=
0
Terry
10/28/2003 12:50:42 PM
BUT, PB9 doesn't work on Windows 98 / Me.
It requires at least Windows NT4 sp6a.

"Dmitri" <dim123nospam@yahoo.com> a ecrit dans le message news:
3f9e71a6@forums-1-dub...
> <Srini> wrote in message news:3f9e4bec.5cca.846930886@sybase.com...
>
> > So, I can migrate from PB 5.0 to PB 9.0 directly with out
> > migrating to the intermediate versions?
>
>    Yes.
>
> > Where can I find some documentation on the Migrations?
>
>    Terry's answers contains everything :).
>
> Dmitri.


0
Olivier
10/28/2003 9:35:41 PM
Actually, it's just not *supported* on those platforms. I've
definitely heard of success using it on W98. (I don't recall hearing a
success on ME, and I *do* recall someone having serious problems, but
then again, *no* version of PB was *ever* supported under ME.) The
kicker with an unsupported platform is that if you run into problems,
you'll have to reproduce it on a supported platform before Sybase will
work on fixing it or finding a work around. Depends on your risk
tolerance. Then again, OP has been on an unsupported version of PB for
years.... <g>

Good luck,

Terry [TeamSybase] and Sequel the techno-kitten

On 28 Oct 2003 14:35:41 -0700, "Olivier Citeau" <ociteau@yahoo.fr>
wrote:

>BUT, PB9 doesn't work on Windows 98 / Me.
>It requires at least Windows NT4 sp6a.
>
>"Dmitri" <dim123nospam@yahoo.com> a ecrit dans le message news:
>3f9e71a6@forums-1-dub...
>> <Srini> wrote in message news:3f9e4bec.5cca.846930886@sybase.com...
>>
>> > So, I can migrate from PB 5.0 to PB 9.0 directly with out
>> > migrating to the intermediate versions?
>>
>>    Yes.
>>
>> > Where can I find some documentation on the Migrations?
>>
>>    Terry's answers contains everything :).
>>
>> Dmitri.
>


Sequel's Sandbox: http://www.techno-kitten.com
Home of PBL Peeper, a free PowerBuilder Developer's Toolkit. 
Version 2.2.06 now available at the Sandbox
See the PB Troubleshooting Guide at the Sandbox
^ ^
o o
=*=
0
Terry
10/28/2003 11:53:49 PM
"Olivier Citeau" <ociteau@yahoo.fr> wrote in message
news:3f9eef3d@forums-1-dub...

> BUT, PB9 doesn't work on Windows 98 / Me.

   PB9 definitely works under Win98, though due to PB's "resource
greediness" Windows may run out of resources pretty quickly.

Dmitri.

0
Dmitri
10/29/2003 5:20:23 AM
PB isn't any more resource greedy than other development tool. Where
you'll run short is GDI, which is a pretty standard one handle per
control. Your GUI design is what's going to cause problems, regardless
of development tool. Where PB shines is the datawindow, where you can
have dozens of "controls" in a datawindow, and the datawindow will
only use two handles. I haven't heard of any other tool that matches
that. (In stark contrast, I've seen one PB app that tried to simulate
a grid datawindow with 100 SLEs and a couple of scrollbar controls.
You might imagine that this app was running out of GDI pretty quickly,
and changing it to a datawindow made a *BIG* difference.)

Good luck,

Terry [TeamSybase] and Sequel the techno-kitten

On 28 Oct 2003 22:20:23 -0700, "Dmitri" <dim123nospam@yahoo.com>
wrote:

>"Olivier Citeau" <ociteau@yahoo.fr> wrote in message
>news:3f9eef3d@forums-1-dub...
>
>> BUT, PB9 doesn't work on Windows 98 / Me.
>
>   PB9 definitely works under Win98, though due to PB's "resource
>greediness" Windows may run out of resources pretty quickly.
>
>Dmitri.


Sequel's Sandbox: http://www.techno-kitten.com
Home of PBL Peeper, a free PowerBuilder Developer's Toolkit. 
Version 2.2.06 now available at the Sandbox
See the PB Troubleshooting Guide at the Sandbox
^ ^
o o
=*=
0
Terry
10/29/2003 5:38:14 AM
Agrees that there sure are some resource problems with libjsybheap.dll file
but PB GA 8.0.4 and higher this file is no longer used and there is no such
problem specific to PB.

"Dmitri" <dim123nospam@yahoo.com> wrote in message
news:3f9f5d3a$1@forums-2-dub...
> "Olivier Citeau" <ociteau@yahoo.fr> wrote in message
> news:3f9eef3d@forums-1-dub...
>
> > BUT, PB9 doesn't work on Windows 98 / Me.
>
>    PB9 definitely works under Win98, though due to PB's "resource
> greediness" Windows may run out of resources pretty quickly.
>
> Dmitri.
>


0
Mell
10/29/2003 1:34:04 PM
Is Power Buider Verison 9 is Stable to migrate from PB 5.0.04 or Does it has
any know issues?

Thanks for your valuble inputs.

"Mell [WS]" <wizardofnet-at-yahoo.com> wrote in message
news:3f9fcfdc@forums-1-dub...
> Agrees that there sure are some resource problems with libjsybheap.dll
file
> but PB GA 8.0.4 and higher this file is no longer used and there is no
such
> problem specific to PB.
>
> "Dmitri" <dim123nospam@yahoo.com> wrote in message
> news:3f9f5d3a$1@forums-2-dub...
> > "Olivier Citeau" <ociteau@yahoo.fr> wrote in message
> > news:3f9eef3d@forums-1-dub...
> >
> > > BUT, PB9 doesn't work on Windows 98 / Me.
> >
> >    PB9 definitely works under Win98, though due to PB's "resource
> > greediness" Windows may run out of resources pretty quickly.
> >
> > Dmitri.
> >
>
>


0
Srinivasa
11/1/2003 8:32:19 PM
"Stable" is in the eye of the beholder. Every version of PB has some
issues, as does every other development tool. If PB9 fixes a problem
that absolutely nailed your application to the wall in PB5, then it's
a lot more "stable". If you were having no problems in PB5, and PB9
introduced a bug that impacts 0.001% of all PB applications, but that
includes *your* app, then it's incredible "unstable". 

The point is, each application is different, taking advantage of
different aspects of PB. There is no universal pat answer with regards
to satisfaction. (Although, given the history of this forum, a lack of
people screaming themselves red in the face about how awful it is,
even if their biggest beef is the colours of the icons, speaks
volumes. <BG>) You'll have to try it out on your own app to find out. 

Good luck,

Terry [TeamSybase] and Sequel the techno-kitten

On 1 Nov 2003 12:32:19 -0800, "Srinivasa Rao Surabathini"
<srinivasa.rao@ntlworld.com> wrote:

>Is Power Buider Verison 9 is Stable to migrate from PB 5.0.04 or Does it has
>any know issues?
>
>Thanks for your valuble inputs.
>
>"Mell [WS]" <wizardofnet-at-yahoo.com> wrote in message
>news:3f9fcfdc@forums-1-dub...
>> Agrees that there sure are some resource problems with libjsybheap.dll
>file
>> but PB GA 8.0.4 and higher this file is no longer used and there is no
>such
>> problem specific to PB.
>>
>> "Dmitri" <dim123nospam@yahoo.com> wrote in message
>> news:3f9f5d3a$1@forums-2-dub...
>> > "Olivier Citeau" <ociteau@yahoo.fr> wrote in message
>> > news:3f9eef3d@forums-1-dub...
>> >
>> > > BUT, PB9 doesn't work on Windows 98 / Me.
>> >
>> >    PB9 definitely works under Win98, though due to PB's "resource
>> > greediness" Windows may run out of resources pretty quickly.

Sequel's Sandbox: http://www.techno-kitten.com
Home of PBL Peeper, a free PowerBuilder Developer's Toolkit. 
Version 2.2.06 now available at the Sandbox
See the PB Troubleshooting Guide at the Sandbox
^ ^
o o
=*=
0
Terry
11/2/2003 3:20:49 AM
Reply:

Similar Artilces:

PB crashes while migrating pb application from PB 8.0 to 9.0
Hi, I am trying migrate a pb application from PB 8.0 to 9.0. It crashes while rebuilding for migration. Is there anything needs to be taken care before the migrating it to pb 9.0 ? Thanks, Mohan Same as any other version: - backup - optimize all PBLs - run Migration Assistant in destination version; try to deal with as much as possible in original version - full build, with information and warning messages turned on, so you know which messages after migration aren't new - backup, backup, backup - migrate - if it crashes, try again and watch messages to see if you ca...

PB GPFs while migrating an app from PB 5.0.2 to PB 8.0.1
Hi, I am trying to migrate an application from PB 5.0.02 to PB 8.0.01. The application runs perfectly under PB 5.0.02. While migrating the app, I get the following message: Pb80 has caused an error in PBVM80.DLL. Then PB crashes. Any suggestions? Moreover, does anyone know of some white paper with some advices on migrating apps? Thx Luca Before migrating, you should run the Migration Assistant (File / New / Tools). Make any suggested changes with PB5 before migrating. Of course, backup, backup, backup. Then, optimize all the PBLs and do a Full Rebuild (Library Pain...

PB 5.0.04 upgrade to PB 8.0
Has anyone done an upgrade from PB 5 to 8? I'm about to attempt this and I was wondering if there is any information out there to help me with this. The applications that need to be migrated are using the PFC 5.0 and cornerstone 5.0. I don't think the Cornerstone 5.0 can be migrated. Any help would be appreciated. Thanks, Mike Wallach mwalla@ca.ibm.com I upgraded and app from 5.0.04 to 8. We don't use the pfc though. One issue I found is that some of the editmask start acting weird. For example, if you use a datetime editmask that uses am/pm, once you tab off i...

ScrollToRow() problem after migrating from PB 5.0 to PB 8.0
I have migrated an application from PB 5.0 to PB 8.0.Have couple of master/detail screens so use scrolltorow for manipulation.That worked fine in PB 5.0 does not work properly after migration. Is that a PB 8.0 bug ,is there anything that I can do as I need the scrolltorow functionality. Thanks Ann Can you define "does not work properly" a little more precisely? Does it not scroll? Does it not scroll to the right row? Does it blow up? It "works" for me in several apps, so you're probably going to have to be more specific than that. There has been a k...

pb 6.5, pb 7.0, pb 8.0 and future releases
I have designed an app using PB 6.5.1 and feel quite confortable to write another app using this version of Power Buulder. I am aware that there have been many other releases after this but have heard many developers complain about not being stable and so forth. I can't say how true this is cause I never bothered to update to later releases. I recently got a contract for a new app and quite likely will be using Power Biulder but I am wondering if am cheating myself by not trying to upgrade myself to a later release of Power Biulder. Thanks. Charlie. Charlie You...

Migrating from PB 4.0 to PB 5.0
I am hving a hard time trying to convert from Powerbuilder v4.0 to v5.0. After I have migrated the entire application, i then try to open up a Window and keep getting the message "Open of Window failed. Application has been converted to newest version; window must be re-migrated". I then try to re-migrate the Window and re-open it and again the same message. Any ideas?? Does it definitely say 'remigrated' and not 'regenerated'? If the latter, then regenerating all objects should sort it. Mark Sanford wrote in message <01bd8e64$08e151e0$a4012682@s...

Migration from PB 5.0 to PB 7.0
Hi All, While using the Migration assistant to check if any of the functions being currently used in our application have become Obsolete.I got these error messages PBORCA LIBRARY - Entry Information Failed and PBORCA error message Obsolete - Replaced by f-wait in n_cst_datetime was not found. Error No: 3 These error messages were displayed for the PFC and PFE PBL's. Could anyone please give any suggestions... TIA, Sg Here's a hunch. Check for duplicate PowerBuilder DLLs or mismatched DLLs being loaded. A good tool to check what's being loaded is HandleEx...

PB 5.0 to PB 6.5, 7.x, 8.0??
I have a client who needs to move from an initial PB 5.0 release (no patches applied) to a newer version of PB. This is a small internal application but they would like to open it up via the internet in the future. They are currently running on a SQL Anywhere DB but would be looking to change that also. I don't have any hands on experience with PB 7.x but from what I heard and read it hasn't been that great. I've been using PB 6.5 since build 444 and was thinking of recommending that they make the move to 6.5 first and then wait for PB 8.0 later this year. Any thoug...

Field size issue migrating DWs from PB 5.0.2 to PB 8.0.1
Hi, I have just migrated an app from PB 5.0.02 to PB 8.0.1.8004 and I had a problem with the size of fields in some dws. The matter is: I use the FixedSys font for my fields, since it is monospaced and easily readable; now, some fields that are completely readable in the PB5 version became partially hidden in the PB8 version. For example, I have some "year" fields with a width of 147 PBUs and edit mask "####"; while they behave perfectly in the PB5 version, in the PB8 one, when the user tabs to such a field the 4th figure is not visible (say, he sees "200" ...

migrating from pb 5.0 to 8.0
Hi all Is there any specific steps involved in migrating a pb 5.0 application to pb 8.0? or is it straight forward? Your valuable comments appreciated! TIA Jana Straight forward but watch out for: * win16 ==> win32 * DBMS client driver updates * Additional reserved words (e.g. throws, try, catch) * Distributed PowerBuilder is EOL (go to EAServer or other component server) * TEST - TEST - TEST the entire functionality of your application. Recently we upgraded PB4 to PB8 and found several strange code snippets that looked like bug fixes but didn't work as expected by u...

migrating from pb 5.0 -> pb 6.0/6.5 any pothole
I am looking for any know potholes to avoid in migrating several PB 5.0 application to PB 6.0/6.5 using an Oracle 7.3 data base on Win 95 client? Thanks Brian, Take a look at http://techinfo.sybase.com/css/techinfo.nsf/DocID/ID=47787 Also, do your own search on 'mirgrating' and you should come up with a few other references. Frank Brian Scanlon wrote in message <01be37fa$0aa527a0$4e4b8282@bscanlon.cdphp.com>... >I am looking for any know potholes to avoid in migrating several PB 5.0 >application to PB 6.0/6.5 >using an Oracle 7.3 data base on Win ...

Descrepancy between summing in PB 5.0 and PB 8.0
I have recently upgraded my reporting application from PB 5.0 to PB 8.0 and the same data window running the same stored procedure that ran in PB 5.0 sometimes generates a total that is a penny or two short in PB 8.0. The total is calculated by summing the money amounts in a group: sum(amount for group 1). Nothing in the data window has been changed by me in the migration process. If you add the numbers manually by eye, the total in PB 8.0 is obviously wrong. For example: XX.50 XX.50 XX.67 XX.00 XX.00 ------- XX.66 However, the same totaling function in the same data wnid...

Migrating from PB 5.0.4 to PB 7.0
Hi, I have some questions regarding migrating from PB 5.0.4 to PB 7.0 1) I am migrating a PB 5.0.4 application to PB 7.0. When I migrated the application, I got some warnings and Informational messages. I also got one error message in a user object : Error : C0181 : The argument to SetNull cannot be an autoinstantiate or structure. The argument I have is a structure instance. Is there another function I can use instead ? 2) This application also uses the funcky library. I was wondering what is a better substitute for these in 7.0. 3) Stephen Dupre also mentioned in on...

Migrating from PB v5 to v5.0.02 and from 5.0.02 to 5.0.03.
Hello, 2 customers have requested information on how to migrate from PowerBuilder v5 to 5.0.02 and from 5.0.02 to 5.0.03. Can anyone offer advice? Do they both need to call Technical Support? I've looked in our Technical Information Library and entering requests via Query Builder yields nothing. Thank you very much. Deborah (Information Products Group) Deborah Blakeney wrote: > > Hello, > > 2 customers have requested information on how to migrate > from PowerBuilder v5 to 5.0.02 and from 5.0.02 to 5.0.03. Can > anyone offer advice? Do the...

Web resources about - Migrate/Upgrade from PB 5.0.xx to PB 8.0/9.0 - sybase.powerbuilder.general

Resources last updated: 12/4/2015 10:12:22 AM