DW-Stored Procedure Problem

Retrieving a PB7 DataWindow from a MS SQL Server 7.0 Stored Procedure.

I am running PowerBuilder 7.0 and using Microsoft SQL Server 7.0 as my
Back-end. I have written a Stored procedure in SQL Server which accepts
two arguments and returns a set of rows after a set of processing.

But my Problem is when I create the DataWindow Object in PB7 it shows a
"Data Conversion error" after the final step of the DW object creation
wizard. This error does not come up if I check the Manual Result set
option in the Wizard. But when I do so I don't get the output and also I

am unaware how to specify the retrieval arguments.

I can execute any Stored Procedure only through script.

Could you help me resolve this problem.


Pradeep






0
P
7/4/2000 7:13:55 PM
sybase.powerbuilder.datawindow 28057 articles. 4 followers. Follow

0 Replies
464 Views

Similar Articles

[PageSpeed] 35

Reply:

Similar Artilces:

problem with a stored procedure datawindow
I often work with datawindow based on oracle stored procedure and i never had any problem except with one. This datawindow works fine during 3 hours (approximately) and then becomes invalid. The error is : ORA-06553: PLS-707: structure non prise en charge ou erreur interne [2601] ORA-06550: Ligne 1, colonne 16:|PL/SQL: Statement ignored| which seems to be an internal error... I thought it was an instance problem and i shutdown the database and re-start it but the problem is still the same. Datawindow based on stored procedure used a cursor that is never closed. Can the problem be ...

Stored Procedure
I have a DW based on a SP which requests 4 parameters (2 are optional) but when executing a retrieve (para1, para2, para3, para4) I don't obtain any result The SP is executed OK in mode interactive What's the problem? Thanks Alejandro Check in detail the value of each one of your parameters. If one of them is NULL, is probably thay your SP doesn't work. Good Luck, Javier Barbieri "Alejandro G�mez" <agomez@ucv.cl> wrote in message news:emM3DATwAHA.157@forums.sybase.com... > I have a DW based on a SP which requests 4 pa...

DW and stored procedure problem
Hi! We have problem with sp as datawindow source. Server: Sybase 11.9.2 Linux, PowerBuilder 7.0.2 When I create dw I get message from PowerBuilder "Cannot create DataWindow SQLSTATE = 37000 [INTERSOLV][ODBC SQL Server driver][SQL Server] Incorrect syntax near '='. 1 execute dbo.test1;0 RETURN_VALUE =:RETURN_VALUE" SP: CREATE PROCEDURE dbo.test1 AS BEGIN select message from load_log END If anybody knows what it means and how can I fix it, please respond Thanx. ...

Powerbuilder datawindow + stored procedure
database ASA 7 When we build a datawindow in powerbuilder we choose the table and the columns to build it. There is also the possibility to build a datawindow from a stored procedure. Is a stored procedure running faster because the database remembers the execution plan? Thanks Eric "ontsnapt" <ontsnapt@hotmail.com> wrote: > database ASA 7 > > When we build a datawindow in powerbuilder we choose the table and the > columns to build it. There is also the possibility to build a datawindow > from a stored procedure. > > Is a stored...

Stored Procedure
I have a DW based on a SP which requests 4 parameters (2 are optional) but when executing a retrieve (para1, para2, para3, para4) I don't obtain any result The SP is executed OK in mode interactive What's the problem? Thanks Alejandro Check in detail the value of each one of your parameters. If one of them is NULL, is probably thay your SP doesn't work. Good Luck, Javier Barbieri "Alejandro G�mez" <agomez@ucv.cl> wrote in message news:emM3DATwAHA.157@forums.sybase.com... > I have a DW based on a SP which requests 4 pa...

Stored procedure DW problem
Hi all, PB 12.1 Net (6639), SQL Server 2005, SNC. Stored procedure DW hangs PB (IDE not respond) when I try retrieve. When I run app and retrieve on this dw hangs app too. I try SQLNCLI10 and SQLNCLI. The same DW on PB 12.1 classic works OK. In trace log I see PB not set parameters for procedure. On retrieve dialog I set sBarcodeId to 24059589 but in trace log I see sBarcodeId = 0. My trace log : (15e5fce8): DIALOG CONNECT TO TRACE SNC SQL NATIVE CLIENT(OLE DB): (15e5fce8): LOGID=... (15e5fce8): SERVER=... (15e5fce8): DBPARM=Database='...',Provider='SQLNCLI...

problem with dw and a stored procedure
Hi all! I'm using a dw with an SP as data source. In design the dw retrieves data perfectly, but at run time I get this error: 5 Select error: ct_bind(): user api layer: external error: An illegal value of 15 given for parameter item. I'm using the same parameters in design and run time. Any idea about this? thanks in advance. PB 8.0.4 ASE 11.92 Win XP In design mode you are using a different database profile then at run time. You can try a few things: change the DBParm to set staticbind=0. It is probably set in the database profile during design (it ...

store procedure datawindow problem
In sybase ASE 11.5, I wrote such a store procedure: CREATE PROCEDURE up_myproc (@arg_parm1 char(40), @arg_parm2 char(40) ) AS CREATE TABLE #temp_alertlist( steprec_id decimal(18,0), ifalert char(1), type char(255), content_1 char(255) null, content_2 char(255) null, content_3 char(255) null, content_4 char(255) null, windowname char(255) null ) Insert into #temp_alertlist values(....) SELECT * FROM #temp_alertlist In pb8, I made a datawindow from this store procedure, when I preview it, it returns the correct results, but when I put this datawindow in my ...

Stored Procedure
Hi, I created a datawindow by using stored proc as datasource in PB 6.0. Db is sqlany 5.5.04. On one machine, when I tried to retrieve same datawindow from same database, it is retrieving. But on another machine, it's giving me the error column list do not match. Is it related to pbodb60.ini file? Or with Powerbuilder profile( dbparm )? I tried to change static bind = 0 to 1, but result is same. Has anyone seen before? What is the problem? TIA -- Mahendra Dhamdhere, CPDA Email:mahendrad@hotmail.com Pl. Remove nospam_ from email id ...

Stored Procedure
I have a DW based on a SP which requests 4 parameters (2 are optional) but when executing a retrieve (para1, para2, para3, para4) I don't obtain any result The SP is executed OK in mode interactive What's the problem? Thanks Alejandro Check in detail the value of each one of your parameters. If one of them is NULL, is probably thay your SP doesn't work. Good Luck, Javier Barbieri "Alejandro G�mez" <agomez@ucv.cl> wrote in message news:emM3DATwAHA.157@forums.sybase.com... > I have a DW based on a SP which requests 4 pa...

Problem with stored procedure datawindow
This is a multi-part message in MIME format. ------=_NextPart_000_0014_01C08078.36D407B0 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable I have converted a datawindow that had a SQL Select to a Stored = Procedure that is retrieved on a page using the HTML generator. Now the = datawindow will not retrieve. I have tried setting the weight of the = datawindow in the dw painter to all options and still no luck. I have = even hardcoded values in the retrieveex script and the datawindow does = not return any rows. The SQL Select dat...

Datawindow against Stored Procedure problem
Has anyone had problems creating a datawindow against a database stored procedure? I have a simple stored procedure that returns a result set. When I try to create a tabular datawindow against the stored procedure, I click 'finish' and PocketBuilder simply disappears (without even the standard 'do you want to send the report to Microsoft' dialog box!). Thanks! Michael Frank ASA9 version 9.0.2 build 3044 PocketBuilder 2.0.1 build 688 I have no problems with this (I am running ASA 9.0.2.3124 in my tests). "Michael Frank" <mfrank.removeme...

Problems with stored procedures in a datawindow
Hi- I'm using an external datawindow which uses stored procedures for insert,=20 delete and update. I always insert a row and if I want to delete or modify a row, I fill in=20 the datawindow with the corresponding information. In order to execute the = appropriate stored procedure, I change the status flags of the row to=20 DataModified! using the SetItemStatus method (and call the deleteRow()=20 method if I want to delete the row). After that, I set the transaction I=20 want the datawindow to use and call the datawindow's of=5Fupdate() method. It executes the stored p...

Datawindow with Stored Procedure Problem
I get the message "Select error: Requested result set number 1 not found" from a datawindow when my Stored Procedure does not get a result set. It works fine when there is data returned. Normally, when no data is returned I just get zero rows returned without an error message. The Stored Procedure works fine when no data is returned outside of PB. I am using PB 7.0.2 C3 with Sybase 11. Any one have any thoughts on this one? TIA Ted Jones If you are using a datawindow, you HAVE to have a result set. That result set could contain 0 rows. If your stored procedure has a...

Web resources about - DW-Stored Procedure Problem - sybase.powerbuilder.datawindow

Resources last updated: 1/5/2016 4:52:14 PM