Column Name in datastore ( invalid row/column ....)

--------------A15DFE08B1A7F5CB43BA4D7D
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

I have a problem with a script, when i reference the column name of a
datastore with GetItem.... function.

I'm using PB 5.03 and MS SQL 6.5.

This is the sql syntax for generating datastore.

sql_syntax_ac = "SELECT tabmer.mer_code, tabmer.mer_desc,
tabreg.reg_code, tabreg.reg_desc, "+&
           "Sum(tabarc.arc_rine - tabarc.arc_reso) 'fatturato', "+&
             "Sum(tabarc.arc_cove - tabarc.arc_core ) 'costo' "+&
         "FROM tabarc, tabcli, tabreg, tabmer " +&
         "WHERE ( tabarc.cli_code = tabcli.cli_code ) and "+&
           "( tabcli.reg_code = tabreg.reg_code ) and "+&
           "( tabreg.mer_code = tabmer.mer_code ) and "+&
           "( ( tabarc.arc_anno = " + anno_ac + " ) AND "+&
           "( tabarc.arc_mese = "+ mese + ") )" +&
       "GROUP BY
tabmer.mer_code,tabmer.mer_desc,tabreg.reg_code,tabreg.reg_desc"

After this i generate the datastore and retrieve data

ds_syntax = SQLCA.SyntaxFromSQL(sql_syntax_ac,"", err )
ds_anno_ac = Create Datastore
ds_anno_ac.Create(ds_syntax,err)
ds_anno_ac.SetTransObject(SQLCA)
ds_anno_ac.Retrieve()

The next step, i open  a FOR .. NEXT and refence the data with these
istructions:

row_ac = ds_anno_ac.RowCount()
FOR j = 1 TO row_ac
  mer      = ds_anno_ac.GetItemNumber(j,"tabmer_mer_code")
  d_mer    = ds_anno_ac.GetItemString(j,"tabmer_mer_desc")
  reg      = ds_anno_ac.GetItemString(j,"tabreg_reg_code")
  regione  = ds_anno_ac.GetItemString(j,"tabreg_reg_code") + " - " +
ds_anno_ac.GetItemString(j,"TABREG_reg_desc")
  vendita  = ds_anno_ac.GetItemNumber(j,"cfatturato")
  acquisto = ds_anno_ac.GetItemNumber(j,"ccosto")

On the PC that I'm using to develop I haven't problems, on the PC where
I have installed the application, when the program enter in the loop
return this error:

"invalid row/column specification at line ....."

The name of the column in run time is cmer_code and not tabmer_mer_code

I have read that is important specify in SQLCA USERID=owner table but
there are no effect.

I don't understand if the problem is the configuration of the MS SQL 6.5
or configuration of PB.

There is anyone that can help me ???

Thanks in advence

roberto

EMAIL = roberto.dellacqua@bticino.it


--------------A15DFE08B1A7F5CB43BA4D7D
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit

<HTML>
I have a problem with a script, when i reference the column name of a datastore
with GetItem.... function.

<P>I'm using PB 5.03 and MS SQL 6.5.

<P>This is the sql syntax for generating datastore.

<P>sql_syntax_ac = "SELECT tabmer.mer_code, tabmer.mer_desc, tabreg.reg_code,
tabreg.reg_desc, "+&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "Sum(tabarc.arc_rine
- tabarc.arc_reso) 'fatturato', "+&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
"Sum(tabarc.arc_cove - tabarc.arc_core ) 'costo' "+&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "FROM tabarc, tabcli,
tabreg, tabmer " +&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "WHERE ( tabarc.cli_code
= tabcli.cli_code ) and "+&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "( tabcli.reg_code
= tabreg.reg_code ) and "+&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "( tabreg.mer_code
= tabmer.mer_code ) and "+&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "( ( tabarc.arc_anno
= " + anno_ac + " ) AND "+&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "( tabarc.arc_mese
= "+ mese + ") )" +&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "GROUP BY tabmer.mer_code,tabmer.mer_desc,tabreg.reg_code,tabreg.reg_desc"

<P>After this i generate the datastore and retrieve data

<P>ds_syntax = SQLCA.SyntaxFromSQL(sql_syntax_ac,"", err )
<BR>ds_anno_ac = Create Datastore
<BR>ds_anno_ac.Create(ds_syntax,err)
<BR>ds_anno_ac.SetTransObject(SQLCA)
<BR>ds_anno_ac.Retrieve()

<P>The next step, i open&nbsp; a FOR .. NEXT and refence the data with
these istructions:

<P>row_ac = ds_anno_ac.RowCount()
<BR>FOR j = 1 TO row_ac
<BR>&nbsp; mer&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = ds_anno_ac.GetItemNumber(j,"tabmer_mer_code")
<BR>&nbsp; d_mer&nbsp;&nbsp;&nbsp; = ds_anno_ac.GetItemString(j,"tabmer_mer_desc")
<BR>&nbsp; reg&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = ds_anno_ac.GetItemString(j,"tabreg_reg_code")
<BR>&nbsp; regione&nbsp; = ds_anno_ac.GetItemString(j,"tabreg_reg_code")
+ " - " + ds_anno_ac.GetItemString(j,"TABREG_reg_desc")
<BR>&nbsp; vendita&nbsp; = ds_anno_ac.GetItemNumber(j,"cfatturato")
<BR>&nbsp; acquisto = ds_anno_ac.GetItemNumber(j,"ccosto")

<P>On the PC that I'm using to develop I haven't problems, on the PC where
I have installed the application, when the program enter in the loop return
this error:

<P>"invalid row/column specification at line ....."

<P>The name of the column in run time is <B>cmer_code</B> and not <B>tabmer_mer_code</B><B></B>

<P>I have read that is important specify in SQLCA USERID=owner table but
there are no effect.

<P>I don't understand if the problem is the configuration of the MS SQL
6.5 or configuration of PB.

<P>There is anyone that can help me ???

<P>Thanks in advence

<P>roberto

<P>EMAIL = roberto.dellacqua@bticino.it
<BR>&nbsp;</HTML>

--------------A15DFE08B1A7F5CB43BA4D7D--

0
Roberto
7/16/1998 4:58:17 PM
sybase.powerbuilder.datawindow 28057 articles. 4 followers. Follow

2 Replies
1018 Views

Similar Articles

[PageSpeed] 9

This is a multi-part message in MIME format.

------=_NextPart_000_0052_01BDB165.052EFA60
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

I believe this was a bug in 5.0.03, fixed in 5.0.04.  Someone will =
correct me if I'm wrong ;-)

    Roberto wrote in message <35AE3129.563017D6@bticino.it>...
    I have a problem with a script, when i reference the column name of =
a datastore with GetItem.... function.=20
    I'm using PB 5.03 and MS SQL 6.5.=20

    This is the sql syntax for generating datastore.=20

    sql_syntax_ac =3D "SELECT tabmer.mer_code, tabmer.mer_desc, =
tabreg.reg_code, tabreg.reg_desc, "+&=20
               "Sum(tabarc.arc_rine - tabarc.arc_reso) 'fatturato', "+&=20
                 "Sum(tabarc.arc_cove - tabarc.arc_core ) 'costo' "+&=20
             "FROM tabarc, tabcli, tabreg, tabmer " +&=20
             "WHERE ( tabarc.cli_code =3D tabcli.cli_code ) and "+&=20
               "( tabcli.reg_code =3D tabreg.reg_code ) and "+&=20
               "( tabreg.mer_code =3D tabmer.mer_code ) and "+&=20
               "( ( tabarc.arc_anno =3D " + anno_ac + " ) AND "+&=20
               "( tabarc.arc_mese =3D "+ mese + ") )" +&=20
           "GROUP BY =
tabmer.mer_code,tabmer.mer_desc,tabreg.reg_code,tabreg.reg_desc"=20

    After this i generate the datastore and retrieve data=20

    ds_syntax =3D SQLCA.SyntaxFromSQL(sql_syntax_ac,"", err )=20
    ds_anno_ac =3D Create Datastore=20
    ds_anno_ac.Create(ds_syntax,err)=20
    ds_anno_ac.SetTransObject(SQLCA)=20
    ds_anno_ac.Retrieve()=20

    The next step, i open  a FOR .. NEXT and refence the data with these =
istructions:=20

    row_ac =3D ds_anno_ac.RowCount()=20
    FOR j =3D 1 TO row_ac=20
      mer      =3D ds_anno_ac.GetItemNumber(j,"tabmer_mer_code")=20
      d_mer    =3D ds_anno_ac.GetItemString(j,"tabmer_mer_desc")=20
      reg      =3D ds_anno_ac.GetItemString(j,"tabreg_reg_code")=20
      regione  =3D ds_anno_ac.GetItemString(j,"tabreg_reg_code") + " - " =
+ ds_anno_ac.GetItemString(j,"TABREG_reg_desc")=20
      vendita  =3D ds_anno_ac.GetItemNumber(j,"cfatturato")=20
      acquisto =3D ds_anno_ac.GetItemNumber(j,"ccosto")=20

    On the PC that I'm using to develop I haven't problems, on the PC =
where I have installed the application, when the program enter in the =
loop return this error:=20

    "invalid row/column specification at line ....."=20

    The name of the column in run time is cmer_code and not =
tabmer_mer_code=20

    I have read that is important specify in SQLCA USERID=3Downer table =
but there are no effect.=20

    I don't understand if the problem is the configuration of the MS SQL =
6.5 or configuration of PB.=20

    There is anyone that can help me ???=20

    Thanks in advence=20

    roberto=20

    EMAIL =3D roberto.dellacqua@bticino.it=20
     =20


------=_NextPart_000_0052_01BDB165.052EFA60
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD W3 HTML//EN">
<HTML>
<HEAD>

<META content=3Dtext/html;charset=3Diso-8859-1 =
http-equiv=3DContent-Type>
<META content=3D'"MSHTML 4.72.2106.6"' name=3DGENERATOR>
</HEAD>
<BODY bgColor=3D#ffffc6>
<DIV><FONT color=3D#000000 size=3D2>I believe this was a bug in 5.0.03, =
fixed in=20
5.0.04.&nbsp; Someone will correct me if I'm wrong ;-)</FONT></DIV>
<DIV><FONT color=3D#000000 size=3D2></FONT>&nbsp;</DIV>
<BLOCKQUOTE=20
style=3D"BORDER-LEFT: #000000 solid 2px; MARGIN-LEFT: 5px; PADDING-LEFT: =
5px">
    <DIV>Roberto<ROBERTO.DELLACQUA@BTICINO.IT> wrote in message &lt;<A=20
    =
href=3D"mailto:35AE3129.563017D6@bticino.it">35AE3129.563017D6@bticino.it=
</A>&gt;...</DIV>I=20
    have a problem with a script, when i reference the column name of a=20
    datastore with GetItem.... function.=20
    <P>I'm using PB 5.03 and MS SQL 6.5.=20
    <P>This is the sql syntax for generating datastore.=20
    <P>sql_syntax_ac =3D &quot;SELECT tabmer.mer_code, tabmer.mer_desc,=20
    tabreg.reg_code, tabreg.reg_desc, &quot;+&amp;=20
    <BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;=20
    &quot;Sum(tabarc.arc_rine - tabarc.arc_reso) 'fatturato', =
&quot;+&amp;=20
    =
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nb=
sp;=20
    &quot;Sum(tabarc.arc_cove - tabarc.arc_core ) 'costo' &quot;+&amp;=20
    <BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &quot;FROM =
tabarc,=20
    tabcli, tabreg, tabmer &quot; +&amp;=20
    <BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &quot;WHERE (=20
    tabarc.cli_code =3D tabcli.cli_code ) and &quot;+&amp;=20
    <BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
&quot;(=20
    tabcli.reg_code =3D tabreg.reg_code ) and &quot;+&amp;=20
    <BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
&quot;(=20
    tabreg.mer_code =3D tabmer.mer_code ) and &quot;+&amp;=20
    <BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
&quot;( (=20
    tabarc.arc_anno =3D &quot; + anno_ac + &quot; ) AND &quot;+&amp;=20
    <BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
&quot;(=20
    tabarc.arc_mese =3D &quot;+ mese + &quot;) )&quot; +&amp;=20
    <BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &quot;GROUP BY=20
    =
tabmer.mer_code,tabmer.mer_desc,tabreg.reg_code,tabreg.reg_desc&quot;=20
    <P>After this i generate the datastore and retrieve data=20
    <P>ds_syntax =3D SQLCA.SyntaxFromSQL(sql_syntax_ac,&quot;&quot;, err =
)=20
    <BR>ds_anno_ac =3D Create Datastore =
<BR>ds_anno_ac.Create(ds_syntax,err)=20
    <BR>ds_anno_ac.SetTransObject(SQLCA) <BR>ds_anno_ac.Retrieve()=20
    <P>The next step, i open&nbsp; a FOR .. NEXT and refence the data =
with these=20
    istructions:=20
    <P>row_ac =3D ds_anno_ac.RowCount() <BR>FOR j =3D 1 TO row_ac =
<BR>&nbsp;=20
    mer&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =3D=20
    ds_anno_ac.GetItemNumber(j,&quot;tabmer_mer_code&quot;) <BR>&nbsp;=20
    d_mer&nbsp;&nbsp;&nbsp; =3D=20
    ds_anno_ac.GetItemString(j,&quot;tabmer_mer_desc&quot;) <BR>&nbsp;=20
    reg&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =3D=20
    ds_anno_ac.GetItemString(j,&quot;tabreg_reg_code&quot;) <BR>&nbsp;=20
    regione&nbsp; =3D =
ds_anno_ac.GetItemString(j,&quot;tabreg_reg_code&quot;) +=20
    &quot; - &quot; + =
ds_anno_ac.GetItemString(j,&quot;TABREG_reg_desc&quot;)=20
    <BR>&nbsp; vendita&nbsp; =3D=20
    ds_anno_ac.GetItemNumber(j,&quot;cfatturato&quot;) <BR>&nbsp; =
acquisto =3D=20
    ds_anno_ac.GetItemNumber(j,&quot;ccosto&quot;)=20
    <P>On the PC that I'm using to develop I haven't problems, on the PC =
where I=20
    have installed the application, when the program enter in the loop =
return=20
    this error:=20
    <P>&quot;invalid row/column specification at line .....&quot;=20
    <P>The name of the column in run time is <B>cmer_code</B> and not=20
    <B>tabmer_mer_code</B><B></B>=20
    <P>I have read that is important specify in SQLCA USERID=3Downer =
table but=20
    there are no effect.=20
    <P>I don't understand if the problem is the configuration of the MS =
SQL 6.5=20
    or configuration of PB.=20
    <P>There is anyone that can help me ???=20
    <P>Thanks in advence=20
    <P>roberto=20
    <P>EMAIL =3D roberto.dellacqua@bticino.it <BR>&nbsp;=20
</P></BLOCKQUOTE></BODY></HTML>

------=_NextPart_000_0052_01BDB165.052EFA60--

0
Simon
7/17/1998 8:26:47 AM
--------------E888C191761A616D91BC4AC9
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

I have upgrade PB to 5.0.04 but the problem is the same.

I have another application in PB 5.0.03 and MS SQL 6.5 that work on
another server and it's work correctly. With the upgrade at PB 5.0.04 I
have the same problem.

There is anyone that can help me ???

Thanks in advence

roberto

EMAIL = roberto.dellacqua@bticino.it

Simon wrote:

>  I believe this was a bug in 5.0.03, fixed in 5.0.04.  Someone will
> correct me if I'm wrong ;-)
>
>      Roberto wrote in message <35AE3129.563017D6@bticino.it>...I
>      have a problem with a script, when i reference the column
>      name of a datastore with GetItem.... function.
>
>      I'm using PB 5.03 and MS SQL 6.5.
>
>      This is the sql syntax for generating datastore.
>
>      sql_syntax_ac = "SELECT tabmer.mer_code, tabmer.mer_desc,
>      tabreg.reg_code, tabreg.reg_desc, "+&
>                 "Sum(tabarc.arc_rine - tabarc.arc_reso)
>      'fatturato', "+&
>                   "Sum(tabarc.arc_cove - tabarc.arc_core )
>      'costo' "+&
>               "FROM tabarc, tabcli, tabreg, tabmer " +&
>               "WHERE ( tabarc.cli_code = tabcli.cli_code ) and
>      "+&
>                 "( tabcli.reg_code = tabreg.reg_code ) and "+&
>                 "( tabreg.mer_code = tabmer.mer_code ) and "+&
>                 "( ( tabarc.arc_anno = " + anno_ac + " ) AND "+&
>                 "( tabarc.arc_mese = "+ mese + ") )" +&
>             "GROUP BY
>      tabmer.mer_code,tabmer.mer_desc,tabreg.reg_code,tabreg.reg_desc"
>
>      After this i generate the datastore and retrieve data
>
>      ds_syntax = SQLCA.SyntaxFromSQL(sql_syntax_ac,"", err )
>      ds_anno_ac = Create Datastore
>      ds_anno_ac.Create(ds_syntax,err)
>      ds_anno_ac.SetTransObject(SQLCA)
>      ds_anno_ac.Retrieve()
>
>      The next step, i open  a FOR .. NEXT and refence the data
>      with these istructions:
>
>      row_ac = ds_anno_ac.RowCount()
>      FOR j = 1 TO row_ac
>        mer      = ds_anno_ac.GetItemNumber(j,"tabmer_mer_code")
>        d_mer    = ds_anno_ac.GetItemString(j,"tabmer_mer_desc")
>        reg      = ds_anno_ac.GetItemString(j,"tabreg_reg_code")
>        regione  = ds_anno_ac.GetItemString(j,"tabreg_reg_code") +
>      " - " + ds_anno_ac.GetItemString(j,"TABREG_reg_desc")
>        vendita  = ds_anno_ac.GetItemNumber(j,"cfatturato")
>        acquisto = ds_anno_ac.GetItemNumber(j,"ccosto")
>
>      On the PC that I'm using to develop I haven't problems, on
>      the PC where I have installed the application, when the
>      program enter in the loop return this error:
>
>      "invalid row/column specification at line ....."
>
>      The name of the column in run time is cmer_code and not
>      tabmer_mer_code
>
>      I have read that is important specify in SQLCA USERID=owner
>      table but there are no effect.
>
>      I don't understand if the problem is the configuration of
>      the MS SQL 6.5 or configuration of PB.
>
>      There is anyone that can help me ???
>
>      Thanks in advence
>
>      roberto
>
>      EMAIL = roberto.dellacqua@bticino.it
>
>


--------------E888C191761A616D91BC4AC9
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit

<HTML>
<BODY BGCOLOR="#FFFFC6">
I have upgrade PB to 5.0.04 but the problem is the same.

<P>I have another application in PB 5.0.03 and MS SQL 6.5 that work on
another server and it's work correctly. With the upgrade at PB 5.0.04 I
have the same problem.

<P>There is anyone that can help me ???

<P>Thanks in advence

<P>roberto

<P>EMAIL = roberto.dellacqua@bticino.it

<P>Simon wrote:
<BLOCKQUOTE TYPE=CITE>&nbsp;<FONT COLOR="#000000"><FONT SIZE=-1>I believe
this was a bug in 5.0.03, fixed in 5.0.04.&nbsp; Someone will correct me
if I'm wrong ;-)</FONT></FONT>&nbsp;
<BLOCKQUOTE 
style="BORDER-LEFT: #000000 solid 2px; MARGIN-LEFT: 5px; PADDING-LEFT: 5px">Roberto<ROBERTO.DELLACQUA@BTICINO.IT>
wrote in message &lt;<A HREF="mailto:35AE3129.563017D6@bticino.it">35AE3129.563017D6@bticino.it</A>>...I
have a problem with a script, when i reference the column name of a datastore
with GetItem.... function.

<P>I'm using PB 5.03 and MS SQL 6.5.

<P>This is the sql syntax for generating datastore.

<P>sql_syntax_ac = "SELECT tabmer.mer_code, tabmer.mer_desc, tabreg.reg_code,
tabreg.reg_desc, "+&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "Sum(tabarc.arc_rine
- tabarc.arc_reso) 'fatturato', "+&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
"Sum(tabarc.arc_cove - tabarc.arc_core ) 'costo' "+&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "FROM tabarc, tabcli,
tabreg, tabmer " +&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "WHERE ( tabarc.cli_code
= tabcli.cli_code ) and "+&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "( tabcli.reg_code
= tabreg.reg_code ) and "+&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "( tabreg.mer_code
= tabmer.mer_code ) and "+&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "( ( tabarc.arc_anno
= " + anno_ac + " ) AND "+&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "( tabarc.arc_mese
= "+ mese + ") )" +&amp;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "GROUP BY tabmer.mer_code,tabmer.mer_desc,tabreg.reg_code,tabreg.reg_desc"

<P>After this i generate the datastore and retrieve data

<P>ds_syntax = SQLCA.SyntaxFromSQL(sql_syntax_ac,"", err )
<BR>ds_anno_ac = Create Datastore
<BR>ds_anno_ac.Create(ds_syntax,err)
<BR>ds_anno_ac.SetTransObject(SQLCA)
<BR>ds_anno_ac.Retrieve()

<P>The next step, i open&nbsp; a FOR .. NEXT and refence the data with
these istructions:

<P>row_ac = ds_anno_ac.RowCount()
<BR>FOR j = 1 TO row_ac
<BR>&nbsp; mer&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = ds_anno_ac.GetItemNumber(j,"tabmer_mer_code")
<BR>&nbsp; d_mer&nbsp;&nbsp;&nbsp; = ds_anno_ac.GetItemString(j,"tabmer_mer_desc")
<BR>&nbsp; reg&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = ds_anno_ac.GetItemString(j,"tabreg_reg_code")
<BR>&nbsp; regione&nbsp; = ds_anno_ac.GetItemString(j,"tabreg_reg_code")
+ " - " + ds_anno_ac.GetItemString(j,"TABREG_reg_desc")
<BR>&nbsp; vendita&nbsp; = ds_anno_ac.GetItemNumber(j,"cfatturato")
<BR>&nbsp; acquisto = ds_anno_ac.GetItemNumber(j,"ccosto")

<P>On the PC that I'm using to develop I haven't problems, on the PC where
I have installed the application, when the program enter in the loop return
this error:

<P>"invalid row/column specification at line ....."

<P>The name of the column in run time is <B>cmer_code</B> and not <B>tabmer_mer_code</B>

<P>I have read that is important specify in SQLCA USERID=owner table but
there are no effect.

<P>I don't understand if the problem is the configuration of the MS SQL
6.5 or configuration of PB.

<P>There is anyone that can help me ???

<P>Thanks in advence

<P>roberto

<P>EMAIL = roberto.dellacqua@bticino.it
<BR>&nbsp;</BLOCKQUOTE>
</BLOCKQUOTE>
&nbsp;
</BODY>
</HTML>

--------------E888C191761A616D91BC4AC9--

0
Roberto
7/20/1998 9:29:32 AM
Reply:

Similar Artilces:

Error Invalid column name (In Sqlserver 2005) While giving Alias column name
ALTER procedure [dbo].[MyPro](@StartRowIndex int,@MaximumRows int) As Begin Declare @Sel Nvarchar(2000)set @Sel=N'Select *,Row_number() over(order by myId) as ROWNUM from MyFirstTable Where ROWNUM Between ' + convert(nvarchar(15),@StartRowIndex) + ' and ('+ convert(nvarchar(15),@StartRowIndex) + '+' + convert(nvarchar(15),@MaximumRows) + ')-1' print @Sel Exec Sp_executesql @Sel End   --Execute Mypro 1,4        --->>Here I Executed  Error Select *,Row_number() over(order by myId) as ROWNUM from My...

How can I get the column name of a datawindow column?
I want to get the column name in tablename.columnname format. I have tried to get it using dbname property. However, I found that it work only if the tables in the datawindow are inner join. If the tables in the datawindow are outer join, the dbname only return the columnname and the tablename is missed. Do you have any idea? Charles You could add the name to the select clause or to the tag property. Or you caould check to see if it is a join or not (by seeing if there is a '.' in the column name) if not then get the sql select statment and parse to find the table...

Invalid DataWindow row/column
We are using PB 7.0.2 Build 8046. On occassion we get the application error message Invalid DataWindow row/column specified and when I check the line of code it is reported against I find this: IF EVENT ue_block_message() = 1 THEN This makes no sense to me in that the line does not refer to a datawindow, a row, or a column. Any help would be appreciated. Thanks. OK, so which is it? A null object reference or an invalid row/column? You've asked the question twice, asking about both messages. I'd agree with Luca. This screams a Full Rebuild. You want to do it fro...

How to go through a datatable row by row and column by column
Hello, I have a dataset with a datatable and I need to insert each row from the datatable on my sql table, anyway there may be errors, so some rows may not be inserted because primary key constraints,  So I need to show the rows that are not inserted in a gridview, the hard thing to do is to go through all the datatable,  is there an wasy way to do it?MCPD ENTERPRISE APPLICATION DEVELOPER Start by looking herehttp://msdn2.microsoft.com/en-us/library/system.data.common.dataadapter.update.aspxPerform an update of your dataset, and if a row fails, you can mark it as invalid.You can ...

Invalid DataWindow row/column #2
I need some help. I have a DW that is using two tables joined together. The tables are called "sieves" and "sievespecs". Sieves has fields (sieveid, size) Sievespec has fields (sievespecid, sieveid, spec, low, high, plantprodid) Within the open script for the window is the following code segment: The dw has be retrieved and displays the correct information: IF ll_rows < 1 THEN ll_rows = dw_sievesize.RowCount() DO UNTIL i = ll_rows +1 dw_sievedata.insertrow(0) dw_sievedata.SetFocus() s1= dw_sievesize.GetItemNumber(ll_rows,"sievespec_sievespe...

Invalid Datawindow Row/Column specified
Hi People, I have a table consisting of columns mgr1_name to mgr5_name. Now I want to check whether their are names in those columns for a particular row and than insert them into a dropdownlistbox. code: For li = 1 To 5 ls_mgr_nm = lds_user_details.GetItemString(li,"mgr" + String(li) + "_name") If Not IsNull(ls_mgr_nm) Or ls_mgr_nm <> "" Then ddlb_mgr_nm.AddItem(ls_mgr_nm) End If Next Its giving me Invalid datawindow row/column specified. Does any one over here know how can I achieve this in any other way or would like to know what am I mis...

How to use a full column name (table name and column name) with a DataReader
Hi, I have a problem retrieving the data with a DataReader from a stored proc that performs a join of two table with the same column's names but different data. Let me explain with an example: I have two tables: Table1: Id, Name Table2: Id, Name, IdTable1 The sproc is something like this: CREATE PROCEDURE [dbo].[SearchByName] (@Name nvarchar(40)) AS BEGIN SELECT * FROM dbo.Table1, dbo.Table2 WHERE Table1.Id = Table2.IdTable1 AND Table1.Name LIKE '%' + @Name + '%' END And my c# code is something like this: Database db = Databas...

When is a column not a column?
I have several extremely similar datawindows that I have to maintain that go against the same table. Recently, I had to add a column to that table, and also add the column to ALL of these datawindows that go against this table. I added the column to the first datawindow, set up the edit control style, etc. I then did a copy/paste of the columns edit control to the remaining dw's (of course remembering to first add the column in SQL). Everything (update props, column specs, column props) seems to indicate that the pasted column is linked to the column I selected, HOWEVER, when I...

Invalid DataWindow row/column #3
version 8 build 9704 error 6: Invalid DataWindow row/column specified at line 36 in clicked event of object dw_1 of w_reports_output The clicked field is in the group header and is a hyperlink. Now, if I move this hyperlink field to the detail area of my report, it works just fine. You are geting an error in the clicked event because of an invalid row. The hearder always has 0 as the row number. Can you show us the code in the clicked event of the datawindow? Jim On 5 Mar 2004 08:51:51 -0800, in sybase.public.powerbuilder.general <Sarah> wrote: >version 8 b...

How to place in DataGrids’s first column table’s column name, in second Datagrid’s column table’s column value?
Hello I use C#. I’m interesting are there samples solved my problem. Andrew. You will need to loop through the datasource of the datagrid or through the datagrid items and fetch the values for the second datagrid.Sonu Kapoor [MVP] Feel free to ask me any .NET question | Ajax Data Controls Forum Thank you! I solved my problem at the server cite. Andrew. ...

[*-)]how to delete all columns except one column for the corresponding column name......?
hi friends,          i've a table with (columns) username, content,data,........... i need to delete all column names(i.e.,content,data,........) except username for the specified username. eg: consider username=mahendran. i've to delete the values in the content,data,...............for the username=mahendran. but username should exist.how to do that?pls help me......  ---------------------------------------------------Don't forget to "Mark as Answer" if you are satisfied. Use the following  DataTable.Columns.Rem...

SqlBulkCopy: the locale id '0' of the source column '<column name> ' and the locale id '1033' of the destination column '<column name>' do not match.
Hi, I am using the sqlbulkcopy object to transfer large amount of data from one SQL server to Other. The code look like this.. SqlDataReader readerSrc = null;SqlBulkCopy bulkCopy = new SqlBulkCopy(connDest);//Prepare Destination Table.SqlCommand cmdDelete = new SqlCommand("DELETE FROM " + destTableName, connDest);//Set the sqlcommand textSqlCommand cmdGet = new SqlCommand("SELECT * FROM " + srcTableName, connSrc);//Open source connection.connSrc.Open();//Open destination connection.connDest.Open();int delete = cmdDelete.ExecuteNonQuery();//Get the data.readerSrc = cmdGet.ExecuteRead...

Error INVALID Datawindow row/column specified
Please help! I am debugging an application that uses Powerbuild 6.0 and when opening a window I receive this message. Any clues. Thanks, Peggy Somewhere in the code path during the window open, you are trying to access or modify a dw row or column that is not valid. It could be a case where you are trying to access a row before the dw has been retrieved. For example, if you are accessing a row in the constructor for the dw but the retrieve is performed in the open event of the window, this will cause the error. HTH, steve [TeamPS] Peggy Jaquith wrote: > > P...

Error: Invalid DataWindow row/column specified
I am using PowerBuilder 10.5. I have an external Datawindow that links to a DropDownDW with a display column called "name1_txt" and a data column called "address_key_id". I am able to populate the field from the DropDownDW after the window opens. Prior to the window opening in the ue_init() of the window: dw_address_names.SetTransObject(itran) ll_Error = dw_address_names.GetChild("name1_txt",ldwc_AddressNames) ldwc_AddressNames.SetTransObject(itran) ll_RowCount = ldwc_AddressNames.Retrieve(idec_CuId) The code correct retrieve...

Web resources about - Column Name in datastore ( invalid row/column ....) - sybase.powerbuilder.datawindow

Fortune Datastore - Home
The Ultimate Resource for marketing, mailings, sales, and research!

F8: No Internet Connection? Parse Local Datastore Has Your Apps Covered
Applications that work offline? Why not? Parse announced the launch of Parse Local Datastore — a new feature in its software-development kit ...

Parse Roundup: Introducing Crash Reporting, Local Datastore for iOS, and Much More
Parse Roundup: Introducing Crash Reporting, Local Datastore for iOS, and Much More

Twitter Engineering: Introducing Gizzard, a framework for creating distributed datastores
Tuesday, April 6, 2010 Introducing Gizzard, a framework for creating distributed datastores An introduction to sharding Many modern web sites ...

Flickr: The Guardian Datastore Pool
... Photos The Commons Getty Collection Galleries World Map App Garden Camera Finder The Weekly Flickr FlickrBlog Upload Sign In Guardian Datastore ...

Datastore Automotive News
$120 - 2008 Top 125 Dealership Groups in the U.S. ranked by revenue for all departments (includes sales by department, makes sold, and top sales ...

Google Cloud Platform enhances Compute Engine, App Engine and Cloud Datastore
... additions: layer 3 load balancing capability for Google Compute Engine new features and productivity improvements for Google Cloud Datastore ...

Google deprecates old App Engine datastore in favor of High-Replication version
Google is deprecating the Master/Slave Datastore used by its cloud platform App Engine in favor of the High-Replication Datastore (HRD), which ...

Welcoming Dropbox Datastore
... I need to stop telling people that Zumero is "like Dropbox, except for data instead of files". :-) This week, Dropbox announced their Datastore ...

Google cuts prices on week-old datastore
Let the cloud price chopping continue. A week after Google announced its Cloud Datastore managed NoSQL database, it’s cutting its price, according ...

Resources last updated: 12/15/2015 5:09:49 PM