PB 5.0.02 connect FoxPro2.5 files using ODBC

Hello,

    I use PB Desktop ver 5.0.02 on Win95 to connect to (*.dbf) files in
FoxPro2.5 format with compaund (*.cdx) indexes. I configure ODBC drivers
which came with this PB version (two Intersolve ODBC ver. 2.12 32-bit and
one Microsoft FoxPro Driver from Win95) and made DB profiles for each ODBC.
I can establish connection to my FoxPro *.dbf files.

    But not everything seems to be correct. In database painter (using
Intersolve ODBC) for I can not see index key definition from *.cdx file
which was build using FoxPro function: Deleted() or I can see the name of a
key but there is no index key definition ( function: Int() ). When I try to
update FoxPro file (in DB painter) there is an error message

SQLSTATE = 37000
[INTERSOLV][ODBC dBase driver]Unknown Function: DELETED

No changes made to database.

INSERT INTO STORE ( PART_NO, GROUP ) VALUES ( 'dddd', 'wwww' )

Microsoft ODBC also does not see index build on Deleted(), but the rest of
indexes it sees in strange order, for example key index
str(store_no)+Upper(part_no+loc_code)it sees this way part_no, store_no,
loc_code.

    Does anybody now how to solve this problem?. Are there any other ODBC
drivers from other vendors which correctlly work with FoxPro databases
(assuming that I can upgrade my Desktop version of PB to at least
Professional one and use this drivers). Or is it a matter of ODBC
configuration?.

Thanks in advance,

Wojtek




0
Wojciech
1/16/1999 1:11:54 PM
sybase.powerbuilder.database 9855 articles. 2 followers. Follow

1 Replies
624 Views

Similar Articles

[PageSpeed] 24

You can try Visigenic if they have ODBC drivers for Foxpro.

--
Terry Dykstra (TeamPS)
Canadian Forest Oil Ltd.
Wojciech Suszek wrote in message ...
>Hello,
>
>    I use PB Desktop ver 5.0.02 on Win95 to connect to (*.dbf) files in
>FoxPro2.5 format with compaund (*.cdx) indexes. I configure ODBC drivers
>which came with this PB version (two Intersolve ODBC ver. 2.12 32-bit and
>one Microsoft FoxPro Driver from Win95) and made DB profiles for each ODBC.
>I can establish connection to my FoxPro *.dbf files.
>
>    But not everything seems to be correct. In database painter (using
>Intersolve ODBC) for I can not see index key definition from *.cdx file
>which was build using FoxPro function: Deleted() or I can see the name of a
>key but there is no index key definition ( function: Int() ). When I try to
>update FoxPro file (in DB painter) there is an error message
>
>SQLSTATE = 37000
>[INTERSOLV][ODBC dBase driver]Unknown Function: DELETED
>
>No changes made to database.
>
>INSERT INTO STORE ( PART_NO, GROUP ) VALUES ( 'dddd', 'wwww' )
>
>Microsoft ODBC also does not see index build on Deleted(), but the rest of
>indexes it sees in strange order, for example key index
>str(store_no)+Upper(part_no+loc_code)it sees this way part_no, store_no,
>loc_code.
>
>    Does anybody now how to solve this problem?. Are there any other ODBC
>drivers from other vendors which correctlly work with FoxPro databases
>(assuming that I can upgrade my Desktop version of PB to at least
>Professional one and use this drivers). Or is it a matter of ODBC
>configuration?.
>
>Thanks in advance,
>
>Wojtek
>
>
>
>


0
Terry
1/18/1999 4:27:40 PM
Reply:

Similar Artilces:

Migrating from PB v5 to v5.0.02 and from 5.0.02 to 5.0.03.
Hello, 2 customers have requested information on how to migrate from PowerBuilder v5 to 5.0.02 and from 5.0.02 to 5.0.03. Can anyone offer advice? Do they both need to call Technical Support? I've looked in our Technical Information Library and entering requests via Query Builder yields nothing. Thank you very much. Deborah (Information Products Group) Deborah Blakeney wrote: > > Hello, > > 2 customers have requested information on how to migrate > from PowerBuilder v5 to 5.0.02 and from 5.0.02 to 5.0.03. Can > anyone offer advice? Do the...

Connecting to MS SQL 6.5 through PB 5.0.02
I have set up a MS SQL ODBC connection in ODBC Administrator that has the server name and database name set, the rest is all default. In PB I make a new database profile called 'MS SQL' and set DBMS to 'ODBC'. In the 'Select Data Source' window that comes up I select the ODBC connection I just made on the 'Machine Data Source' tabpage. When I press OK to connect, PB crashes. I am running Win NT Server 4.0 and it has the MS SQL database, client software and PB installed on it. What am I doing wrong? I've tried all sorts of things like setting ...

Are you using PB 5.0.03 version of PBODB050.DLL with PB 5.0.04??
PB 5.0.04 applications connected to SQL Anywhere 5.5 will GPF on disconnect when ODBC 3.5 or greater is installed. I believe this may only happen for win95 as opposed NT/98. Replacing PBODB050.DLL with the PB 5.0.03 version has been a common 'folk remedy'. We have just discovered a problematic side-effect: If instead of connecting to SA 5.5, you connect to SA 7, and your PB application uses datawindows which retrieve through calls to Stored Procedures, then such a retrieve produces a database error: Select error: SQLSTATE = S1009 [Sybase][ODBC Driver]Invalid use o...

PB 5.0.02 to 5.0.04
Hi, We updated PowerBuilder 5.0.02 to 5.0.04 on a WIN95 machine with the update downloaded from the Sybase Support site but the Help / About window still says version 5.0.02! I tried writing a small app that gets the PBMajorRevision, PBMinorRevision and PBFixesRevision from the Enviroment object and still get 5, 0, and 2, respectively. The executables and DLL's have date/time stamps of 3/98 and later indicating that the update occurred. The same update applied to an NT machine shows the correct version 5.0.04 in the Help / About window, so this may be a WIN95-specific probl...

PB 5.0.02 to PB 6.5
Hi, I tried to miograte our applications to PB6.5, all it's riht. In developpement mode, all it's ok. I do the excutable OK. I launch it : ERROR, call settrans object ....Datawindow information, not available !! I recompile the exe with trace mode and a lot of messages boxes to see if the SQLCA transaction, it's ok. I launch, transaction it's ok, I get the error message, the trace file is empty !!! What 's wrong doctor ? Could you give me some help ? fred Have you dynamically assigned the datawindow object - e.g., dw_1.DataObject='d_mydat...

Problem connecting to Anywhere 5.5 using a PowerBuilder 4.0 app
I am having problems connecting to a SQl Anywhere 5.5 database running is server mode on a Novell network. The application is in PowerBuilder 4.0. I am able to use Access 97 and Infomaker to connect, but not the PB 4.0 app. Thank you in advance! kedersha_brian@aac.com Do you have some error messages? What client are you using? Win 95/3.11/NT? I know of no reason that PB4 cannot connect to SA 5.5.x server. -- Jim Egan [TeamPS] Dealer Solutions, LLC Houston, TX Is your PB4 app 16 or 32 bit? How are the ODBC Profiles defined? Are they 16 or 32 bit Profiles? Are they...

Migrating from PB 5.0.02 to PB 6.5...
Hello, The migration went pretty well, but I have an error and don't know where to look. Here it is: Object: ue_cie_ie Instance Variables (0031): Error C0176: Badly ordered TYPE and VARIABLE declarations. Is this modified exported source? Any ideas?? Thanks in Advance, Fred. (fred.goldbach@fiserv.com) What's on line 31 of the instance variables? Terry [TeamPS] and Sequel the techno-kitten On Fri, 21 Aug 1998 19:06:08 -0400, Fred Goldbach <fred.goldbach@fiserv.com> wrote: > The migration went pretty well, but I have an error and...

Files to upgrade from PB 5.02 to PB 5.04
Hi, I have got an application that is Powerbuilder 5.02 and would need to get the upgrade files to PB 5.04. Does any one know where one can find them. Unfortunatley this crazy application has some migration problems when upgrading to a higher version and we are as such stuck with it. Any pointers to any websites or if anyone has the upgrade files and could post it, that would be appreciated. ---== Posted via the PFCGuide Web Newsreader ==--- http://www.pfcguide.com/_newsgroups/group_list.asp "mahenn" <mahenn45@hotmail.com> wrote: > I have got an application tha...

5.0.03 PFC with 5.0.02 PB
Our group would like to upgrade to 5.0.03 because of the bug fixes for the PFC pbls, but we are hesitant due to the regression errors in 5.0.03 PowerBuilder. Is there any reason we couldn't upgrade our PFC pbls to 5.0.03 but keep our PowerBuilder at 5.0.02? I would expect it to work fine, but would like to get other opinions. TIA -Jay Paulsen Running 16 bit PB under NT 4.0, we ran PB 5.0.02 with PFC 5.0.00 for a few months of development and had no problems related to the different versions. Eventually we did re-synch. The only re-synching problems we had were a coup...

Pb6.5 Connecting to SQL Anywhere 5.5.0.4 Database
Does PB6.5 support SQL Anywhere 5.5.0.4 database interface, I don't see it when I try to create a database profile in PB6.5 ??. I can create an ODBC database profile though, but i don't want to use ODBC. Thanks Ravi Nath Ravi, SQL Anywhere uses the ODBC interface as native so that's the right way to go. Regards, John Olson [TeamSybase] Developower, Inc. www.developower.com SAS wrote in message ... >Does PB6.5 support SQL Anywhere 5.5.0.4 database interface, I don't see it >when I try to create >a database profile in PB6.5 ??. >I c...

Cannot use SQl Sample Database 5.0 after updating to 6.5 PB... pls help
Please help. What is going on ? This is the errors DBENG50 caused an invalid page fault in module KERNEL32.DLL at 0177:bff9d709. Registers: EAX=c00300ec CS=0177 EIP=bff9d709 EFLGS=00010216 EBX=00000005 SS=017f ESP=0060feb4 EBP=00610150 ECX=00000000 DS=017f ESI=00610238 FS=4ee7 EDX=00000028 ES=017f EDI=00610254 GS=0000 Bytes at CS:EIP: 53 8b 15 dc 9c fc bf 56 89 4d e4 57 89 4d dc 89 Stack dump: Is it possible that the 5.0 database was upgraded? I'm just thinking out loud here.... I can't think of a reason that the PB 6.5 upgrade would cause the SQL Anywhere db engi...

PB 5.0.03 Pro Win95, SqlAny 5.5, RPC in ODBC
I am having trouble getting a Remote Procedure call to work in PB 5.0.03. I am using the Win95 Professional edition with SQLany 5.5 and an ODBC connection. The docs seem to say that I can use Stored Procedures with SQLAnywhere and ODBC. I tried to set them up as shown in the book, with the transaction object's External Local prototypes, and the right permissions on the SP. When I try to call it from my code with SQLCA.ProcName(), I get the following error: Database Interface does not support Remote Procedure Calls. I have two OUT parms. It sounds a lot like I either ...

Oracle 8.0.5 and PB 5.0.04 connection
Hi All! My company wants to migrate to Oracle 8.0.5 but we will have PB 5.0.04 apps running on Win95 and NT clients. PB 5.0.04 contains only beta version of PBOR8050.dll which I would not like to use (we are talking thousands of users worlwide). Technote 47630 does not offer anything for Oracle 8.0.5. So, is there PB native driver (non beta) for PB 5.0.04 to talk to Oracle 8.0.5 ? Thank you No. But you can use the O73 driver, aslong as you don't need any specific Oracle8 functionality -- Terry Dykstra (TeamPS) Canadian Forest Oil Ltd. Gary Vashkulat wrote in me...

Ho to update from PB 5.0.02 to 5.0.04
How can I Update Powerbuilder from 5.0.02 to 5.0.04? Do I have to update to 5.0.03 and then to 5.0.04? Does the Enterprise Edition need special Patches? How can I get the Patches? mfg Roman Seidl Roman, Go to https://support.sybase.com/esd/pb.html and download the appropriate patch and install it. They are not incremental (you can go directly from 5.0.02 to 5.0.04) and work for all of the PB editions. After you have correctly installed the patch (check the about box from the help menu), be sure to do a full rebuild on your applications. HTH, Greg -- _____...

Oracle 10g Database connectivity in PowerBuilder 11.5 Desktop Version using ODBC
This is a multi-part message in MIME format. ---=_forums-1-dub4940f6b1 Content-Type: text/plain; charset="ISO-8859-1" Content-Transfer-Encoding: 7bit Hi, I have installed PB 11.5 Desktop version with all the EBF`s. I created a DSN for the Oracle 10g default ('Orcl') database through ODBC Administrator. I was successfully able to connect to the database through the DSN. Now I created a Database Profile in PowerBuilder 11.5 Desktop version for the DSN created above. When I tried testing the database connection I got the errors present in attached in document...

SQL Anywhere runtime 5.0.02 and PB 5.0.04
Hi. We currently use PB5.0.02 and want to implement PB5.0.04. We purchased SQL Anywhere runtime system for standalone use and I'd like advise as to how to update this... or whether I need to. As I understand it the 5.0.04 setup will update SQL Anywhere on my machine but we use the runtime floppies at remote sites. On a related matter when we update a client with a newer PB5.0.04 application and relevant DLLs do we actually need to do anything to the database or ODBC profile? Thanks for the help, Adam. You can download the current release of SQL Anywhere through the S...

Connection Pb with SQLA 5.5.5
Hello, I'm facing a strange problem with SQL Anywhere 5.5.5 build 2817. I'm developping an application with PB7. I would like to connect to 2 databases : one local with rtdsk50.exe and one on a network with dbclient.exe. One at a time, it works very well. Local and after network it works If i connect to the network base, then to the local the rtdsk hangs. It starts the database but never returns to the application or to PB7 Thanks Pierre ...

Upgrading from PB 5 to 5.0.02.
Hello, A customer is inquiring about upgrading from PB5 to v5.0.02. He currently uses PB4 and when he installed the Internet Developer Toolkit in the PB5 Enterprise package, he receive the message: "It can be installed on PB v5.0.02 or higher". Any advice? Thank you. Deborah Deborah, I believe the IDT requires PB5.0.02. You can obtain the 5.0.02 patch from the PowerSoft website https://support.sybase.com or from your InfoBase subscription. hth, -- Anthony M. Perugini President Forte Information Systems Inc. CPDP, CPI, CSPdba, MCPS aperugini@csi.com ...

PB 5.0.03 and PB 5.0.04
Hi. Do I need to install PB 5.0.03 and after PB 5.0.04 or I can just install PB 5.0.04 ? You can just install 5.0.04. Make a backup of your pbls prior to installing 5.0.04 in case you need to revert back to the current version. hth, Anthony M. Perugini President Forte Information Systems, Inc. www.ConsultForte.com Having a Bad Day? www.ConsultForte.com/Disgruntled.htm Kleber Pimentel Koti wrote in message ... >Hi. >Do I need to install PB 5.0.03 and after PB 5.0.04 or I can just install PB >5.0.04 ? > > ...

PowerBuilder 5.0 to 5.0.0.2
I hope this the correct venue for this question. I have a fresh install of PB 5.0 and I need to upgrade it to 5.0.0.2. I have found plenty of reference/downloads to 5.0.0.4 on the sybase website, but I need to go from 5.0 to 5.0.0.2. Where can I download the correct patch/upgrade? Thanks 5.0.0.2 is no longer available. You can choose between 5.0.03 (bug infested) and 5.0.04 (stable). -- pbm_hopethishelps, Roy Kiesler [TeamSybase] Sybase Developer Network (SDN) - http://sdn.sybase.com MySybase - http://my.sybase.com "Dwayne Bordelon" <dwayne.bordelon@shawinc...

Trouble sharing a dbclient ODBC connection between two processes on web server SQLAnywhere 5.5.0.5
Hello, I am trying to tie a whole bunch of legacy components together with a new reporting engine and I've come across an interesting problem. I have a W2k Web server that is connecting to an NT4.0 SQLAnywhere 5.5.0.5 database server via an ODBC dbclient connection. The web server is running classic ASP pages for the bulk of the web site, with a single ASP.net section for viewing reports. Everything works great and I can connect to the database as long as I have only one of the connections active - either the ASP or ASP.net site. As soon as I try to connect both at ...

Triggers in SQL Anywhere 5.5.0 and PowerBuilder 5.0.03
Hi: I'm trying to get a series of triggers working, but am having lots of difficulties. Initially, the following trigger did not update the 'product' table on an insert. create trigger ti_inventory after insert on inventory referencing new as new_inventory for each row begin update product set product.current_in_stock = product.current_in_stock + new_inventory.qty_new + new_inventory.qty_used_excl + new_inventory.qty_used_good + new_inventory.qty_used_poor where product.product_code = new_inventory.product_code end; I tried to put other commands into the t...

PB 5.0 cursor fetch error using MS SQL Server 6.5 (Service Pack 5)
We have PB5.0.02 and are upgrading to PB5.0.04 for Y2K compliance. Both are 16 bit. We have been using MS SQL Server 6.50.201 (the original release). Everything has been fine. We have just put MS SQL Server 6.50.415 (Service Pack 5) on a test server for Y2K compliance and are getting cursor fetch errors using either version of PB5.0. The error is 10037 "unexpected EOF from SQL Server." In looking at the SQL error log we see an EXCEPTION_ACCESS_VIOLATION error message involving sp_cursorfetch. Does this rings any bells with anyone? Is there an upgraded dll (or dlls) ...

Web resources about - PB 5.0.02 connect FoxPro2.5 files using ODBC - sybase.powerbuilder.database

First Capital Connect - Wikipedia, the free encyclopedia
( FCC ) is a British train operating company , owned by FirstGroup , operating the Thameslink Great Northern franchise . FCC operates passenger ...

Connect
mobile photography technology, culture and community www.dpreview.com News Reviews Features Phones Tablets Cameras Apps Forums Mobile photography ...

CloudCraze Connects Consumers To Facebook Brands Via Cloud Technology
Brands on Facebook are always looking for new, efficient ways to connect with customers . CloudCraze, which recently released its 3.0 e-commerce ...

Feature Request: 7 ways Apple Music Connect could be improved
... two years later . This year, alongside the announcement of the highly anticipated Apple Music streaming service , the company launched Connect, ...

Dating App Festar Connects Users Based on Mutual Interests, Not Looks
... release in Japanese, dating app Festar has launched in beta on Android in 13 countries in English and Korean. From AI Pacific , Festar connects ...

'People v. O.J. Simpson' connects dots from L.A. to Ferguson, Baltimore
The White Ford Bronco. The darkening of O.J. Simpson 's face on the cover of Time magazine. Attorney Johnnie Cochran holding up the blood-soaked ...

Morocco Connects First Unit of Giant Noor Solar Complex to Grid
The first phase of North Africa’s largest solar-power complex was connected to the grid in Morocco, with a generating capacity of 160 megawatts. ...

Qualcomm’s New LTE Gigabit Modem Will Make Phones Very Fast… If It Ever Gets A Network To Connect To
... powers the majority of Android phone brands, including Samsung, LG, Nokia, Motorola, and HTC handsets. They also have a reach into most connected ...

NYC mayor wants a streetcar to connect Brooklyn and Queens
New York City Mayor Bill de Blasio is once again trying to make an impact on transportation but this time it's with streetcars, not taxi apps. ...

How to Immediately Connect With Anyone
Too many people succumb to the mistaken belief that connecting with people is an innate skill that belongs only to the lucky few

Resources last updated: 2/18/2016 1:25:22 AM