ASE Version number

Does it really make that difference while changing Connection String where
SQLCA.DbParm="ModifySyntax=0,Release='11',Async=1"
                                        and
SQLCA.DbParm="ModifySyntax=0,Release='12.5',Async=1"

The sentence is from PowerBuilder 9.0.1 login script.
My production server is ASE 11.9.2 and my Development server is ASE 12.5.1.

I thought that Ct-Lib or PB dlls will take care of this version problem.  I
am able to connect by
using any version, however, my problem is that one of the SP (stored proc)
is not working
properly.

The compiled EXE works fine on my local drive (C:) but failed to work in my
network drive.
Am I missing a PowerBuilder dll to handle the situration?
Rao/..


0
Rao
6/30/2004 8:18:56 PM
sybase.powerbuilder.database 9855 articles. 0 followers. Follow

3 Replies
517 Views

Similar Articles

[PageSpeed] 50

See the documention for this DbParm as this is covered. I have pasted the
relevant information for convinience.

When to use  Certain features are supported only when you access a specified
version of a SQL Server 10/11 or Adaptive Server Enterprise database using
its associated Open Client software. For example, you must be using Open
Client 11.x to take advantage of network-based security and directory
services in your application.
Therefore, to use any of the DBParm parameters in PowerBuilder that support
Open Client 11.x security and directory services, you must set Release to
'11' or '11.5'. To use any of the new features supported in Adaptive Server
Enterprise 12.x, you must set Release to '12'.

-- 

Chris Keating
Sybase Adaptive Server Anywhere Professional Version 8

****************************************************************************
*
Sign up today for your copy of the SQL Anywhere Studio 9 Developer Edition
and try out the market-leading database for mobile, embedded and small to
medium sized business environments for free!

http://www.ianywhere.com/promos/deved/index.html

****************************************************************************
*

iAnywhere Solutions  http://www.iAnywhere.com

** Please only post to the newsgroup

** Whitepapers can be found at http://www.iAnywhere.com/developer
** EBFs can be found at http://downloads.sybase.com/swx/sdmain.stm
** Use CaseXpress to report bugs http://casexpress.sybase.com

****************************************************************************
*

"Rao Hanumara" <rhanumar@wam.umd.edu> wrote in message
news:40e320d6@forums-2-dub...
> Does it really make that difference while changing Connection String where
> SQLCA.DbParm="ModifySyntax=0,Release='11',Async=1"
>                                         and
> SQLCA.DbParm="ModifySyntax=0,Release='12.5',Async=1"
>
> The sentence is from PowerBuilder 9.0.1 login script.
> My production server is ASE 11.9.2 and my Development server is ASE
12.5.1.
>
> I thought that Ct-Lib or PB dlls will take care of this version problem.
I
> am able to connect by
> using any version, however, my problem is that one of the SP (stored proc)
> is not working
> properly.
>
> The compiled EXE works fine on my local drive (C:) but failed to work in
my
> network drive.
> Am I missing a PowerBuilder dll to handle the situration?
> Rao/..
>
>


0
Chris
7/1/2004 1:33:32 PM
Chris,
   Thanks.  The reason I posted the message was that I was using Release
11.5 parameter which was copied from my login script  even for release
12.x/12.5x for nearly two years and see no problem whether it is ASE 11.9 or
12.X.
All of sudden I noticed that my new Stored Procedure did not work when my
EXE is on network drive.  The new stored procedure code is 100% same on 11.X
and 12.5X servers.
I thought that I may be missing some DLL or LIB files  to propery execute PB
application.
Rao/..

"Chris Keating (iAnywhere Solutions)" <FightSpam_keating@iAnywhere.com>
wrote in message news:40e412ac$1@forums-1-dub...
> See the documention for this DbParm as this is covered. I have pasted the
> relevant information for convinience.
>
> When to use  Certain features are supported only when you access a
specified
> version of a SQL Server 10/11 or Adaptive Server Enterprise database using
> its associated Open Client software. For example, you must be using Open
> Client 11.x to take advantage of network-based security and directory
> services in your application.
> Therefore, to use any of the DBParm parameters in PowerBuilder that
support
> Open Client 11.x security and directory services, you must set Release to
> '11' or '11.5'. To use any of the new features supported in Adaptive
Server
> Enterprise 12.x, you must set Release to '12'.
>
> -- 
>
> Chris Keating
> Sybase Adaptive Server Anywhere Professional Version 8
>
>
****************************************************************************
> *
> Sign up today for your copy of the SQL Anywhere Studio 9 Developer Edition
> and try out the market-leading database for mobile, embedded and small to
> medium sized business environments for free!
>
> http://www.ianywhere.com/promos/deved/index.html
>
>
****************************************************************************
> *
>
> iAnywhere Solutions  http://www.iAnywhere.com
>
> ** Please only post to the newsgroup
>
> ** Whitepapers can be found at http://www.iAnywhere.com/developer
> ** EBFs can be found at http://downloads.sybase.com/swx/sdmain.stm
> ** Use CaseXpress to report bugs http://casexpress.sybase.com
>
>
****************************************************************************
> *
>
> "Rao Hanumara" <rhanumar@wam.umd.edu> wrote in message
> news:40e320d6@forums-2-dub...
> > Does it really make that difference while changing Connection String
where
> > SQLCA.DbParm="ModifySyntax=0,Release='11',Async=1"
> >                                         and
> > SQLCA.DbParm="ModifySyntax=0,Release='12.5',Async=1"
> >
> > The sentence is from PowerBuilder 9.0.1 login script.
> > My production server is ASE 11.9.2 and my Development server is ASE
> 12.5.1.
> >
> > I thought that Ct-Lib or PB dlls will take care of this version problem.
> I
> > am able to connect by
> > using any version, however, my problem is that one of the SP (stored
proc)
> > is not working
> > properly.
> >
> > The compiled EXE works fine on my local drive (C:) but failed to work in
> my
> > network drive.
> > Am I missing a PowerBuilder dll to handle the situration?
> > Rao/..
> >
> >
>
>


0
Rao
7/1/2004 4:30:52 PM
Unless I missed it (which is entirely possible), you don't
mention which version of the OpenClient libraries you are
using.  If you are using the 11.x version and set the
release parameter to 12.x, maybe that is causing the
problems you are seeing.

Also, you don't indicate exactly what the problem is, just
that a particular proc is not working correctly.

steve
[TeamSybase]

> Chris,
>    Thanks.  The reason I posted the message was that I was
> using Release 11.5 parameter which was copied from my
> login script  even for release 12.x/12.5x for nearly two
> years and see no problem whether it is ASE 11.9 or 12.X.
> All of sudden I noticed that my new Stored Procedure did
> not work when my EXE is on network drive.  The new stored
> procedure code is 100% same on 11.X and 12.5X servers.
> I thought that I may be missing some DLL or LIB files  to
> propery execute PB application.
> Rao/..
>
> "Chris Keating (iAnywhere Solutions)"
> <FightSpam_keating@iAnywhere.com> wrote in message
> > news:40e412ac$1@forums-1-dub... See the documention for
> > this DbParm as this is covered. I have pasted the
> relevant information for convinience. >
> > When to use  Certain features are supported only when
> you access a specified
> > version of a SQL Server 10/11 or Adaptive Server
> > Enterprise database using its associated Open Client
> > software. For example, you must be using Open Client
> 11.x to take advantage of network-based security and
> > directory services in your application.
> > Therefore, to use any of the DBParm parameters in
> PowerBuilder that support
> > Open Client 11.x security and directory services, you
> > must set Release to '11' or '11.5'. To use any of the
> new features supported in Adaptive Server
> > Enterprise 12.x, you must set Release to '12'.
> >
> > --
> >
> > Chris Keating
> > Sybase Adaptive Server Anywhere Professional Version 8
> >
> >
> **********************************************************
> > ****************** *
> > Sign up today for your copy of the SQL Anywhere Studio 9
> > Developer Edition and try out the market-leading
> > database for mobile, embedded and small to medium sized
> business environments for free! >
> > http://www.ianywhere.com/promos/deved/index.html
> >
> >
> **********************************************************
> > ****************** *
> >
> > iAnywhere Solutions  http://www.iAnywhere.com
> >
> > ** Please only post to the newsgroup
> >
> > ** Whitepapers can be found at
> > http://www.iAnywhere.com/developer ** EBFs can be found
> > at http://downloads.sybase.com/swx/sdmain.stm ** Use
> CaseXpress to report bugs http://casexpress.sybase.com >
> >
> **********************************************************
> > ****************** *
> >
> > "Rao Hanumara" <rhanumar@wam.umd.edu> wrote in message
> > news:40e320d6@forums-2-dub...
> > > Does it really make that difference while changing
> Connection String where
> > > SQLCA.DbParm="ModifySyntax=0,Release='11',Async=1"
> > >                                         and
> > > SQLCA.DbParm="ModifySyntax=0,Release='12.5',Async=1"
> > >
> > > The sentence is from PowerBuilder 9.0.1 login script.
> > > My production server is ASE 11.9.2 and my Development
> > server is ASE 12.5.1.
> > >
> > > I thought that Ct-Lib or PB dlls will take care of
> > this version problem. I
> > > am able to connect by
> > > using any version, however, my problem is that one of
> the SP (stored proc)
> > > is not working
> > > properly.
> > >
> > > The compiled EXE works fine on my local drive (C:) but
> > failed to work in my
> > > network drive.
> > > Am I missing a PowerBuilder dll to handle the
> > > situration? Rao/..
> > >
> > >
> >
> >
>
>
0
Steve
7/15/2004 8:56:36 PM
Reply:

Similar Artilces:

Version of PowerBuilder (ref: Creating database for PowerBuilder)
I'm using PowerBuilder v8.0 and would like to create a notification system for my practiculum project. I'd like to use Access to create the database. Please enlighten me on what should I create (e.g. tables, queries) for the usage of it. Thank You. Regards, Yang Ashra Don't double post, it's bad etiquette. Unless you have a very good reason to do so, we recommend you don't use Access. Use SQL Anywhere instead - it's more stable - and a far better database in my opinion. PowerBuilder (enterprise) supports just about every database out there, so if you...

Database File Version vs Database Engine Version
Hi. I was recently visiting a customer site and noticed, from Sybase Central, that the customer's database file displayed a 5.x version number, even though the ASA engine was version 7.0.2. This customer is running our pb6.5 / ASA 7 application under Citrix and is having problems which are not appearing at other customer sites. I would like to rule-out any possibility of these problems being generated by our application. Has anyone eliminated problems by upgrading the database file to the same version as the database engine? Does Sybase recommend that the file be kept &quo...

PowerBuilder version number compatibility
I use InfoMaker version 6.5, build 444, which is bundled with two software packages distributed by Primavera Systems. Due to this bundling, this version number will not be changing for quite a while. I am looking into purchasing PowerBuilder in order to write embedded functions for this version of InfoMaker. I have noticed that the PowerBuilder version shipping is 7.0. Is this PowerBuilder version compatible with InfoMaker version 6.5, build 444? If not, what PowerBuilder version do I need (6.5 perhaps) and where would this "older" version be available? Thank you, ...

Getting database version numbers
Hi I've got some code that relies on a newish version of postgres ( let's say > 7.0 ). Now, I'm writing a wizardy type thing to find a database to connect this application to ( not nescesarily on the same machine ). I'd like to prevent people from setting the code up on a database that isn't new enough. Is there please in DBI somewhere that let's you retrieve the remove database version number? Thanks Adam Kennedy Under DBD::ODBC you can use GetInfo with SQL_DBMS_VER (18) but I guess you would need to know which underlying DBMS that applied...

How to upgrade/convert version 8.1 database to version 10 database
Hi, I would like to upgrade a 8.1 version into version 10 database. Could you please tell me, how to go about it ? regards Venu "venu" <venuc@hotmail.com> wrote: > I would like to upgrade a 8.1 version into version 10 database. > > Could you please tell me, how to go about it ? Have you heard about the SA manual ;)? Start from the following: -------------------------------------------------- SQL AnywhereR 10 - Changes and Upgrading Upgrading to SQL Anywhere 10 Upgrading SQL Anywhere .... --------------------------------------...

TDS Version and ASE Version
Where can I find out a little bit about TDS and how different ASE versions (specifically 11.5.1 vs 12.x) affect DBLIB behaviour? Also, we have HPUX DBLIBS apps. Is the TDS version relevant as far as they are concerned? We have a DBLIB app that uses the default TDS version TDS 4.6 under ASE 11.5.1. Under ASE 12.0.1 the app "hangs" occasionally when run using TDS ver. 4.6 but seems to behave better when run using TDS 5.0. Cliff Youse wrote: > Where can I find out a little bit about TDS and how > different ASE versions (specifically 11.5.1 vs 12.x) affec...

How to get the version-Number of on old database-file
I am using ASA 9.01 I have started an older database-file. How to get the version-Number of the database-file ( abcdef.DB ) Thanks Peter Peter Stojkovic wrote: > > I have started an older database-file. > How to get the version-Number of the database-file ( abcdef.DB ) > There really isn't a way. The "version" number in a database file represents the capabilities of the .db file, not the version with which it was created. Is there a particular reason you are hoping to get this information? greg.fenton -- Greg Fenton Consultant, S...

Problem connecting to oracle database in powerbuilder 9.0 desktop version
I am not able to connect to oracle database using odbc in powerbuilder 9.0 desktop version.I am getting error message which says 'Inavlid or unsupported datasource' Ershad, Have you verified that you have the required Oracle ODBC drivers? The latest set of drivers is available at: http://www.oracle.com/technology/software/tech/windows/odbc/index.html\ Could you also please post the attributes of the transaction object (except the password) that you use to try and connect to the oracle db? Sanjiv. <Ershad Ali Mohammad> wrote in message news:41aea458.51d5...

The assembly version does not match the database version
Hi, everybody, My name's thuantam and I'm very interested in using DNN to study with my PC. I want to install the DNN 2.0 Beta with the OS: Windows 2003 Server, SQL server 2000 and IIS 6.0 on my PC. but IE noted me with the page "The assembly version [ASSEMBLYVERSION] does not match the database version [DATABASEVERSION]", I think the error caused by my SQL Server. What can I do to fix this error. Thanks, thuantam In there are two places in your web.config that you need to set your own<appSettings><add key="connectionString"....... ensure both plac...

RTM version number same as RC version///?
I installed RTM (1.0) on 24-Jan and the version (1.0.61025) is what I am seeing in Add Remove Programs-> Microsoft ASP.Net 2.0 AJAX Extensions 1.0 -> Click here for support information... I thought this version was for RC.. AM I missing something here??  Thanks Sriram...

Assembly version does not match Database version
I'm trying for the first time to open DotNetNuke in my browser and get the following error:   DotNetNuke Upgrade Error The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] ) ERROR: Could not connect to database.Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection. Any suggestions? Thanks in advance   it looks like theres a problem with your connection string...Wessam Zeidan Is that the first time you try to install dotnetnuke ? Is it a local installation. What Version of DNN What o...

Database version vs. Server version
I am running the SQL Anywhere 5.5.02 server/engine and when I inspect the properties for my database object within SQL central it says that my database version is 5.0.03. Does anyone know what exactly the database version means? Do I need to update my database? If so, How? -Scott scharris@worldnet.att.net >I am running the SQL Anywhere 5.5.02 server/engine and when I inspect the >properties for my database object within SQL central it says that my >database version is 5.0.03. Does anyone know what exactly the database >version means? Do I need to update my ...

version.pm and developer version numbers
I just discovered that version.pm always treats version numbers with an = underscore as less than the equivalent version number without the = underscore. So "6.63_02" is less than "6.6302". Is it it just me, or = does that seem crazy? Dealing with $VERSION numbers in Perl is hard = enough as it is. This doesn't help.=20 -Jeff= It's crazy. But it's been that way since Perl 5.10.0 in 2007. So now we're stuck with it. The C<$VERSION =3D eval $VERSION> idiom avoids some issues with it by losing the underscore at runtime, but that might n...

Error during a load database coming from a 11.9.2 version to a 12.5 ASE
Platform : Digital Unix 5.1 When I tried to load a database ( the dump was coming from a 11.9.2 server) on a 12.5 ASE servr, I got the following messages many times : Backup Server: 3.42.1.1: LOAD is complete (database toxic2). Database 5, 'toxic2': Object 3 requires translation. Col/off -length-- --type--- mem disk mem disk mem disk 3: 8 8 2 1 52 48 4: 10 9 5: 11 10 6: 12 11 4 1 56 48 7: 16 12 8: 22 14 9: 24 16 10: 28 20 15: -5 -5 38 56 Database 5, &...

Web resources about - ASE Version number - sybase.powerbuilder.database

Authorized King James Version - Wikipedia, the free encyclopedia
The title page to the 1611 first edition of the Authorized Version Bible by Cornelis Boel shows the Apostles Peter and Paul seated centrally ...

Journalist Samples the Holiday Version of ‘Disciplinary Loaf’
... his peers. Politico colleagues Josefa Velasquez and Bill Mahoney , for a Christmas party in Albany, used the recipe to create a cupcake version ...

Kurt Warner: 2015 Cardinals better version than 2008
Kurt Warner talks about how different the 2015 Arizona Cardinals are compared to his 2008 Super Bowl team.

Lenovo launches business versions of MIIX 700 and Yoga 900
... positioned the device as an alternative to Microsoft’s Surface. The Business Edition of this device retains the design of the original version ...

Microsoft might launch a slim Xbox One version to take on the Apple TV
Microsoft is rumored to be prepping a slimmer Xbox One console that may launch next year to compete directly against Apple’s brand new Apple ...

Distributing a beta version of an iOS app
I am not an iOS expert by any means, but recently I’ve had to maintain an iOS app and distribute it to beta testers. I had to jump through a ...

Google just revealed what its next version of Google Glass will look like, and it's aimed at business ...
... smart thermostat company Nest for hundreds of millions in 2014. While the device doesn't look very different from the previous Explorer versions, ...

Viber Releases Its Own Version of Snapchat
Snapchat doesn’t have the market cornered on disappearing pictures after all. Viber, which has been doing some cool stuff outside of its normal ...

Chris Christie's version of his national security creds completely overblown
This is going to come as a shock, so brace yourself: Chris Christie isn't telling the truth about his national security record. The New Jersey ...

HCWD unveils white-concrete version of portable LED lamp
New York-based HCWD Studio has released a white-concrete version of its cordless Brick lamp, which is activated by movement rather than a switch ...

Resources last updated: 1/6/2016 3:54:54 AM